Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Списание.Помогите пожалуйста!Корректировка документа
Алена Харченко
Пост №1
Алена Харченко
читатель
офлайн
Дата регистрации: 01.08.2007
Сообщений: 1
Пост №1
 
01.08.2007 15:03

"Неправильное списание выглядит так:
Амортизация ОС/ дебет 26/ кредит 02/-37991?66
Списана балансовая стоимость/дб 01.2/кр. 01.1/32857,66
Списана остаточная стоимость/дб 91.2/кр. 01.2/32857,66
Анужно сделать так:
Списана бал стоимость/кр01.2/дб 01.1
Списана амортизация/дб 02/01.2
И если Балансовая стоимость > Амортизации, то списать остаточную стоимость по дб 91.2 и по кредиту 01.2
Помогите пожалуйста, хотя бы примерно где что изменять
Это модуль списания, если поможет
Перем ПроцентЧС;

//******************************************************************************
// ДоначислениеАмортизацииДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура ДоначислениеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОбъекте)

РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");

Если (РассчитаннаяАмортизация <> 0) И (ПроцентЧС = 1) Тогда
СчетИАналитикаДляОтнесенияРасходов = глПолучитьСчетРасходовДляЦелейНалоговогоУчета(ОсновноеСредство.ВидРасхода.Получить(ДатаДок), ОсновноеСредство.ЭлементРасхода.Получить(ДатаДок), ОсновноеСредство.Объект.Получить(ДатаДок), ДатаДок);
СчетРасходов = СчетИАналитикаДляОтнесенияРасходов.Получить("Счет");
Если ПустоеЗначение(СчетРасходов) = 1 Тогда
ТекстСообщения = "На закладке """"Налоговый учет"""" неверно указано направление отнесения расходов по начисленной амортизации для объекта: "
+ ОсновноеСредство.Наименование + ", инв.№" + ОсновноеСредство.Код + ".";
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
СчетРасходов = глПолучитьСчетУчетаКосвенныхРасходовНУ(ДатаДок, ОсновноеСредство.СчетЗатрат.Получить(ДатаДок), ОсновноеСредство.Субконто1.Получить(ДатаДок), СчетРасходов);

Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Аморт.за "+Формат(ДатаДок,"Д ММММГГГГ");
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ПустоеЗначение(СчетРасходов) = 0 Тогда
Операция.Дебет.Счет = СчетРасходов;
Операция.Дебет.Субконто(1, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто1"));
Операция.Дебет.Субконто(2, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто2"));
Операция.Дебет.Субконто(3, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто3"));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("Н05.02");
Операция.Кредит.Субконто(1, ОсновноеСредство);
Операция.Сумма = РассчитаннаяАмортизация;
КонецЕсли;

КонецПроцедуры // ДоначислениеАмортизацииДляЦелейНалоговогоУчета()

//******************************************************************************
// СписаниеАмортизацииДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура СписаниеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОбъекте)
                                                                                    
РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");
НачисленнаяАмортизацияНУ = РассчитаннаяАмортизация + СведенияОбОбъекте.Получить("НачисленнаяАмортизацияНалогКон");

Если НачисленнаяАмортизацияНУ <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = СчетПоКоду("Н05.02");
Операция.Дебет.Субконто(1, ОсновноеСредство);
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.Субконто(1, ОсновноеСредство);
Операция.Сумма = НачисленнаяАмортизацияНУ*ПроцентЧС;
КонецЕсли;

КонецПроцедуры // СписаниеАмортизацииДляЦелейНалоговогоУчета()

//******************************************************************************
// ВыбытиеОСДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура ВыбытиеОСДляЦелейНалоговогоУчета(СведенияОбОбъекте)

РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");
КапВложенияНаправленныеНаРасходы =СведенияОбОбъекте.Получить("КапВложенияНаправленныеНаРасходы");
НачисленнаяАмортизацияНУ = РассчитаннаяАмортизация + СведенияОбОбъекте.Получить("НачисленнаяАмортизацияНалогКон");
ОстаточнаяСтоимость = СведенияОбОбъекте.Получить("БалансоваяСтоимостьНалогКон") - НачисленнаяАмортизацияНУ - КапВложенияНаправленныеНаРасходы;
            
Если ОстаточнаяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Списание остаточной стоимости";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = СчетПоКоду("Н09");
Операция.Дебет.ВнереализационныеРасходы = Перечисление.ВнереализационныеРасходы.ПрочиеВнереализационныеРасходы;
Операция.Дебет.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.СписаниеИмущества;
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.СписаниеИмущества;
Операция.Сумма = ОстаточнаяСтоимость*ПроцентЧС;
КонецЕсли;

КонецПроцедуры // ВыбытиеОСДляЦелейНалоговогоУчета()

//******************************************************************************
// ВключениеКапитальныхВложенийВРасходы()
//
// Описание:
// Включение не более 10% от капитальных вложений в состав расходов.
//
Процедура ВключениеКапитальныхВложенийВРасходы(СведенияОбОбъекте)

КапВложенияНаправленныеНаРасходы = СведенияОбОбъекте.Получить("КапВложенияНаправленныеНаРасходы");

Если КапВложенияНаправленныеНаРасходы <> 0 Тогда
СчетИАналитикаДляОтнесенияРасходов = глПолучитьСчетРасходовДляЦелейНалоговогоУчета(ОсновноеСредство.ВидРасхода.Получить(ДатаДок), ОсновноеСредство.ЭлементРасхода.Получить(ДатаДок), ОсновноеСредство.Объект.Получить(ДатаДок), ДатаДок);
СчетРасходов = СчетИАналитикаДляОтнесенияРасходов.Получить("Счет");
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Включение кап.вложений в расходы";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ПустоеЗначение(СчетРасходов) = 0 Тогда
Операция.Дебет.Счет = СчетРасходов;
Операция.Дебет.Субконто(1, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто1"));
Операция.Дебет.Субконто(2, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто2"));
Операция.Дебет.Субконто(3, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто3"));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.Другие;
Операция.Сумма = КапВложенияНаправленныеНаРасходы;

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Включение кап.вложений в расходы";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Кредит.Счет = СчетПоКоду("Н05.КВ");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = КапВложенияНаправленныеНаРасходы;
КонецЕсли;

КонецПроцедуры // ВключениеКапитальныхВложенийВРасходы()

//******************************************************************************
// Предопределенная процедура
//
Процедура ОбработкаПроведения()

Сч01_1 = СчетПоКоду("01.1");
Сч01_2 = СчетПоКоду("01.2");
Сч83_1 = СчетПоКоду("83.1");
Сч84_1 = СчетПоКоду("84.1");
Сч91_2 = СчетПоКоду("91.2");
Сч99_1 = СчетПоКоду("99.1");
СчМЦ_01= СчетПоКоду("МЦ.01");

НовыеПравилаВеденияНУ = глНовыеПравилаВеденияНУ(ДатаДок);

БухИтНПР = СоздатьОбъект("БухгалтерскиеИтоги");
БухИтНПР.ПериодМ(ДатаДок);
                        
СписокОС = СоздатьОбъект("СписокЗначений");
ВыгрузитьТабличнуюЧасть(СписокОС);

БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, СписокОС, 2);
БухИт.ВыполнитьЗапрос(, ТекущийДокумент(),"83.1, МЦ.01");

Если ПроцентЧастичногоСписания<>0 Тогда
ПроцентЧС = ПроцентЧастичногоСписания/100;
Иначе
ПроцентЧС = 1;
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
СведенияОбОС = глРасчетАмортизацииОС(ОсновноеСредство, ДатаДок);
НачисленнаяАмортизацияНач = СведенияОбОС.Получить("НачисленнаяАмортизацияКон");
СчетНачисленияАмортизации = СведенияОбОС.Получить("СчетНачисленияАмортизации");

СписаноПостоянныхРазниц = 0;

ДоначисленнаяАмортизация = НачисленнаяАмортизация - НачисленнаяАмортизацияНач;
Если (ДоначисленнаяАмортизация <> 0) и (ПустоеЗначение(СчетНачисленияАмортизации) = 0) И (ПроцентЧС = 1) Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = ДоначисленнаяАмортизация;

Если СчетНачисленияАмортизации.Забалансовый = 1 Тогда
Операция.СодержаниеПроводки = "Износ за "+Формат(ДатаДок,"Д ММММГГГГ");
Операция.Дебет.Счет = СчетНачисленияАмортизации;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;

Иначе
Если ОсновноеСредство.СчетЗатрат.Получить(ДатаДок).Выбран() = 0 Тогда
ТекстСообщения = "Не указан счет отнесения затрат по начисленной амортизации для ОС: "+ОсновноеСредство.Наименование+", инв.№"+ОсновноеСредство.Код+".";
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
Операция.СодержаниеПроводки = "Аморт.за "+Формат(ДатаДок,"Д ММММГГГГ");

Операция.Дебет.Счет = ОсновноеСредство.СчетЗатрат.Получить(ДатаДок);
Операция.Дебет.Субконто(1, ОсновноеСредство.Субконто1.Получить(ДатаДок));
Операция.Дебет.Субконто(2, ОсновноеСредство.Субконто2.Получить(ДатаДок));
Операция.Дебет.Субконто(3, ОсновноеСредство.Субконто3.Получить(ДатаДок));
Операция.Кредит.Счет = СчетНачисленияАмортизации;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

// Списание постоянных разниц
Если СчетНачисленияАмортизации.Забалансовый <> 1 Тогда
Если Константа.ПрименяетсяПБУ18.Получить(ДатаДок) = Да Тогда
ВсегоПостоянныхРазниц = БухИтНПР.СНД("НПР.01",,, ОсновноеСредство);
Если ВсегоПостоянныхРазниц <> 0 Тогда
БалансоваяСтоимостьНач = СведенияОбОС.Получить("БалансоваяСтоимостьНач");
НачисленнаяАмортизацияНач = СведенияОбОС.Получить("НачисленнаяАмортизацияНач");
ОстаточнаяСтоимостьНаНачало = БалансоваяСтоимостьНач - НачисленнаяАмортизацияНач;
Если ОстаточнаяСтоимостьНаНачало <> 0 Тогда
СписатьПостоянныхРазниц = Окр(ВсегоПостоянныхРазниц * (ДоначисленнаяАмортизация / ОстаточнаяСтоимостьНаНачало), 2);
Если СписатьПостоянныхРазниц <> 0 Тогда
СчетДт = ОсновноеСредство.СчетЗатрат.Получить(ДатаДок);
СчетНПР = глПолучитьСчетДебетаНПР(СчетДт, ОсновноеСредство.Субконто1.Получить(ДатаДок));

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ПР";
Операция.СодержаниеПроводки = "Списание постоянных разниц";
Если ПустоеЗначение(СчетНПР) = 0 Тогда
Операция.Дебет.Счет = СчетНПР;
Операция.Дебет.Субконто(1, ОсновноеСредство.Субконто1.Получить(ДатаДок));
Операция.Дебет.Субконто(2, ОсновноеСредство.Субконто2.Получить(ДатаДок));
Операция.Дебет.Субконто(3, ОсновноеСредство.Субконто3.Получить(ДатаДок));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("НПР.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = СписатьПостоянныхРазниц;

СписаноПостоянныхРазниц = СписатьПостоянныхРазниц;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Доначислим амортизацию для целей налогового учета.
Если НовыеПравилаВеденияНУ >= 1 Тогда
ДоначислениеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОС);

// Если невозможно определить счет отнесения амортизации для целей налогового учета.
Если СтатусВозврата() = 0 Тогда
Возврат;
КонецЕсли;
КонецЕсли;

Если (НачисленнаяАмортизация <> 0) и (ПустоеЗначение(СчетНачисленияАмортизации) = 0) Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = НачисленнаяАмортизация*ПроцентЧС;

Если СчетНачисленияАмортизации.Забалансовый = 1 Тогда
Операция.СодержаниеПроводки = "Списан износ";
Операция.Кредит.Счет = СчетНачисленияАмортизации;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;

Иначе
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.Кредит.Счет = Сч01_2;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Дебет.Счет = СчетНачисленияАмортизации;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;
КонецЕсли;

// Списание амортизации для целей налогового учета.
Если НовыеПравилаВеденияНУ >= 1 Тогда
СписаниеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОС);
КонецЕсли;

Если БалансоваяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана баланс.ст-ть";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = БалансоваяСтоимость*ПроцентЧС;
Операция.Кредит.Счет = Сч01_1;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Дебет.Счет = Сч01_2;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

ОстаточнаяСтоимость = ?(СчетНачисленияАмортизации.Забалансовый = 1, Окр(БалансоваяСтоимость*ПроцентЧС,2,1), Окр(БалансоваяСтоимость*ПроцентЧС,2,1) - Окр(НачисленнаяАмортизация*ПроцентЧС,2,1));
Если ОстаточнаяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = ?(СчетНачисленияАмортизации.Забалансовый = 1, "Списана баланс.ст-ть", "Списана остат.ст-ть");
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ТипСписания = 1 Тогда
Операция.Дебет.Счет = Сч99_1;
Операция.Дебет.ПрибылиИУбытки = Перечисление.ПрибылиИУбытки.ЧрезвычайныеРасходы;

Иначе
Операция.Дебет.Счет = Сч91_2;
Операция.Дебет.ПрочиеДоходыИРасходы = СтатьяПрочихДоходовИРасходов;
КонецЕсли;

Операция.Кредит.Счет = Сч01_2;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = ОстаточнаяСтоимость;
КонецЕсли;

// Списание суммы переоценки.
Если БухИт.ПолучитьСчет(, Сч83_1) = 1 Тогда
Если БухИт.ПолучитьСубконто(,, ОсновноеСредство) = 1 Тогда
Если БухИт.СКК("С") > 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Сумма дооценки включена в состав нераспр. прибыли";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = Сч83_1;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.Счет = Сч84_1;
Операция.Сумма = БухИт.СКК("С");
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Если основное средство учитывается на забалансовом счете МЦ.01,
// то необходимо списать его с этого счета.
Если БухИт.ПолучитьСчет(, СчМЦ_01) = 1 Тогда
Если БухИт.ПолучитьСубконто(, , ОсновноеСредство) = 1 Тогда
Если БухИт.СКД("С") > 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана первоначальная стоимость";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Кредит.Счет = СчМЦ_01;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = БухИт.СКД("С")*ПроцентЧС;
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Списание постоянных разниц
Если Константа.ПрименяетсяПБУ18.Получить(ДатаДок) = Да Тогда
СписатьПостоянныхРазниц = БухИтНПР.СКД("НПР.01",,, ОсновноеСредство) - СписаноПостоянныхРазниц;
Если СписатьПостоянныхРазниц <> 0 Тогда
СчетДт = ПолучитьПустоеЗначение("Счет");
Если ТипСписания = 1 Тогда
СчетДт = Сч99_1;
Субконто1 = Перечисление.ПрибылиИУбытки.ЧрезвычайныеРасходы;

Иначе
СчетДт = Сч91_2;
Субконто1 = СтатьяПрочихДоходовИРасходов;
КонецЕсли;
СчетНПР = глПолучитьСчетДебетаНПР(СчетДт, Субконто1);

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ПР";
Операция.СодержаниеПроводки = "Списание постоянных разниц";
Если ПустоеЗначение(СчетНПР) = 0 Тогда
Операция.Дебет.Счет = СчетНПР;
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("НПР.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = СписатьПостоянныхРазниц;
КонецЕсли;
КонецЕсли;

// Списание остаточной стоимости ОС для целей налогообложения.
Если НовыеПравилаВеденияНУ >= 1 Тогда
ВыбытиеОСДляЦелейНалоговогоУчета(СведенияОбОС);
ВключениеКапитальныхВложенийВРасходы(СведенияОбОС);
КонецЕсли;

Если ДатаДок < '01.01.2002' Тогда
РассчитаннаяАмортизацияНалог = СведенияОбОС.Получить("РассчитаннаяАмортизацияНалог");
НачисленнаяАмортизацияНалог = СведенияОбОС.Получить("НачисленнаяАмортизацияНалог");
Если РассчитаннаяАмортизацияНалог <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.СодержаниеПроводки = "Начислена амортизация";
Операция.Сумма = РассчитаннаяАмортизацияНалог;
Операция.Кредит.Счет = СчетПоКоду("АОС");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

Если НачисленнаяАмортизацияНалог + РассчитаннаяАмортизацияНалог <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = НачисленнаяАмортизацияНалог + РассчитаннаяАмортизацияНалог;
Операция.Дебет.Счет = СчетПоКоду("АОС");
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;
КонецЕсли;



СпрОС = СоздатьОбъект("Справочник.ОсновныеСредства");
Если СпрОС.НайтиЭлемент(ОсновноеСредство) = 0 Тогда
СтатусВозврата(0); Возврат;
КонецЕсли;

Если ПроцентЧС=1 Тогда
СпрОС.ДатаВыбытия = ДатаДок;
Если ТипСписания = 1 Тогда
СпрОС.ПричинаВыбытия = Перечисление.ПричиныВыбытияОС.Иная;

Иначе
СпрОС.ПричинаВыбытия = Перечисление.ПричиныВыбытияОС.Списание;
КонецЕсли;
СпрОС.Записать();

УстановитьРеквизитСправочника(ОсновноеСредство, "НачислятьАмортизацию", 0, ДатаДок);
УстановитьРеквизитСправочника(ОсновноеСредство, "Состояние", Перечисление.СостоянияОС.Выбыло, ДатаДок);
КонецЕсли;

КонецЦикла;
Операция.Записать();

КонецПроцедуры // ОбработкаПроведения()
"

 
Алена Харченко
Пост №1
01.08.2007 15:03
 

"Неправильное списание выглядит так:
Амортизация ОС/ дебет 26/ кредит 02/-37991?66
Списана балансовая стоимость/дб 01.2/кр. 01.1/32857,66
Списана остаточная стоимость/дб 91.2/кр. 01.2/32857,66
Анужно сделать так:
Списана бал стоимость/кр01.2/дб 01.1
Списана амортизация/дб 02/01.2
И если Балансовая стоимость > Амортизации, то списать остаточную стоимость по дб 91.2 и по кредиту 01.2
Помогите пожалуйста, хотя бы примерно где что изменять
Это модуль списания, если поможет
Перем ПроцентЧС;

//******************************************************************************
// ДоначислениеАмортизацииДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура ДоначислениеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОбъекте)

РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");

Если (РассчитаннаяАмортизация <> 0) И (ПроцентЧС = 1) Тогда
СчетИАналитикаДляОтнесенияРасходов = глПолучитьСчетРасходовДляЦелейНалоговогоУчета(ОсновноеСредство.ВидРасхода.Получить(ДатаДок), ОсновноеСредство.ЭлементРасхода.Получить(ДатаДок), ОсновноеСредство.Объект.Получить(ДатаДок), ДатаДок);
СчетРасходов = СчетИАналитикаДляОтнесенияРасходов.Получить("Счет");
Если ПустоеЗначение(СчетРасходов) = 1 Тогда
ТекстСообщения = "На закладке """"Налоговый учет"""" неверно указано направление отнесения расходов по начисленной амортизации для объекта: "
+ ОсновноеСредство.Наименование + ", инв.№" + ОсновноеСредство.Код + ".";
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
СчетРасходов = глПолучитьСчетУчетаКосвенныхРасходовНУ(ДатаДок, ОсновноеСредство.СчетЗатрат.Получить(ДатаДок), ОсновноеСредство.Субконто1.Получить(ДатаДок), СчетРасходов);

Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Аморт.за "+Формат(ДатаДок,"Д ММММГГГГ");
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ПустоеЗначение(СчетРасходов) = 0 Тогда
Операция.Дебет.Счет = СчетРасходов;
Операция.Дебет.Субконто(1, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто1"));
Операция.Дебет.Субконто(2, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто2"));
Операция.Дебет.Субконто(3, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто3"));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("Н05.02");
Операция.Кредит.Субконто(1, ОсновноеСредство);
Операция.Сумма = РассчитаннаяАмортизация;
КонецЕсли;

КонецПроцедуры // ДоначислениеАмортизацииДляЦелейНалоговогоУчета()

//******************************************************************************
// СписаниеАмортизацииДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура СписаниеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОбъекте)
                                                                                    
РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");
НачисленнаяАмортизацияНУ = РассчитаннаяАмортизация + СведенияОбОбъекте.Получить("НачисленнаяАмортизацияНалогКон");

Если НачисленнаяАмортизацияНУ <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = СчетПоКоду("Н05.02");
Операция.Дебет.Субконто(1, ОсновноеСредство);
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.Субконто(1, ОсновноеСредство);
Операция.Сумма = НачисленнаяАмортизацияНУ*ПроцентЧС;
КонецЕсли;

КонецПроцедуры // СписаниеАмортизацииДляЦелейНалоговогоУчета()

//******************************************************************************
// ВыбытиеОСДляЦелейНалоговогоУчета()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура ВыбытиеОСДляЦелейНалоговогоУчета(СведенияОбОбъекте)

РассчитаннаяАмортизация = СведенияОбОбъекте.Получить("РассчитаннаяАмортизацияНалог");
КапВложенияНаправленныеНаРасходы =СведенияОбОбъекте.Получить("КапВложенияНаправленныеНаРасходы");
НачисленнаяАмортизацияНУ = РассчитаннаяАмортизация + СведенияОбОбъекте.Получить("НачисленнаяАмортизацияНалогКон");
ОстаточнаяСтоимость = СведенияОбОбъекте.Получить("БалансоваяСтоимостьНалогКон") - НачисленнаяАмортизацияНУ - КапВложенияНаправленныеНаРасходы;
            
Если ОстаточнаяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "НУ";
Операция.СодержаниеПроводки = "Списание остаточной стоимости";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = СчетПоКоду("Н09");
Операция.Дебет.ВнереализационныеРасходы = Перечисление.ВнереализационныеРасходы.ПрочиеВнереализационныеРасходы;
Операция.Дебет.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.СписаниеИмущества;
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.СписаниеИмущества;
Операция.Сумма = ОстаточнаяСтоимость*ПроцентЧС;
КонецЕсли;

КонецПроцедуры // ВыбытиеОСДляЦелейНалоговогоУчета()

//******************************************************************************
// ВключениеКапитальныхВложенийВРасходы()
//
// Описание:
// Включение не более 10% от капитальных вложений в состав расходов.
//
Процедура ВключениеКапитальныхВложенийВРасходы(СведенияОбОбъекте)

КапВложенияНаправленныеНаРасходы = СведенияОбОбъекте.Получить("КапВложенияНаправленныеНаРасходы");

Если КапВложенияНаправленныеНаРасходы <> 0 Тогда
СчетИАналитикаДляОтнесенияРасходов = глПолучитьСчетРасходовДляЦелейНалоговогоУчета(ОсновноеСредство.ВидРасхода.Получить(ДатаДок), ОсновноеСредство.ЭлементРасхода.Получить(ДатаДок), ОсновноеСредство.Объект.Получить(ДатаДок), ДатаДок);
СчетРасходов = СчетИАналитикаДляОтнесенияРасходов.Получить("Счет");
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Включение кап.вложений в расходы";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ПустоеЗначение(СчетРасходов) = 0 Тогда
Операция.Дебет.Счет = СчетРасходов;
Операция.Дебет.Субконто(1, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто1"));
Операция.Дебет.Субконто(2, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто2"));
Операция.Дебет.Субконто(3, СчетИАналитикаДляОтнесенияРасходов.Получить("Субконто3"));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("Н05.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.УсловияПоступленияИВыбытия = Перечисление.УсловияПоступленияИВыбытия.Другие;
Операция.Сумма = КапВложенияНаправленныеНаРасходы;

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Включение кап.вложений в расходы";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Кредит.Счет = СчетПоКоду("Н05.КВ");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = КапВложенияНаправленныеНаРасходы;
КонецЕсли;

КонецПроцедуры // ВключениеКапитальныхВложенийВРасходы()

//******************************************************************************
// Предопределенная процедура
//
Процедура ОбработкаПроведения()

Сч01_1 = СчетПоКоду("01.1");
Сч01_2 = СчетПоКоду("01.2");
Сч83_1 = СчетПоКоду("83.1");
Сч84_1 = СчетПоКоду("84.1");
Сч91_2 = СчетПоКоду("91.2");
Сч99_1 = СчетПоКоду("99.1");
СчМЦ_01= СчетПоКоду("МЦ.01");

НовыеПравилаВеденияНУ = глНовыеПравилаВеденияНУ(ДатаДок);

БухИтНПР = СоздатьОбъект("БухгалтерскиеИтоги");
БухИтНПР.ПериодМ(ДатаДок);
                        
СписокОС = СоздатьОбъект("СписокЗначений");
ВыгрузитьТабличнуюЧасть(СписокОС);

БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, СписокОС, 2);
БухИт.ВыполнитьЗапрос(, ТекущийДокумент(),"83.1, МЦ.01");

Если ПроцентЧастичногоСписания<>0 Тогда
ПроцентЧС = ПроцентЧастичногоСписания/100;
Иначе
ПроцентЧС = 1;
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
СведенияОбОС = глРасчетАмортизацииОС(ОсновноеСредство, ДатаДок);
НачисленнаяАмортизацияНач = СведенияОбОС.Получить("НачисленнаяАмортизацияКон");
СчетНачисленияАмортизации = СведенияОбОС.Получить("СчетНачисленияАмортизации");

СписаноПостоянныхРазниц = 0;

ДоначисленнаяАмортизация = НачисленнаяАмортизация - НачисленнаяАмортизацияНач;
Если (ДоначисленнаяАмортизация <> 0) и (ПустоеЗначение(СчетНачисленияАмортизации) = 0) И (ПроцентЧС = 1) Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = ДоначисленнаяАмортизация;

Если СчетНачисленияАмортизации.Забалансовый = 1 Тогда
Операция.СодержаниеПроводки = "Износ за "+Формат(ДатаДок,"Д ММММГГГГ");
Операция.Дебет.Счет = СчетНачисленияАмортизации;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;

Иначе
Если ОсновноеСредство.СчетЗатрат.Получить(ДатаДок).Выбран() = 0 Тогда
ТекстСообщения = "Не указан счет отнесения затрат по начисленной амортизации для ОС: "+ОсновноеСредство.Наименование+", инв.№"+ОсновноеСредство.Код+".";
глНеПроводить(Контекст, ТекстСообщения);
Возврат;
КонецЕсли;
Операция.СодержаниеПроводки = "Аморт.за "+Формат(ДатаДок,"Д ММММГГГГ");

Операция.Дебет.Счет = ОсновноеСредство.СчетЗатрат.Получить(ДатаДок);
Операция.Дебет.Субконто(1, ОсновноеСредство.Субконто1.Получить(ДатаДок));
Операция.Дебет.Субконто(2, ОсновноеСредство.Субконто2.Получить(ДатаДок));
Операция.Дебет.Субконто(3, ОсновноеСредство.Субконто3.Получить(ДатаДок));
Операция.Кредит.Счет = СчетНачисленияАмортизации;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

// Списание постоянных разниц
Если СчетНачисленияАмортизации.Забалансовый <> 1 Тогда
Если Константа.ПрименяетсяПБУ18.Получить(ДатаДок) = Да Тогда
ВсегоПостоянныхРазниц = БухИтНПР.СНД("НПР.01",,, ОсновноеСредство);
Если ВсегоПостоянныхРазниц <> 0 Тогда
БалансоваяСтоимостьНач = СведенияОбОС.Получить("БалансоваяСтоимостьНач");
НачисленнаяАмортизацияНач = СведенияОбОС.Получить("НачисленнаяАмортизацияНач");
ОстаточнаяСтоимостьНаНачало = БалансоваяСтоимостьНач - НачисленнаяАмортизацияНач;
Если ОстаточнаяСтоимостьНаНачало <> 0 Тогда
СписатьПостоянныхРазниц = Окр(ВсегоПостоянныхРазниц * (ДоначисленнаяАмортизация / ОстаточнаяСтоимостьНаНачало), 2);
Если СписатьПостоянныхРазниц <> 0 Тогда
СчетДт = ОсновноеСредство.СчетЗатрат.Получить(ДатаДок);
СчетНПР = глПолучитьСчетДебетаНПР(СчетДт, ОсновноеСредство.Субконто1.Получить(ДатаДок));

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ПР";
Операция.СодержаниеПроводки = "Списание постоянных разниц";
Если ПустоеЗначение(СчетНПР) = 0 Тогда
Операция.Дебет.Счет = СчетНПР;
Операция.Дебет.Субконто(1, ОсновноеСредство.Субконто1.Получить(ДатаДок));
Операция.Дебет.Субконто(2, ОсновноеСредство.Субконто2.Получить(ДатаДок));
Операция.Дебет.Субконто(3, ОсновноеСредство.Субконто3.Получить(ДатаДок));
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("НПР.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = СписатьПостоянныхРазниц;

СписаноПостоянныхРазниц = СписатьПостоянныхРазниц;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Доначислим амортизацию для целей налогового учета.
Если НовыеПравилаВеденияНУ >= 1 Тогда
ДоначислениеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОС);

// Если невозможно определить счет отнесения амортизации для целей налогового учета.
Если СтатусВозврата() = 0 Тогда
Возврат;
КонецЕсли;
КонецЕсли;

Если (НачисленнаяАмортизация <> 0) и (ПустоеЗначение(СчетНачисленияАмортизации) = 0) Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = НачисленнаяАмортизация*ПроцентЧС;

Если СчетНачисленияАмортизации.Забалансовый = 1 Тогда
Операция.СодержаниеПроводки = "Списан износ";
Операция.Кредит.Счет = СчетНачисленияАмортизации;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;

Иначе
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.Кредит.Счет = Сч01_2;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Дебет.Счет = СчетНачисленияАмортизации;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;
КонецЕсли;

// Списание амортизации для целей налогового учета.
Если НовыеПравилаВеденияНУ >= 1 Тогда
СписаниеАмортизацииДляЦелейНалоговогоУчета(СведенияОбОС);
КонецЕсли;

Если БалансоваяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана баланс.ст-ть";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = БалансоваяСтоимость*ПроцентЧС;
Операция.Кредит.Счет = Сч01_1;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Дебет.Счет = Сч01_2;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

ОстаточнаяСтоимость = ?(СчетНачисленияАмортизации.Забалансовый = 1, Окр(БалансоваяСтоимость*ПроцентЧС,2,1), Окр(БалансоваяСтоимость*ПроцентЧС,2,1) - Окр(НачисленнаяАмортизация*ПроцентЧС,2,1));
Если ОстаточнаяСтоимость <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = ?(СчетНачисленияАмортизации.Забалансовый = 1, "Списана баланс.ст-ть", "Списана остат.ст-ть");
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Если ТипСписания = 1 Тогда
Операция.Дебет.Счет = Сч99_1;
Операция.Дебет.ПрибылиИУбытки = Перечисление.ПрибылиИУбытки.ЧрезвычайныеРасходы;

Иначе
Операция.Дебет.Счет = Сч91_2;
Операция.Дебет.ПрочиеДоходыИРасходы = СтатьяПрочихДоходовИРасходов;
КонецЕсли;

Операция.Кредит.Счет = Сч01_2;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = ОстаточнаяСтоимость;
КонецЕсли;

// Списание суммы переоценки.
Если БухИт.ПолучитьСчет(, Сч83_1) = 1 Тогда
Если БухИт.ПолучитьСубконто(,, ОсновноеСредство) = 1 Тогда
Если БухИт.СКК("С") > 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Сумма дооценки включена в состав нераспр. прибыли";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = Сч83_1;
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
Операция.Кредит.Счет = Сч84_1;
Операция.Сумма = БухИт.СКК("С");
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Если основное средство учитывается на забалансовом счете МЦ.01,
// то необходимо списать его с этого счета.
Если БухИт.ПолучитьСчет(, СчМЦ_01) = 1 Тогда
Если БухИт.ПолучитьСубконто(, , ОсновноеСредство) = 1 Тогда
Если БухИт.СКД("С") > 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана первоначальная стоимость";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Кредит.Счет = СчМЦ_01;
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = БухИт.СКД("С")*ПроцентЧС;
КонецЕсли;
КонецЕсли;
КонецЕсли;

// Списание постоянных разниц
Если Константа.ПрименяетсяПБУ18.Получить(ДатаДок) = Да Тогда
СписатьПостоянныхРазниц = БухИтНПР.СКД("НПР.01",,, ОсновноеСредство) - СписаноПостоянныхРазниц;
Если СписатьПостоянныхРазниц <> 0 Тогда
СчетДт = ПолучитьПустоеЗначение("Счет");
Если ТипСписания = 1 Тогда
СчетДт = Сч99_1;
Субконто1 = Перечисление.ПрибылиИУбытки.ЧрезвычайныеРасходы;

Иначе
СчетДт = Сч91_2;
Субконто1 = СтатьяПрочихДоходовИРасходов;
КонецЕсли;
СчетНПР = глПолучитьСчетДебетаНПР(СчетДт, Субконто1);

Операция.НоваяПроводка();
Операция.НомерЖурнала = "ПР";
Операция.СодержаниеПроводки = "Списание постоянных разниц";
Если ПустоеЗначение(СчетНПР) = 0 Тогда
Операция.Дебет.Счет = СчетНПР;
КонецЕсли;
Операция.Кредит.Счет = СчетПоКоду("НПР.01");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
Операция.Сумма = СписатьПостоянныхРазниц;
КонецЕсли;
КонецЕсли;

// Списание остаточной стоимости ОС для целей налогообложения.
Если НовыеПравилаВеденияНУ >= 1 Тогда
ВыбытиеОСДляЦелейНалоговогоУчета(СведенияОбОС);
ВключениеКапитальныхВложенийВРасходы(СведенияОбОС);
КонецЕсли;

Если ДатаДок < '01.01.2002' Тогда
РассчитаннаяАмортизацияНалог = СведенияОбОС.Получить("РассчитаннаяАмортизацияНалог");
НачисленнаяАмортизацияНалог = СведенияОбОС.Получить("НачисленнаяАмортизацияНалог");
Если РассчитаннаяАмортизацияНалог <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.СодержаниеПроводки = "Начислена амортизация";
Операция.Сумма = РассчитаннаяАмортизацияНалог;
Операция.Кредит.Счет = СчетПоКоду("АОС");
Операция.Кредит.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;

Если НачисленнаяАмортизацияНалог + РассчитаннаяАмортизацияНалог <> 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "ОС";
Операция.СодержаниеПроводки = "Списана амортизация";
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Сумма = НачисленнаяАмортизацияНалог + РассчитаннаяАмортизацияНалог;
Операция.Дебет.Счет = СчетПоКоду("АОС");
Операция.Дебет.ОсновныеСредства = ОсновноеСредство;
КонецЕсли;
КонецЕсли;



СпрОС = СоздатьОбъект("Справочник.ОсновныеСредства");
Если СпрОС.НайтиЭлемент(ОсновноеСредство) = 0 Тогда
СтатусВозврата(0); Возврат;
КонецЕсли;

Если ПроцентЧС=1 Тогда
СпрОС.ДатаВыбытия = ДатаДок;
Если ТипСписания = 1 Тогда
СпрОС.ПричинаВыбытия = Перечисление.ПричиныВыбытияОС.Иная;

Иначе
СпрОС.ПричинаВыбытия = Перечисление.ПричиныВыбытияОС.Списание;
КонецЕсли;
СпрОС.Записать();

УстановитьРеквизитСправочника(ОсновноеСредство, "НачислятьАмортизацию", 0, ДатаДок);
УстановитьРеквизитСправочника(ОсновноеСредство, "Состояние", Перечисление.СостоянияОС.Выбыло, ДатаДок);
КонецЕсли;

КонецЦикла;
Операция.Записать();

КонецПроцедуры // ОбработкаПроведения()
"

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры