Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Проблема с заполнением табличной части
Волтос
Пост №1
Волтос
читатель
офлайн
Дата регистрации: 14.11.2006
Сообщений: 19
Пост №1
 
15.10.2007 10:06

"Здравствуйте. В 1С:Бухгалтерия 7.7 имеется документ. При нажатии кнопки "Заполнить" должна заполняться табличная часть и одновременно выводиться отчет. Проблема в том, что когда реквизит табличной части формы совпадает с именем ячейки в таблице отчета, наименование ОС перестает выводится. Вместо этого выводятся пустые ячейки.

Вот код процедуры:

Перем Ит, м, мв, итм, г, гт, мср;
Перем аморт10;
Перем оно65, оно175;
Перем Таб;
Перем бухнач, налнач;
Перем разн, уменьш65, уменьш175, сумманарит;
Перем итог;
//*******************************************
Процедура Заполнить()
       Ном=1;
амортпремит=0;
оно65ит=0;
оно175ит=0;
бухначит=0;
налначит=0;
разнит=0;
уменьш65ит=0;
уменьш175ит=0;

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ПовторятьПриПечатиСтроки(Таб.ВысотаСекции("Заголовок")+1,Таб.ВысотаСекции("Заголовок")+Таб.ВысотаСекции("Шапка"));
Таб.ВывестиСекцию("Заголовок");
Таб.ВывестиСекцию("Шапка");
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства,,,);
Ит.ВыполнитьЗапрос(Д1,Д2);

спрОС = СоздатьОбъект("Справочник.ОсновныеСредства");

спрОС.ВыбратьЭлементы();
Пока СпрОС.ПолучитьЭлемент() = 1 Цикл

ИнвНомер = спрОС.Код;
НаименованиеП= спрОС.Наименование;
ГодВВЭкспл = спрОС.ДатаВводаВЭксплуатацию;
БалансСтоимость = спрОС.ПервоначальнаяСтоимость.Получить(Д2);
сз=спрОС.СчетЗатрат.Получить(Д2);
СрокИсп=спрОС.СрокПолезногоИспользования.Получить(Д2);


аморт10=БалансСтоимость*10/100;
БалансСтоимостьН=БалансСтоимость-аморт10;
оно65=аморт10*6.5/100;
оно175=аморт10*17.5/100;
м=ДатаМесяц(Д2);
мв=ДатаМесяц(ГодВВЭкспл);
г=ДатаГод(ГодВВЭкспл);
гт=ДатаГод(Д2);
гд1=ДатаГод(Д1);
мд1=ДатаМесяц(Д1);
мт=ДатаМесяц(ТекущаяДата());
гс=ДатаГод(ТекущаяДата());
Если гт>г Тогда
итм=12-мв+м;
Иначе
итм=м-мв;
итог=(оно65+оно175);
КонецЕсли;
Если СрокИсп > 0 Тогда
бухнач=БалансСтоимость/СрокИсп;
налнач=БалансСтоимостьН/СрокИсп;
КонецЕсли;
разн=бухнач-налнач;
уменьш65=разн*6.5/100;
уменьш175=разн*17.5/100;
сумманарит=(Окр(уменьш65,2)+Окр(уменьш175,2))*итм;
Если м-мд1 > 0 Тогда
Если итог<>сумманарит Тогда
Если БалансСтоимость>=10000 Тогда
Если г>2005 Тогда
Если (Лев(сз,2) > "44") или (Лев(сз,2) < "44") Тогда      
Если г<=гт Тогда
Если ГодВВЭкспл>Д1 Тогда
Если (мв < м) Тогда
НоваяСтрока();
НомерПП=Ном;
ИнвНомер=ИнвНомер;
Наименование=НаименованиеП;
ВводВЭксплуатацию=ГодВВЭкспл;
СрокИсп=СрокИсп;
ПервНачСтоим=БалансСтоимость;
АмортПрем10=аморт10;
СтоимНалУч=БалансСтоимостьН;
ОНО65=оно65;
ОНО175=оно175;
СумНачБухУч=бухнач;
СумНачНалУч=налнач;
Разница=разн;
УменьшОНО65=уменьш65;
УменьшОНО175=уменьш175;
ОНО=сумманарит;


амортпремит=Окр(амортпремит+аморт10,2);
оно65ит=Окр(оно65ит+оно65,2);
оно175ит=Окр(оно175ит+оно175,2);
бухначит=Окр(бухначит+бухнач*(м-мв),2);
налначит=Окр(налначит+налнач*(м-мв),2);
разнит=Окр(разнит+разн,2);
уменьш65ит=Окр(уменьш65ит+уменьш65*(м-мв),2);
уменьш175ит=Окр(уменьш175ит+уменьш175*(м-мв),2);
КонецЕсли;
КонецЕсли;
КонецЕсли;
             КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

Иначе
Если итог<>сумманарит Тогда
Если БалансСтоимость>=10000 Тогда
Если г>2005 Тогда
Если (Лев(сз,2) > "44") или (Лев(сз,2) < "44") Тогда      
Если (мв = мд1-1) Тогда

НоваяСтрока();
НомерПП=Ном;
ИнвНомер=ИнвНомер;
Наименование=НаименованиеП;
ВводВЭксплуатацию=ГодВВЭкспл;
СрокИсп=СрокИсп;
ПервНачСтоим=БалансСтоимость;
АмортПрем10=аморт10;
СтоимНалУч=БалансСтоимостьН;
ОНО65=оно65;
ОНО175=оно175;
СумНачБухУч=бухнач;
СумНачНалУч=налнач;
Разница=разн;
УменьшОНО65=уменьш65;
УменьшОНО175=уменьш175;
ОНО=сумманарит;

амортпремит=амортпремит+аморт10;
             оно65ит=оно65ит+оно65;
оно175ит=оно175ит+оно175;
бухначит=бухначит+бухнач*(м-мв);
налначит=налначит+налнач*(м-мв);
разнит=разнит+разн;
уменьш65ит=уменьш65ит+уменьш65*(м-мв);
уменьш175ит=уменьш175ит+уменьш175*(м-мв);
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Пока ПолучитьСтроку() =1 Цикл
Таб.ВывестиСекцию("Строка");
Ном=Ном+1;
КонецЦикла;

Таб.ВывестиСекцию("Подвал");
Таб.ВывестиСекцию("Подписи");
Таб.ПараметрыСтраницы(2,50,1,10,10,10,0);
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,6,0);
Таб.Показать("Ведомость учета ОС");
КонецПроцедуры      "

 
Волтос
Пост №1
15.10.2007 10:06
 

"Здравствуйте. В 1С:Бухгалтерия 7.7 имеется документ. При нажатии кнопки "Заполнить" должна заполняться табличная часть и одновременно выводиться отчет. Проблема в том, что когда реквизит табличной части формы совпадает с именем ячейки в таблице отчета, наименование ОС перестает выводится. Вместо этого выводятся пустые ячейки.

Вот код процедуры:

Перем Ит, м, мв, итм, г, гт, мср;
Перем аморт10;
Перем оно65, оно175;
Перем Таб;
Перем бухнач, налнач;
Перем разн, уменьш65, уменьш175, сумманарит;
Перем итог;
//*******************************************
Процедура Заполнить()
       Ном=1;
амортпремит=0;
оно65ит=0;
оно175ит=0;
бухначит=0;
налначит=0;
разнит=0;
уменьш65ит=0;
уменьш175ит=0;

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ПовторятьПриПечатиСтроки(Таб.ВысотаСекции("Заголовок")+1,Таб.ВысотаСекции("Заголовок")+Таб.ВысотаСекции("Шапка"));
Таб.ВывестиСекцию("Заголовок");
Таб.ВывестиСекцию("Шапка");
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства,,,);
Ит.ВыполнитьЗапрос(Д1,Д2);

спрОС = СоздатьОбъект("Справочник.ОсновныеСредства");

спрОС.ВыбратьЭлементы();
Пока СпрОС.ПолучитьЭлемент() = 1 Цикл

ИнвНомер = спрОС.Код;
НаименованиеП= спрОС.Наименование;
ГодВВЭкспл = спрОС.ДатаВводаВЭксплуатацию;
БалансСтоимость = спрОС.ПервоначальнаяСтоимость.Получить(Д2);
сз=спрОС.СчетЗатрат.Получить(Д2);
СрокИсп=спрОС.СрокПолезногоИспользования.Получить(Д2);


аморт10=БалансСтоимость*10/100;
БалансСтоимостьН=БалансСтоимость-аморт10;
оно65=аморт10*6.5/100;
оно175=аморт10*17.5/100;
м=ДатаМесяц(Д2);
мв=ДатаМесяц(ГодВВЭкспл);
г=ДатаГод(ГодВВЭкспл);
гт=ДатаГод(Д2);
гд1=ДатаГод(Д1);
мд1=ДатаМесяц(Д1);
мт=ДатаМесяц(ТекущаяДата());
гс=ДатаГод(ТекущаяДата());
Если гт>г Тогда
итм=12-мв+м;
Иначе
итм=м-мв;
итог=(оно65+оно175);
КонецЕсли;
Если СрокИсп > 0 Тогда
бухнач=БалансСтоимость/СрокИсп;
налнач=БалансСтоимостьН/СрокИсп;
КонецЕсли;
разн=бухнач-налнач;
уменьш65=разн*6.5/100;
уменьш175=разн*17.5/100;
сумманарит=(Окр(уменьш65,2)+Окр(уменьш175,2))*итм;
Если м-мд1 > 0 Тогда
Если итог<>сумманарит Тогда
Если БалансСтоимость>=10000 Тогда
Если г>2005 Тогда
Если (Лев(сз,2) > "44") или (Лев(сз,2) < "44") Тогда      
Если г<=гт Тогда
Если ГодВВЭкспл>Д1 Тогда
Если (мв < м) Тогда
НоваяСтрока();
НомерПП=Ном;
ИнвНомер=ИнвНомер;
Наименование=НаименованиеП;
ВводВЭксплуатацию=ГодВВЭкспл;
СрокИсп=СрокИсп;
ПервНачСтоим=БалансСтоимость;
АмортПрем10=аморт10;
СтоимНалУч=БалансСтоимостьН;
ОНО65=оно65;
ОНО175=оно175;
СумНачБухУч=бухнач;
СумНачНалУч=налнач;
Разница=разн;
УменьшОНО65=уменьш65;
УменьшОНО175=уменьш175;
ОНО=сумманарит;


амортпремит=Окр(амортпремит+аморт10,2);
оно65ит=Окр(оно65ит+оно65,2);
оно175ит=Окр(оно175ит+оно175,2);
бухначит=Окр(бухначит+бухнач*(м-мв),2);
налначит=Окр(налначит+налнач*(м-мв),2);
разнит=Окр(разнит+разн,2);
уменьш65ит=Окр(уменьш65ит+уменьш65*(м-мв),2);
уменьш175ит=Окр(уменьш175ит+уменьш175*(м-мв),2);
КонецЕсли;
КонецЕсли;
КонецЕсли;
             КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

Иначе
Если итог<>сумманарит Тогда
Если БалансСтоимость>=10000 Тогда
Если г>2005 Тогда
Если (Лев(сз,2) > "44") или (Лев(сз,2) < "44") Тогда      
Если (мв = мд1-1) Тогда

НоваяСтрока();
НомерПП=Ном;
ИнвНомер=ИнвНомер;
Наименование=НаименованиеП;
ВводВЭксплуатацию=ГодВВЭкспл;
СрокИсп=СрокИсп;
ПервНачСтоим=БалансСтоимость;
АмортПрем10=аморт10;
СтоимНалУч=БалансСтоимостьН;
ОНО65=оно65;
ОНО175=оно175;
СумНачБухУч=бухнач;
СумНачНалУч=налнач;
Разница=разн;
УменьшОНО65=уменьш65;
УменьшОНО175=уменьш175;
ОНО=сумманарит;

амортпремит=амортпремит+аморт10;
             оно65ит=оно65ит+оно65;
оно175ит=оно175ит+оно175;
бухначит=бухначит+бухнач*(м-мв);
налначит=налначит+налнач*(м-мв);
разнит=разнит+разн;
уменьш65ит=уменьш65ит+уменьш65*(м-мв);
уменьш175ит=уменьш175ит+уменьш175*(м-мв);
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Пока ПолучитьСтроку() =1 Цикл
Таб.ВывестиСекцию("Строка");
Ном=Ном+1;
КонецЦикла;

Таб.ВывестиСекцию("Подвал");
Таб.ВывестиСекцию("Подписи");
Таб.ПараметрыСтраницы(2,50,1,10,10,10,0);
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,6,0);
Таб.Показать("Ведомость учета ОС");
КонецПроцедуры      "

 
N@talia
Пост №2
>>реквизит табличной части формы совпадает с имене...
15.10.2007 11:51
 
 
impuls
Пост №3
"Введите строку > Таб.ВывестиСекцию("Строка");в пр...
15.10.2007 13:13
 
 
Волтос
Пост №4
Нет! Так тоже не получается. Дело в том что он выв...
15.10.2007 15:15
 
 
Tanya
Пост №5
Проверьте что стоит в отчете у ячейки с "наименова...
15.10.2007 16:53
 
 
Волтос
Пост №6
У ячейки тип - выражение.Ладно. Ну с этим отчетом....
15.10.2007 17:21
 
 
Tanya
Пост №7
"Какой тип столбца в табличной части документа, су...
15.10.2007 18:43
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры