Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Excel+1C
antonn28
Пост №1
antonn28
читатель
офлайн
Дата регистрации: 01.10.2008
Сообщений: 6
Пост №1
 
01.10.2008 12:11

"Здравствуйте! Написал обработку по загрузке док-ов из XLS в 1С. но есть некоторые трудности.Код:

Код

Перем Лист, Путь, Excel, Файл;
//---------------------------------------
Процедура ВыборФайла()
Каталог = """";
Если ФС.ВыбратьФайл(0,ИмяФайла ,Каталог,"Выберите файл","*.xls|*.xls",,) = 1 Тогда
      ИмяФайла = Каталог + ИмяФайла;
КонецЕсли;
КонецПроцедуры
//-----------------------------------
Функция ПроверитьНаДату(ВыбДата)
Если ПустоеЗначение(выбДата)=1 Тогда
      Возврат 1;
КонецЕсли;
Если ПустоеЗначение(НачДата)=1 Тогда
      Возврат 1;
КонецЕсли;
Если ПустоеЗначение(КонДата)=1 Тогда
      Возврат 1;
КонецЕсли;
Если чкПериод=0 Тогда
      Возврат 1;
Иначе
      Если (ВыбДата>=НачДата) И (ВыбДата<=КонДата) Тогда
       Возврат 1;
      Иначе
       Возврат 0;
      КонецЕсли;
КонецЕсли;
КонецФункции
//------------------------------------
Процедура ПриСменечкПериод()
Форма.НачДата.Доступность(чкПериод);
Форма.КонДата.Доступность(чкПериод);
Форма.ВыбПериода.Доступность(чкПериод);
КонецПроцедуры
//-------------------------

Процедура Открыть()
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
      ЗапуститьПриложение(ИмяФайла);
Иначе
      Предупреждение("Указанный файл " +ИмяФайла+ " не существует!");
      
КонецЕсли;
КонецПроцедуры
//----------------------------------------------------
Процедура Загрузить()
Если ТЗ.КоличествоСтрок()>0 Тогда
      Если Вопрос("Таблица не пуста. Очистить ?",4)=6 Тогда
       ТЗ.УдалитьСтроки();
      КонецЕсли;
КонецЕсли;
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
      ОкноExcel = СоздатьОбъект("Excel.Application");
      ОкноExcel.Workbooks.Add(ИмяФайла);
      КолвоОшибок=0;
      Для Ном=1 По 10000 Цикл
       Состояние("Обрабатываем строку "+Ном);
       ВидДок=СокрЛП(ОкноExcel.Cells(Ном,1).Value);
       Если ПустаяСтрока(ВидДок)=1 Тогда
            КолвоОшибок=КолвоОшибок+1;
            Если КолвоОшибок=10 Тогда
             Прервать;
            КонецЕсли;
            Продолжить;
       Иначе
            КолвоОшибок=0;
       КонецЕсли;
       Если ВидДок<>"Бухсправка" Тогда
            Продолжить;
       КонецЕсли;
       ДДата = Дата(СокрЛП(ОкноExcel.Cells(Ном,3).Value));
       Если ПроверитьНаДату(ДДата)=0 Тогда
            Продолжить;
       КонецЕсли;
       ТЗ.НоваяСтрока();
       ТЗ.ФлагВкл=2;
       ТЗ.ВидДок=ВидДок;
       ТЗ.Номер=СокрЛП(ОкноExcel.Cells(Ном,2).Value);
       ТЗ.ДатаДок=ДДата;
       ТЗ.Содержание=СокрЛП(ОкноExcel.Cells(Ном,4).Value);
       ТЗ.Основание=СокрЛП(ОкноExcel.Cells(Ном,5).Value);
       ТЗ.Сумма=Число(СокрЛП(ОкноExcel.Cells(Ном,6).Value));
       ТЗ.Количество=Число(СокрЛП(ОкноExcel.Cells(Ном,7).Value));
       //------------------------------------------------------- счет дебета
       КорСчет = СокрЛП(ОкноExcel.Cells(Ном,8).Value);
       Если ПустоеЗначение(КорСчет)=0 Тогда
            Спр=СоздатьОбъект("Счет");
            Если Спр.НайтиПоКоду(КорСчет)=1 Тогда
             ТЗ.СчетДт=Спр.ТекущийСчет();
             // 1е субконто
            ЗС1=СокрЛП(ОкноExcel.Cells(Ном,9).Value);
             С1=ТЗ.СчетДт.ВидСубконто(1).Идентификатор();
             Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
                        Спр=СоздатьОбъект("Справочник."+С1);
                   Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                        ТЗ.СубконтоДт1=Спр.ТекущийЭлемент();
                        Иначе
                         Сообщить("Не найдено Субконто1 по наименованию "+ЗС1, "!");
                        КонецЕсли;
                   КонецЕсли;
            // 2е субконто
                  ЗС1=СокрЛП(ОкноExcel.Cells(Ном,10).Value);
                  С1=ТЗ.СчетДт.ВидСубконто(2).Идентификатор();
                  Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда                  
                        Спр=СоздатьОбъект("Справочник."+С1);
                        Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                         ТЗ.СубконтоДт2=Спр.ТекущийЭлемент();
                        Иначе
                         Сообщить("Не найдено Субконто2 по наименованию "+ЗС1, "!");
                        КонецЕсли;
                   КонецЕсли;
             // 3е субконто
             ЗС1=СокрЛП(ОкноExcel.Cells(Ном,11).Value);
             С1=ТЗ.СчетДт.ВидСубконто(1).Идентификатор();
             Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
                  Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                   ТЗ.СубконтоДт3=Спр.ТекущийЭлемент();                                                
                   Иначе
                        Сообщить("Не найдено Субконто3 по наименованию "+ЗС1, "!");
                   КонецЕсли;
                  КонецЕсли;
            Иначе
             Сообщить("Не найден счет "+КорСчет, "!");
            КонецЕсли;
       //------------------------------------------------------- КРЕДИТ
       КорСчет = СокрЛП(ОкноExcel.Cells(Ном,12).Value);
       Если ПустоеЗначение(КорСчет)=0 Тогда
            Спр=СоздатьОбъект("Счет");
            Если Спр.НайтиПоКоду(КорСчет)=1 Тогда
             ТЗ.СчетКт=Спр.ТекущийСчет();
             // 1е субконто
             ЗС1=СокрЛП(ОкноExcel.Cells(Ном,13).Value);
             С1=ТЗ.СчетКт.ВидСубконто(1).Идентификатор();
             Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
                  Спр=СоздатьОбъект("Справочник."+С1);
                   Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                        ТЗ.СубконтоКт1=Спр.ТекущийЭлемент();
                        Иначе
                         Сообщить("Не найдено Субконто1 по наименованию "+ЗС1, "!");
                   КонецЕсли;
             КонецЕсли;
             // 2е субконто
                  ЗС1=СокрЛП(ОкноExcel.Cells(Ном,14).Value);
                  С1=ТЗ.СчетКт.ВидСубконто(2).Идентификатор();
                  Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
                        Спр=СоздатьОбъект("Справочник."+С1);
                        Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                         ТЗ.СубконтоКт2=Спр.ТекущийЭлемент();
                        Иначе
                         Сообщить("Не найдено Субконто2 по наименованию "+ЗС1, "!");
                        КонецЕсли;
                   КонецЕсли;
             // 3е субконто
             ЗС1=СокрЛП(ОкноExcel.Cells(Ном,15).Value);
             С1=ТЗ.СчетКт.ВидСубконто(1).Идентификатор();
             Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда            
                  Спр=СоздатьОбъект("Справочник."+С1);
                   Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
                        ТЗ.СубконтоКт3=Спр.ТекущийЭлемент();
                   Иначе
                        Сообщить("Не найдено Субконто3 по наименованию "+ЗС1, "!");
                   КонецЕсли;
                  КонецЕсли;
            Иначе
             Сообщить("Не найден счет "+КорСчет, "!");
            КонецЕсли;
       КонецЕсли;
       КонецЕсли;
КонецЦикла;
       КонецЕсли;
      ОкноExcel.Workbooks.Close();
      ОкноExcel.DisplayAlerts = 0;
      ОкноExcel.Quit();
      Предупреждение("Загрузка из файла закончена !" ,10);
КонецПроцедуры // СформироватьСправку
//-----------------------------------------------
Процедура ПриОткрытии()
ТЗ.НоваяКолонка("ВидДок","Строка",,,"Вид",5,);
ТЗ.НоваяКолонка("ФлагВкл","Число",1,,"""",3,);
ТЗ.НоваяКолонка("Номер","Строка",10,,,10,);
ТЗ.НоваяКолонка("ДатаДок","Дата",,,"Дата",9,);
ТЗ.НоваяКолонка("Сумма","Число",15,2,"Сумма",9,);
ТЗ.НоваяКолонка("Количество","Число",10,3,"Кол-во",8,);
ТЗ.НоваяКолонка("Основание","Строка",50,,"Осн.",10,);
ТЗ.НоваяКолонка("Содержание","Строка",50,,"Сод.проводки",10,);
ТЗ.НоваяКолонка("СчетДт",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт1",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт2",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт3",,,,,,);
ТЗ.НоваяКолонка("СчетКт",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт1",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт2",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт3",,,,,,);
ТЗ.ВыводитьПиктограммы("ФлагВкл");
ВидДокумента.ДобавитьЗначение(1,"Бухгалтерская справка");
Конфа.ДобавитьЗначение(1, "Бухгалтерия");
КонецПРоцедуры
//-------------------------------------
Процедура КлиКНаТЗ()
Если ТЗ.ТекущаяСтрока()>0 Тогда
      Если ТЗ.ФлагВкл=1 Тогда
       ТЗ.ФлагВкл=2;
      Иначе
       ТЗ.ФлагВкл=1;
      КонецЕсли;
КонецЕсли;
КонецПроцедуры //КлиКНаТЗ
//-------------------------------------------------------
Процедура Создать()
Док = СоздатьОбъект("Документ.БухгалтерскаяСправка");
Док.Новый();
ТЗ.ВыбратьСтроки();
Пока Тз.ПолучитьСтроку()=1 Цикл
      Док.НоваяСтрока();
      Док.Сумма=ТЗ.Сумма;
      Док.Количество=ТЗ.Количество;
      Док.Основание=ТЗ.Основание;
      Док.Содержание=ТЗ.Содержание;
      Док.СчетДт=ТЗ.СчетДт;
      Док.СчетКт=ТЗ.СчетКт;
      Для КК=1 по 3 Цикл
      Док.НазначитьТип("СубконтоДт"+КК,ТЗ.СчетДт.ВидСубконто(КК));      
      Док.НазначитьТип("СубконтоКт"+КК,ТЗ.СчетКт.ВидСубконто(КК));
      КонецЦикла;
      Док.ЮрЛицо=ТЗ.СубконтоДТ3;
      Док.СубконтоДт1=ТЗ.СубконтоДТ1;
      Док.СубконтоДт2=Тз.СубконтоДт2;
      Док.СубконтоДт3=ТЗ.СубконтоДт3;
      Док.СубконтоКт1=ТЗ.СубконтоКт1;
      Док.СубконтоКт2=ТЗ.СубконтоКт2;
      Док.СубконтоКт3=ТЗ.СубконтоКт3;
      Док.Записать();
КонецЦикла;
КонецПроцедуры

Трудность заключается в том,что в док-те 1С не выводятся данные по СубконтоДт3. За раннее благодарен!






"

 
antonn28
Пост №1
01.10.2008 12:11
 

"Здравствуйте! Написал обработку по загрузке док-ов из XLS в 1С. но есть некоторые трудности.Код:
[CODE]
Перем Лист, Путь, Excel, Файл;
//---------------------------------------
Процедура ВыборФайла()
Каталог = """";
Если ФС.ВыбратьФайл(0,ИмяФайла ,Каталог,"Выберите файл","*.xls|*.xls",,) = 1 Тогда
ИмяФайла = Каталог + ИмяФайла;
КонецЕсли;
КонецПроцедуры
//-----------------------------------
Функция ПроверитьНаДату(ВыбДата)
Если ПустоеЗначение(выбДата)=1 Тогда
Возврат 1;
КонецЕсли;
Если ПустоеЗначение(НачДата)=1 Тогда
Возврат 1;
КонецЕсли;
Если ПустоеЗначение(КонДата)=1 Тогда
Возврат 1;
КонецЕсли;
Если чкПериод=0 Тогда
Возврат 1;
Иначе
Если (ВыбДата>=НачДата) И (ВыбДата<=КонДата) Тогда
Возврат 1;
Иначе
Возврат 0;
КонецЕсли;
КонецЕсли;
КонецФункции
//------------------------------------
Процедура ПриСменечкПериод()
Форма.НачДата.Доступность(чкПериод);
Форма.КонДата.Доступность(чкПериод);
Форма.ВыбПериода.Доступность(чкПериод);
КонецПроцедуры
//-------------------------

Процедура Открыть()
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
ЗапуститьПриложение(ИмяФайла);
Иначе
Предупреждение("Указанный файл " +ИмяФайла+ " не существует!");

КонецЕсли;
КонецПроцедуры
//----------------------------------------------------
Процедура Загрузить()
Если ТЗ.КоличествоСтрок()>0 Тогда
Если Вопрос("Таблица не пуста. Очистить ?",4)=6 Тогда
ТЗ.УдалитьСтроки();
КонецЕсли;
КонецЕсли;
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
ОкноExcel = СоздатьОбъект("Excel.Application");
ОкноExcel.Workbooks.Add(ИмяФайла);
КолвоОшибок=0;
Для Ном=1 По 10000 Цикл
Состояние("Обрабатываем строку "+Ном);
ВидДок=СокрЛП(ОкноExcel.Cells(Ном,1).Value);
Если ПустаяСтрока(ВидДок)=1 Тогда
КолвоОшибок=КолвоОшибок+1;
Если КолвоОшибок=10 Тогда
Прервать;
КонецЕсли;
Продолжить;
Иначе
КолвоОшибок=0;
КонецЕсли;
Если ВидДок<>"Бухсправка" Тогда
Продолжить;
КонецЕсли;
ДДата = Дата(СокрЛП(ОкноExcel.Cells(Ном,3).Value));
Если ПроверитьНаДату(ДДата)=0 Тогда
Продолжить;
КонецЕсли;
ТЗ.НоваяСтрока();
ТЗ.ФлагВкл=2;
ТЗ.ВидДок=ВидДок;
ТЗ.Номер=СокрЛП(ОкноExcel.Cells(Ном,2).Value);
ТЗ.ДатаДок=ДДата;
ТЗ.Содержание=СокрЛП(ОкноExcel.Cells(Ном,4).Value);
ТЗ.Основание=СокрЛП(ОкноExcel.Cells(Ном,5).Value);
ТЗ.Сумма=Число(СокрЛП(ОкноExcel.Cells(Ном,6).Value));
ТЗ.Количество=Число(СокрЛП(ОкноExcel.Cells(Ном,7).Value));
//------------------------------------------------------- счет дебета
КорСчет = СокрЛП(ОкноExcel.Cells(Ном,8).Value);
Если ПустоеЗначение(КорСчет)=0 Тогда
Спр=СоздатьОбъект("Счет");
Если Спр.НайтиПоКоду(КорСчет)=1 Тогда
ТЗ.СчетДт=Спр.ТекущийСчет();
// 1е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,9).Value);
С1=ТЗ.СчетДт.ВидСубконто(1).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Спр=СоздатьОбъект("Справочник."+С1);
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоДт1=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто1 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
// 2е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,10).Value);
С1=ТЗ.СчетДт.ВидСубконто(2).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Спр=СоздатьОбъект("Справочник."+С1);
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоДт2=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто2 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
// 3е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,11).Value);
С1=ТЗ.СчетДт.ВидСубконто(1).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоДт3=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто3 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
Иначе
Сообщить("Не найден счет "+КорСчет, "!");
КонецЕсли;
//------------------------------------------------------- КРЕДИТ
КорСчет = СокрЛП(ОкноExcel.Cells(Ном,12).Value);
Если ПустоеЗначение(КорСчет)=0 Тогда
Спр=СоздатьОбъект("Счет");
Если Спр.НайтиПоКоду(КорСчет)=1 Тогда
ТЗ.СчетКт=Спр.ТекущийСчет();
// 1е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,13).Value);
С1=ТЗ.СчетКт.ВидСубконто(1).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Спр=СоздатьОбъект("Справочник."+С1);
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоКт1=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто1 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
// 2е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,14).Value);
С1=ТЗ.СчетКт.ВидСубконто(2).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Спр=СоздатьОбъект("Справочник."+С1);
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоКт2=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто2 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
// 3е субконто
ЗС1=СокрЛП(ОкноExcel.Cells(Ном,15).Value);
С1=ТЗ.СчетКт.ВидСубконто(1).Идентификатор();
Если (СокрЛП(С1)<>"""") И (ЗС1<>"""") Тогда
Спр=СоздатьОбъект("Справочник."+С1);
Если Спр.НайтиПоНаименованию(ЗС1,0,1)=1 Тогда
ТЗ.СубконтоКт3=Спр.ТекущийЭлемент();
Иначе
Сообщить("Не найдено Субконто3 по наименованию "+ЗС1, "!");
КонецЕсли;
КонецЕсли;
Иначе
Сообщить("Не найден счет "+КорСчет, "!");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
ОкноExcel.Workbooks.Close();
ОкноExcel.DisplayAlerts = 0;
ОкноExcel.Quit();
Предупреждение("Загрузка из файла закончена !" ,10);
КонецПроцедуры // СформироватьСправку
//-----------------------------------------------
Процедура ПриОткрытии()
ТЗ.НоваяКолонка("ВидДок","Строка",,,"Вид",5,);
ТЗ.НоваяКолонка("ФлагВкл","Число",1,,"""",3,);
ТЗ.НоваяКолонка("Номер","Строка",10,,,10,);
ТЗ.НоваяКолонка("ДатаДок","Дата",,,"Дата",9,);
ТЗ.НоваяКолонка("Сумма","Число",15,2,"Сумма",9,);
ТЗ.НоваяКолонка("Количество","Число",10,3,"Кол-во",8,);
ТЗ.НоваяКолонка("Основание","Строка",50,,"Осн.",10,);
ТЗ.НоваяКолонка("Содержание","Строка",50,,"Сод.проводки",10,);
ТЗ.НоваяКолонка("СчетДт",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт1",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт2",,,,,,);
ТЗ.НоваяКолонка("СубконтоДт3",,,,,,);
ТЗ.НоваяКолонка("СчетКт",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт1",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт2",,,,,,);
ТЗ.НоваяКолонка("СубконтоКт3",,,,,,);
ТЗ.ВыводитьПиктограммы("ФлагВкл");
ВидДокумента.ДобавитьЗначение(1,"Бухгалтерская справка");
Конфа.ДобавитьЗначение(1, "Бухгалтерия");
КонецПРоцедуры
//-------------------------------------
Процедура КлиКНаТЗ()
Если ТЗ.ТекущаяСтрока()>0 Тогда
Если ТЗ.ФлагВкл=1 Тогда
ТЗ.ФлагВкл=2;
Иначе
ТЗ.ФлагВкл=1;
КонецЕсли;
КонецЕсли;
КонецПроцедуры //КлиКНаТЗ
//-------------------------------------------------------
Процедура Создать()
Док = СоздатьОбъект("Документ.БухгалтерскаяСправка");
Док.Новый();
ТЗ.ВыбратьСтроки();
Пока Тз.ПолучитьСтроку()=1 Цикл
Док.НоваяСтрока();
Док.Сумма=ТЗ.Сумма;
Док.Количество=ТЗ.Количество;
Док.Основание=ТЗ.Основание;
Док.Содержание=ТЗ.Содержание;
Док.СчетДт=ТЗ.СчетДт;
Док.СчетКт=ТЗ.СчетКт;
Для КК=1 по 3 Цикл
Док.НазначитьТип("СубконтоДт"+КК,ТЗ.СчетДт.ВидСубконто(КК));
Док.НазначитьТип("СубконтоКт"+КК,ТЗ.СчетКт.ВидСубконто(КК));
КонецЦикла;
Док.ЮрЛицо=ТЗ.СубконтоДТ3;
Док.СубконтоДт1=ТЗ.СубконтоДТ1;
Док.СубконтоДт2=Тз.СубконтоДт2;
Док.СубконтоДт3=ТЗ.СубконтоДт3;
Док.СубконтоКт1=ТЗ.СубконтоКт1;
Док.СубконтоКт2=ТЗ.СубконтоКт2;
Док.СубконтоКт3=ТЗ.СубконтоКт3;
Док.Записать();
КонецЦикла;
КонецПроцедуры
[/CODE]
Трудность заключается в том,что в док-те 1С не выводятся данные по СубконтоДт3. За раннее благодарен!






"

 
ElenaV
Пост №2
"// 3е субконтоЗС1=СокрЛП(ОкноExcel.Cells(Ном,11)....
01.10.2008 15:38
 
 
antonn28
Пост №3
Исправил,не помогает!
02.10.2008 04:47
 
 
buh88
Пост №4
Вобщем-то все просто - нужно смотреть в отладчике ...
02.10.2008 10:52
 
 
antonn28
Пост №5
Прогонял уже несколько раз,просто обработка не бер...
02.10.2008 10:56
 
 
buh88
Пост №6
"Все таки СубконтоДт1 или СубконтоДт3?Ставите бре...
02.10.2008 11:17
 
 
antonn28
Пост №7
"// 1е субконто ЗС1=СокрЛП(ОкноExcel.Cells(Ном...
02.10.2008 11:20
 
 
antonn28
Пост №8
Если ставлю брекпоинт на 3-е СубконтоДт3то ЗС1="Ра...
02.10.2008 11:23
 
 
antonn28
Пост №9
Так все проблему с Субконто решил,теперь хочу испр...
02.10.2008 11:46
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры