Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Проблема с 1с, кафе-бар
_LexA1987_
Пост №1
_LexA1987_
читатель
офлайн
Дата регистрации: 22.07.2009
Сообщений: 10
Пост №1
 
22.07.2009 21:54

"Стоит 1с 7.70.027, Кафе-Бар. При закрытии стола высвечивает ошибку:

Регистр.Деньги.ДвижениеПриходВыполнить();
{Документ.Заказ.Модуль Документа(14)}: Движения регистров не могут выполняться у данного объекта.

и стол не закрывается.
Вот код:

Процедура ОбработкаПроведения()



ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Если СокрЛП(Продукт.Подразделение) = "БАР-2" Тогда
Регистр.Деньги.СуммаБар2 = СуммаСоСкидкой;
Иначе
Регистр.Деньги.Сумма = СуммаСоСкидкой;
КонецЕсли;
Регистр.Деньги.Статья = Константа.ОсновнаяДеятельность;
Регистр.Деньги.Официант = Официант;
Регистр.Деньги.ДвижениеПриходВыполнить();
КонецЦикла;
Константа.ДокументОткрыт = 0;


//Списание
ВыбратьСтроки();
Спр = СоздатьОбъект("Справочник.КалькуляционнаяКарта");
Пока ПолучитьСтроку() = 1 Цикл
Спр.ИспользоватьВладельца(Продукт);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.ПометкаУдаления() = 0 Тогда
Регистр.ДвижениеТоваров.Ингридиент = Спр.Ингридиент;
Регистр.ДвижениеТоваров.Подразделение = Продукт.Подразделение;
Регистр.ДвижениеТоваров.Количество = Спр.Брутто*Кво;
Регистр.ДвижениеТоваров.Продукт = Продукт;
Регистр.ДвижениеТоваров.ДвижениеРасходВыполнить();
КонецЕсли;
КонецЦикла;
КонецЦикла




КонецПроцедуры"

 
_LexA1987_
Пост №1
22.07.2009 21:54
 

"Стоит 1с 7.70.027, Кафе-Бар. При закрытии стола высвечивает ошибку:

Регистр.Деньги.ДвижениеПриходВыполнить();
{Документ.Заказ.Модуль Документа(14)}: Движения регистров не могут выполняться у данного объекта.

и стол не закрывается.
Вот код:

Процедура ОбработкаПроведения()



ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Если СокрЛП(Продукт.Подразделение) = "БАР-2" Тогда
Регистр.Деньги.СуммаБар2 = СуммаСоСкидкой;
Иначе
Регистр.Деньги.Сумма = СуммаСоСкидкой;
КонецЕсли;
Регистр.Деньги.Статья = Константа.ОсновнаяДеятельность;
Регистр.Деньги.Официант = Официант;
Регистр.Деньги.ДвижениеПриходВыполнить();
КонецЦикла;
Константа.ДокументОткрыт = 0;


//Списание
ВыбратьСтроки();
Спр = СоздатьОбъект("Справочник.КалькуляционнаяКарта");
Пока ПолучитьСтроку() = 1 Цикл
Спр.ИспользоватьВладельца(Продукт);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.ПометкаУдаления() = 0 Тогда
Регистр.ДвижениеТоваров.Ингридиент = Спр.Ингридиент;
Регистр.ДвижениеТоваров.Подразделение = Продукт.Подразделение;
Регистр.ДвижениеТоваров.Количество = Спр.Брутто*Кво;
Регистр.ДвижениеТоваров.Продукт = Продукт;
Регистр.ДвижениеТоваров.ДвижениеРасходВыполнить();
КонецЕсли;
КонецЦикла;
КонецЦикла




КонецПроцедуры"

 
Денис (САМАРА)
Пост №2
http://img521.imageshack.us/i/48843223.jpg/
23.07.2009 08:16
 
 
_LexA1987_
Пост №3
не могу найти такого у себя :(Где смотреть? http:/...
23.07.2009 16:31
 
 
Prikum
Пост №4
2 раза быстро щелкнуть левой кнопкой мыши на нужно...
23.07.2009 16:40
 
 
_LexA1987_
Пост №5
это то я знаю)я не знаю в каком документе, все обм...
23.07.2009 17:13
 
 
Prikum
Пост №6
Ничего не напоминает :> Документ.Заказ.Модуль Доку...
23.07.2009 17:14
 
 
_LexA1987_
Пост №7
Я так понял что у меня не стоит компонента "Операт...
23.07.2009 18:00
 
 
zak555 (398843952)
Пост №8
в папке платформы есть файл trade.dll ?
23.07.2009 18:08
 
 
_LexA1987_
Пост №9
нет
23.07.2009 18:09
 
 
zak555 (398843952)
Пост №10
дистрибутив есть 1с ?
23.07.2009 18:11
 
 
_LexA1987_
Пост №11
Да. 1с:Предприятие.1с:Бухгалтерия 7.7 ПРОФ для Укр...
23.07.2009 18:12
 
 
_LexA1987_
Пост №12
Суть в том, что с него и ставилось, а он при инста...
23.07.2009 18:30
 
 
Prikum
Пост №13
Купить надо торговлю и склад, все остальное здесь ...
23.07.2009 20:14
 
 
_LexA1987_
Пост №14
"Побился головой о стену. Взял в bin файлик lckls....
23.07.2009 20:18
 
 
Thorvardr
Пост №15
Ну вы даете... переименовали какой то файл и думае...
23.07.2009 21:14
 
 
IceBeerg
Пост №16
Не нужно этого ничего делать, если ключом поддержи...
24.07.2009 10:36
 
 
_LexA1987_
Пост №17
Суть в том, что без оперативного учёта "кафе-бар-р...
24.07.2009 12:17
 
 
Thorvardr
Пост №18
"Суть в том, что без оперативного учёта "кафе-бар-...
24.07.2009 13:17
 
 
Prikum
Пост №19
Похоже на Рарус!
24.07.2009 13:25
 
 
Thorvardr
Пост №20
Да, похоже, но у Раруса название "Ресторан, Бар, К...
24.07.2009 13:34
 
 
_LexA1987_
Пост №21
чень может быть что и оно, ибо только компонента Б...
24.07.2009 18:34
 
 
Prikum
Пост №22
Тебе же уже ответили на этот вопрос? У тебя не уст...
24.07.2009 21:14
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры