Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] 1с 7.7 Бухгалтерия Подскажите как заполнить значениями таблицу Печатной формы?
Leonardo2009
Пост №1
Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №1
 
12.08.2009 14:59

"Сделал отчет "Возврат товаров", все данные получены, но встал вопрос каким методом их заполнить в таблицу.

вот код отчета:
Процедура Выполнить()

Док=СоздатьОбъект("Документ.РасходнаяНакладная");
Док.ВыбратьДокументы(Дата1,Дата2);

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("""");            
Таб.ВывестиСекцию("Шапка");

Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ВозвратГП=1 Тогда
ДатаПер=Док.ПолучитьАтрибут("ДатаДок");
НомерДока=Док.ПолучитьАтрибут("НомерДок");
Контр=Док.ПолучитьАтрибут("Контрагент");
Док.ВыбратьСтроки();
Если Док.КоличествоСтрок()>0 Тогда
Пока Док.ПолучитьСтроку()=1 Цикл

Тов=Док.ПолучитьАтрибут("Товар");
Км=Док.ПолучитьАтрибут("Количество");
К=Км*(-1);
Таб.ВывестиСекцию("Строка|Строка1");

КонецЦикла;
КонецЕсли;
КонецЕсли;


КонецЦикла;
// Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.Показать("""");

КонецПроцедуры

таблица должна иметь следующий вид.
       | товар | товар | товар | товар | товар
контрагент число число ... ... ...
контрагент ... ... ... ... ...
контрагент ... ... ... ... ...

Если кто знает подскажите, оч. буду благодарен."

 
Leonardo2009
Пост №1
12.08.2009 14:59
 

"Сделал отчет "Возврат товаров", все данные получены, но встал вопрос каким методом их заполнить в таблицу.

вот код отчета:
Процедура Выполнить()

Док=СоздатьОбъект("Документ.РасходнаяНакладная");
Док.ВыбратьДокументы(Дата1,Дата2);

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("""");            
Таб.ВывестиСекцию("Шапка");

Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ВозвратГП=1 Тогда
ДатаПер=Док.ПолучитьАтрибут("ДатаДок");
НомерДока=Док.ПолучитьАтрибут("НомерДок");
Контр=Док.ПолучитьАтрибут("Контрагент");
Док.ВыбратьСтроки();
Если Док.КоличествоСтрок()>0 Тогда
Пока Док.ПолучитьСтроку()=1 Цикл

Тов=Док.ПолучитьАтрибут("Товар");
Км=Док.ПолучитьАтрибут("Количество");
К=Км*(-1);
Таб.ВывестиСекцию("Строка|Строка1");

КонецЦикла;
КонецЕсли;
КонецЕсли;


КонецЦикла;
// Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.Показать("""");

КонецПроцедуры

таблица должна иметь следующий вид.
       | товар | товар | товар | товар | товар
контрагент число число ... ... ...
контрагент ... ... ... ... ...
контрагент ... ... ... ... ...

Если кто знает подскажите, оч. буду благодарен."

 
Prikum
Пост №2
Трудности то в чем?
12.08.2009 15:26
 
 
Leonardo2009
Пост №3
Тудность в том что номенклатуры много, нужно чтобы...
12.08.2009 16:29
 
 
Prikum
Пост №4
Есть такое дело, как конструктор запросов, в том ч...
12.08.2009 16:33
 
 
Leonardo2009
Пост №5
"С помощью макета печатных форм получилось=>код:Пр...
12.08.2009 20:28
 
 
zak555 (398843952)
Пост №6
делай запросом!пришли скрин макета в конфигураторе...
13.08.2009 10:56
 
 
Leonardo2009
Пост №7
Куда тебе прислать???
13.08.2009 11:07
 
 
zak555 (398843952)
Пост №8
> Куда тебе прислать???ссуда нельзя ссылку на radi...
13.08.2009 11:53
 
 
Leonardo2009
Пост №9
http://s39.radikal.ru/i085/0908/6b/ce5882fdfede.pn...
13.08.2009 12:05
 
 
zak555 (398843952)
Пост №10
кстати обычным запрос кажись не так просто...а поч...
13.08.2009 13:39
 
 
Leonardo2009
Пост №11
А зачем? у меня не возникло проблем с получением д...
13.08.2009 13:48
 
 
zak555 (398843952)
Пост №12
> > но должно быть так:> > Номенклат...
13.08.2009 14:13
 
 
zak555 (398843952)
Пост №13
"а вот сам текст:Процедура Сформировать() Перем За...
13.08.2009 14:14
 
 
Leonardo2009
Пост №14
Ты на самом деле мозг, мне еще многому надо учитьс...
13.08.2009 14:41
 
 
zak555 (398843952)
Пост №15
> Ты на самом деле мозг, мне еще многому надо учит...
13.08.2009 14:44
 
 
Leonardo2009
Пост №16
Сам запрос с помощью конструктора тоже составлял, ...
13.08.2009 14:52
 
 
zak555 (398843952)
Пост №17
> Сам запрос с помощью конструктора тоже составлял...
13.08.2009 14:56
 
 
Leonardo2009
Пост №18
1. В личку напиши номер телефона, в благодарность ...
13.08.2009 18:34
 
 
zak555 (398843952)
Пост №19
"> 1. В личку напиши номер телефона, в благодарнос...
14.08.2009 10:44
 
 
zak555 (398843952)
Пост №20
"если док хочешь, замени строку|Контрагент = Докум...
14.08.2009 11:00
 
 
Leonardo2009
Пост №21
Получилось, только я все равно во второй половине ...
14.08.2009 12:34
 
 
zak555 (398843952)
Пост №22
Запрос.Сумма_ или что-то другое?
14.08.2009 13:26
 
 
Leonardo2009
Пост №23
В самом низу чтобы выводился итог под каждым товар...
14.08.2009 13:33
 
 
zak555 (398843952)
Пост №24
> В самом низу чтобы выводился итог под каждым тов...
14.08.2009 13:51
 
 
Leonardo2009
Пост №25
> 1. или группировку местами меняй> 2. или проще с...
17.08.2009 14:48
 
 
zak555 (398843952)
Пост №26
"> З.Ы. Тел получил, в понедельник закину.что-то н...
17.08.2009 14:51
 
 
Leonardo2009
Пост №27
еще рабочий день не кончился)
17.08.2009 14:53
 
 
zak555 (398843952)
Пост №28
"> > 1. или группировку местами меняй> > 2. или пр...
17.08.2009 14:59
 
 
zak555 (398843952)
Пост №29
"> еще рабочий день не кончился)по-моему следующий...
18.08.2009 06:09
 
 
Leonardo2009
Пост №30
я тебе закинул 100р еще вчера!
18.08.2009 06:16
 
 
zak555 (398843952)
Пост №31
"> я тебе закинул 100р еще вчера!а я и не заметил ...
18.08.2009 06:50
 
 
Leonardo2009
Пост №32
нет не получается никак, че то я не могу разобрать...
18.08.2009 06:59
 
 
zak555 (398843952)
Пост №33
> нет не получается никак, че то я не могу разобра...
18.08.2009 07:18
 
 
Leonardo2009
Пост №34
> > нет не получается никак, че то я не могу разоб...
18.08.2009 07:21
 
 
zak555 (398843952)
Пост №35
держи >>> http://slil.ru/27908951
18.08.2009 10:36
 
 
zak555 (398843952)
Пост №36
"а вот и сам текстПроцедура Сформировать() Перем З...
18.08.2009 10:37
 
 
zak555 (398843952)
Пост №37
теперь-то разобрался?
18.08.2009 11:20
 
 
zak555 (398843952)
Пост №38
ну так то или не то?
18.08.2009 15:17
 
 
1108
Пост №39
А как сделать такой же отбор, только чтобы рядом с...
20.04.2010 19:56
 
 
zak555 (398843952)
Пост №40
> А как сделать такой же отбор, только чтобы рядом...
20.04.2010 22:22
 
 
1108
Пост №41
"Сумма - колонка из табличной части документа расх...
20.04.2010 23:56
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры