Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Как прописать покороче отчет
177
Пост №1
177
читатель
офлайн
Дата регистрации: 07.05.2008
Сообщений: 470
Пост №1
 
19.08.2009 10:37

"Пишу отчет в ПУБе 7.7 по трудозатратам на готовую продукцию, т.е.мы выбираем готовую продукцию и по ней должны выбрать все тех операциикоторые даже входят в полуфабрикаты, а эти полуфабрикаты тоже состоят из полуфабрикатов.Подскажите как прописать правильно чтобы отследить все техОперации до конечных полуфабрикатов, я кое-что накидала, но с такой писаниной можно писать до бесконечности, если кто может подскажите какая команда мне поможет, я пробовала ВключатьПодчиненные, но я ей не правильно воспользовалась и результата нет, посмотрите подскажите, СПАСИБО.
перем ПояснениеПоНоменклатуре;
перем Колво;
//*******************************************


//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//если выбрали
Если ВыбНоменклатура.Выбран()=1 Тогда
ИтогоТ = 0;
Запрос2 = СоздатьОбъект("Запрос");
//здесь мы находим количество для выполнения плана продаж на месяц
ТекстЗапроса = "С ВыбНачПериода по ВыбКонПериода;
|Номенклатура =Регистр.План.Номенклатура;
|Количество = регистр.План.Количество;
|Функция КолвоС = НачОст(Количество);
|Условие (Номенклатура = ВыбНоменклатура);
|Группировка Номенклатура;
|"
;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Если Запрос2.Выполнить(ТекстЗапроса) = 0 тогда
Сообщить("Ошибка выполнения запроса");
СтатусВозврата(0);
Возврат;
КонецЕсли;

Пока Запрос2.Группировка(1) = 1 Цикл
Номенклатура = Запрос2.Номенклатура;
Артикул = Номенклатура.Артикул;
КолП = Запрос2.КолвоС;
//выводим саму продукцию или выбранную номенклатуру
Таб.ВывестиСекцию("Номенклатура");
//здесь по выбранной номенклатуре выбираем техоперации
СпрНР = СоздатьОбъект("Справочник.НормыРасходов");
СпрНР.ИспользоватьВладельца(Запрос2.Номенклатура);
СпрНР.ВыбратьЭлементы();
Пока СпрНр.ПолучитьЭлемент() = 1 Цикл
//проверка на тех операции, чтобы отбросить ненужные данные
Если СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.ТехОперация Тогда
Продукция = СпрНР.Владелец;
Работа = СпрНР.Элемент;
Норма = СпрНР.Норма.Получить(ВыбКонПериода);;
Стоимость = СпрНР.Стоимость.Получить(ВыбКонПериода);
//СОЗДАЕМ ЗАПРОС ДЛЯ ПОИСКА ОСТАТКА ПО РАНЕЕ ПОЛУЧЕНОЙ ТехОперации т.е. её оприходовали
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(про)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Наименование = Регистр.Работа.Наименование;
|Количество = Регистр.Работа.Количество;
|Цена = Регистр.Работа.Цена;
|Функция КолвоКонОст = КонОст(Количество);
|Функция ЦенаКонОст = КонОст(Цена);
|Условие(Наименование = Работа.ТекущийЭлемент());
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

КолвоО = Запрос.КолвоКонОст;
ЦенаО = Запрос.ЦенаКонОст;
ИтогоО = Окр(КолвоО * ЦенаО,2);
КолвоТ = Окр((Норма * КолП)-КолвоО,2);
СуммаТ = Окр(КолвоТ * Стоимость,2);
ИтогоТ = ИтогоТ + СуммаТ;
//выводим саму работу
Таб.ВывестиСекцию("Работа");
//проверяем есть ли в спецификации полуфабрикаты
ИначеЕсли СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Полуфабрикат Тогда
Полуфабрикат = СпрНР.Элемент;
ЗапросПолуфабрикат = СоздатьОбъект("Запрос");
//проверяем есть ли она в плане продаж
ТекстЗапроса = "С ВыбНачПериода по ВыбКонПериода;
|Номенклатура =Регистр.План.Номенклатура;
|Количество = регистр.План.Количество;
|Функция КолвоС = НачОст(Количество);
|Условие (Номенклатура = Полуфабрикат.ТекущийЭлемент());
|Группировка Номенклатура;
|"
;
Если ЗапросПолуфабрикат.Выполнить(ТекстЗапроса) = 0 тогда
Сообщить("Ошибка выполнения запроса");
СтатусВозврата(0);
Возврат;
КонецЕсли;

Пока ЗапросПолуфабрикат.Группировка(1) = 1 Цикл
Полуфабрикат1 = ЗапросПолуфабрикат.Номенклатура;
Артикул = Полуфабрикат.Артикул;
КолвоП = ЗапросПолуфабрикат.КолвоС;
//выводим полуфабрикат
Таб.ВывестиСекцию("Полуфабрикат");
СпрНР.использоватьВладельца(Полуфабрикат);
СпрНР.ВыбратьЭлементы();
Пока СпрНР.ПолучитьЭлемент()=1 Цикл
Если СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.ТехОпреация Тогда
Полуфабрикат2 = СпрНР.СпрНР.Владелец;
Артикул = Полуфабрикат2.Артикул;
РаботаП = СпрНР.Элемент;///и получается в таком духе до бесконечности
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЕсли;


ПояснениеПоНоменклатуре = " Для выполнения плана в размере "+КолП+" шт. по продукции "+"*"+Номенклатура+"*" + " потребуется "+ИтогоТ+"руб" ;
Таб.ВывестиСекцию("Итого");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", """");
КонецПроцедуры
"

 
177
Пост №1
19.08.2009 10:37
 

"Пишу отчет в ПУБе 7.7 по трудозатратам на готовую продукцию, т.е.мы выбираем готовую продукцию и по ней должны выбрать все тех операциикоторые даже входят в полуфабрикаты, а эти полуфабрикаты тоже состоят из полуфабрикатов.Подскажите как прописать правильно чтобы отследить все техОперации до конечных полуфабрикатов, я кое-что накидала, но с такой писаниной можно писать до бесконечности, если кто может подскажите какая команда мне поможет, я пробовала ВключатьПодчиненные, но я ей не правильно воспользовалась и результата нет, посмотрите подскажите, СПАСИБО.
перем ПояснениеПоНоменклатуре;
перем Колво;
//*******************************************


//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//если выбрали
Если ВыбНоменклатура.Выбран()=1 Тогда
ИтогоТ = 0;
Запрос2 = СоздатьОбъект("Запрос");
//здесь мы находим количество для выполнения плана продаж на месяц
ТекстЗапроса = "С ВыбНачПериода по ВыбКонПериода;
|Номенклатура =Регистр.План.Номенклатура;
|Количество = регистр.План.Количество;
|Функция КолвоС = НачОст(Количество);
|Условие (Номенклатура = ВыбНоменклатура);
|Группировка Номенклатура;
|"
;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Если Запрос2.Выполнить(ТекстЗапроса) = 0 тогда
Сообщить("Ошибка выполнения запроса");
СтатусВозврата(0);
Возврат;
КонецЕсли;

Пока Запрос2.Группировка(1) = 1 Цикл
Номенклатура = Запрос2.Номенклатура;
Артикул = Номенклатура.Артикул;
КолП = Запрос2.КолвоС;
//выводим саму продукцию или выбранную номенклатуру
Таб.ВывестиСекцию("Номенклатура");
//здесь по выбранной номенклатуре выбираем техоперации
СпрНР = СоздатьОбъект("Справочник.НормыРасходов");
СпрНР.ИспользоватьВладельца(Запрос2.Номенклатура);
СпрНР.ВыбратьЭлементы();
Пока СпрНр.ПолучитьЭлемент() = 1 Цикл
//проверка на тех операции, чтобы отбросить ненужные данные
Если СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.ТехОперация Тогда
Продукция = СпрНР.Владелец;
Работа = СпрНР.Элемент;
Норма = СпрНР.Норма.Получить(ВыбКонПериода);;
Стоимость = СпрНР.Стоимость.Получить(ВыбКонПериода);
//СОЗДАЕМ ЗАПРОС ДЛЯ ПОИСКА ОСТАТКА ПО РАНЕЕ ПОЛУЧЕНОЙ ТехОперации т.е. её оприходовали
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(про)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Наименование = Регистр.Работа.Наименование;
|Количество = Регистр.Работа.Количество;
|Цена = Регистр.Работа.Цена;
|Функция КолвоКонОст = КонОст(Количество);
|Функция ЦенаКонОст = КонОст(Цена);
|Условие(Наименование = Работа.ТекущийЭлемент());
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

КолвоО = Запрос.КолвоКонОст;
ЦенаО = Запрос.ЦенаКонОст;
ИтогоО = Окр(КолвоО * ЦенаО,2);
КолвоТ = Окр((Норма * КолП)-КолвоО,2);
СуммаТ = Окр(КолвоТ * Стоимость,2);
ИтогоТ = ИтогоТ + СуммаТ;
//выводим саму работу
Таб.ВывестиСекцию("Работа");
//проверяем есть ли в спецификации полуфабрикаты
ИначеЕсли СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Полуфабрикат Тогда
Полуфабрикат = СпрНР.Элемент;
ЗапросПолуфабрикат = СоздатьОбъект("Запрос");
//проверяем есть ли она в плане продаж
ТекстЗапроса = "С ВыбНачПериода по ВыбКонПериода;
|Номенклатура =Регистр.План.Номенклатура;
|Количество = регистр.План.Количество;
|Функция КолвоС = НачОст(Количество);
|Условие (Номенклатура = Полуфабрикат.ТекущийЭлемент());
|Группировка Номенклатура;
|"
;
Если ЗапросПолуфабрикат.Выполнить(ТекстЗапроса) = 0 тогда
Сообщить("Ошибка выполнения запроса");
СтатусВозврата(0);
Возврат;
КонецЕсли;

Пока ЗапросПолуфабрикат.Группировка(1) = 1 Цикл
Полуфабрикат1 = ЗапросПолуфабрикат.Номенклатура;
Артикул = Полуфабрикат.Артикул;
КолвоП = ЗапросПолуфабрикат.КолвоС;
//выводим полуфабрикат
Таб.ВывестиСекцию("Полуфабрикат");
СпрНР.использоватьВладельца(Полуфабрикат);
СпрНР.ВыбратьЭлементы();
Пока СпрНР.ПолучитьЭлемент()=1 Цикл
Если СпрНР.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.ТехОпреация Тогда
Полуфабрикат2 = СпрНР.СпрНР.Владелец;
Артикул = Полуфабрикат2.Артикул;
РаботаП = СпрНР.Элемент;///и получается в таком духе до бесконечности
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЕсли;


ПояснениеПоНоменклатуре = " Для выполнения плана в размере "+КолП+" шт. по продукции "+"*"+Номенклатура+"*" + " потребуется "+ИтогоТ+"руб" ;
Таб.ВывестиСекцию("Итого");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", """");
КонецПроцедуры
"

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% ндс при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет доходов при УСН учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги