Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Конфигуратор, помогите с написанием кода на сортировку документов по определенным реквизит
Алекс Crazy
Пост №1
Алекс Crazy
читатель
офлайн
Дата регистрации: 13.01.2010
Сообщений: 83
Пост №1
 
13.01.2010 23:20

"т+с 9.2 Общий журнал документов
хочу сделать сортировку документов по кассам, на подобие как и по складам
к примеру , вывести все документы где в реквизитах упоминается касса №2

написал код по аналогии кода по сортировке по складам, визуально все работает, но только не сортирует документ а выводит весь список, как буд то нету сортировки


оброзец кода, с сравнением с кодом под склад

      СкладДляОтбора, ВидДокументаДляОтбора, АвторДляОтбора, ПроектДляОтбора, КассаДляОтбора; // Переменные для отбора


Процедура ПриВыбореСклада()

Если СкладДляОтбора.Выбран()>0 Тогда
УстановитьОтбор("Склад", СкладДляОтбора);
СкладДляОтбора = СкладДляОтбора.ТекущийЭлемент();
Иначе
УстановитьОтбор("""");
КонецЕсли;

КонецПроцедуры // ПриВыбореСклада()

Процедура ПриВыбореКассы()                              
Если КассаДляОтбора.Выбран()>0 Тогда                        
УстановитьОтбор("Касса", КассаДляОтбора);                  
КассаДляОтбора = КассаДляОтбора.ТекущийЭлемент();                  
Иначе                                                                        
УстановитьОтбор("""");                                                      
КонецЕсли;                                                                              
                                                                                          
КонецПроцедуры // ПриВыбореКассы()      


Процедура ПриВыбореСклада()

Если СкладДляОтбора.Выбран()>0 Тогда
УстановитьОтбор("Склад", СкладДляОтбора);
СкладДляОтбора = СкладДляОтбора.ТекущийЭлемент();
Иначе
УстановитьОтбор("""");
КонецЕсли;

КонецПроцедуры // ПриВыбореСклада()

Процедура ПриВыбореКассы()                              
Если КассаДляОтбора.Выбран()>0 Тогда                        
УстановитьОтбор("Касса", КассаДляОтбора);                  
КассаДляОтбора = КассаДляОтбора.ТекущийЭлемент();                  
Иначе                                                                        
УстановитьОтбор("""");                                                      
КонецЕсли;                                                                              
                                                                                          
КонецПроцедуры // ПриВыбореКассы()



ИначеЕсли ОтборПо = "по складу" Тогда
ПриВыбореСклада();
ЗначениеВВидеСтроки=Строка(СкладДляОтбора);

ИначеЕсли ОтборПо = "по кассе" Тогда                  
ПриВыбореПроекта();                                    
ЗначениеВВидеСтроки=Строка(КассаДляОтбора);       



ИначеЕсли ОтборПо = "по складу" Тогда
СтароеЗначение=СкладДляОтбора;
ВыбЗначение = СоздатьОбъект("Справочник.Склады");
Если ВыбЗначение.Выбрать("Выбор склада",)=1 Тогда
СкладДляОтбора = ВыбЗначение;
Если ВыбЗначение<>СтароеЗначение Тогда
ЗначениеИзменилось=1;
КонецЕсли;
КонецЕсли;


ИначеЕсли ОтборПо = "по кассе" Тогда      
СтароеЗначение=КассаДляОтбора;                  
ВыбЗначение = СоздатьОбъект("Справочник.Кассы");      
Если ВыбЗначение.Выбрать("Выбор кассы",)=1 Тогда            
КассаДляОтбора = ВыбЗначение;                                    
Если ВыбЗначение<>СтароеЗначение Тогда                               //
ЗначениеИзменилось=1;                                                                  
КонецЕсли;                                                 
КонецЕсли;                                                            

// определение склада для отбора
СкладДляОтбора =ВосстановитьЗначение("СкладОтбораЖурнала");
СкладДляОтбора= ?(ПустоеЗначение(СкладДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Склады"), СкладДляОтбора);


// определение Кассы для отбора                        
КассаДляОтбора =ВосстановитьЗначение("КассаОтбораЖурнала");      
КассаДляОтбора= ?(ПустоеЗначение(КассаДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Кассы"), КассаДляОтбора);


ИначеЕсли ОтборПо = "по складу" Тогда
Если глЕстьРеквизитШапки("Склад", ТекДок.Вид()) = 1 Тогда
СкладДляОтбора = ТекДок.Склад;

ИначеЕсли ОтборПо = "по кассе" Тогда                  
Если глЕстьРеквизитШапки("Касса", ТекДок.Вид()) = 1 Тогда
КассаДляОтбора = ТекДок.Касса; // общий реквизит документов      

СохранитьЗначение("СкладОтбораЖурнала",СкладДляОтбора);

СохранитьЗначение("КассаДляОтбораЖурнала",КассаДляОтбора);      


ВидОтбора.ДобавитьЗначение("по складу");
ВидОтбора.ДобавитьЗначение("по кассе")


СкладДляОтбора = СоздатьОбъект("Справочник.Склады");

КассаДляОтбора      = СоздатьОбъект("Справочник.Кассы");



"

 
Алекс Crazy
Пост №1
13.01.2010 23:20
 

"т+с 9.2 Общий журнал документов
хочу сделать сортировку документов по кассам, на подобие как и по складам
к примеру , вывести все документы где в реквизитах упоминается касса №2

написал код по аналогии кода по сортировке по складам, визуально все работает, но только не сортирует документ а выводит весь список, как буд то нету сортировки


оброзец кода, с сравнением с кодом под склад

      СкладДляОтбора, ВидДокументаДляОтбора, АвторДляОтбора, ПроектДляОтбора, КассаДляОтбора; // Переменные для отбора


Процедура ПриВыбореСклада()

Если СкладДляОтбора.Выбран()>0 Тогда
УстановитьОтбор("Склад", СкладДляОтбора);
СкладДляОтбора = СкладДляОтбора.ТекущийЭлемент();
Иначе
УстановитьОтбор("""");
КонецЕсли;

КонецПроцедуры // ПриВыбореСклада()

Процедура ПриВыбореКассы()                              
Если КассаДляОтбора.Выбран()>0 Тогда                        
УстановитьОтбор("Касса", КассаДляОтбора);                  
КассаДляОтбора = КассаДляОтбора.ТекущийЭлемент();                  
Иначе                                                                        
УстановитьОтбор("""");                                                      
КонецЕсли;                                                                              
                                                                                          
КонецПроцедуры // ПриВыбореКассы()      


Процедура ПриВыбореСклада()

Если СкладДляОтбора.Выбран()>0 Тогда
УстановитьОтбор("Склад", СкладДляОтбора);
СкладДляОтбора = СкладДляОтбора.ТекущийЭлемент();
Иначе
УстановитьОтбор("""");
КонецЕсли;

КонецПроцедуры // ПриВыбореСклада()

Процедура ПриВыбореКассы()                              
Если КассаДляОтбора.Выбран()>0 Тогда                        
УстановитьОтбор("Касса", КассаДляОтбора);                  
КассаДляОтбора = КассаДляОтбора.ТекущийЭлемент();                  
Иначе                                                                        
УстановитьОтбор("""");                                                      
КонецЕсли;                                                                              
                                                                                          
КонецПроцедуры // ПриВыбореКассы()



ИначеЕсли ОтборПо = "по складу" Тогда
ПриВыбореСклада();
ЗначениеВВидеСтроки=Строка(СкладДляОтбора);

ИначеЕсли ОтборПо = "по кассе" Тогда                  
ПриВыбореПроекта();                                    
ЗначениеВВидеСтроки=Строка(КассаДляОтбора);       



ИначеЕсли ОтборПо = "по складу" Тогда
СтароеЗначение=СкладДляОтбора;
ВыбЗначение = СоздатьОбъект("Справочник.Склады");
Если ВыбЗначение.Выбрать("Выбор склада",)=1 Тогда
СкладДляОтбора = ВыбЗначение;
Если ВыбЗначение<>СтароеЗначение Тогда
ЗначениеИзменилось=1;
КонецЕсли;
КонецЕсли;


ИначеЕсли ОтборПо = "по кассе" Тогда      
СтароеЗначение=КассаДляОтбора;                  
ВыбЗначение = СоздатьОбъект("Справочник.Кассы");      
Если ВыбЗначение.Выбрать("Выбор кассы",)=1 Тогда            
КассаДляОтбора = ВыбЗначение;                                    
Если ВыбЗначение<>СтароеЗначение Тогда                               //
ЗначениеИзменилось=1;                                                                  
КонецЕсли;                                                 
КонецЕсли;                                                            

// определение склада для отбора
СкладДляОтбора =ВосстановитьЗначение("СкладОтбораЖурнала");
СкладДляОтбора= ?(ПустоеЗначение(СкладДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Склады"), СкладДляОтбора);


// определение Кассы для отбора                        
КассаДляОтбора =ВосстановитьЗначение("КассаОтбораЖурнала");      
КассаДляОтбора= ?(ПустоеЗначение(КассаДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Кассы"), КассаДляОтбора);


ИначеЕсли ОтборПо = "по складу" Тогда
Если глЕстьРеквизитШапки("Склад", ТекДок.Вид()) = 1 Тогда
СкладДляОтбора = ТекДок.Склад;

ИначеЕсли ОтборПо = "по кассе" Тогда                  
Если глЕстьРеквизитШапки("Касса", ТекДок.Вид()) = 1 Тогда
КассаДляОтбора = ТекДок.Касса; // общий реквизит документов      

СохранитьЗначение("СкладОтбораЖурнала",СкладДляОтбора);

СохранитьЗначение("КассаДляОтбораЖурнала",КассаДляОтбора);      


ВидОтбора.ДобавитьЗначение("по складу");
ВидОтбора.ДобавитьЗначение("по кассе")


СкладДляОтбора = СоздатьОбъект("Справочник.Склады");

КассаДляОтбора      = СоздатьОбъект("Справочник.Кассы");



"

 
zak555 (398843952)
Пост №2
кого-кого сделать?
13.01.2010 23:25
 
 
BelikovS
Пост №3
В "Графы отбора" кассу добавляли?
14.01.2010 10:31
 
 
zak555 (398843952)
Пост №4
> В "Графы отбора" кассу добавляли?а потом база бу...
14.01.2010 12:08
 
 
Алекс Crazy
Пост №5
> В "Графы отбора" кассу добавляли?http://img705.i...
14.01.2010 21:06
 
 
Thorvardr
Пост №6
Отбор он и есть отбор - фильтрация, проще говоря, ...
14.01.2010 21:14
 
 
Алекс Crazy
Пост №7
если вы не заметили то там реализация, а в ней нет...
14.01.2010 21:18
 
 
zak555 (398843952)
Пост №8
сделай "журнал" на ТЗ и выводи, как хочешь (в како...
15.01.2010 09:22
 
 
Алекс Crazy
Пост №9
> сделай "журнал" на ТЗ и выводи, как хочешь (в ка...
15.01.2010 20:50
 
 
Thorvardr
Пост №10
"я картинку посмотрел, примерно понял о чем вопрос...
15.01.2010 20:54
 
 
Алекс Crazy
Пост №11
> я картинку посмотрел, примерно понял о чем вопро...
15.01.2010 21:00
 
 
Thorvardr
Пост №12
"Да я все равно не пью уж года 4 :)А ошибка типова...
17.01.2010 08:32
 
 
Алекс Crazy
Пост №13
"самое досадное, что в синтаксической ошибки то не...
17.01.2010 15:17
 
 
Thorvardr
Пост №14
"> у меня в обоих случаях при открытие постое знач...
17.01.2010 20:45
 
 
Алекс Crazy
Пост №15
"Ты не совсем правильно меня понял, чего чего а си...
17.01.2010 22:25
 
 
Thorvardr
Пост №16
А, ясно...В VB тоже есть такая функция: http://msd...
18.01.2010 07:55
 
 
BelikovS
Пост №17
Спасибо за эти примеры. Меня тут попросили прийти ...
18.01.2010 11:35
 
 
Thorvardr
Пост №18
У меня их больше, но я пока не могу обобщить и все...
18.01.2010 12:12
 
 
Алекс Crazy
Пост №19
"> Ну и в описание языка 1С смотрите:> ?(,,)> Синт...
18.01.2010 23:05
 
 
Алекс Crazy
Пост №20
Как в отладчике сделать чтобы на каждой строчке вы...
19.01.2010 00:26
 
 
Thorvardr
Пост №21
Надо поставить одну точку останова, а потом по алг...
19.01.2010 10:16
 
 
Thorvardr
Пост №22
"В копилку проблем:В модуле формы документа Больни...
20.01.2010 15:21
 
 
zak555 (398843952)
Пост №23
"> В копилку проблем:> В модуле формы документа Бо...
20.01.2010 16:13
 
 
Thorvardr
Пост №24
Ну... для меня тема переросла в "Ошибки комплексно...
20.01.2010 16:42
 
 
zak555 (398843952)
Пост №25
> Ну... для меня тема переросла в "Ошибки комплекс...
20.01.2010 18:04
 
 
BelikovS
Пост №26
Хорошее предложение. Кто будет автором? :)
20.01.2010 18:27
 
 
zak555 (398843952)
Пост №27
> Хорошее предложение. Кто будет автором? :)ну кто...
20.01.2010 18:41
 
 
Thorvardr
Пост №28
Ладно, сейчас устроим
20.01.2010 20:43
 
 
Алекс Crazy
Пост №29
не совсем понятно, как это?а то тратить кучу време...
20.01.2010 21:34
 
 
Thorvardr
Пост №30
http://s003.radikal.ru/i201/1001/2a/a12e4548b518.j...
21.01.2010 16:09
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры