Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Сравнение 2-х ТЗ и вывод в ТЗ_Р. Нужна помощь.
Julia13
Пост №1
Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №1
 
20.05.2010 12:29

"Есть 2-е ТЗ. ТЗ_УТ(колонки:Документ(УТ), Сумма(УТ), Кол-во(УТ), ДатаВД(УТ), НомерВД(УТ),КонИНН(УТ)) и

ТЗ_БП ((колонки:Документ(БП), Сумма(БП), Кол-во(БП), ДатаВД(БП), НомерВД(БП), КонИНН(БП))) у

которых совпадают 3 колонки(ДатаВД, НомерВД, КонИНН ), в данный момент у меня макет получается вот такой
---------------------------
Документы УТ
---------------------------
Период с [НачПериода] по [КонПериода]
---------------------------
Документ(УТ) Сумма(УТ) Кол-во(УТ) ДатаВД(УТ) НомерВД(УТ) КонИНН(УТ)
<Документ_УТ> <Сумма_УТ> <Колво_УТ> <ДатаВД_УТ> <НомерВД_УТ> <КонИНН_УТ>
---------------------------
Документы БП
---------------------------
Документ(БП) Сумма(БП) Кол-во(БП) ДатаВД(БП) НомерВД(БП) КонИНН(БП)
<Документ_БП> <Сумма_БП> <Колво_БП> <ДатаВД_БП> <НомерВД_БП> <КонИНН_БП>

а надо получить макет, где колонки совпадают по ДатаВД, НомерВД, КонИНН

ДатаВД            НомерВД       КонИНН Документ(УТ) Сумма(УТ) Кол-во(УТ) Документ(БП)       Сумма(БП)        Кол-во(БП)
<ДатаВД_БП> <НомерВД_БП> <КонИНН_БП> <Документ_УТ> <Сумма_УТ> <Колво_УТ> <Документ_БП> <Сумма_БП> <Колво_БП>

и в том же макете + где колонки не совпадают

---------------------------
Документы УТ
---------------------------
Документ(УТ) Сумма(УТ) Кол-во(УТ) ДатаВД(УТ) НомерВД(УТ) КонИНН(УТ)
<Документ_УТ> <Сумма_УТ> <Колво_УТ> <ДатаВД_УТ> <НомерВД_УТ> <КонИНН_УТ>
---------------------------
Документы БП
---------------------------
Документ(БП) Сумма(БП) Кол-во(БП) ДатаВД(БП) НомерВД(БП) КонИНН(БП)
<Документ_БП> <Сумма_БП> <Колво_БП> <ДатаВД_БП> <НомерВД_БП> <КонИНН_БП>

Надо сравнить 2-е ТЗ по этим колонкам и если они совпадают сразу записывать в ТЗ_Р


л_сч_ут = 0;

Пока (л_сч_ут < ТЗ_УТ.Количество()) Цикл
л_Нашли_соответствие = Ложь;
Строка_УТ = ТЗ_УТ[л_сч_ут];
л_сч_бп = 0;
Пока (л_сч_бп < ТЗ_БП.Количество()) Цикл
Строка_БП = ТЗ_БП.Получить(л_сч_бп);
Если НачалоДня(Строка_УТ.Дата) = НачалоДня(Строка_БП.Дата)
И Строка_УТ.Количество = Строка_БП.Количество
И Окр(Строка_УТ.СуммаДокумента,2) = Окр(Строка_БП.СуммаДокумента,2)
И Строка_УТ.ДатаВходящегоДокумента = Строка_БП.ДатаВходящегоДокумента
И Строка_УТ.НомерВходящегоДокумента = Строка_БП.НомерВходящегоДокумента
И Строка_УТ.КонтрагентИНН = Строка_БП.КонтрагентИНН Тогда

л_Нашли_соответствие = Истина;
ТЗ_БП.Удалить(Строка_БП);
Прервать;
Иначе
л_сч_бп = л_сч_бп + 1;
КонецЕсли;
КонецЦикла;
Если (л_Нашли_соответствие = Истина) Тогда
ТЗ_УТ.Удалить(Строка_УТ);
Иначе
л_сч_ут = л_сч_ут + 1;
КонецЕсли;
КонецЦикла;

Макет = ПолучитьМакет("Печать");

ОбластьШапкаУТ = Макет.ПолучитьОбласть("ШапкаУТ");
ОбластьШапкаБП = Макет.ПолучитьОбласть("ШапкаБП");
ОбластьШапкаДеталиУТ = Макет.ПолучитьОбласть("ШапкаДеталиУТ");
ОбластьШапкаДеталиБП = Макет.ПолучитьОбласть("ШапкаДеталиБП");
ОбластьДеталиУТ = Макет.ПолучитьОбласть("ДеталиУТ");
ОбластьДеталиБП = Макет.ПолучитьОбласть("ДеталиБП");

ТабДок = Новый ТабличныйДокумент;

ОбластьШапкаУТ.Параметры.НачПериода = НачПериода;
ОбластьШапкаУТ.Параметры.КонПериода = КонПериода;

ТабДок.Вывести(ОбластьШапкаУТ);
ТабДок.Вывести(ОбластьШапкаДеталиУТ);

Для Каждого Строка_УТ Из ТЗ_УТ Цикл
ОбластьДеталиУТ.Параметры.Документ_УТ = Строка_УТ.Ссылка;
ОбластьДеталиУТ.Параметры.Сумма_УТ = Строка_УТ.СуммаДокумента;
ОбластьДеталиУТ.Параметры.Колво_УТ = Строка_УТ.Количество;
ОбластьДеталиУТ.Параметры.ДатаВД_УТ = Строка_УТ.ДатаВходящегоДокумента;
ОбластьДеталиУТ.Параметры.НомерВД_УТ = Строка_УТ.НомерВходящегоДокумента;
ОбластьДеталиУТ.Параметры.КонИНН_УТ = Строка_УТ.КонтрагентИНН;
ТабДок.Вывести(ОбластьДеталиУТ);
КонецЦикла;

ТабДок.Вывести(ОбластьШапкаБП);
ТабДок.Вывести(ОбластьШапкаДеталиБП);

Для Каждого Строка_БП Из ТЗ_БП Цикл
ОбластьДеталиБП.Параметры.Документ_БП = Строка_БП.СсылкаПредставление;
ОбластьДеталиБП.Параметры.Сумма_БП = Строка_БП.СуммаДокумента;
ОбластьДеталиБП.Параметры.Колво_БП = Строка_БП.Количество;
ОбластьДеталиБП.Параметры.ДатаВД_БП = Строка_БП.ДатаВходящегоДокумента;
ОбластьДеталиБП.Параметры.НомерВД_БП = Строка_БП.НомерВходящегоДокумента;
ОбластьДеталиБП.Параметры.КонИНН_БП = Строка_БП.КонтрагентИНН;
ТабДок.Вывести(ОбластьДеталиБП);
КонецЦикла;

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();"

 
Julia13
Пост №1
20.05.2010 12:29
 

"Есть 2-е ТЗ. ТЗ_УТ(колонки:Документ(УТ), Сумма(УТ), Кол-во(УТ), ДатаВД(УТ), НомерВД(УТ),КонИНН(УТ)) и

ТЗ_БП ((колонки:Документ(БП), Сумма(БП), Кол-во(БП), ДатаВД(БП), НомерВД(БП), КонИНН(БП))) у

которых совпадают 3 колонки(ДатаВД, НомерВД, КонИНН ), в данный момент у меня макет получается вот такой
---------------------------
Документы УТ
---------------------------
Период с [НачПериода] по [КонПериода]
---------------------------
Документ(УТ) Сумма(УТ) Кол-во(УТ) ДатаВД(УТ) НомерВД(УТ) КонИНН(УТ)
<Документ_УТ> <Сумма_УТ> <Колво_УТ> <ДатаВД_УТ> <НомерВД_УТ> <КонИНН_УТ>
---------------------------
Документы БП
---------------------------
Документ(БП) Сумма(БП) Кол-во(БП) ДатаВД(БП) НомерВД(БП) КонИНН(БП)
<Документ_БП> <Сумма_БП> <Колво_БП> <ДатаВД_БП> <НомерВД_БП> <КонИНН_БП>

а надо получить макет, где колонки совпадают по ДатаВД, НомерВД, КонИНН

ДатаВД            НомерВД       КонИНН Документ(УТ) Сумма(УТ) Кол-во(УТ) Документ(БП)       Сумма(БП)        Кол-во(БП)
<ДатаВД_БП> <НомерВД_БП> <КонИНН_БП> <Документ_УТ> <Сумма_УТ> <Колво_УТ> <Документ_БП> <Сумма_БП> <Колво_БП>

и в том же макете + где колонки не совпадают

---------------------------
Документы УТ
---------------------------
Документ(УТ) Сумма(УТ) Кол-во(УТ) ДатаВД(УТ) НомерВД(УТ) КонИНН(УТ)
<Документ_УТ> <Сумма_УТ> <Колво_УТ> <ДатаВД_УТ> <НомерВД_УТ> <КонИНН_УТ>
---------------------------
Документы БП
---------------------------
Документ(БП) Сумма(БП) Кол-во(БП) ДатаВД(БП) НомерВД(БП) КонИНН(БП)
<Документ_БП> <Сумма_БП> <Колво_БП> <ДатаВД_БП> <НомерВД_БП> <КонИНН_БП>

Надо сравнить 2-е ТЗ по этим колонкам и если они совпадают сразу записывать в ТЗ_Р


л_сч_ут = 0;

Пока (л_сч_ут < ТЗ_УТ.Количество()) Цикл
л_Нашли_соответствие = Ложь;
Строка_УТ = ТЗ_УТ[л_сч_ут];
л_сч_бп = 0;
Пока (л_сч_бп < ТЗ_БП.Количество()) Цикл
Строка_БП = ТЗ_БП.Получить(л_сч_бп);
Если НачалоДня(Строка_УТ.Дата) = НачалоДня(Строка_БП.Дата)
И Строка_УТ.Количество = Строка_БП.Количество
И Окр(Строка_УТ.СуммаДокумента,2) = Окр(Строка_БП.СуммаДокумента,2)
И Строка_УТ.ДатаВходящегоДокумента = Строка_БП.ДатаВходящегоДокумента
И Строка_УТ.НомерВходящегоДокумента = Строка_БП.НомерВходящегоДокумента
И Строка_УТ.КонтрагентИНН = Строка_БП.КонтрагентИНН Тогда

л_Нашли_соответствие = Истина;
ТЗ_БП.Удалить(Строка_БП);
Прервать;
Иначе
л_сч_бп = л_сч_бп + 1;
КонецЕсли;
КонецЦикла;
Если (л_Нашли_соответствие = Истина) Тогда
ТЗ_УТ.Удалить(Строка_УТ);
Иначе
л_сч_ут = л_сч_ут + 1;
КонецЕсли;
КонецЦикла;

Макет = ПолучитьМакет("Печать");

ОбластьШапкаУТ = Макет.ПолучитьОбласть("ШапкаУТ");
ОбластьШапкаБП = Макет.ПолучитьОбласть("ШапкаБП");
ОбластьШапкаДеталиУТ = Макет.ПолучитьОбласть("ШапкаДеталиУТ");
ОбластьШапкаДеталиБП = Макет.ПолучитьОбласть("ШапкаДеталиБП");
ОбластьДеталиУТ = Макет.ПолучитьОбласть("ДеталиУТ");
ОбластьДеталиБП = Макет.ПолучитьОбласть("ДеталиБП");

ТабДок = Новый ТабличныйДокумент;

ОбластьШапкаУТ.Параметры.НачПериода = НачПериода;
ОбластьШапкаУТ.Параметры.КонПериода = КонПериода;

ТабДок.Вывести(ОбластьШапкаУТ);
ТабДок.Вывести(ОбластьШапкаДеталиУТ);

Для Каждого Строка_УТ Из ТЗ_УТ Цикл
ОбластьДеталиУТ.Параметры.Документ_УТ = Строка_УТ.Ссылка;
ОбластьДеталиУТ.Параметры.Сумма_УТ = Строка_УТ.СуммаДокумента;
ОбластьДеталиУТ.Параметры.Колво_УТ = Строка_УТ.Количество;
ОбластьДеталиУТ.Параметры.ДатаВД_УТ = Строка_УТ.ДатаВходящегоДокумента;
ОбластьДеталиУТ.Параметры.НомерВД_УТ = Строка_УТ.НомерВходящегоДокумента;
ОбластьДеталиУТ.Параметры.КонИНН_УТ = Строка_УТ.КонтрагентИНН;
ТабДок.Вывести(ОбластьДеталиУТ);
КонецЦикла;

ТабДок.Вывести(ОбластьШапкаБП);
ТабДок.Вывести(ОбластьШапкаДеталиБП);

Для Каждого Строка_БП Из ТЗ_БП Цикл
ОбластьДеталиБП.Параметры.Документ_БП = Строка_БП.СсылкаПредставление;
ОбластьДеталиБП.Параметры.Сумма_БП = Строка_БП.СуммаДокумента;
ОбластьДеталиБП.Параметры.Колво_БП = Строка_БП.Количество;
ОбластьДеталиБП.Параметры.ДатаВД_БП = Строка_БП.ДатаВходящегоДокумента;
ОбластьДеталиБП.Параметры.НомерВД_БП = Строка_БП.НомерВходящегоДокумента;
ОбластьДеталиБП.Параметры.КонИНН_БП = Строка_БП.КонтрагентИНН;
ТабДок.Вывести(ОбластьДеталиБП);
КонецЦикла;

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();"

 
uinny
Пост №2
и в чем проблема? записываете в результирующую ТЗ ...
20.05.2010 15:23
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры