Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Ошибка при выполнении обработки
Dendik
Пост №1
Dendik
читатель
офлайн
Дата регистрации: 15.11.2009
Сообщений: 106
Пост №1
 
17.08.2010 10:02

"Есть обработка которая переносит проводки из ЗУПа в Бух (код ниже) при выполнении выдает ошибку
{Форма.Форма(73)}: Поле объекта не обнаружено (ПолныйКодЭлемента)
СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));

Я так понимаю это связано с тем что com-соединений не видит это поле

Процедура ПереносЗПНажатие(Элемент)

Состояние("подключение ..");

кнТест = Новый COMОбъект("V81.COMConnector");
соед = кнТест.connect(ПодключениекБУ);

Состояние("запрос ..");
Запрос = соед.NewObject("Запрос");

Запрос.Текст ="ВЫБРАТЬ
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СчетДт,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт1,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт2,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт3,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СчетКт,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт1,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт2,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт3,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Сумма
|ИЗ
| Документ.ОтражениеЗарплатыВРеглУчете.ОтражениеВУчете КАК ОтражениеЗарплатыВРеглУчетеОтражениеВУчете
|ГДЕ
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Ссылка.Дата МЕЖДУ &ДатаНач И &ДатаКон
| И ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Ссылка.Проведен = ИСТИНА";

Запрос.УстановитьПараметр("ДатаНач", НачалоМесяца(ДатаКон));
Запрос.УстановитьПараметр("ДатаКон", КонецМесяца(ДатаКон));

Выборка = Запрос.Выполнить().Выбрать();

// НАЧАЛО Булгаков А.В.: Добавил запрос 2009-08-17


ЗапросСоответствия = Новый Запрос;
ЗапросСоответствия.Текст =
"ВЫБРАТЬ
| ТаблицаСоответствияЗП.Наименование,
| ТаблицаСоответствияЗП.Субконто,
| ТаблицаСоответствияЗП.СчетЗП,
| ТаблицаСоответствияЗП.СчетБух
|ИЗ
| Справочник.ТаблицаСоответствияЗП КАК ТаблицаСоответствияЗП";

ВыборкаСоответствия = ЗапросСоответствия.Выполнить().Выбрать();

СтруктураПоиска = Новый Структура("Наименование, СчетЗП");

// КОНЕЦ Булгаков А.В.: Добавил запрос 2009-08-17


Состояние("обработка ..");

ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("СчетДт");
ТЗ.Колонки.Добавить("СубконтоДт1");
ТЗ.Колонки.Добавить("СубконтоДт2");
ТЗ.Колонки.Добавить("СубконтоДт3");
ТЗ.Колонки.Добавить("СчетКт");
ТЗ.Колонки.Добавить("СубконтоКт1");
ТЗ.Колонки.Добавить("СубконтоКт2");
ТЗ.Колонки.Добавить("СубконтоКт3");
ТЗ.Колонки.Добавить("Сумма");
n=0;
Пока Выборка.Следующий() Цикл
       n=n+1;
       СубконтоДт1 = Неопределено; СубконтоДт2 = Неопределено; СубконтоДт3 = Неопределено;
       СубконтоКт1 = Неопределено; СубконтоКт2 = Неопределено; СубконтоКт3 = Неопределено;
       СчетДт = Неопределено;СчетКт = Неопределено;
       Если (Выборка.СчетДт.Код = "20.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("25");
            //Сообщить (ТипЗнч(соед.String(Выборка.СубконтоДт2)));

            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));//Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование)).Субконто;

            //СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
       ИначеЕсли (Выборка.СчетДт.Код = "20.60")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("20.10");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт3.ПолныйКодЭлемента));
            //Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

       (Выборка.СубконтоДт1.Наименование);//Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            //КонецЕсли;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;

       ИначеЕсли (Выборка.СчетДт.Код = "20.93")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("20.20");
            СубконтоДт1=Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");
            //СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

            СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",Выборка.СубконтоДт3.ПолныйКодЭлемента);
            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            //СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование); // ЗАКОММЕНТИРОВАЛ

            //СубконтоДт3=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт3 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт3 = Неопределено Тогда
             СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;

       ИначеЕсли (Выборка.СчетДт.Код = "23")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("23");
            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт1=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт2.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт1 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

                        
            Если СубконтоДт1 = Неопределено Тогда
             СубконтоДт1=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт2.Наименование);
            КонецЕсли;
            
            СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",Выборка.СубконтоДт3.ПолныйКодЭлемента);
            СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
       ИначеЕсли (Выборка.СчетДт.Код = "25")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("25");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));//Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто;

            (Выборка.СубконтоДт1.Наименование);//Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            //КонецЕсли;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

                        
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
       ИначеЕсли (Выборка.СчетДт.Код = "26")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("26");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));
            //СубконтоДт1=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто;//Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

            //СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);            

            //СубконтоДт2=Справочники.Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
            
       ИначеЕсли (Выборка.СчетДт.Код = "69.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("69.50.01");
            СубконтоДт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "70")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("70");
            СубконтоДт1=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "92.40")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("92.40");
            СубконтоДт1=Справочники.ПрочиеДоходыРасходы.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "97.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("97.10");
            СубконтоДт1=Справочники.РасходыБудущихПериодов.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "76.09")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("76.90.18");
            СубконтоДт1=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "68.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("68.10.03");
            СубконтоДт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоДт2=Перечисления.ВидыБюджета.МИНВЕД1;
            СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "71.20")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("71.20");
       ИначеЕсли (Выборка.СчетДт.Код = "96")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("96");
            СубконтоДт1=Справочники.Резервы.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
       КОнецЕсли;
       Если СчетДт=Неопределено ТОгда
            Сообщить("Дт "+Выборка.СчетДт.Код+" не найден",СтатусСообщения.Важное)
       КонецЕсли;
      
       Если (Выборка.СчетКт.Код = "69.01")Тогда //

            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.01");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.04")Тогда //

            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.10.02");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.03.1")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.03");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.03.2")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.04");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.02.1")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.05");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.02.2")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.06");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.11")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.20");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "70")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("70");
            СубконтоКт1=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "73.03")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("73.90");
            СубконтоКт1=Справочники.ФизическиеЛица.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "76.09")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.18");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоКт1.Наименование));
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "76.41")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.13");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт2=Справочники.Договоры.НайтиПоКоду(Выборка.СубконтоКт1.Код);
       ИначеЕсли (Выборка.СчетКт.Код = "76.90.1")Тогда            
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.17");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "68.01")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("68.10.03");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Перечисления.ВидыБюджета.МИНВЕД1;
            СубконтоКт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "71.20")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("71.20");
       ИначеЕсли (Выборка.СчетКт.Код = "97.01")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("97.10");
            СубконтоКт1=Справочники.РасходыБудущихПериодов.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоКт1.Наименование));
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       КОнецЕсли;
       Если СчетКт=Неопределено ТОгда
            Сообщить("Кт "+Выборка.СчетКт.Код+" не найден",СтатусСообщения.Важное)
       КонецЕсли;
      
            
       новстр = ТЗ.Добавить();
       новстр.СчетДт = СчетДт;
       новстр.СубконтоДт1 = СубконтоДт1;
       новстр.СубконтоДт2 = СубконтоДт2;
       новстр.СубконтоДт3 = СубконтоДт3;
       новстр.СчетКт = СчетКт;
       новстр.СубконтоКт1 = СубконтоКт1;
       новстр.СубконтоКт2 = СубконтоКт2;
       новстр.СубконтоКт3 = СубконтоКт3;
       новстр.Сумма = Выборка.Сумма;
КонецЦикла;

//ТЗ.Свернуть("СчетДт,СубконтоДт1,СубконтоДт2,СубконтоДт3,СчетКт,СубконтоКт1,СубконтоКт2,СубконтоКт3","Сумма");


НаборПроводок = РегистрыБухгалтерии.Основной.СоздатьНаборЗаписей();

Для Каждого стр Из ТЗ Цикл
       Если Строка(стр.СчетДт)=""""Тогда
            продолжить;
       КОнецЕсли;
       НоваяПроводка = НаборПроводок.Добавить();
       НоваяПроводка.Период = ДатаКон;
       НоваяПроводка.СчетДт = стр.СчетДт;
       НоваяПроводка.СчетКт = стр.СчетКт;
       НоваяПроводка.Сумма = стр.Сумма;
      
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,1,стр.СубконтоДт1);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,2,стр.СубконтоДт2);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,3,стр.СубконтоДт3);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,1,стр.СубконтоКт1);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,2,стр.СубконтоКт2);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,3,стр.СубконтоКт3);
      
КонецЦикла;

Если НаборПроводок.Количество()>0 Тогда
       ДокОперация = Документы.Операция.СоздатьДокумент();
       ДокОперация.Дата = ДатаКон;
       ДокОперация.Организация = Справочники.Организации.НайтиПоНаименованию("Астраханский филиал");
       ДокОперация.Содержание = "Перенос проводок из ЗУП";
       ДокОперация.Записать();

       НаборПроводок.Отбор.Регистратор.Значение = ДокОперация.Ссылка;
       НаборПроводок.Записать();
            
       Сообщить("Операция: "+ДокОперация);





"

 
Dendik
Пост №1
17.08.2010 10:02
 

"Есть обработка которая переносит проводки из ЗУПа в Бух (код ниже) при выполнении выдает ошибку
{Форма.Форма(73)}: Поле объекта не обнаружено (ПолныйКодЭлемента)
СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));

Я так понимаю это связано с тем что com-соединений не видит это поле

Процедура ПереносЗПНажатие(Элемент)

Состояние("подключение ..");

кнТест = Новый COMОбъект("V81.COMConnector");
соед = кнТест.connect(ПодключениекБУ);

Состояние("запрос ..");
Запрос = соед.NewObject("Запрос");

Запрос.Текст ="ВЫБРАТЬ
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СчетДт,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт1,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт2,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоДт3,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СчетКт,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт1,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт2,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.СубконтоКт3,
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Сумма
|ИЗ
| Документ.ОтражениеЗарплатыВРеглУчете.ОтражениеВУчете КАК ОтражениеЗарплатыВРеглУчетеОтражениеВУчете
|ГДЕ
| ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Ссылка.Дата МЕЖДУ &ДатаНач И &ДатаКон
| И ОтражениеЗарплатыВРеглУчетеОтражениеВУчете.Ссылка.Проведен = ИСТИНА";

Запрос.УстановитьПараметр("ДатаНач", НачалоМесяца(ДатаКон));
Запрос.УстановитьПараметр("ДатаКон", КонецМесяца(ДатаКон));

Выборка = Запрос.Выполнить().Выбрать();

// НАЧАЛО Булгаков А.В.: Добавил запрос 2009-08-17


ЗапросСоответствия = Новый Запрос;
ЗапросСоответствия.Текст =
"ВЫБРАТЬ
| ТаблицаСоответствияЗП.Наименование,
| ТаблицаСоответствияЗП.Субконто,
| ТаблицаСоответствияЗП.СчетЗП,
| ТаблицаСоответствияЗП.СчетБух
|ИЗ
| Справочник.ТаблицаСоответствияЗП КАК ТаблицаСоответствияЗП";

ВыборкаСоответствия = ЗапросСоответствия.Выполнить().Выбрать();

СтруктураПоиска = Новый Структура("Наименование, СчетЗП");

// КОНЕЦ Булгаков А.В.: Добавил запрос 2009-08-17


Состояние("обработка ..");

ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("СчетДт");
ТЗ.Колонки.Добавить("СубконтоДт1");
ТЗ.Колонки.Добавить("СубконтоДт2");
ТЗ.Колонки.Добавить("СубконтоДт3");
ТЗ.Колонки.Добавить("СчетКт");
ТЗ.Колонки.Добавить("СубконтоКт1");
ТЗ.Колонки.Добавить("СубконтоКт2");
ТЗ.Колонки.Добавить("СубконтоКт3");
ТЗ.Колонки.Добавить("Сумма");
n=0;
Пока Выборка.Следующий() Цикл
       n=n+1;
       СубконтоДт1 = Неопределено; СубконтоДт2 = Неопределено; СубконтоДт3 = Неопределено;
       СубконтоКт1 = Неопределено; СубконтоКт2 = Неопределено; СубконтоКт3 = Неопределено;
       СчетДт = Неопределено;СчетКт = Неопределено;
       Если (Выборка.СчетДт.Код = "20.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("25");
            //Сообщить (ТипЗнч(соед.String(Выборка.СубконтоДт2)));

            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));//Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование)).Субконто;

            //СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
       ИначеЕсли (Выборка.СчетДт.Код = "20.60")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("20.10");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт3.ПолныйКодЭлемента));
            //Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

       (Выборка.СубконтоДт1.Наименование);//Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            //КонецЕсли;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;

       ИначеЕсли (Выборка.СчетДт.Код = "20.93")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("20.20");
            СубконтоДт1=Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");
            //СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

            СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",Выборка.СубконтоДт3.ПолныйКодЭлемента);
            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            //СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование); // ЗАКОММЕНТИРОВАЛ

            //СубконтоДт3=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт3 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт3 = Неопределено Тогда
             СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;

       ИначеЕсли (Выборка.СчетДт.Код = "23")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("23");
            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт1=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт2.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт1 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

                        
            Если СубконтоДт1 = Неопределено Тогда
             СубконтоДт1=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт2.Наименование);
            КонецЕсли;
            
            СубконтоДт2=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",Выборка.СубконтоДт3.ПолныйКодЭлемента);
            СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
       ИначеЕсли (Выборка.СчетДт.Код = "25")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("25");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));//Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто;

            (Выборка.СубконтоДт1.Наименование);//Справочники.ВидыДеятельности.НайтиПоНаименованию("Выдача технических условий и проектные работы");Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            //КонецЕсли;

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

                        
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
       ИначеЕсли (Выборка.СчетДт.Код = "26")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("26");
            СубконтоДт1=Справочники.СтатьиРасходов.НайтиПоРеквизиту("ПолныйКодЭлемента",СокрЛП(Выборка.СубконтоДт2.ПолныйКодЭлемента));
            //СубконтоДт1=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт2.Наименование)).Субконто;//Справочники.СтатьиРасходов.НайтиПоНаименованию("Оплата по окладу, тарифным ставкам");

            //СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);            

            //СубконтоДт2=Справочники.Подразделения.НайтиПоРеквизиту("ВнешнийКлюч",Выборка.СубконтоДт1.Код);

            
            // НАЧАЛО Булгаков А.В.: Добавил фрагмент 2009-08-17

            // СубконтоДт2=Справочники.ТаблицаСоответствияЗП.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование).Субконто; // ЗАКОММЕНТИРОВАЛ

            СтруктураПоиска.Наименование = Выборка.СубконтоДт1.Наименование;
            СтруктураПоиска.СчетЗП = Выборка.СчетДт.Код;
            ВыборкаСоответствия.Сбросить();
            
            Пока ВыборкаСоответствия.НайтиСледующий(СтруктураПоиска) Цикл
             СубконтоДт2 = ВыборкаСоответствия.Субконто;
            КонецЦикла;
            // КОНЕЦ Булгаков А.В.: Добавил фрагмент 2009-08-17

            
            Если СубконтоДт2 = Неопределено Тогда
             СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            КонецЕсли;
            
       ИначеЕсли (Выборка.СчетДт.Код = "69.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("69.50.01");
            СубконтоДт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "70")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("70");
            СубконтоДт1=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "92.40")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("92.40");
            СубконтоДт1=Справочники.ПрочиеДоходыРасходы.НайтиПоНаименованию(Выборка.СубконтоДт1.Наименование);
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "97.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("97.10");
            СубконтоДт1=Справочники.РасходыБудущихПериодов.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "76.09")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("76.90.18");
            СубконтоДт1=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
            СубконтоДт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "68.01")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("68.10.03");
            СубконтоДт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоДт2=Перечисления.ВидыБюджета.МИНВЕД1;
            СубконтоДт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетДт.Код = "71.20")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("71.20");
       ИначеЕсли (Выборка.СчетДт.Код = "96")Тогда
            СчетДт=ПланыСчетов.Основной.НайтиПоКоду("96");
            СубконтоДт1=Справочники.Резервы.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоДт1.Наименование));
       КОнецЕсли;
       Если СчетДт=Неопределено ТОгда
            Сообщить("Дт "+Выборка.СчетДт.Код+" не найден",СтатусСообщения.Важное)
       КонецЕсли;
      
       Если (Выборка.СчетКт.Код = "69.01")Тогда //

            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.01");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.04")Тогда //

            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.10.02");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.03.1")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.03");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.03.2")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.04");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.02.1")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.05");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.02.2")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.50.06");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "69.11")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("69.20");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "70")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("70");
            СубконтоКт1=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "73.03")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("73.90");
            СубконтоКт1=Справочники.ФизическиеЛица.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "76.09")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.18");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоКт1.Наименование));
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "76.41")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.13");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт2=Справочники.Договоры.НайтиПоКоду(Выборка.СубконтоКт1.Код);
       ИначеЕсли (Выборка.СчетКт.Код = "76.90.1")Тогда            
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("76.90.17");
            СубконтоКт1=Справочники.Контрагенты.НайтиПоНаименованию(Выборка.СубконтоКт1.Наименование);
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "68.01")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("68.10.03");
            СубконтоКт1=Перечисления.ПлатежиВБюджет.Налог;
            СубконтоКт2=Перечисления.ВидыБюджета.МИНВЕД1;
            СубконтоКт3=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       ИначеЕсли (Выборка.СчетКт.Код = "71.20")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("71.20");
       ИначеЕсли (Выборка.СчетКт.Код = "97.01")Тогда
            СчетКт=ПланыСчетов.Основной.НайтиПоКоду("97.10");
            СубконтоКт1=Справочники.РасходыБудущихПериодов.НайтиПоНаименованию(СокрЛП(Выборка.СубконтоКт1.Наименование));
            СубконтоКт2=Справочники.Подразделения.НайтиПоНаименованию("Астраханский филиал");
       КОнецЕсли;
       Если СчетКт=Неопределено ТОгда
            Сообщить("Кт "+Выборка.СчетКт.Код+" не найден",СтатусСообщения.Важное)
       КонецЕсли;
      
            
       новстр = ТЗ.Добавить();
       новстр.СчетДт = СчетДт;
       новстр.СубконтоДт1 = СубконтоДт1;
       новстр.СубконтоДт2 = СубконтоДт2;
       новстр.СубконтоДт3 = СубконтоДт3;
       новстр.СчетКт = СчетКт;
       новстр.СубконтоКт1 = СубконтоКт1;
       новстр.СубконтоКт2 = СубконтоКт2;
       новстр.СубконтоКт3 = СубконтоКт3;
       новстр.Сумма = Выборка.Сумма;
КонецЦикла;

//ТЗ.Свернуть("СчетДт,СубконтоДт1,СубконтоДт2,СубконтоДт3,СчетКт,СубконтоКт1,СубконтоКт2,СубконтоКт3","Сумма");


НаборПроводок = РегистрыБухгалтерии.Основной.СоздатьНаборЗаписей();

Для Каждого стр Из ТЗ Цикл
       Если Строка(стр.СчетДт)=""""Тогда
            продолжить;
       КОнецЕсли;
       НоваяПроводка = НаборПроводок.Добавить();
       НоваяПроводка.Период = ДатаКон;
       НоваяПроводка.СчетДт = стр.СчетДт;
       НоваяПроводка.СчетКт = стр.СчетКт;
       НоваяПроводка.Сумма = стр.Сумма;
      
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,1,стр.СубконтоДт1);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,2,стр.СубконтоДт2);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетДт,НоваяПроводка.СубконтоДт,3,стр.СубконтоДт3);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,1,стр.СубконтоКт1);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,2,стр.СубконтоКт2);
       БухгалтерскийУчет.УстановитьСубконто(НоваяПроводка.СчетКт,НоваяПроводка.СубконтоКт,3,стр.СубконтоКт3);
      
КонецЦикла;

Если НаборПроводок.Количество()>0 Тогда
       ДокОперация = Документы.Операция.СоздатьДокумент();
       ДокОперация.Дата = ДатаКон;
       ДокОперация.Организация = Справочники.Организации.НайтиПоНаименованию("Астраханский филиал");
       ДокОперация.Содержание = "Перенос проводок из ЗУП";
       ДокОперация.Записать();

       НаборПроводок.Отбор.Регистратор.Значение = ДокОперация.Ссылка;
       НаборПроводок.Записать();
            
       Сообщить("Операция: "+ДокОперация);





"

 
Prikum
Пост №2
А что разве в бухгалтерии есть такой реквизит "Пол...
17.08.2010 10:05
 
 
Tanya
Пост №3
А что в 8-ке есть такой реквизит ?
17.08.2010 10:12
 
 
Денис (САМАРА)
Пост №4
А есть чё?
18.08.2010 16:15
 
 
Денис (САМАРА)
Пост №5
А есть чё?
18.08.2010 16:22
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры