Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Можно ли сохранять ТаблицуЗначений???1С 7.7.Комплексная(дописанная - переписанная)
Saxarok
Пост №1
Saxarok
читатель
офлайн
Дата регистрации: 31.10.2007
Сообщений: 69
Пост №1
 
21.09.2010 12:46

"Подскажите пожалуйста с вопросиком.

Есть обработка "ПакетОтчетовДоп" с печатной формой "Отчет по ордерам", в которой есть поле "Неисправность"(НА ЧТО ОБРАЩАЮ ВАШЕ ВНИМАНИЕ!!!).
Вообще суть обработки состоит в том,чтобы взять и вывести отчет по ОРДЕРАМ сразу для всех сотрудников(к примеру их туда попало 3 человека - Осипов,Иванов и Петров).
Всё отлично формируеться за исключения одной маленькой прихоти БОССА....чтобы после формирования группы таких отчетов при двойном клике на ячейку "Неисправность" весь отчет отсортировался по этой самой графе.

И вот тут возникает такая проблемка - Все эти 3 отчета формировались с помощью ТаблицыЗначений(ТЗ1)
....
ТЗ1.НомерДок = Док.ТекущийДокумент();
ТЗ1.ДатаДок = Док.ДатаДок;
ТЗ1.ДатаОкончания = Док.ДатаОкончания;
....
и получаеться что каждый раз при выборе следующего сотрудника для отчета предыдущие затирались.

Поэтому когда все отчеты сформированы и нажать двойным кликом на ячейку "Неисправность" на любом из них,то сортируеться и соответственно обновляеться только отчет по последнему сотруднику.

//-------------------------------------------
Процедура ОбновитьТаблицу()
...
ТЗ1.ВыбратьСтроки();
Пока ТЗ1.ПолучитьСтроку() = 1 цикл
       Таб.ВывестиСекцию("Строка");
       НомерПП = НомерПП + 1;
КонецЦикла;
...
КонецПроцедуры
//-------------------------------------------
Процедура ОбработкаЯчейкиТаблицы(Зн, Стандарт, Таб, Адр)
...
Если Зн = "Неисправность" тогда
ТЗ1.Сортировать(Зн);
ОбновитьТаблицу();
КонецЕсли;
КонецПроцедуры
//-------------------------------------------

Теперь не знаю как можно сделать чтобы из ТЗ1 каждый раз все поля сохранялись куда-то!!!!!!,чтобы впоследствии сортировалось всё правильно...

"

 
Saxarok
Пост №1
21.09.2010 12:46
 

"Подскажите пожалуйста с вопросиком.

Есть обработка "ПакетОтчетовДоп" с печатной формой "Отчет по ордерам", в которой есть поле "Неисправность"(НА ЧТО ОБРАЩАЮ ВАШЕ ВНИМАНИЕ!!!).
Вообще суть обработки состоит в том,чтобы взять и вывести отчет по ОРДЕРАМ сразу для всех сотрудников(к примеру их туда попало 3 человека - Осипов,Иванов и Петров).
Всё отлично формируеться за исключения одной маленькой прихоти БОССА....чтобы после формирования группы таких отчетов при двойном клике на ячейку "Неисправность" весь отчет отсортировался по этой самой графе.

И вот тут возникает такая проблемка - Все эти 3 отчета формировались с помощью ТаблицыЗначений(ТЗ1)
....
ТЗ1.НомерДок = Док.ТекущийДокумент();
ТЗ1.ДатаДок = Док.ДатаДок;
ТЗ1.ДатаОкончания = Док.ДатаОкончания;
....
и получаеться что каждый раз при выборе следующего сотрудника для отчета предыдущие затирались.

Поэтому когда все отчеты сформированы и нажать двойным кликом на ячейку "Неисправность" на любом из них,то сортируеться и соответственно обновляеться только отчет по последнему сотруднику.

//-------------------------------------------
Процедура ОбновитьТаблицу()
...
ТЗ1.ВыбратьСтроки();
Пока ТЗ1.ПолучитьСтроку() = 1 цикл
       Таб.ВывестиСекцию("Строка");
       НомерПП = НомерПП + 1;
КонецЦикла;
...
КонецПроцедуры
//-------------------------------------------
Процедура ОбработкаЯчейкиТаблицы(Зн, Стандарт, Таб, Адр)
...
Если Зн = "Неисправность" тогда
ТЗ1.Сортировать(Зн);
ОбновитьТаблицу();
КонецЕсли;
КонецПроцедуры
//-------------------------------------------

Теперь не знаю как можно сделать чтобы из ТЗ1 каждый раз все поля сохранялись куда-то!!!!!!,чтобы впоследствии сортировалось всё правильно...

"

 
zak555 (398843952)
Пост №2
каков её смысл обработки ?
21.09.2010 13:01
 
 
Saxarok
Пост №3
Вообще суть обработки состоит в том,чтобы взять и ...
21.09.2010 13:07
 
 
zak555 (398843952)
Пост №4
> Вообще суть обработки состоит в том,чтобы взять ...
21.09.2010 13:08
 
 
IceBeerg
Пост №5
Как формируется отчет по каждому сотруднику? Запро...
21.09.2010 13:43
 
 
Saxarok
Пост №6
"это дописанная конфа,в ней есть док.Ордер,в котор...
21.09.2010 14:32
 
 
Saxarok
Пост №7
перебором документов
21.09.2010 14:46
 
 
IceBeerg
Пост №8
"Так, идем далее, отчеты вы делаете по каждому сот...
21.09.2010 15:41
 
 
Saxarok
Пост №9
"> то есть сформировали по Иванову, а когда начина...
22.09.2010 21:58
 
 
Prikum
Пост №10
"вот для этого :> ТЗ1.НовыяСтрока(Стр);З,Ы, пока п...
22.09.2010 22:01
 
 
Saxarok
Пост №11
угу,я тож сначала написала, а потом досмотрелась.....
22.09.2010 22:06
 
 
Prikum
Пост №12
"написалА!? ;)"
22.09.2010 22:10
 
 
Saxarok
Пост №13
ну тогда уже надо познакомиться - да,НАПИСАЛА!!!!С...
22.09.2010 22:17
 
 
zak555 (398843952)
Пост №14
> ну тогда уже надо познакомиться - да,НАПИСАЛА!!!...
22.09.2010 22:31
 
 
Prikum
Пост №15
очень, приятно, Олег!
23.09.2010 09:17
 
 
Prikum
Пост №16
"может быть тебе еще и телефон надо? ;)"
23.09.2010 09:18
 
 
zak555 (398843952)
Пост №17
"> может быть тебе еще и телефон надо? ;)это я сам...
23.09.2010 09:24
 
 
IceBeerg
Пост №18
"> Только как я понимаю код,у вас будет одна ТЗ1, ...
23.09.2010 10:43
 
 
IceBeerg
Пост №19
"> вот для этого :> > ТЗ1.НовыяСтрока(Стр);> З,Ы, ...
23.09.2010 10:45
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры