Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] внешний отчёт по списанию с ценой и суммой ТИС 9.2
Flava_John
Пост №1
Flava_John
читатель
офлайн
Дата регистрации: 01.11.2010
Сообщений: 6
Пост №1
 
01.11.2010 17:19

"Помогите пожалуйста с внешним отчётом,
это выгрузка актов списаний в ексель из 1с, дело в том что не выводится цена и сумма.

// Предопределенная процедура
Процедура ПриОткрытии(ФлагВосстановленияНастройки)
Если ФлагВосстановленияНастройки = 0 Тогда
ВидРазделителя = 1;
ВидЕдиницы = 1;
ПоГруппам = 1;
ДатаНачала = глЗначениеПоУмолчанию("ОсновнаяДатаНачалаОтчетов");
Если ПустоеЗначение(ДатаНачала) = 1 Тогда
ДатаНачала = НачМесяца(ДатаКонца);
КонецЕсли;
КонецЕсли;
Если глФлагРасшифровки = 1 Тогда
Обновить = глОбновить;
// восстанавливаем настройки из списка
ДатаНачала = глРасшифровка.Получить("ДатаНачала");
ДатаКонца = глРасшифровка.Получить("ДатаКонца");
ВыбКонтр = глРасшифровка.Получить("ВыбКонтр");
Если Обновить <> 0 Тогда
Таб = глТаблица;
КонецЕсли;
Иначе
Обновить = 0;
КонецЕсли;
КонецПроцедуры // ПриОткрытии()
Процедура Сформировать()
Док=СоздатьОбъект("Документ");
Док.УстановитьФильтр(1,0,0,2,1,1);
Если ВыбФирма.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Фирма",ВыбФирма);
ИначеЕсли ВыбСклад.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Склад",ВыбСклад);
ИначеЕсли ВыбПроект.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Проект",ВыбПроект);
Иначе
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
КонецЕсли;
Загол="""";
Если ВыбФирма.Выбран()=1 Тогда
Загол=Загол + "По фирме "+ВыбФирма.Наименование+". ";
КонецЕсли;
Если ВыбСклад.Выбран()=1 Тогда
Загол=Загол + "По складу "+ВыбСклад.Наименование+". ";
КонецЕсли;
Если ВыбПроект.Выбран()=1 Тогда
Загол=Загол + "По трактору "+ВыбСклад.Наименование+". ";
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Шапка");
Счетчик=1;
ИтогСумма=0;
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид()<>"СписаниеТМЦ" Тогда
Продолжить;
КонецЕсли;
РегПартии=СоздатьОбъект("Регистр.ПартииНаличие");
Если (ВыбФирма.Выбран()=1) и (Док.Фирма<>ВыбФирма.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбСклад.Выбран()=1) и (Док.Склад<>ВыбСклад.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбПроект.Выбран()=1) и (Док.Проект<>ВыбПроект.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ДокТрактор=1) и (ПустоеЗначение(Док.Проект)=1) Тогда
Продолжить;
КонецЕсли;
Таб.ВывестиСекцию("Строка");
Если Док.Вид()="СписаниеТМЦ" Тогда
Если Док.Проведен()=1 Тогда
ИтогСумма=0;
РегПартии.ВыбратьДвиженияДокумента(Док.ТекущийДокумент());
Пока РегПартии.ПолучитьДвижение()=1 Цикл
Если РегПартии.КодОперации=глКО.Списание Тогда
ИтогСумма=ИтогСумма+РегПартии.СуммаРуб;
КонецЕсли;
КонецЦикла;
Иначе
ИтогСумма=0;
КонецЕсли;
Иначе
ИтогСумма = глСуммаДокументаВЖурнале(Док.ТекущийДокумент(), "число");
КонецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
Состояние("Отчет сформирован. Печать...");
Таб.Опции(0, 0, 3, 0, "Реестр документов");
Таб.ТолькоПросмотр(1);
Таб.Показать("Реестр документов","""");
КонецПроцедуры
Процедура ПечатьСписания()
Док=СоздатьОбъект("Документ");
Док.УстановитьФильтр(1,0,0,2,1,1);
Если ВыбФирма.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Фирма",ВыбФирма);
ИначеЕсли ВыбСклад.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Склад",ВыбСклад);
ИначеЕсли ВыбПроект.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Проект",ВыбПроект);
Иначе
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
КонецЕсли;
Загол="""";
Если ВыбФирма.Выбран()=1 Тогда
Загол=Загол + "По фирме "+ВыбФирма.Наименование+". ";
КонецЕсли;
Если ВыбСклад.Выбран()=1 Тогда
Загол=Загол + "По складу "+ВыбСклад.Наименование+". ";
КонецЕсли;
Если ВыбПроект.Выбран()=1 Тогда
Загол=Загол + "По трактору "+ВыбСклад.Наименование+". ";
КонецЕсли;
Проект=СоздатьОбъект("ТаблицаЗначений");
Проект.НоваяКолонка("Док", "Документ.СписаниеТМЦ");
Проект.НоваяКолонка("Трактор", "Строка");
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид()<>"СписаниеТМЦ" Тогда
Продолжить;
КонецЕсли;
Если (ВыбФирма.Выбран()=1) и (Док.Фирма<>ВыбФирма.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбСклад.Выбран()=1) и (Док.Склад<>ВыбСклад.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбПроект.Выбран()=1) и (Док.Проект<>ВыбПроект.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ДокТрактор=1) и (ПустоеЗначение(Док.Проект)=1) Тогда
Продолжить;
КонецЕсли;
Проект.НоваяСтрока();
Проект.Док=Док.ТекущийДокумент();
Проект.Трактор=Док.Проект.Наименование;
КонецЦикла;
Проект.Сортировать("Трактор, Док");
Счетчик=1;
ПечСумма=0;
Если ВЭксель=1 Тогда
ВыбФ=""""; ВыбКат="""";
Зн=ФС.ВыбратьФайл(1,ВыбФ,ВыбКат,"Сохранить файл как...","Файлы Excel|*.xls","xls",10);
Если ВыбФ="""" Тогда СтатусВозврата(0); Возврат; КонецЕсли;
_Ч=0;_м=0;_с=0;_сч1=0;
ТекущееВремя(_ч,_м,_с);
маскаФайл="~"+ДатаГод(ТекущаяДата())+ДатаМесяц(ТекущаяДата())+ДатаЧисло(ТекущаяДата())+_
маска=КаталогВременныхФайлов()+маскафайл;
ИмяФФ = ВыбКат + ВыбФ;
Файлы=СоздатьОбъект("ТаблицаЗначений");
Файлы.НоваяКолонка("Файл", "Строка");
Файлы.НоваяКолонка("ИмяЛиста", "Строка");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
Проект.ВыбратьСтроки();
КолвоВременныхФайлов=0;
СтарыйПроект=ПолучитьПустоеЗначение("Справочник.Проекты");
Пока Проект.ПолучитьСтроку()=1 Цикл
Док.НайтиДокумент(Проект.Док);
Если (СтарыйПроект<>Док.Проект) и (ВЭксель=1) Тогда
КолвоВременныхФайлов=КолвоВременныхФайлов+1;
Таб.Записать(Маска+КолвоВременныхФайлов+".xls",1);
Файлы.НоваяСтрока();
Файлы.Файл=Маска+КолвоВременныхФайлов+".xls";
Если ПустоеЗначение(СтарыйПроект)=1 Тогда
Файлы.ИмяЛиста="Без трактора";
Иначе
Файлы.ИмяЛиста=СокрЛП(СтарыйПроект.Наименование);
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
КонецЕсли;
// выводим табличную часть
НомСтроки = 0;
СуммаИтог=0;
Таб.ВывестиСекцию("Заголовок");
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл
НомСтроки = НомСтроки + 1;
Таб.ВывестиСекцию("Строка");
СуммаИтог=СуммаИтог+Док.Сумма;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
СтарыйПроект=Док.Проект;
Счетчик = Счетчик + 1;
КонецЦикла;
Если ВЭксель=1 Тогда
КолвоВременныхФайлов=КолвоВременныхФайлов+1;
Таб.Записать(Маска+КолвоВременныхФайлов+".xls",1);
Файлы.НоваяСтрока();
Файлы.Файл=Маска+КолвоВременныхФайлов+".xls";
Если ПустоеЗначение(СтарыйПроект)=1 Тогда
Файлы.ИмяЛиста="Без трактора";
Иначе
Файлы.ИмяЛиста=СокрЛП(СтарыйПроект.Наименование);
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
КонецЕсли;
//ChDir "C:\"
//Workbooks.Open Filename:="C:\q.xls"
//Workbooks.Open Filename:="C:\~2008922125281.xls"
//Cells.Select
//Selection.Copy
//Windows("Книга1").Activate
//ActiveSheet.Paste
Если ВЭксель=1 Тогда
Если КолвоВременныхФайлов=0 Тогда
Таб.Записать(Маска+"1.xls",1);
КонецЕсли;
Эксель=СоздатьОбъект("Excel.Application");
РабочаяКнига = Эксель.Workbooks.Add();
РабочаяКнига.Activate();
// Удалить все листы, оставить один
Колво = РабочаяКнига.WorkSheets.Count;
Для I = 1 По Колво-1 Цикл
//РабочаяКнига.WorkSheets(I).Select();
Эксель.Application.DisplayAlerts = 0;
РабочаяКнига.WorkSheets(I).Delete();
Эксель.Application.DisplayAlerts = 1;
КонецЦикла;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Если Файлы.НомерСтроки=Файлы.КоличествоСтрок() Тогда
Продолжить;
КонецЕсли;
РабочаяКнига.WorkSheets().Add();
КонецЦикла;
// Изменение названий ярлычкой листов рабочей книги
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
РабочаяКнига.WorkSheets(Файлы.НомерСтроки).Name = Файлы.ИмяЛиста;
КонецЦикла;
// Копируем содержимое листов книг в созданную книгу
Эксель.Application.DisplayAlerts = 0;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Сч=Файлы.НомерСтроки;
Книга2=Эксель.Workbooks.Open(маска+Сч+".xls");
Книга2.ActiveSheet.Select();
Эксель.Cells.Select();
Эксель.Selection.Copy();
РабочаяКнига.WorkSheets(Сч).Paste();
Книга2.Close();
КонецЦикла;
Эксель.Application.DisplayAlerts = 1;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Эксель.Sheets(Файлы.ИмяЛиста).Select();
Эксель.Range("A1").Select();
КонецЦикла;
// Спозиционируемся в рабочей книге на 1-й лист
Файлы.ПолучитьСтрокуПоНомеру(1);
Эксель.Sheets(Файлы.ИмяЛиста).Select();
Эксель.DisplayAlerts=0;
Эксель.ActiveWorkbook.SaveAs(ИмяФФ,-4143);
Эксель.DisplayAlerts=1;
Эксель.Visible=1;
Для й=1 по КолвоВременныхФайлов Цикл
Попытка
ФС.УдалитьФайл(Маска+й+".xls");
Исключение КонецПопытки;
КонецЦикла;
Эксель = 0;
Иначе
Состояние("Отчет сформирован. Печать...");
Таб.Опции(0, 0, 0, 0, "Списания");
Таб.ТолькоПросмотр(1);
Таб.Показать("Списания","""");
КонецЕсли;
КонецПроцедуры
ДатаНачала=РабочаяДата();
ДатаКонца=РабочаяДата();

"

 
Flava_John
Пост №1
01.11.2010 17:19
 

"Помогите пожалуйста с внешним отчётом,
это выгрузка актов списаний в ексель из 1с, дело в том что не выводится цена и сумма.

// Предопределенная процедура
Процедура ПриОткрытии(ФлагВосстановленияНастройки)
Если ФлагВосстановленияНастройки = 0 Тогда
ВидРазделителя = 1;
ВидЕдиницы = 1;
ПоГруппам = 1;
ДатаНачала = глЗначениеПоУмолчанию("ОсновнаяДатаНачалаОтчетов");
Если ПустоеЗначение(ДатаНачала) = 1 Тогда
ДатаНачала = НачМесяца(ДатаКонца);
КонецЕсли;
КонецЕсли;
Если глФлагРасшифровки = 1 Тогда
Обновить = глОбновить;
// восстанавливаем настройки из списка
ДатаНачала = глРасшифровка.Получить("ДатаНачала");
ДатаКонца = глРасшифровка.Получить("ДатаКонца");
ВыбКонтр = глРасшифровка.Получить("ВыбКонтр");
Если Обновить <> 0 Тогда
Таб = глТаблица;
КонецЕсли;
Иначе
Обновить = 0;
КонецЕсли;
КонецПроцедуры // ПриОткрытии()
Процедура Сформировать()
Док=СоздатьОбъект("Документ");
Док.УстановитьФильтр(1,0,0,2,1,1);
Если ВыбФирма.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Фирма",ВыбФирма);
ИначеЕсли ВыбСклад.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Склад",ВыбСклад);
ИначеЕсли ВыбПроект.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Проект",ВыбПроект);
Иначе
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
КонецЕсли;
Загол="""";
Если ВыбФирма.Выбран()=1 Тогда
Загол=Загол + "По фирме "+ВыбФирма.Наименование+". ";
КонецЕсли;
Если ВыбСклад.Выбран()=1 Тогда
Загол=Загол + "По складу "+ВыбСклад.Наименование+". ";
КонецЕсли;
Если ВыбПроект.Выбран()=1 Тогда
Загол=Загол + "По трактору "+ВыбСклад.Наименование+". ";
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Шапка");
Счетчик=1;
ИтогСумма=0;
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид()<>"СписаниеТМЦ" Тогда
Продолжить;
КонецЕсли;
РегПартии=СоздатьОбъект("Регистр.ПартииНаличие");
Если (ВыбФирма.Выбран()=1) и (Док.Фирма<>ВыбФирма.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбСклад.Выбран()=1) и (Док.Склад<>ВыбСклад.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбПроект.Выбран()=1) и (Док.Проект<>ВыбПроект.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ДокТрактор=1) и (ПустоеЗначение(Док.Проект)=1) Тогда
Продолжить;
КонецЕсли;
Таб.ВывестиСекцию("Строка");
Если Док.Вид()="СписаниеТМЦ" Тогда
Если Док.Проведен()=1 Тогда
ИтогСумма=0;
РегПартии.ВыбратьДвиженияДокумента(Док.ТекущийДокумент());
Пока РегПартии.ПолучитьДвижение()=1 Цикл
Если РегПартии.КодОперации=глКО.Списание Тогда
ИтогСумма=ИтогСумма+РегПартии.СуммаРуб;
КонецЕсли;
КонецЦикла;
Иначе
ИтогСумма=0;
КонецЕсли;
Иначе
ИтогСумма = глСуммаДокументаВЖурнале(Док.ТекущийДокумент(), "число");
КонецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
Состояние("Отчет сформирован. Печать...");
Таб.Опции(0, 0, 3, 0, "Реестр документов");
Таб.ТолькоПросмотр(1);
Таб.Показать("Реестр документов","""");
КонецПроцедуры
Процедура ПечатьСписания()
Док=СоздатьОбъект("Документ");
Док.УстановитьФильтр(1,0,0,2,1,1);
Если ВыбФирма.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Фирма",ВыбФирма);
ИначеЕсли ВыбСклад.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Склад",ВыбСклад);
ИначеЕсли ВыбПроект.Выбран()=1 Тогда
Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Проект",ВыбПроект);
Иначе
Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
КонецЕсли;
Загол="""";
Если ВыбФирма.Выбран()=1 Тогда
Загол=Загол + "По фирме "+ВыбФирма.Наименование+". ";
КонецЕсли;
Если ВыбСклад.Выбран()=1 Тогда
Загол=Загол + "По складу "+ВыбСклад.Наименование+". ";
КонецЕсли;
Если ВыбПроект.Выбран()=1 Тогда
Загол=Загол + "По трактору "+ВыбСклад.Наименование+". ";
КонецЕсли;
Проект=СоздатьОбъект("ТаблицаЗначений");
Проект.НоваяКолонка("Док", "Документ.СписаниеТМЦ");
Проект.НоваяКолонка("Трактор", "Строка");
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид()<>"СписаниеТМЦ" Тогда
Продолжить;
КонецЕсли;
Если (ВыбФирма.Выбран()=1) и (Док.Фирма<>ВыбФирма.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбСклад.Выбран()=1) и (Док.Склад<>ВыбСклад.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ВыбПроект.Выбран()=1) и (Док.Проект<>ВыбПроект.ТекущийЭлемент()) Тогда
Продолжить;
ИначеЕсли (ДокТрактор=1) и (ПустоеЗначение(Док.Проект)=1) Тогда
Продолжить;
КонецЕсли;
Проект.НоваяСтрока();
Проект.Док=Док.ТекущийДокумент();
Проект.Трактор=Док.Проект.Наименование;
КонецЦикла;
Проект.Сортировать("Трактор, Док");
Счетчик=1;
ПечСумма=0;
Если ВЭксель=1 Тогда
ВыбФ=""""; ВыбКат="""";
Зн=ФС.ВыбратьФайл(1,ВыбФ,ВыбКат,"Сохранить файл как...","Файлы Excel|*.xls","xls",10);
Если ВыбФ="""" Тогда СтатусВозврата(0); Возврат; КонецЕсли;
_Ч=0;_м=0;_с=0;_сч1=0;
ТекущееВремя(_ч,_м,_с);
маскаФайл="~"+ДатаГод(ТекущаяДата())+ДатаМесяц(ТекущаяДата())+ДатаЧисло(ТекущаяДата())+_
маска=КаталогВременныхФайлов()+маскафайл;
ИмяФФ = ВыбКат + ВыбФ;
Файлы=СоздатьОбъект("ТаблицаЗначений");
Файлы.НоваяКолонка("Файл", "Строка");
Файлы.НоваяКолонка("ИмяЛиста", "Строка");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
Проект.ВыбратьСтроки();
КолвоВременныхФайлов=0;
СтарыйПроект=ПолучитьПустоеЗначение("Справочник.Проекты");
Пока Проект.ПолучитьСтроку()=1 Цикл
Док.НайтиДокумент(Проект.Док);
Если (СтарыйПроект<>Док.Проект) и (ВЭксель=1) Тогда
КолвоВременныхФайлов=КолвоВременныхФайлов+1;
Таб.Записать(Маска+КолвоВременныхФайлов+".xls",1);
Файлы.НоваяСтрока();
Файлы.Файл=Маска+КолвоВременныхФайлов+".xls";
Если ПустоеЗначение(СтарыйПроект)=1 Тогда
Файлы.ИмяЛиста="Без трактора";
Иначе
Файлы.ИмяЛиста=СокрЛП(СтарыйПроект.Наименование);
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
КонецЕсли;
// выводим табличную часть
НомСтроки = 0;
СуммаИтог=0;
Таб.ВывестиСекцию("Заголовок");
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл
НомСтроки = НомСтроки + 1;
Таб.ВывестиСекцию("Строка");
СуммаИтог=СуммаИтог+Док.Сумма;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
СтарыйПроект=Док.Проект;
Счетчик = Счетчик + 1;
КонецЦикла;
Если ВЭксель=1 Тогда
КолвоВременныхФайлов=КолвоВременныхФайлов+1;
Таб.Записать(Маска+КолвоВременныхФайлов+".xls",1);
Файлы.НоваяСтрока();
Файлы.Файл=Маска+КолвоВременныхФайлов+".xls";
Если ПустоеЗначение(СтарыйПроект)=1 Тогда
Файлы.ИмяЛиста="Без трактора";
Иначе
Файлы.ИмяЛиста=СокрЛП(СтарыйПроект.Наименование);
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Списания");
КонецЕсли;
//ChDir "C:\"
//Workbooks.Open Filename:="C:\q.xls"
//Workbooks.Open Filename:="C:\~2008922125281.xls"
//Cells.Select
//Selection.Copy
//Windows("Книга1").Activate
//ActiveSheet.Paste
Если ВЭксель=1 Тогда
Если КолвоВременныхФайлов=0 Тогда
Таб.Записать(Маска+"1.xls",1);
КонецЕсли;
Эксель=СоздатьОбъект("Excel.Application");
РабочаяКнига = Эксель.Workbooks.Add();
РабочаяКнига.Activate();
// Удалить все листы, оставить один
Колво = РабочаяКнига.WorkSheets.Count;
Для I = 1 По Колво-1 Цикл
//РабочаяКнига.WorkSheets(I).Select();
Эксель.Application.DisplayAlerts = 0;
РабочаяКнига.WorkSheets(I).Delete();
Эксель.Application.DisplayAlerts = 1;
КонецЦикла;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Если Файлы.НомерСтроки=Файлы.КоличествоСтрок() Тогда
Продолжить;
КонецЕсли;
РабочаяКнига.WorkSheets().Add();
КонецЦикла;
// Изменение названий ярлычкой листов рабочей книги
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
РабочаяКнига.WorkSheets(Файлы.НомерСтроки).Name = Файлы.ИмяЛиста;
КонецЦикла;
// Копируем содержимое листов книг в созданную книгу
Эксель.Application.DisplayAlerts = 0;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Сч=Файлы.НомерСтроки;
Книга2=Эксель.Workbooks.Open(маска+Сч+".xls");
Книга2.ActiveSheet.Select();
Эксель.Cells.Select();
Эксель.Selection.Copy();
РабочаяКнига.WorkSheets(Сч).Paste();
Книга2.Close();
КонецЦикла;
Эксель.Application.DisplayAlerts = 1;
Файлы.ВыбратьСтроки();
Пока Файлы.ПолучитьСтроку()=1 Цикл
Эксель.Sheets(Файлы.ИмяЛиста).Select();
Эксель.Range("A1").Select();
КонецЦикла;
// Спозиционируемся в рабочей книге на 1-й лист
Файлы.ПолучитьСтрокуПоНомеру(1);
Эксель.Sheets(Файлы.ИмяЛиста).Select();
Эксель.DisplayAlerts=0;
Эксель.ActiveWorkbook.SaveAs(ИмяФФ,-4143);
Эксель.DisplayAlerts=1;
Эксель.Visible=1;
Для й=1 по КолвоВременныхФайлов Цикл
Попытка
ФС.УдалитьФайл(Маска+й+".xls");
Исключение КонецПопытки;
КонецЦикла;
Эксель = 0;
Иначе
Состояние("Отчет сформирован. Печать...");
Таб.Опции(0, 0, 0, 0, "Списания");
Таб.ТолькоПросмотр(1);
Таб.Показать("Списания","""");
КонецЕсли;
КонецПроцедуры
ДатаНачала=РабочаяДата();
ДатаКонца=РабочаяДата();

"

 
Thorvardr
Пост №2
"Макет бы увидеть, может там форматирование сумм д...
01.11.2010 19:44
 
 
Flava_John
Пост №3
я отправил вам обработку, форматирование для эксел...
02.11.2010 08:31
 
 
Thorvardr
Пост №4
"Да, я получил.Не совсем понял пару моментов.Обраб...
02.11.2010 10:25
 
 
Flava_John
Пост №5
Спасибо. отправь пожалуйста обработку мне на почту...
02.11.2010 10:44
 
 
Flava_John
Пост №6
ещё один маленький вопросик, а в макете таблица, ...
02.11.2010 12:24
 
 
Thorvardr
Пост №7
Макет "Таблица" в вашей обработке показывает сведе...
02.11.2010 12:33
 
 
Flava_John
Пост №8
помоги пожалуйста, что-то не получается итоговую с...
02.11.2010 13:12
 
 
Thorvardr
Пост №9
Отправил
02.11.2010 13:30
 
 
Flava_John
Пост №10
Спасибо!
02.11.2010 13:37
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% ндс при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет доходов при УСН учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги