Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] 1C 8.2.9.356, УТ 10.3.7.9. Не работает метод справочника "Уровень()"
Мозголом
Пост №1
Мозголом
читатель
офлайн
Дата регистрации: 27.02.2007
Сообщений: 145
Пост №1
 
17.12.2010 08:13

"Начинаю постигать азы восьмерки, поэтому сильно прошу не пинать.

Не могу понять, в чем собственно дело, но почему то не работает метод СправочникаСсылки.Уровень()

Вот код (тут работает):

Справочник = Справочники.Номенклатура.ВыбратьИерархически(Группа);
Пока Справочник.Следующий() Цикл
Если Справочник.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;
Цены = РегистрыСведений.ЦеныНоменклатуры.Выбрать(,ТекущаяДата(),Новый Структура("Номенклатура", Справочник.Ссылка));
Цена = 0;
Пока Цены.Следующий() Цикл
Если Цены.ТипЦен = ТипЦен Тогда
      Цена = Цены.Цена;
КонецЕсли;
КонецЦикла;
Если Цена = 0 Тогда
Сообщить("У товара " + Справочник.Наименование + " не назначена цена. Пропущен...");
Продолжить;
КонецЕсли;
ОбработаноШтрихкодов = 0;
Если Справочник.Весовой = 0 Тогда
ШтрихКоды = РегистрыСведений.Штрихкоды.Выбрать(Новый Структура("Владелец", Справочник.Ссылка));
Пока ШтрихКоды.Следующий() Цикл
...
Родитель = Справочник.Родитель;
Если ЗначениеЗаполнено(Родитель) Тогда
      Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
      Родитель = Родитель.Родитель;
      Если ЗначениеЗаполнено(Родитель) Тогда
       Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
       Родитель = Родитель.Родитель;
       Если ЗначениеЗаполнено(Родитель) Тогда
       Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
       Родитель = Родитель.Родитель;
       Если ЗначениеЗаполнено(Родитель) Тогда
            Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
            Родитель = Родитель.Родитель;
            Если ЗначениеЗаполнено(Родитель) Тогда
             Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
            КонецЕсли;
       КонецЕсли;
       КонецЕсли;
      КонецЕсли;
КонецЕсли;
...

А вот тут почему то не работает:

Процедура ЗаполнитьПоля(Номенклатура, Цена, Отдел, ШтрихКод, Единица)
Товары = Товары_.Добавить();
Товары.Номенклатура = Номенклатура.Ссылка;
...
Номенклатура_ = Справочники.Номенклатура.ВыбратьИерархически();
Пока Номенклатура_.Следующий() Цикл
Если Не Номенклатура_.ЭтоГруппа Тогда
      Продолжить;
КонецЕсли;
Если Номенклатура_.Ссылка = Номенклатура.Родитель Тогда
      Родитель = Номенклатура_;
      Если Родитель.Уровень() = 0 Тогда
       Товары.Группа1 = Число(СокрЛП(Родитель.Код));
      ИначеЕсли Родитель.Уровень() = 1 Тогда
       Товары.Группа1 = Число(СокрЛП(Родитель.Родитель.Код));
       Товары.Группа2 = Число(СокрЛП(Родитель.Код));
      ИначеЕсли Родитель.Уровень() = 2 Тогда
      ...

вот в последнем варианте вообще ругается, говорит что метод "Уровень()" не обнаружен. В чем дело? Может еще чем дополнить вопрос или кто так уже догадался? "

 
Мозголом
Пост №1
17.12.2010 08:13
 

"Начинаю постигать азы восьмерки, поэтому сильно прошу не пинать.

Не могу понять, в чем собственно дело, но почему то не работает метод СправочникаСсылки.Уровень()

Вот код (тут работает):

Справочник = Справочники.Номенклатура.ВыбратьИерархически(Группа);
Пока Справочник.Следующий() Цикл
Если Справочник.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;
Цены = РегистрыСведений.ЦеныНоменклатуры.Выбрать(,ТекущаяДата(),Новый Структура("Номенклатура", Справочник.Ссылка));
Цена = 0;
Пока Цены.Следующий() Цикл
Если Цены.ТипЦен = ТипЦен Тогда
      Цена = Цены.Цена;
КонецЕсли;
КонецЦикла;
Если Цена = 0 Тогда
Сообщить("У товара " + Справочник.Наименование + " не назначена цена. Пропущен...");
Продолжить;
КонецЕсли;
ОбработаноШтрихкодов = 0;
Если Справочник.Весовой = 0 Тогда
ШтрихКоды = РегистрыСведений.Штрихкоды.Выбрать(Новый Структура("Владелец", Справочник.Ссылка));
Пока ШтрихКоды.Следующий() Цикл
...
Родитель = Справочник.Родитель;
Если ЗначениеЗаполнено(Родитель) Тогда
      Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
      Родитель = Родитель.Родитель;
      Если ЗначениеЗаполнено(Родитель) Тогда
       Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
       Родитель = Родитель.Родитель;
       Если ЗначениеЗаполнено(Родитель) Тогда
       Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
       Родитель = Родитель.Родитель;
       Если ЗначениеЗаполнено(Родитель) Тогда
            Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
            Родитель = Родитель.Родитель;
            Если ЗначениеЗаполнено(Родитель) Тогда
             Файл.УстановитьЗначениеПоля("GRUPPA" + (Родитель.Уровень() + 1), Число(СокрЛП(Родитель.Код)));
            КонецЕсли;
       КонецЕсли;
       КонецЕсли;
      КонецЕсли;
КонецЕсли;
...

А вот тут почему то не работает:

Процедура ЗаполнитьПоля(Номенклатура, Цена, Отдел, ШтрихКод, Единица)
Товары = Товары_.Добавить();
Товары.Номенклатура = Номенклатура.Ссылка;
...
Номенклатура_ = Справочники.Номенклатура.ВыбратьИерархически();
Пока Номенклатура_.Следующий() Цикл
Если Не Номенклатура_.ЭтоГруппа Тогда
      Продолжить;
КонецЕсли;
Если Номенклатура_.Ссылка = Номенклатура.Родитель Тогда
      Родитель = Номенклатура_;
      Если Родитель.Уровень() = 0 Тогда
       Товары.Группа1 = Число(СокрЛП(Родитель.Код));
      ИначеЕсли Родитель.Уровень() = 1 Тогда
       Товары.Группа1 = Число(СокрЛП(Родитель.Родитель.Код));
       Товары.Группа2 = Число(СокрЛП(Родитель.Код));
      ИначеЕсли Родитель.Уровень() = 2 Тогда
      ...

вот в последнем варианте вообще ругается, говорит что метод "Уровень()" не обнаружен. В чем дело? Может еще чем дополнить вопрос или кто так уже догадался? "

 
BelikovS
Пост №2
"А в каком модуле располагается эта процедура (Зап...
17.12.2010 09:34
 
 
Мозголом
Пост №3
Это все процедуры в модуле формы внешней обработки...
17.12.2010 09:48
 
 
BelikovS
Пост №4
А Родитель?Если у вас есть элемент на форме с таки...
17.12.2010 10:21
 
 
Мозголом
Пост №5
"Блин, ошибочка вышла. Родитель и Номенклатура_ им...
17.12.2010 11:21
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат переплаты возмещение пособия за счет ФСС восстановление НДС выездная налоговая проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зачет страховых взносов защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от НДС освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков перерасчет налогов переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебные издержки суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ формы документов хроники 54-ФЗ штрафные санкции ЭДО экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры