Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Другие решения на платформе "1С:Предприятие 8"] УТ 10.3 заполнение табличной части
Natalia111
Пост №1
Natalia111
читатель
офлайн
Дата регистрации: 04.07.2011
Сообщений: 52
Пост №1
 
13.03.2012 17:00

"Добрый день, стоит такая задача: для документа Реализация Товаров и Услугз в табличной части есть кнопка Изменить, при нажатии которой открывается форма подбора элементов, по которым может быть заполнена таб часть документа реализация. Так вот, при открытии формы подбора, сначала выбирается действие, например, "Добавить из документа" затем из списка документов выбирается тип документа, например, "Заказ покупателя" затем открывается ещё одно окно выбора со списком всех Заказов покупателей, а задача отфильтровать заказы только по тому контрагенту, который указан в док-те "Реализация". Исходя из кода, за вывод списка самих документов отвечает какая-то системная обработка "Стандартная обработка". Её код можно как-то просмотреть, или нужно будет дописывать выбор объектов самой? Или я всё делаю неправильно и решать эту задачу нужно по-другому?


 Процедура ПолеВводаВариантаЗначенияНачалоВыбора(Элемент, СтандартнаяОбработка)

// Заполним список возможных типов для выбора
СписокВидов = Новый СписокЗначений;
МассивТипов = ЭлементыФормы.ПолеВводаВариантаЗачения.ОграничениеТипа.Типы();
РазмерСписка = МассивТипов.Количество();
Если РазмерСписка = 1 Тогда

       Если МассивТипов[0] = Тип("СправочникСсылка.ТипыЦенНоменклатурыКонтрагентов")
       И Не ЗначениеЗаполнено(ДокументОбъект.Контрагент) Тогда
            // Не понятно что выбирать, это ошибка.
            Предупреждение("Для установки цен поставщика необходимо в документе выбрать тип цен контрагента!");
            СтандартнаяОбработка = Ложь;
            Возврат;
       КонецЕсли;

ИначеЕсли РазмерСписка > 1 Тогда

       // В случае одного элемента выбирать нечего, нужное значение мы установили при выборе действия,
       // поэтому этот случай здесь не обрабатывается.
      
       Для каждого ЭлементМассива Из МассивТипов Цикл

            Если Документы.ТипВсеСсылки().СодержитТип(ЭлементМассива)
             ИЛИ Справочники.ТипВсеСсылки().СодержитТип(ЭлементМассива) Тогда
             ПустоеЗначение = Новый(ЭлементМассива);
             ОбъектОписанияМетаданного = ПустоеЗначение.Метаданные();
             СписокВидов.Добавить(ЭлементМассива, ОбъектОписанияМетаданного.Представление());
            КонецЕсли;
       КонецЦикла;

       СписокВидов.СортироватьПоПредставлению();

       НачальноеЗначение = Неопределено;
       Если ТипЗнч(ВариантЗначения) = Тип("СписокЗначений") Тогда
            НачальноеЗначение = ЭлементыФормы.ПолеВводаВариантаЗачения.Значение.ТипЗначения.Типы()[0];
       КонецЕсли;
       НачальноеЗначениеСписка = СписокВидов.НайтиПоЗначению(НачальноеЗначение);
       ВыбранныйЭлемент = ВыбратьИзСписка(СписокВидов, Элемент, НачальноеЗначениеСписка);

       Если ВыбранныйЭлемент = Неопределено Тогда // отказ от выбора
            СтандартнаяОбработка = Ложь;
            Возврат;
       КонецЕсли;

       Если Документы.ТипВсеСсылки().СодержитТип(ВыбранныйЭлемент.Значение) Тогда
            ЭлементыФормы.ПолеВводаВариантаЗачения.Значение = Новый СписокЗначений;
            МассивТипов = Новый Массив;
            МассивТипов.Добавить(ВыбранныйЭлемент.Значение);
            ЭлементыФормы.ПолеВводаВариантаЗачения.Значение.ТипЗначения = Новый ОписаниеТипов(МассивТипов);
       Иначе
            Элемент.Значение = ОбщегоНазначения.ПустоеЗначениеТипа(ВыбранныйЭлемент.Значение);
       КонецЕсли;

Иначе // размер списка = 0

       // Не понятно что выбирать, это ошибка.
       Предупреждение("Не заданы возможные типы значения!");
       СтандартнаяОбработка = Ложь;
       Возврат;

КонецЕсли;

КонецПроцедуры // ПолеВводаВариантаЗаченияНачалоВыбора()
"

 
Natalia111
Пост №1
13.03.2012 17:00
 

"Добрый день, стоит такая задача: для документа Реализация Товаров и Услугз в табличной части есть кнопка Изменить, при нажатии которой открывается форма подбора элементов, по которым может быть заполнена таб часть документа реализация. Так вот, при открытии формы подбора, сначала выбирается действие, например, "Добавить из документа" затем из списка документов выбирается тип документа, например, "Заказ покупателя" затем открывается ещё одно окно выбора со списком всех Заказов покупателей, а задача отфильтровать заказы только по тому контрагенту, который указан в док-те "Реализация". Исходя из кода, за вывод списка самих документов отвечает какая-то системная обработка "Стандартная обработка". Её код можно как-то просмотреть, или нужно будет дописывать выбор объектов самой? Или я всё делаю неправильно и решать эту задачу нужно по-другому?


 Процедура ПолеВводаВариантаЗначенияНачалоВыбора(Элемент, СтандартнаяОбработка)

// Заполним список возможных типов для выбора
СписокВидов = Новый СписокЗначений;
МассивТипов = ЭлементыФормы.ПолеВводаВариантаЗачения.ОграничениеТипа.Типы();
РазмерСписка = МассивТипов.Количество();
Если РазмерСписка = 1 Тогда

       Если МассивТипов[0] = Тип("СправочникСсылка.ТипыЦенНоменклатурыКонтрагентов")
       И Не ЗначениеЗаполнено(ДокументОбъект.Контрагент) Тогда
            // Не понятно что выбирать, это ошибка.
            Предупреждение("Для установки цен поставщика необходимо в документе выбрать тип цен контрагента!");
            СтандартнаяОбработка = Ложь;
            Возврат;
       КонецЕсли;

ИначеЕсли РазмерСписка > 1 Тогда

       // В случае одного элемента выбирать нечего, нужное значение мы установили при выборе действия,
       // поэтому этот случай здесь не обрабатывается.
      
       Для каждого ЭлементМассива Из МассивТипов Цикл

            Если Документы.ТипВсеСсылки().СодержитТип(ЭлементМассива)
             ИЛИ Справочники.ТипВсеСсылки().СодержитТип(ЭлементМассива) Тогда
             ПустоеЗначение = Новый(ЭлементМассива);
             ОбъектОписанияМетаданного = ПустоеЗначение.Метаданные();
             СписокВидов.Добавить(ЭлементМассива, ОбъектОписанияМетаданного.Представление());
            КонецЕсли;
       КонецЦикла;

       СписокВидов.СортироватьПоПредставлению();

       НачальноеЗначение = Неопределено;
       Если ТипЗнч(ВариантЗначения) = Тип("СписокЗначений") Тогда
            НачальноеЗначение = ЭлементыФормы.ПолеВводаВариантаЗачения.Значение.ТипЗначения.Типы()[0];
       КонецЕсли;
       НачальноеЗначениеСписка = СписокВидов.НайтиПоЗначению(НачальноеЗначение);
       ВыбранныйЭлемент = ВыбратьИзСписка(СписокВидов, Элемент, НачальноеЗначениеСписка);

       Если ВыбранныйЭлемент = Неопределено Тогда // отказ от выбора
            СтандартнаяОбработка = Ложь;
            Возврат;
       КонецЕсли;

       Если Документы.ТипВсеСсылки().СодержитТип(ВыбранныйЭлемент.Значение) Тогда
            ЭлементыФормы.ПолеВводаВариантаЗачения.Значение = Новый СписокЗначений;
            МассивТипов = Новый Массив;
            МассивТипов.Добавить(ВыбранныйЭлемент.Значение);
            ЭлементыФормы.ПолеВводаВариантаЗачения.Значение.ТипЗначения = Новый ОписаниеТипов(МассивТипов);
       Иначе
            Элемент.Значение = ОбщегоНазначения.ПустоеЗначениеТипа(ВыбранныйЭлемент.Значение);
       КонецЕсли;

Иначе // размер списка = 0

       // Не понятно что выбирать, это ошибка.
       Предупреждение("Не заданы возможные типы значения!");
       СтандартнаяОбработка = Ложь;
       Возврат;

КонецЕсли;

КонецПроцедуры // ПолеВводаВариантаЗаченияНачалоВыбора()
"

 
Alizar
Пост №2
СтандартнаяОбработка - это параметр Вашей процедур...
13.03.2012 17:25
 
 
Natalia111
Пост №3
в таком случае, я не могу понять, где лежит тот ко...
13.03.2012 17:30
 
 
Alizar
Пост №4
Торговли, к сожалению, под рукой нет, но Вы уверен...
13.03.2012 17:32
 
 
Natalia111
Пост №5
думаю, да. к этому полю ввода привязаны только две...
13.03.2012 17:43
 
 
Natalia111
Пост №6
"начало выбора" я имела ввиду
13.03.2012 17:44
 
 
Natalia111
Пост №7
"Разобралась, как это работает, а может быть можно...
13.03.2012 19:15
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% ндс при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет доходов при УСН учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги