Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Зарплата и управление персоналом 8] Движения документа по регистрам, очередное чудо
Тэра
Пост №1
Тэра
активный пользователь
онлайн
Дата регистрации: 25.12.2008
Сообщений: 21353
Пост №1
 
11.09.2012 06:18

"День добрый. Ниже приведен фрагмент кода (извиняюсь за вид, не знаю, как вставить, чтобы красиво было):


Процедура ОбработкаПроведения(Отказ, Режим)
//структура, содержащая имена регистров сведений по которым надо проводить документ
Перем СтруктураПроведенияПоРегистрамНакопления;

// Заголовок для сообщений об ошибках проведения.
Заголовок = ОбщегоНазначения.ПредставлениеДокументаПриПроведении(Ссылка);

РезультатЗапросаПоШапке = СформироватьЗапросПоШапке();

// Получим реквизиты шапки из запроса
ВыборкаПоШапкеДокумента = РезультатЗапросаПоШапке.Выбрать();

Если ВыборкаПоШапкеДокумента.Следующий() Тогда

       //Надо позвать проверку заполнения реквизитов шапки
       ПроверитьЗаполнениеШапки(ВыборкаПоШапкеДокумента, Отказ, Заголовок);

       // Движения стоит добавлять, если в проведении еще не отказано (отказ =ложь)
       Если НЕ Отказ Тогда

            // получим учетную политику
            УпрощенныйУчетНДФЛ                   = ПроцедурыУправленияПерсоналом.ЗначениеУчетнойПолитикиПоПерсоналуОрганизации(глЗначениеПеременной("глУчетнаяПолитикаПоПерсоналуОрганизации"), Организация, "УпрощенныйУчетНДФЛ");
            
            // ведется ли учет задолженности в разрезе периодов возникновения задолженности
            УчетЗадолженностиПоМесяцам = ПроцедурыУправленияПерсоналом.ЗначениеУчетнойПолитикиПоПерсоналуОрганизации(глЗначениеПеременной("глУчетнаяПолитикаПоПерсоналуОрганизации"), Организация, "УчетЗадолженностиПоМесяцам");
            
            // получим реквизиты табличной части
            ВыборкаПоНачислениям = СформироватьЗапросПоНачисления(ВыборкаПоШапкеДокумента).Выбрать();
            
            Пока ВыборкаПоНачислениям.СледующийПоЗначениюПоля("НомерСтроки") Цикл

             // проверим очередную строку табличной части
             ПроверитьЗаполнениеСтрокиРаботникаОрганизации(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, Отказ, Заголовок);

             Если НЕ Отказ Тогда

                   // В регистр расчета начисления пишем только для работников организации
                   // Комментарий поставлен в начале 2010 г
                   //Если НЕ ВыборкаПоНачислениям.ФизлицоАкционер Тогда
                   // ДобавитьСтрокуДополнительныхНачислений(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям);
                   // СтруктураПроведенияПоРегистрамНакопления = Новый Структура("НДФЛСведенияОДоходах, НДФЛРасчетыСБюджетом, ВзаиморасчетыСРаботникамиОрганизаций");
                   //Иначе
                   // СтруктураПроведенияПоРегистрамНакопления = Новый Структура("НДФЛСведенияОДоходах, НДФЛРасчетыСБюджетом");
                   //КонецЕсли;
                   //
                   //ДобавитьСтрокуВДвиженияПоРегистрамНакопления(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, СтруктураПроведенияПоРегистрамНакопления, УпрощенныйУчетНДФЛ, УчетЗадолженностиПоМесяцам);
                  
                   Если НЕ ВыборкаПоНачислениям.ФизлицоАкционер Тогда
                        ДобавитьСтрокуДополнительныхНачислений(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям);
                        СтруктураПроведенияПоРегистрамНакопления = Новый Структура("ВзаиморасчетыСРаботникамиОрганизаций,НДФЛСведенияОДоходах");
                  
                        ДобавитьСтрокуВДвиженияПоРегистрамНакопления(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, СтруктураПроведенияПоРегистрамНакопления, УпрощенныйУчетНДФЛ, УчетЗадолженностиПоМесяцам);
                   КонецЕсли;
                  
             КонецЕсли;

            КонецЦикла;
            
       КонецЕсли;

КонецЕсли;

КонецПроцедуры

Т.е. документ должен делать движения по двум регистрам. Вопрос: КАК надо создать и провести документ, чтобы движения по регистру ВзаиморасчетыСРаботникамиОрганизаций были, а по регистру НДФЛСведенияОДоходах не было? Наши в один голос твердят, что это не возможно. Однако смотрю в базу, а там именно это и вижу. У одного пользователя за январь, февраль, март, апрель движения есть, май, июнь - движений нет, июль, август, сентябрь - движения есть, октябрь, ноябрь,декабрь - движений нет. Такие же документы создавали и другие пользователи, но у них все нормально, чертовски талантливой только одна оказалась.
ЗЫ: Речь идет ещё про 8.1."

 
Тэра
Пост №1
11.09.2012 06:18
 

"День добрый. Ниже приведен фрагмент кода (извиняюсь за вид, не знаю, как вставить, чтобы красиво было):


Процедура ОбработкаПроведения(Отказ, Режим)
//структура, содержащая имена регистров сведений по которым надо проводить документ
Перем СтруктураПроведенияПоРегистрамНакопления;

// Заголовок для сообщений об ошибках проведения.
Заголовок = ОбщегоНазначения.ПредставлениеДокументаПриПроведении(Ссылка);

РезультатЗапросаПоШапке = СформироватьЗапросПоШапке();

// Получим реквизиты шапки из запроса
ВыборкаПоШапкеДокумента = РезультатЗапросаПоШапке.Выбрать();

Если ВыборкаПоШапкеДокумента.Следующий() Тогда

       //Надо позвать проверку заполнения реквизитов шапки
       ПроверитьЗаполнениеШапки(ВыборкаПоШапкеДокумента, Отказ, Заголовок);

       // Движения стоит добавлять, если в проведении еще не отказано (отказ =ложь)
       Если НЕ Отказ Тогда

            // получим учетную политику
            УпрощенныйУчетНДФЛ                   = ПроцедурыУправленияПерсоналом.ЗначениеУчетнойПолитикиПоПерсоналуОрганизации(глЗначениеПеременной("глУчетнаяПолитикаПоПерсоналуОрганизации"), Организация, "УпрощенныйУчетНДФЛ");
            
            // ведется ли учет задолженности в разрезе периодов возникновения задолженности
            УчетЗадолженностиПоМесяцам = ПроцедурыУправленияПерсоналом.ЗначениеУчетнойПолитикиПоПерсоналуОрганизации(глЗначениеПеременной("глУчетнаяПолитикаПоПерсоналуОрганизации"), Организация, "УчетЗадолженностиПоМесяцам");
            
            // получим реквизиты табличной части
            ВыборкаПоНачислениям = СформироватьЗапросПоНачисления(ВыборкаПоШапкеДокумента).Выбрать();
            
            Пока ВыборкаПоНачислениям.СледующийПоЗначениюПоля("НомерСтроки") Цикл

             // проверим очередную строку табличной части
             ПроверитьЗаполнениеСтрокиРаботникаОрганизации(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, Отказ, Заголовок);

             Если НЕ Отказ Тогда

                   // В регистр расчета начисления пишем только для работников организации
                   // Комментарий поставлен в начале 2010 г
                   //Если НЕ ВыборкаПоНачислениям.ФизлицоАкционер Тогда
                   // ДобавитьСтрокуДополнительныхНачислений(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям);
                   // СтруктураПроведенияПоРегистрамНакопления = Новый Структура("НДФЛСведенияОДоходах, НДФЛРасчетыСБюджетом, ВзаиморасчетыСРаботникамиОрганизаций");
                   //Иначе
                   // СтруктураПроведенияПоРегистрамНакопления = Новый Структура("НДФЛСведенияОДоходах, НДФЛРасчетыСБюджетом");
                   //КонецЕсли;
                   //
                   //ДобавитьСтрокуВДвиженияПоРегистрамНакопления(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, СтруктураПроведенияПоРегистрамНакопления, УпрощенныйУчетНДФЛ, УчетЗадолженностиПоМесяцам);
                  
                   Если НЕ ВыборкаПоНачислениям.ФизлицоАкционер Тогда
                        ДобавитьСтрокуДополнительныхНачислений(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям);
                        СтруктураПроведенияПоРегистрамНакопления = Новый Структура("ВзаиморасчетыСРаботникамиОрганизаций,НДФЛСведенияОДоходах");
                  
                        ДобавитьСтрокуВДвиженияПоРегистрамНакопления(ВыборкаПоШапкеДокумента, ВыборкаПоНачислениям, СтруктураПроведенияПоРегистрамНакопления, УпрощенныйУчетНДФЛ, УчетЗадолженностиПоМесяцам);
                   КонецЕсли;
                  
             КонецЕсли;

            КонецЦикла;
            
       КонецЕсли;

КонецЕсли;

КонецПроцедуры

Т.е. документ должен делать движения по двум регистрам. Вопрос: КАК надо создать и провести документ, чтобы движения по регистру ВзаиморасчетыСРаботникамиОрганизаций были, а по регистру НДФЛСведенияОДоходах не было? Наши в один голос твердят, что это не возможно. Однако смотрю в базу, а там именно это и вижу. У одного пользователя за январь, февраль, март, апрель движения есть, май, июнь - движений нет, июль, август, сентябрь - движения есть, октябрь, ноябрь,декабрь - движений нет. Такие же документы создавали и другие пользователи, но у них все нормально, чертовски талантливой только одна оказалась.
ЗЫ: Речь идет ещё про 8.1."

 
Денис (САМАРА)
Пост №2
Видимо все самое интересное в "ДобавитьСтрокуВДвиж...
11.09.2012 09:48
 
 
Тэра
Пост №3
"Процедура ДобавитьСтрокуВДвиженияПоРегистрамНакоп...
11.09.2012 10:04
 
 
Денис (САМАРА)
Пост №4
Зачем здесь этот код? Он у вас отличается от типов...
11.09.2012 10:21
 
 
Тэра
Пост №5
Ты писал:>Видимо все самое интересное в "ДобавитьС...
11.09.2012 10:24
 
 
Денис (САМАРА)
Пост №6
А ошибка вообще воспроизводится? А то может это бы...
11.09.2012 10:58
 
 
Тэра
Пост №7
нет, не воспроизводится. Если в текущей базе прове...
11.09.2012 11:52
 
 
Денис (САМАРА)
Пост №8
Даже если перепроводишь под ее пользователем, то д...
11.09.2012 12:01
 
 
Тэра
Пост №9
ну перепроводила то я под своим именем...Попробую ...
11.09.2012 12:07
 
 
Тэра
Пост №10
при перепроведении и под её именем все нормально. ...
11.09.2012 12:17
 
 
Денис (САМАРА)
Пост №11
Да код проведения был другой на момент проведения ...
11.09.2012 12:19
 
 
Тэра
Пост №12
я восстановила базу на июнь 2010 года. В ней же пе...
11.09.2012 12:26
 
 
Vovan1975
Пост №13
да легковариант номер раз - невоспроизводимый - у ...
11.09.2012 12:42
 
 
Тэра
Пост №14
> ну или обработки обновления ИБ как пример...пояс...
11.09.2012 12:43
 
 
Денис (САМАРА)
Пост №15
А где уверенность, что архив был сделан не ПОСЛЕ в...
11.09.2012 12:47
 
 
Денис (САМАРА)
Пост №16
> ну или обработки обновления ИБ как пример... Я в...
11.09.2012 12:50
 
 
Тэра
Пост №17
о господи. Эти документы делаются каждый месяц. У ...
11.09.2012 12:53
 
 
Тэра
Пост №18
обработкой (специально написанной) могла бы удалит...
11.09.2012 12:54
 
 
Vovan1975
Пост №19
да просто все - когда пользюк провел документ, дви...
11.09.2012 13:00
 
 
Тэра
Пост №20
> да просто все - когда пользюк провел документ, д...
11.09.2012 13:04
 
 
Vovan1975
Пост №21
а это не обязательно специально. Это могла быть ба...
11.09.2012 13:05
 
 
Тэра
Пост №22
какой обработки, например? я веду эту базу три год...
11.09.2012 13:10
 
 
Vovan1975
Пост №23
"СтруктураПроведенияПоРегистрамНакопления" - сия с...
11.09.2012 13:31
 
 
Тэра
Пост №24
в первой процедуре смотри
11.09.2012 13:32
 
 
Денис (САМАРА)
Пост №25
Там еще есть условие "ВыборкаПоТЧ.НДФЛ 0", которы...
11.09.2012 14:15
 
 
Тэра
Пост №26
НДФЛ там отсутствует. Во всех документах. Это про ...
11.09.2012 14:20
 
 
Денис (САМАРА)
Пост №27
Вобщем при следующей подобной процедуре садись ряд...
11.09.2012 15:02
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов вычетов коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемая иностранная компания контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры