Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Другие решения на платформе "1С:Предприятие 8"] Загрузка из Excel в 1С 8.1 УТ
EL Khan
Пост №1
EL Khan
читатель
офлайн
Дата регистрации: 10.02.2012
Сообщений: 92
Пост №1
 
06.10.2012 13:13

"Элементы создаются, документ поступление создается, но вот установка цен номенклатуры ругается:

{Форма.Форма(209)}: Ошибка при вызове метода контекста (Записать): Запись с такими ключевыми полями существует! : Рознизная : хххххххх : : 06.10.2012 0:00:00 (Регистр сведений: Цены номенклатуры; Номер строки: 7)
       ДокУстановкаЦенНоменклатуры.Записать(РежимЗаписиДокумента.Проведение);
О чем говорит эта ошибка? номенклатура в экселе встречается несколько раз, и оно не может записаться в регистр сведений, так?
Скажите пожалуйста в чем проблема?

Процедура ЗагрузкаИзExcel()    Экзель = Новый COMОбъект("Excel.Application");    Книга = Экзель.Application.Workbooks.Open(Путь);    ТекЛист = Книга.WorkSheets(1);    КолСтрок = ТекЛист.Cells(1,1).SpecialCells(11).Row;    КолКолонок = ТекЛист.Cells(1,1).SpecialCells(11).Column;    КоличествоСтраниц = 1;            Для ТекНомер  = 1 По КоличествоСтраниц Цикл    Артикул = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Арт).Value);    Наименование = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Наим).Value);    Если (ШК = 0) или (ШК > КолКолонок) Тогда        Сообщить("ШтрихКод отсутсвует в данной номенклатуре!");    Иначе     ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,ШК).Value);    КонецЕсли;    Коллекция = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Коллекция1).Value);    Цвет = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Цвет1).Value);    Размер = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Размер1).Value);    Количество = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Колич).Value);    Цена = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Цен).Value);    Сообщить("Внешняя накладная прочитана, начилась запись элементов справочника Номенклатура!");    счСтроки = НачСтрока;        //// Заполняем шапку Документа Поступление товаров и услуг //////////////////////////////////////             НовыйДокПоступление = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();        НовыйДокПоступление.Дата = Дата;        НовыйДокПоступление.ВидПоступления = Перечисления.ВидыПоступленияТоваров.НаСклад;        НовыйДокПоступление.Организация = Организация;        НовыйДокПоступление.Контрагент = Контрагент;        НовыйДокПоступление.ДоговорКонтрагента = Дог;        НовыйДокПоступление.ВалютаДокумента = ВалютаДок;        НовыйДокПоступление.КурсВзаиморасчетов = 1;        НовыйДокПоступление.КратностьВзаиморасчетов = 1;        НовыйДокПоступление.СкладОрдер = Склад;        НовыйДокПоступление.ОтражатьВУправленческомУчете = Истина;        НовыйДокПоступление.ОтражатьВБухгалтерскомУчете = Истина;        НовыйДокПоступление.ОтражатьВНалоговомУчете = Ложь;            //// Создаю док УстановкаЦенНоменклатуры  ///////////////////////////////////////////////////////                         ДокУстановкаЦенНоменклатуры = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();        ДокУстановкаЦенНоменклатуры.Дата = Дата;        ДокУстановкаЦенНоменклатуры.ТипыЦен.Очистить();        НовСтрТипыЦен = ДокУстановкаЦенНоменклатуры.ТипыЦен.Добавить();                ТипЦены = ТипЦен; // Справочники.ТипыЦенНоменклатуры.НайтиПоКоду("000000001");         НовСтрТипыЦен.ТипЦен = ТипЦены;                            Для    ш = НачСтрока по КолСтрок Цикл        Артикул = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Арт).Value);                                         Наименование = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Наим).Value);                    Если (ШтрихКод = 0) Тогда        Сообщить("ШтрихКод отсутсвует в данной номенклатуре!");        Иначе         ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,ШК).Value);        КонецЕсли;        //ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,ШК).Value);         Коллекция = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Коллекция1).Value);        Цвет = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Цвет1).Value);        Размер = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Размер1).Value);        Количество = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Колич).Value);        Цена  = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Цен).Value);                счСтроки = счСтроки + 1;                    Если (Наименование = """") или (Наименование = Неопределено) или (Наименование = null) Тогда            Продолжить;        КонецЕсли;                    Запись = Истина;        СпрНоменклатура = Справочники.Номенклатура;                 Если Справочники.Номенклатура.НайтиПоНаименованию(Наименование + " " + Цвет + " " + Размер).Пустая() Тогда                                       НовыйЭлемент = Справочники.Номенклатура.СоздатьЭлемент();            Родитель = ГрпНом;            НовыйЭлемент.Родитель = Родитель;            НовыйЭлемент.Артикул = Артикул;            НовыйЭлемент.Коллекция = Коллекция;            НовыйЭлемент.Цвет = Цвет;            НовыйЭлемент.Размер = Размер;            НовыйЭлемент.Наименование = Наименование + " " + Цвет + " " + Размер;            НовыйЭлемент.НаименованиеПолное = Наименование + " " + Цвет + " " + Размер;            НовыйЭлемент.ВидНоменклатуры = ВидНомен;            НовыйЭлемент.БазоваяЕдиницаИзмерения = ЕдИзмер;                    НовыйЭлемент.Записать();            НовыйЕдИзмер = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();            НовыйЕдИзмер.ЕдиницаПоКлассификатору = ЕдИзмер;            НовыйЕдИзмер.Наименование = ЕдИзмер.Наименование;            НовыйЕдИзмер.Коэффициент = 1;            НовыйЕдИзмер.Владелец = НовыйЭлемент.Ссылка;            НовыйЕдИзмер.Записать();            НовыйЭлемент.ЕдиницаХраненияОстатков = НовыйЕдИзмер.Ссылка;            НовыйЭлемент.СтавкаНДС = СтавкаНДС;            //НовыйЭлемент.ВестиУчетПоХарактеристикам = Истина;             НовыйЭлемент.Записать();                           //Запись РегистраСведений Штрихкоды                         ЗаписьШК = Истина;            РегСведШК = РегистрыСведений.Штрихкоды;            ВыборкаРегСведШК = РегистрыСведений.Штрихкоды.Выбрать();            Пока ВыборкаРегСведШК.Следующий() Цикл                Если ВыборкаРегСведШК.Штрихкод = ШтрихКод Тогда                    ЗаписьШК = Ложь;                КонецЕсли;            КонецЦикла;            ЗаписьВРегистрСвед = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();            ЗаписьВРегистрСвед.Владелец = НовыйЭлемент.Ссылка;            ЗаписьВРегистрСвед.ЕдиницаИзмерения = НовыйЭлемент.ЕдиницаХраненияОстатков;            ЗаписьВРегистрСвед.Штрихкод = ШтрихКод;            ЗаписьВРегистрСвед.ТипШтрихкода = ЭлементыФормы.ТипШтрихкода.Значение;//ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;             ЗаписьВРегистрСвед.Качество = Справочники.Качество.Новый;            Если (ШК = 0) или (ШК > КолКолонок) Тогда            Сообщить("ШтрихКод не будет добавлен к данному элементу: " + Наименование + " " + Цвет + " " + Размер);            Иначе            Попытка                ЗаписьВРегистрСвед.Записать();            Исключение            Сообщить("Номенклатура с таким штрихкодом существует!");            КонецПопытки;            КонецЕсли;            Иначе            НовыйЭлемент = Справочники.Номенклатура.НайтиПоНаименованию(Наименование + " " + Цвет + " " + Размер);        КонецЕсли;                        //Создадим Док Поступления товаров и услуг ////////////////////////////////////////////////////                         ДокПоступление = НовыйДокПоступление.Товары.Добавить();        ДокПоступление.Номенклатура = НовыйЭлемент.Ссылка;        ДокПоступление.Количество = Количество;        ДокПоступление.Цена = Цена;         ДокПоступление.Склад = Склад;        ДокПоступление.ЕдиницаИзмерения = НовыйЭлемент.ЕдиницаХраненияОстатков;        ДокПоступление.Коэффициент = НовыйЭлемент.ЕдиницаХраненияОстатков.Коэффициент;        ДокПоступление.СтавкаНДС = СтавкаНДС;        ДокПоступление.Сумма = Количество * Цена;                            Сообщить(НовыйЭлемент.Наименование + "       " + ШтрихКод + " : "+"Элемент записан");                                //Запишем товар и цену в документ установки цен         тчТовары = ДокУстановкаЦенНоменклатуры["Товары"];        СтрокаТаблицаТовары = тчТовары.Добавить();        СтрокаТаблицаТовары["Номенклатура"] = НовыйЭлемент.Ссылка;        СтрокаТаблицаТовары["Валюта"]       = ВалютаДок;        СтрокаТаблицаТовары["ЕдиницаИзмерения"] = НовыйЭлемент.ЕдиницаХраненияОстатков;        СтрокаТаблицаТовары["ТипЦен"]       = ТипЦены;        СтрокаТаблицаТовары["Цена"]         = Цена;        КонецЦикла;        Попытка        НовыйДокПоступление.Записать(РежимЗаписиДокумента.Проведение);        ДокУстановкаЦенНоменклатуры.Записать(РежимЗаписиДокумента.Проведение);        Исключение        Сообщить("НЕ ЗАПИСАН");        КонецПопытки;        КонецЦикла;             Экзель.Quit();        Сообщить("Загрузка накладной успешно завершена!");КонецПроцедуры



 
"

 
EL Khan
Пост №1
06.10.2012 13:13
 

"Элементы создаются, документ поступление создается, но вот установка цен номенклатуры ругается:

{Форма.Форма(209)}: Ошибка при вызове метода контекста (Записать): Запись с такими ключевыми полями существует! : Рознизная : хххххххх : : 06.10.2012 0:00:00 (Регистр сведений: Цены номенклатуры; Номер строки: 7)
       ДокУстановкаЦенНоменклатуры.Записать(РежимЗаписиДокумента.Проведение);
О чем говорит эта ошибка? номенклатура в экселе встречается несколько раз, и оно не может записаться в регистр сведений, так?
Скажите пожалуйста в чем проблема?

Процедура ЗагрузкаИзExcel()    Экзель = Новый COMОбъект("Excel.Application");    Книга = Экзель.Application.Workbooks.Open(Путь);    ТекЛист = Книга.WorkSheets(1);    КолСтрок = ТекЛист.Cells(1,1).SpecialCells(11).Row;    КолКолонок = ТекЛист.Cells(1,1).SpecialCells(11).Column;    КоличествоСтраниц = 1;            Для ТекНомер  = 1 По КоличествоСтраниц Цикл    Артикул = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Арт).Value);    Наименование = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Наим).Value);    Если (ШК = 0) или (ШК > КолКолонок) Тогда        Сообщить("ШтрихКод отсутсвует в данной номенклатуре!");    Иначе     ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,ШК).Value);    КонецЕсли;    Коллекция = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Коллекция1).Value);    Цвет = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Цвет1).Value);    Размер = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Размер1).Value);    Количество = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Колич).Value);    Цена = СокрЛП(Книга.Sheets(ТекНомер).Cells(1,Цен).Value);    Сообщить("Внешняя накладная прочитана, начилась запись элементов справочника Номенклатура!");    счСтроки = НачСтрока;        //// Заполняем шапку Документа Поступление товаров и услуг //////////////////////////////////////             НовыйДокПоступление = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();        НовыйДокПоступление.Дата = Дата;        НовыйДокПоступление.ВидПоступления = Перечисления.ВидыПоступленияТоваров.НаСклад;        НовыйДокПоступление.Организация = Организация;        НовыйДокПоступление.Контрагент = Контрагент;        НовыйДокПоступление.ДоговорКонтрагента = Дог;        НовыйДокПоступление.ВалютаДокумента = ВалютаДок;        НовыйДокПоступление.КурсВзаиморасчетов = 1;        НовыйДокПоступление.КратностьВзаиморасчетов = 1;        НовыйДокПоступление.СкладОрдер = Склад;        НовыйДокПоступление.ОтражатьВУправленческомУчете = Истина;        НовыйДокПоступление.ОтражатьВБухгалтерскомУчете = Истина;        НовыйДокПоступление.ОтражатьВНалоговомУчете = Ложь;            //// Создаю док УстановкаЦенНоменклатуры  ///////////////////////////////////////////////////////                         ДокУстановкаЦенНоменклатуры = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();        ДокУстановкаЦенНоменклатуры.Дата = Дата;        ДокУстановкаЦенНоменклатуры.ТипыЦен.Очистить();        НовСтрТипыЦен = ДокУстановкаЦенНоменклатуры.ТипыЦен.Добавить();                ТипЦены = ТипЦен; // Справочники.ТипыЦенНоменклатуры.НайтиПоКоду("000000001");         НовСтрТипыЦен.ТипЦен = ТипЦены;                            Для    ш = НачСтрока по КолСтрок Цикл        Артикул = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Арт).Value);                                         Наименование = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Наим).Value);                    Если (ШтрихКод = 0) Тогда        Сообщить("ШтрихКод отсутсвует в данной номенклатуре!");        Иначе         ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,ШК).Value);        КонецЕсли;        //ШтрихКод = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,ШК).Value);         Коллекция = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Коллекция1).Value);        Цвет = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Цвет1).Value);        Размер = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Размер1).Value);        Количество = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Колич).Value);        Цена  = СокрЛП(Книга.Sheets(ТекНомер).Cells(СчСтроки,Цен).Value);                счСтроки = счСтроки + 1;                    Если (Наименование = """") или (Наименование = Неопределено) или (Наименование = null) Тогда            Продолжить;        КонецЕсли;                    Запись = Истина;        СпрНоменклатура = Справочники.Номенклатура;                 Если Справочники.Номенклатура.НайтиПоНаименованию(Наименование + " " + Цвет + " " + Размер).Пустая() Тогда                                       НовыйЭлемент = Справочники.Номенклатура.СоздатьЭлемент();            Родитель = ГрпНом;            НовыйЭлемент.Родитель = Родитель;            НовыйЭлемент.Артикул = Артикул;            НовыйЭлемент.Коллекция = Коллекция;            НовыйЭлемент.Цвет = Цвет;            НовыйЭлемент.Размер = Размер;            НовыйЭлемент.Наименование = Наименование + " " + Цвет + " " + Размер;            НовыйЭлемент.НаименованиеПолное = Наименование + " " + Цвет + " " + Размер;            НовыйЭлемент.ВидНоменклатуры = ВидНомен;            НовыйЭлемент.БазоваяЕдиницаИзмерения = ЕдИзмер;                    НовыйЭлемент.Записать();            НовыйЕдИзмер = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();            НовыйЕдИзмер.ЕдиницаПоКлассификатору = ЕдИзмер;            НовыйЕдИзмер.Наименование = ЕдИзмер.Наименование;            НовыйЕдИзмер.Коэффициент = 1;            НовыйЕдИзмер.Владелец = НовыйЭлемент.Ссылка;            НовыйЕдИзмер.Записать();            НовыйЭлемент.ЕдиницаХраненияОстатков = НовыйЕдИзмер.Ссылка;            НовыйЭлемент.СтавкаНДС = СтавкаНДС;            //НовыйЭлемент.ВестиУчетПоХарактеристикам = Истина;             НовыйЭлемент.Записать();                           //Запись РегистраСведений Штрихкоды                         ЗаписьШК = Истина;            РегСведШК = РегистрыСведений.Штрихкоды;            ВыборкаРегСведШК = РегистрыСведений.Штрихкоды.Выбрать();            Пока ВыборкаРегСведШК.Следующий() Цикл                Если ВыборкаРегСведШК.Штрихкод = ШтрихКод Тогда                    ЗаписьШК = Ложь;                КонецЕсли;            КонецЦикла;            ЗаписьВРегистрСвед = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();            ЗаписьВРегистрСвед.Владелец = НовыйЭлемент.Ссылка;            ЗаписьВРегистрСвед.ЕдиницаИзмерения = НовыйЭлемент.ЕдиницаХраненияОстатков;            ЗаписьВРегистрСвед.Штрихкод = ШтрихКод;            ЗаписьВРегистрСвед.ТипШтрихкода = ЭлементыФормы.ТипШтрихкода.Значение;//ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;             ЗаписьВРегистрСвед.Качество = Справочники.Качество.Новый;            Если (ШК = 0) или (ШК > КолКолонок) Тогда            Сообщить("ШтрихКод не будет добавлен к данному элементу: " + Наименование + " " + Цвет + " " + Размер);            Иначе            Попытка                ЗаписьВРегистрСвед.Записать();            Исключение            Сообщить("Номенклатура с таким штрихкодом существует!");            КонецПопытки;            КонецЕсли;            Иначе            НовыйЭлемент = Справочники.Номенклатура.НайтиПоНаименованию(Наименование + " " + Цвет + " " + Размер);        КонецЕсли;                        //Создадим Док Поступления товаров и услуг ////////////////////////////////////////////////////                         ДокПоступление = НовыйДокПоступление.Товары.Добавить();        ДокПоступление.Номенклатура = НовыйЭлемент.Ссылка;        ДокПоступление.Количество = Количество;        ДокПоступление.Цена = Цена;         ДокПоступление.Склад = Склад;        ДокПоступление.ЕдиницаИзмерения = НовыйЭлемент.ЕдиницаХраненияОстатков;        ДокПоступление.Коэффициент = НовыйЭлемент.ЕдиницаХраненияОстатков.Коэффициент;        ДокПоступление.СтавкаНДС = СтавкаНДС;        ДокПоступление.Сумма = Количество * Цена;                            Сообщить(НовыйЭлемент.Наименование + "       " + ШтрихКод + " : "+"Элемент записан");                                //Запишем товар и цену в документ установки цен         тчТовары = ДокУстановкаЦенНоменклатуры["Товары"];        СтрокаТаблицаТовары = тчТовары.Добавить();        СтрокаТаблицаТовары["Номенклатура"] = НовыйЭлемент.Ссылка;        СтрокаТаблицаТовары["Валюта"]       = ВалютаДок;        СтрокаТаблицаТовары["ЕдиницаИзмерения"] = НовыйЭлемент.ЕдиницаХраненияОстатков;        СтрокаТаблицаТовары["ТипЦен"]       = ТипЦены;        СтрокаТаблицаТовары["Цена"]         = Цена;        КонецЦикла;        Попытка        НовыйДокПоступление.Записать(РежимЗаписиДокумента.Проведение);        ДокУстановкаЦенНоменклатуры.Записать(РежимЗаписиДокумента.Проведение);        Исключение        Сообщить("НЕ ЗАПИСАН");        КонецПопытки;        КонецЦикла;             Экзель.Quit();        Сообщить("Загрузка накладной успешно завершена!");КонецПроцедуры



 
"

 
Prikum
Пост №2
Проблема в точ, что для одной и той же номенклатур...
06.10.2012 13:53
 
 
EL Khan
Пост №3
не совсем понял...ошибка выходит в строке номен 7,...
06.10.2012 14:01
 
 
Тимур15rus
Пост №4
это номер строки регистра сведений. А не документа...
06.10.2012 18:19
 
 
Денис (САМАРА)
Пост №5
У тебя одна и таже номенклатура встречается нескол...
08.10.2012 09:32
 
 
EL Khan
Пост №6
"да знаю, из-за этого были проблемы с записью ШК, ...
08.10.2012 09:40
 
 
Денис (САМАРА)
Пост №7
И "рукой" документ проводится?
08.10.2012 09:42
 
 
EL Khan
Пост №8
а в доке нет проблем, проводится и вся номенклатур...
08.10.2012 09:43
 
 
EL Khan
Пост №9
а как добавить к еще одну тип цены, то есть в одно...
08.10.2012 09:49
 
 
EL Khan
Пост №10
"можно сделать так: ДокУстановкаЦенНоменклатуры = ...
08.10.2012 10:00
 
 
Вьюн
Пост №11
"тчТовары = ДокУстановкаЦенНоменклатуры["Товары"];...
08.10.2012 13:08
 
 
EL Khan
Пост №12
"Спасибо) я сильно не парился создал для каждого о...
08.10.2012 13:24
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов вычетов коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемая иностранная компания контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры