Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Бухгалтерия 8] Создание внешней обработки для 1С: Бухгалтерия государственного учреждения
Zebraaa
Пост №1
Zebraaa
читатель
офлайн
Дата регистрации: 16.03.2012
Сообщений: 23
Пост №1
 
22.11.2012 13:36

"Для выписки квитанций есть печатная форма. Мне нужно её немного изменить. Делаю это через внешнюю обработку. Захожу в конфигуратор, выбираю Файл-Новый- Внешняя обработка. Добавляю туда ревизит "Ссылка на объект", создаю форму, копирую из исходного документа шаблон печатной формы, правлю название ревизитов(собственного говоря из-за чего создаю отдельную форму) . В модуль объекта обработки копирую Функцию Печать() с пометкой Экспорт. Везде меняю ОбъектСсылка на СсылкаНаОбъект. Заменяю название печатной формы на новую. После открываю обработку. Файл-открыть. Выбираю Выписку Квитанций (это все работает). Когда нажимаю на кнопку выполнить выдается сообщение:
{ВнешняяОбработка.ВыпискаКвитанций.МодульОбъекта(35)}: Ошибка при вызове конструктора (МоментВремени) МоментДокумента       =Новый МоментВремени(Дата, СсылкаНаОбъект);по причине:Несоответствие типов (параметр номер '1')

Не понимаю с чем это связано. Помогите пожалуиста, что не так. Вот модуль:
       Перем Дата;
Функция Печать() Экспорт Запрос= Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект); Запрос.Текст =
"ВЫБРАТЬ | ВыпискаКвитанций.Номер, | ВыпискаКвитанций.Дата, | ВыпискаКвитанций.Учреждение КАК УчреждениеСсылка, | ВыпискаКвитанций.Учреждение.НаименованиеПолное КАК НаименованиеОрганизации, | ВыпискаКвитанций.Учреждение.ИНН КАК ИННПолучателя, | ВыпискаКвитанций.Учреждение.КПП КАК КПППолучателя, | ВыпискаКвитанций.ЛицевойСчет КАК ЛицевойСчетПолучателя, | ВыпискаКвитанций.РеквизитыЛицевогоСчета КАК РеквизитыЛицевогоСчетаПолучателя, | ВыпискаКвитанций.КБКСчетУчетаРП.Представление КАК КБК, | ВыпискаКвитанций.КОСГУСчетУчетаРП.Представление КАК КОСГУ, | ВыпискаКвитанций.НаправлениеДеятельности, | ВыпискаКвитанций.КвитанцииВЦелыхРублях, | ВыпискаКвитанций.ОплатаВКассу |ИЗ | Документ.РП_ВыпискаКвитанций КАК ВыпискаКвитанций |ГДЕ | ВыпискаКвитанций.Ссылка = &ТекущийДокумент";
Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();
НаименованиеОрганизации = Шапка.НаименованиеОрганизации; ИННПолучателя            = Шапка.ИННПолучателя; КПППолучателя            = Шапка.КПППолучателя; ЛицевойСчетПолучателя = Шапка.ЛицевойСчетПолучателя; РеквизитыЛицевогоСчетаПолучателя = Шапка.РеквизитыЛицевогоСчетаПолучателя; КБК                   = Шапка.КБК; КОСГУ                   = Шапка.КОСГУ;
МоментДокумента       =Новый МоментВремени(Дата, СсылкаНаОбъект);
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Период"       ,МоментДокумента);
Запрос.Текст =
"ВЫБРАТЬ | ВыпискаКвитанцийКвитанции.Ребенок, | ВыпискаКвитанцийКвитанции.Контрагент, | ВыпискаКвитанцийКвитанции.НомерЛицевогоСчета, | ВыпискаКвитанцийКвитанции.Договор, | ВыпискаКвитанцийКвитанции.Сумма КАК Сумма, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик.Представление КАК ПлательщикИмя, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик.ВидКонтрагента КАК ВидКонтрагента |ИЗ | Документ.РП_ВыпискаКвитанций.Квитанции КАК ВыпискаКвитанцийКвитанции | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПараметрыКомпенсацииРодительскойПлаты.СрезПоследних(&Период, ) КАК ПараметрыКомпенсацииРодительскойПлатыСрезПоследних | ПО ВыпискаКвитанцийКвитанции.Ребенок = ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Ребенок |ГДЕ | ВыпискаКвитанцийКвитанции.Ссылка = &ТекущийДокумент | И ВыпискаКвитанцийКвитанции.Сумма > 0 | |УПОРЯДОЧИТЬ ПО | ВыпискаКвитанцийКвитанции.НомерСтроки"; ТаблицаКвитанций = Запрос.Выполнить().Выгрузить(); ТабДокумент = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Если НЕ Шапка.ОплатаВКассу Тогда РеквизитыПолучателя = Новый Структура("ИННПолучателя, КПППолучателя, ТекстПолучателя, НомерРасчетногоСчета, НазваниеБанка, БИК, КоррСчет", "ИНН", "КПП", "Корреспондент", "СчетНомер", "Банк", "БИК", "КоррСчет");
РаботаСДиалогами.ПолучитьПлатежныеРеквизитыПоТребованиюБанка(ЛицевойСчетПолучателя, РеквизитыЛицевогоСчетаПолучателя, РеквизитыПолучателя, Истина);
НомерРасчетногоСчета = РеквизитыПолучателя.НомерРасчетногоСчета; НазваниеБанка            = РеквизитыПолучателя.НазваниеБанка; БИК                   = РеквизитыПолучателя.БИК; КоррСчет             = РеквизитыПолучателя.КоррСчет; ПредставлениеОрганизации = "ИНН "+РеквизитыПолучателя.ИННПолучателя+" КПП "+РеквизитыПолучателя.КПППолучателя+" "+РеквизитыПолучателя.ТекстПолучателя; Иначе НомерРасчетногоСчета = """"; НазваниеБанка            = """"; БИК                   = """"; КоррСчет             = """"; ПредставлениеОрганизации = "ИНН "+ИННПолучателя+" КПП "+КПППолучателя+" "+НаименованиеОрганизации; КонецЕсли;
// Выводим квитанции Для Каждого Строка Из ТаблицаКвитанций Цикл Если Строка.Сумма=0 Тогда Продолжить; КонецЕсли; ОбластьМакета = Макет.ПолучитьОбласть("Квитанция"); ОбластьМакета.Параметры.ПредставлениеОрганизации = ПредставлениеОрганизации; ОбластьМакета.Параметры.НомерРасчетногоСчета = НомерРасчетногоСчета; ОбластьМакета.Параметры.НазваниеБанка            = НазваниеБанка; ОбластьМакета.Параметры.БИК                   = БИК; ОбластьМакета.Параметры.КоррСчет             = КоррСчет; ОбластьМакета.Параметры.КБК                   = КБК; ОбластьМакета.Параметры.КОСГУ                   = КОСГУ; ПредставлениеПериода = РаботаСДиалогами.ПолучитьПредставлениеПериодаРегистрации(КонецМесяца(Шапка.Дата))+" г."; НазначениеПлатежа = СокрЛП(Шапка.НаправлениеДеятельности); НазваниеДоговора = СокрЛП(Строка.Договор); ПредставлениеРебенка = Строка(Строка.Ребенок) + "," + " л/с "+Строка.НомерЛицевогоСчета + ?(ПустаяСтрока(НазваниеДоговора) ИЛИ НазваниеДоговора=НазначениеПлатежа, """", ", " + НазваниеДоговора); ПлательщикИмяАдрес = """"; Плательщик       = Строка.Плательщик; Если ЗначениеЗаполнено(Плательщик) Тогда ПлательщикИмяАдрес = Строка.ПлательщикИмя; СтруктураРеквизитов = Новый Структура; СтруктураРеквизитов.Вставить("КИКонтрагента", Новый Структура); Если Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.Организация Тогда СтруктураРеквизитов.КИКонтрагента.Вставить("ЮрАдресКонтрагента"); ИначеЕсли Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.ФизЛицо Тогда СтруктураРеквизитов.КИКонтрагента.Вставить("ЮрАдресФизЛица"); КонецЕсли; ПолучениеНСИ.ПолучитьДанные(Плательщик, Дата, СтруктураРеквизитов); Если Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.Организация Тогда ПлательщикИмяАдрес = ПлательщикИмяАдрес+" "+СтруктураРеквизитов.ЮрАдресКонтрагента; ИначеЕсли Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.ФизЛицо Тогда ПлательщикИмяАдрес = ПлательщикИмяАдрес+" "+СтруктураРеквизитов.ЮрАдресФизЛица; КонецЕсли; КонецЕсли; ОбластьМакета.Параметры.ПлательщикИмяАдрес = ПлательщикИмяАдрес; СуммаКОплате = ?(Шапка.КвитанцииВЦелыхРублях, Окр(Строка.Сумма), Строка.Сумма); Рублей       = Цел(СуммаКОплате); Копеек       = (СуммаКОплате-Рублей)*100; СуммаЦифрами = """"+Рублей+" руб."+Цел(Копеек/10)+(Копеек-10*Цел(Копеек/10))+"коп."; ОбластьМакета.Параметры.НазначениеПлатежа = НазначениеПлатежа; ОбластьМакета.Параметры.ПредставлениеПериода = ПредставлениеПериода; ОбластьМакета.Параметры.ПредставлениеРебенка = ПредставлениеРебенка; ОбластьМакета.Параметры.СуммаЦифрами       = СуммаЦифрами; Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц(); КонецЕсли; ТабДокумент.Вывести(ОбластьМакета); КонецЦикла; //Параметры документа ТабДокумент.ПолеСлева       = 0; ТабДокумент.ПолеСправа       = 0; ТабДокумент.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ВыпискаКвитанций_Квитанции";
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
Возврат ТабДокумент;
КонецФункции"

 
Zebraaa
Пост №1
22.11.2012 13:36
 

"Для выписки квитанций есть печатная форма. Мне нужно её немного изменить. Делаю это через внешнюю обработку. Захожу в конфигуратор, выбираю Файл-Новый- Внешняя обработка. Добавляю туда ревизит "Ссылка на объект", создаю форму, копирую из исходного документа шаблон печатной формы, правлю название ревизитов(собственного говоря из-за чего создаю отдельную форму) . В модуль объекта обработки копирую Функцию Печать() с пометкой Экспорт. Везде меняю ОбъектСсылка на СсылкаНаОбъект. Заменяю название печатной формы на новую. После открываю обработку. Файл-открыть. Выбираю Выписку Квитанций (это все работает). Когда нажимаю на кнопку выполнить выдается сообщение:
{ВнешняяОбработка.ВыпискаКвитанций.МодульОбъекта(35)}: Ошибка при вызове конструктора (МоментВремени) МоментДокумента       =Новый МоментВремени(Дата, СсылкаНаОбъект);по причине:Несоответствие типов (параметр номер '1')

Не понимаю с чем это связано. Помогите пожалуиста, что не так. Вот модуль:
       Перем Дата;
Функция Печать() Экспорт Запрос= Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект); Запрос.Текст =
"ВЫБРАТЬ | ВыпискаКвитанций.Номер, | ВыпискаКвитанций.Дата, | ВыпискаКвитанций.Учреждение КАК УчреждениеСсылка, | ВыпискаКвитанций.Учреждение.НаименованиеПолное КАК НаименованиеОрганизации, | ВыпискаКвитанций.Учреждение.ИНН КАК ИННПолучателя, | ВыпискаКвитанций.Учреждение.КПП КАК КПППолучателя, | ВыпискаКвитанций.ЛицевойСчет КАК ЛицевойСчетПолучателя, | ВыпискаКвитанций.РеквизитыЛицевогоСчета КАК РеквизитыЛицевогоСчетаПолучателя, | ВыпискаКвитанций.КБКСчетУчетаРП.Представление КАК КБК, | ВыпискаКвитанций.КОСГУСчетУчетаРП.Представление КАК КОСГУ, | ВыпискаКвитанций.НаправлениеДеятельности, | ВыпискаКвитанций.КвитанцииВЦелыхРублях, | ВыпискаКвитанций.ОплатаВКассу |ИЗ | Документ.РП_ВыпискаКвитанций КАК ВыпискаКвитанций |ГДЕ | ВыпискаКвитанций.Ссылка = &ТекущийДокумент";
Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();
НаименованиеОрганизации = Шапка.НаименованиеОрганизации; ИННПолучателя            = Шапка.ИННПолучателя; КПППолучателя            = Шапка.КПППолучателя; ЛицевойСчетПолучателя = Шапка.ЛицевойСчетПолучателя; РеквизитыЛицевогоСчетаПолучателя = Шапка.РеквизитыЛицевогоСчетаПолучателя; КБК                   = Шапка.КБК; КОСГУ                   = Шапка.КОСГУ;
МоментДокумента       =Новый МоментВремени(Дата, СсылкаНаОбъект);
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Период"       ,МоментДокумента);
Запрос.Текст =
"ВЫБРАТЬ | ВыпискаКвитанцийКвитанции.Ребенок, | ВыпискаКвитанцийКвитанции.Контрагент, | ВыпискаКвитанцийКвитанции.НомерЛицевогоСчета, | ВыпискаКвитанцийКвитанции.Договор, | ВыпискаКвитанцийКвитанции.Сумма КАК Сумма, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик.Представление КАК ПлательщикИмя, | ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Плательщик.ВидКонтрагента КАК ВидКонтрагента |ИЗ | Документ.РП_ВыпискаКвитанций.Квитанции КАК ВыпискаКвитанцийКвитанции | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПараметрыКомпенсацииРодительскойПлаты.СрезПоследних(&Период, ) КАК ПараметрыКомпенсацииРодительскойПлатыСрезПоследних | ПО ВыпискаКвитанцийКвитанции.Ребенок = ПараметрыКомпенсацииРодительскойПлатыСрезПоследних.Ребенок |ГДЕ | ВыпискаКвитанцийКвитанции.Ссылка = &ТекущийДокумент | И ВыпискаКвитанцийКвитанции.Сумма > 0 | |УПОРЯДОЧИТЬ ПО | ВыпискаКвитанцийКвитанции.НомерСтроки"; ТаблицаКвитанций = Запрос.Выполнить().Выгрузить(); ТабДокумент = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Если НЕ Шапка.ОплатаВКассу Тогда РеквизитыПолучателя = Новый Структура("ИННПолучателя, КПППолучателя, ТекстПолучателя, НомерРасчетногоСчета, НазваниеБанка, БИК, КоррСчет", "ИНН", "КПП", "Корреспондент", "СчетНомер", "Банк", "БИК", "КоррСчет");
РаботаСДиалогами.ПолучитьПлатежныеРеквизитыПоТребованиюБанка(ЛицевойСчетПолучателя, РеквизитыЛицевогоСчетаПолучателя, РеквизитыПолучателя, Истина);
НомерРасчетногоСчета = РеквизитыПолучателя.НомерРасчетногоСчета; НазваниеБанка            = РеквизитыПолучателя.НазваниеБанка; БИК                   = РеквизитыПолучателя.БИК; КоррСчет             = РеквизитыПолучателя.КоррСчет; ПредставлениеОрганизации = "ИНН "+РеквизитыПолучателя.ИННПолучателя+" КПП "+РеквизитыПолучателя.КПППолучателя+" "+РеквизитыПолучателя.ТекстПолучателя; Иначе НомерРасчетногоСчета = """"; НазваниеБанка            = """"; БИК                   = """"; КоррСчет             = """"; ПредставлениеОрганизации = "ИНН "+ИННПолучателя+" КПП "+КПППолучателя+" "+НаименованиеОрганизации; КонецЕсли;
// Выводим квитанции Для Каждого Строка Из ТаблицаКвитанций Цикл Если Строка.Сумма=0 Тогда Продолжить; КонецЕсли; ОбластьМакета = Макет.ПолучитьОбласть("Квитанция"); ОбластьМакета.Параметры.ПредставлениеОрганизации = ПредставлениеОрганизации; ОбластьМакета.Параметры.НомерРасчетногоСчета = НомерРасчетногоСчета; ОбластьМакета.Параметры.НазваниеБанка            = НазваниеБанка; ОбластьМакета.Параметры.БИК                   = БИК; ОбластьМакета.Параметры.КоррСчет             = КоррСчет; ОбластьМакета.Параметры.КБК                   = КБК; ОбластьМакета.Параметры.КОСГУ                   = КОСГУ; ПредставлениеПериода = РаботаСДиалогами.ПолучитьПредставлениеПериодаРегистрации(КонецМесяца(Шапка.Дата))+" г."; НазначениеПлатежа = СокрЛП(Шапка.НаправлениеДеятельности); НазваниеДоговора = СокрЛП(Строка.Договор); ПредставлениеРебенка = Строка(Строка.Ребенок) + "," + " л/с "+Строка.НомерЛицевогоСчета + ?(ПустаяСтрока(НазваниеДоговора) ИЛИ НазваниеДоговора=НазначениеПлатежа, """", ", " + НазваниеДоговора); ПлательщикИмяАдрес = """"; Плательщик       = Строка.Плательщик; Если ЗначениеЗаполнено(Плательщик) Тогда ПлательщикИмяАдрес = Строка.ПлательщикИмя; СтруктураРеквизитов = Новый Структура; СтруктураРеквизитов.Вставить("КИКонтрагента", Новый Структура); Если Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.Организация Тогда СтруктураРеквизитов.КИКонтрагента.Вставить("ЮрАдресКонтрагента"); ИначеЕсли Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.ФизЛицо Тогда СтруктураРеквизитов.КИКонтрагента.Вставить("ЮрАдресФизЛица"); КонецЕсли; ПолучениеНСИ.ПолучитьДанные(Плательщик, Дата, СтруктураРеквизитов); Если Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.Организация Тогда ПлательщикИмяАдрес = ПлательщикИмяАдрес+" "+СтруктураРеквизитов.ЮрАдресКонтрагента; ИначеЕсли Строка.ВидКонтрагента = Перечисления.ВидыКонтрагентов.ФизЛицо Тогда ПлательщикИмяАдрес = ПлательщикИмяАдрес+" "+СтруктураРеквизитов.ЮрАдресФизЛица; КонецЕсли; КонецЕсли; ОбластьМакета.Параметры.ПлательщикИмяАдрес = ПлательщикИмяАдрес; СуммаКОплате = ?(Шапка.КвитанцииВЦелыхРублях, Окр(Строка.Сумма), Строка.Сумма); Рублей       = Цел(СуммаКОплате); Копеек       = (СуммаКОплате-Рублей)*100; СуммаЦифрами = """"+Рублей+" руб."+Цел(Копеек/10)+(Копеек-10*Цел(Копеек/10))+"коп."; ОбластьМакета.Параметры.НазначениеПлатежа = НазначениеПлатежа; ОбластьМакета.Параметры.ПредставлениеПериода = ПредставлениеПериода; ОбластьМакета.Параметры.ПредставлениеРебенка = ПредставлениеРебенка; ОбластьМакета.Параметры.СуммаЦифрами       = СуммаЦифрами; Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц(); КонецЕсли; ТабДокумент.Вывести(ОбластьМакета); КонецЦикла; //Параметры документа ТабДокумент.ПолеСлева       = 0; ТабДокумент.ПолеСправа       = 0; ТабДокумент.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ВыпискаКвитанций_Квитанции";
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
Возврат ТабДокумент;
КонецФункции"

 
Денис (САМАРА)
Пост №2
Вы думаете в этом неформатированном коде можно что...
22.11.2012 13:41
 
 
ZhAmAn
Пост №3
Отладчиком нужно посмотреть что в переменной "Дата...
22.11.2012 13:55
 
 
Zebraaa
Пост №4
Можно подробнее
22.11.2012 15:04
 
 
ZhAmAn
Пост №5
Если не умеете пользоваться отладчиком, то не стои...
22.11.2012 15:42
 
 
Zebraaa
Пост №6
Отлично, спасибо. Прекрасный ответ, он мне очень п...
22.11.2012 16:22
 
 
ZhAmAn
Пост №7
Всегда пожалуйста.
22.11.2012 16:48
 
 
Рисовод
Пост №8
зря обижаешься. Ценность совета поймешь позже, есл...
22.11.2012 16:55
 
 
Вьюн
Пост №9
"МоментДокумента =Новый МоментВремени(Ссы...
23.11.2012 00:39
 
 
Денис (САМАРА)
Пост №10
Зачем Вы передаете в параметр запроса момент време...
23.11.2012 09:28
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов доходов коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% ндс при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет доходов при УСН учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги