Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Бухгалтерия 8] об оказании услуг для документа корректировка реализации
ЕвгенийАгро
Пост №1
ЕвгенийАгро
читатель
офлайн
Дата регистрации: 04.10.2012
Сообщений: 19
Пост №1
 
04.12.2012 10:13

"Добрый день помогите найти ошибку во внешней печатной форме. Подключаю пишет ошибку: {ВнешняяОбработка.Услуги.МодульОбъекта(7)}: Поле объекта не обнаружено (ДополнительнаяКолонкаПечатныхФормДокументов)
ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
Вот КОД ФОРМЫ:

Функция Печать() Экспорт

мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
      
ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();                                    - пишет ошибка тут!
Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
       ВыводитьКоды = Истина;
       Колонка       = "Артикул";
       ТекстКодАртикул = "Артикул";
ИначеЕсли ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
       ВыводитьКоды = Истина;
       Колонка       = "Код";
       ТекстКодАртикул = "Код";
Иначе
       ВыводитьКоды = Ложь;
       Колонка       = """";
       ТекстКодАртикул = "Код";
КонецЕсли;

Если ВыводитьКоды Тогда
       ОбластьШапки = "ШапкаСКодом";
       ОбластьСтроки = "СтрокаСКодом";
Иначе
       ОбластьШапки = "ШапкаТаблицы";
       ОбластьСтроки = "Строка";
КонецЕсли;

ЗапросШапка = Новый Запрос;
ЗапросШапка.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка.ИсправляемыйДокументРеализации);
ЗапросШапка.Текст =
"ВЫБРАТЬ
| Номер,
| Дата,
| ДоговорКонтрагента,
| ДоговорКонтрагента.РасчетыВУсловныхЕдиницах КАК РасчетыВУсловныхЕдиницах,
| Контрагент КАК Получатель,
| Организация КАК Поставщик,
| Организация,
| СуммаДокумента,
| ВалютаДокумента,
| УчитыватьНДС,
| СуммаВключаетНДС
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
Шапка = ЗапросШапка.Выполнить().Выбрать();
Шапка.Следующий();

ЗапросУслуги = Новый Запрос;
ЗапросУслуги.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
ЗапросУслуги.УстановитьПараметр("Курс",            ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект,      мВалютаРегламентированногоУчета));
ЗапросУслуги.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));

ЧастьЗапросаДляВыбораСодержанияУслуг = ФормированиеПечатныхФорм.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("РеализацияТоваровУслуг");

ЗапросУслуги.Текст =
"ВЫБРАТЬ
| Номенклатура КАК Номенклатура,
| ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК Товар,
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.Товары КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
| И
| РеализацияТоваровУслуг.Номенклатура.Услуга = Истина
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.Услуги КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.АгентскиеУслуги КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
ТаблицаУслуги = ЗапросУслуги.Выполнить().Выгрузить();

Если СсылкаНаОбъект.Проведен И (Шапка.РасчетыВУсловныхЕдиницах
       ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И СсылкаНаОбъект.Дата >= '20090101000000')) Тогда
      
       Запрос = Новый Запрос;
       Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
       Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", СсылкаНаОбъект.СчетУчетаРасчетовСКонтрагентом);
       Текст =
       "ВЫБРАТЬ
       | СУММА(Хозрасчетный.Сумма) КАК Сумма
       |ИЗ
       | РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
       |ГДЕ
       | Хозрасчетный.Регистратор = &Ссылка
       | И Хозрасчетный.СчетДт = &СчетУчетаРасчетовСКонтрагентом
       | И Хозрасчетный.СчетКт В
       |            (ВЫБРАТЬ РАЗЛИЧНЫЕ
       |             РеализацияТоваровУслугТовары.СчетДоходов
       |            ИЗ
       |             Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
       |            ГДЕ
       |             РеализацияТоваровУслугТовары.Ссылка = &Ссылка
       |
       |       ОБЪЕДИНИТЬ
       |
       |            ВЫБРАТЬ РАЗЛИЧНЫЕ
       |             РеализацияТоваровУслугУслуги.СчетДоходов
       |            ИЗ
       |             Документ.КорректировкаРеализации.Услуги КАК РеализацияТоваровУслугУслуги
       |            ГДЕ
       |             РеализацияТоваровУслугУслуги.Ссылка = &Ссылка)
       |";
       Запрос.Текст = Текст;
       СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;
      
       РасчетСуммыНДСПоСтавке = УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.Дата);
      
       Если НЕ СуммаВзаиморасчетов = NULL Тогда
            
            ТаблицаУслуги.Колонки.Добавить("СуммаБезНДС");
            
            МассивРаспределения = Новый Массив;
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
            
             СуммаСНДС = СтрокаТовар.Сумма + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);
             СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;

             МассивРаспределения.Добавить(СуммаСНДС);
             СтрокаТовар.СуммаБезНДС = СуммаБезНДС;
                              
            КонецЦикла;
            
            ТаблицаУслуги.Колонки.Добавить("СуммаРублевая");
            УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ТаблицаУслуги, "СуммаРублевая");
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
            
             Если РасчетСуммыНДСПоСтавке Тогда
                   //Выделение суммы НДС, Расчет суммы без НДС
                   ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);
                  
                   СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));
                   СтрокаТовар.Сумма = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;
                  
             Иначе
                   МассивРаспределения.Очистить();
                   МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);
                   МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);
                   МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);
                   Если МассивРаспределенныхСумм <> Неопределено Тогда
                        СтрокаТовар.Сумма = МассивРаспределенныхСумм[0];
                        СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];
                   КонецЕсли;
             КонецЕсли;
            
             Если Шапка.СуммаВключаетНДС Тогда
                   СтрокаТовар.Сумма = СтрокаТовар.Сумма+СтрокаТовар.СуммаНДС;
             КонецЕсли;
            
            КонецЦикла;
            
       КонецЕсли;
      
КонецЕсли;

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт";
Макет       = ПолучитьМакет("Акт");

ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, "Акт");
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
ОбластьМакета.Параметры.Поставщик             = Шапка.Поставщик;
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
СведенияОКонтрагенте = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
ПредставлениеПолучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОКонтрагенте, "НаименованиеДляПечатныхФорм,");
ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
ОбластьМакета.Параметры.Получатель = Шапка.Получатель;
ТабДокумент.Вывести(ОбластьМакета);

ЕстьСкидки = Ложь;

// Вывести табличную часть
ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
Если ВыводитьКоды Тогда
       ОбластьМакета.Параметры.ИмяКодАртикул = ТекстКодАртикул;
КонецЕсли;
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть(ОбластьСтроки);

НомерСтроки = 0;

Для Каждого СтрокаТабличнойЧасти Из ТаблицаУслуги Цикл

       НомерСтроки = НомерСтроки + 1;
      
       ОбластьМакета.Параметры.Заполнить(СтрокаТабличнойЧасти);
       ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
       ОбластьМакета.Параметры.Товар = СокрЛП(СтрокаТабличнойЧасти.Товар);
      
       Если Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета Тогда
            ОбластьМакета.Параметры.Цена = СтрокаТабличнойЧасти.Сумма / ?(СтрокаТабличнойЧасти.Количество = 0, 1, СтрокаТабличнойЧасти.Количество);
       КонецЕсли;
      
       ТабДокумент.Вывести(ОбластьМакета);

КонецЦикла;

Если ТаблицаУслуги <> Неопределено Тогда

       Сумма = ТаблицаУслуги.Итог("Сумма");
       СуммаНДС = ТаблицаУслуги.Итог("СуммаНДС");

Иначе

       Сумма = 0;
       СуммаНДС = 0;

КонецЕсли;

ОбластьМакета = Макет.ПолучитьОбласть("Итого");
ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Сумма);
ТабДокумент.Вывести(ОбластьМакета);

Если Шапка.УчитыватьНДС Тогда

       ОбластьМакета = Макет.ПолучитьОбласть("ИтогоНДС");
      
       Если СуммаНДС <> 0 Тогда
            ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);
            ОбластьМакета.Параметры.НДС      = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
       Иначе
            ОбластьМакета.Параметры.ВсегоНДС = "-";
            ОбластьМакета.Параметры.НДС      = "Без налога (НДС)";
       КонецЕсли;
      
       ТабДокумент.Вывести(ОбластьМакета);

КонецЕсли;

СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего оказано услуг " + НомерСтроки
                                           + ", на сумму " + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, мВалютаРегламентированногоУчета);
ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, мВалютаРегламентированногоУчета);
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ТабДокумент.Вывести(ОбластьМакета);

Возврат ТабДокумент;




КонецФункции"

 
ЕвгенийАгро
Пост №1
04.12.2012 10:13
 

"Добрый день помогите найти ошибку во внешней печатной форме. Подключаю пишет ошибку: {ВнешняяОбработка.Услуги.МодульОбъекта(7)}: Поле объекта не обнаружено (ДополнительнаяКолонкаПечатныхФормДокументов)
ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
Вот КОД ФОРМЫ:

Функция Печать() Экспорт

мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
      
ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();                                    - пишет ошибка тут!
Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
       ВыводитьКоды = Истина;
       Колонка       = "Артикул";
       ТекстКодАртикул = "Артикул";
ИначеЕсли ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
       ВыводитьКоды = Истина;
       Колонка       = "Код";
       ТекстКодАртикул = "Код";
Иначе
       ВыводитьКоды = Ложь;
       Колонка       = """";
       ТекстКодАртикул = "Код";
КонецЕсли;

Если ВыводитьКоды Тогда
       ОбластьШапки = "ШапкаСКодом";
       ОбластьСтроки = "СтрокаСКодом";
Иначе
       ОбластьШапки = "ШапкаТаблицы";
       ОбластьСтроки = "Строка";
КонецЕсли;

ЗапросШапка = Новый Запрос;
ЗапросШапка.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка.ИсправляемыйДокументРеализации);
ЗапросШапка.Текст =
"ВЫБРАТЬ
| Номер,
| Дата,
| ДоговорКонтрагента,
| ДоговорКонтрагента.РасчетыВУсловныхЕдиницах КАК РасчетыВУсловныхЕдиницах,
| Контрагент КАК Получатель,
| Организация КАК Поставщик,
| Организация,
| СуммаДокумента,
| ВалютаДокумента,
| УчитыватьНДС,
| СуммаВключаетНДС
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
Шапка = ЗапросШапка.Выполнить().Выбрать();
Шапка.Следующий();

ЗапросУслуги = Новый Запрос;
ЗапросУслуги.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
ЗапросУслуги.УстановитьПараметр("Курс",            ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект,      мВалютаРегламентированногоУчета));
ЗапросУслуги.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));

ЧастьЗапросаДляВыбораСодержанияУслуг = ФормированиеПечатныхФорм.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("РеализацияТоваровУслуг");

ЗапросУслуги.Текст =
"ВЫБРАТЬ
| Номенклатура КАК Номенклатура,
| ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК Товар,
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.Товары КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
| И
| РеализацияТоваровУслуг.Номенклатура.Услуга = Истина
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.Услуги КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
| Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
| Количество,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
| Цена * &Курс / &Кратность КАК Цена,
| Сумма * &Курс / &Кратность КАК Сумма,
| СтавкаНДС,
| СуммаНДС * &Курс / &Кратность КАК СуммаНДС
|ИЗ
| Документ.КорректировкаРеализации.АгентскиеУслуги КАК РеализацияТоваровУслуг
|
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
ТаблицаУслуги = ЗапросУслуги.Выполнить().Выгрузить();

Если СсылкаНаОбъект.Проведен И (Шапка.РасчетыВУсловныхЕдиницах
       ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И СсылкаНаОбъект.Дата >= '20090101000000')) Тогда
      
       Запрос = Новый Запрос;
       Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
       Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", СсылкаНаОбъект.СчетУчетаРасчетовСКонтрагентом);
       Текст =
       "ВЫБРАТЬ
       | СУММА(Хозрасчетный.Сумма) КАК Сумма
       |ИЗ
       | РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
       |ГДЕ
       | Хозрасчетный.Регистратор = &Ссылка
       | И Хозрасчетный.СчетДт = &СчетУчетаРасчетовСКонтрагентом
       | И Хозрасчетный.СчетКт В
       |            (ВЫБРАТЬ РАЗЛИЧНЫЕ
       |             РеализацияТоваровУслугТовары.СчетДоходов
       |            ИЗ
       |             Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
       |            ГДЕ
       |             РеализацияТоваровУслугТовары.Ссылка = &Ссылка
       |
       |       ОБЪЕДИНИТЬ
       |
       |            ВЫБРАТЬ РАЗЛИЧНЫЕ
       |             РеализацияТоваровУслугУслуги.СчетДоходов
       |            ИЗ
       |             Документ.КорректировкаРеализации.Услуги КАК РеализацияТоваровУслугУслуги
       |            ГДЕ
       |             РеализацияТоваровУслугУслуги.Ссылка = &Ссылка)
       |";
       Запрос.Текст = Текст;
       СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;
      
       РасчетСуммыНДСПоСтавке = УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.Дата);
      
       Если НЕ СуммаВзаиморасчетов = NULL Тогда
            
            ТаблицаУслуги.Колонки.Добавить("СуммаБезНДС");
            
            МассивРаспределения = Новый Массив;
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
            
             СуммаСНДС = СтрокаТовар.Сумма + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);
             СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;

             МассивРаспределения.Добавить(СуммаСНДС);
             СтрокаТовар.СуммаБезНДС = СуммаБезНДС;
                              
            КонецЦикла;
            
            ТаблицаУслуги.Колонки.Добавить("СуммаРублевая");
            УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ТаблицаУслуги, "СуммаРублевая");
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
            
             Если РасчетСуммыНДСПоСтавке Тогда
                   //Выделение суммы НДС, Расчет суммы без НДС
                   ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);
                  
                   СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));
                   СтрокаТовар.Сумма = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;
                  
             Иначе
                   МассивРаспределения.Очистить();
                   МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);
                   МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);
                   МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);
                   Если МассивРаспределенныхСумм <> Неопределено Тогда
                        СтрокаТовар.Сумма = МассивРаспределенныхСумм[0];
                        СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];
                   КонецЕсли;
             КонецЕсли;
            
             Если Шапка.СуммаВключаетНДС Тогда
                   СтрокаТовар.Сумма = СтрокаТовар.Сумма+СтрокаТовар.СуммаНДС;
             КонецЕсли;
            
            КонецЦикла;
            
       КонецЕсли;
      
КонецЕсли;

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт";
Макет       = ПолучитьМакет("Акт");

ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, "Акт");
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
ОбластьМакета.Параметры.Поставщик             = Шапка.Поставщик;
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
СведенияОКонтрагенте = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
ПредставлениеПолучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОКонтрагенте, "НаименованиеДляПечатныхФорм,");
ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
ОбластьМакета.Параметры.Получатель = Шапка.Получатель;
ТабДокумент.Вывести(ОбластьМакета);

ЕстьСкидки = Ложь;

// Вывести табличную часть
ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
Если ВыводитьКоды Тогда
       ОбластьМакета.Параметры.ИмяКодАртикул = ТекстКодАртикул;
КонецЕсли;
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть(ОбластьСтроки);

НомерСтроки = 0;

Для Каждого СтрокаТабличнойЧасти Из ТаблицаУслуги Цикл

       НомерСтроки = НомерСтроки + 1;
      
       ОбластьМакета.Параметры.Заполнить(СтрокаТабличнойЧасти);
       ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
       ОбластьМакета.Параметры.Товар = СокрЛП(СтрокаТабличнойЧасти.Товар);
      
       Если Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета Тогда
            ОбластьМакета.Параметры.Цена = СтрокаТабличнойЧасти.Сумма / ?(СтрокаТабличнойЧасти.Количество = 0, 1, СтрокаТабличнойЧасти.Количество);
       КонецЕсли;
      
       ТабДокумент.Вывести(ОбластьМакета);

КонецЦикла;

Если ТаблицаУслуги <> Неопределено Тогда

       Сумма = ТаблицаУслуги.Итог("Сумма");
       СуммаНДС = ТаблицаУслуги.Итог("СуммаНДС");

Иначе

       Сумма = 0;
       СуммаНДС = 0;

КонецЕсли;

ОбластьМакета = Макет.ПолучитьОбласть("Итого");
ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Сумма);
ТабДокумент.Вывести(ОбластьМакета);

Если Шапка.УчитыватьНДС Тогда

       ОбластьМакета = Макет.ПолучитьОбласть("ИтогоНДС");
      
       Если СуммаНДС <> 0 Тогда
            ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);
            ОбластьМакета.Параметры.НДС      = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
       Иначе
            ОбластьМакета.Параметры.ВсегоНДС = "-";
            ОбластьМакета.Параметры.НДС      = "Без налога (НДС)";
       КонецЕсли;
      
       ТабДокумент.Вывести(ОбластьМакета);

КонецЕсли;

СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего оказано услуг " + НомерСтроки
                                           + ", на сумму " + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, мВалютаРегламентированногоУчета);
ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, мВалютаРегламентированногоУчета);
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ТабДокумент.Вывести(ОбластьМакета);

Возврат ТабДокумент;




КонецФункции"

 
ЕвгенийАгро
Пост №2
"Добрый день помогите найти ошибку во внешней печа...
04.12.2012 10:13
 
 
Prikum
Пост №3
"> {ВнешняяОбработка.Услуги.МодульОбъекта(7)}: Пол...
04.12.2012 11:32
 
 
ЕвгенийАгро
Пост №4
Не понятно то что не хватает 1с для работы этой фо...
04.12.2012 11:46
 
 
Prikum
Пост №5
Пригласите специалиста, если Вы не можете понять, ...
04.12.2012 12:21
 
 
Sh_S
Пост №6
но она же в бухгалтерии есть
04.12.2012 12:36
 
 
Денис (САМАРА)
Пост №7
В типовой БП 2.0 да, но мы же не знаем какая конфи...
04.12.2012 12:43
 
 
ЕвгенийАгро
Пост №8
Конфигурация Агрокомплекс подскажите где посмотрет...
04.12.2012 12:45
 
 
Тэра
Пост №9
:((и вы ещё программируете...
04.12.2012 12:48
 
 
Prikum
Пост №10
Вам так жалко денег на специалиста?
04.12.2012 12:54
 
 
ЕвгенийАгро
Пост №11
Кто сказал что программирую я просто хочу запустит...
04.12.2012 12:58
 
 
Рисовод
Пост №12
Коллега, а что за конфигурация? Кто "автор"?
04.12.2012 12:59
 
 
ЕвгенийАгро
Пост №13
Я в документе КорректировкаРеализации не нашел кон...
04.12.2012 13:08
 
 
Денис (САМАРА)
Пост №14
А Вы где взяли эту ВПФ?
04.12.2012 13:27
 
 
ЕвгенийАгро
Пост №15
Подскажите какая у меня константа в моей конфигура...
04.12.2012 13:38
 
 
Тэра
Пост №16
Мы понятия не имеем, какая там у вас константа. Вы...
04.12.2012 13:43
 
 
Sh_S
Пост №17
т.е. вы думаете, что на этой ошибке все и закончит...
04.12.2012 13:44
 
 
Денис (САМАРА)
Пост №18
Возможно, что у Вас и нет такой константы. Из-за э...
04.12.2012 14:00
 
 
ЕвгенийАгро
Пост №19
Да они находяться в форме константант. Что там иск...
04.12.2012 14:02
 
 
Рисовод
Пост №20
а кто ничего не умеет - в депутаты! :-)
04.12.2012 14:15
 
 
Prikum
Пост №21
У него конфигурация на базе БП 1.6, а ВПФ для БП 2...
04.12.2012 14:29
 
 
ZhAmAn
Пост №22
Помогу за 900р,перечисленные насчет любой благотво...
04.12.2012 17:32
 
 
Prikum
Пост №23
Уже не смешно!
04.12.2012 20:45
 
 
ZhAmAn
Пост №24
Зато полезно,на халяву не буду помогать,а так хоть...
04.12.2012 22:17
 
 
Prikum
Пост №25
"Вечер перестал быть томным! © Уважаемый авто...
04.12.2012 22:52
 
 
ZhAmAn
Пост №26
"Данная константа задается в настройках программы,...
04.12.2012 23:22
 
 
ZhAmAn
Пост №27
И еще..какие услуги должны туда попасть,откорректи...
04.12.2012 23:34
 
 
Тэра
Пост №28
а ты то об этом как узнал?!
05.12.2012 04:59
 
 
ЕвгенийАгро
Пост №29
"Наконец то хоть какой то нормальный ответ, однако...
05.12.2012 09:35
 
 
Sh_S
Пост №30
читайте все сообщения, вам вроде помочь готовы: > ...
05.12.2012 09:42
 
 
Prikum
Пост №31
Думаете, что другая ВПФ подойдет Вашей конфигураци...
05.12.2012 09:54
 
 
ZhAmAn
Пост №32
Пришлите мне в ЛС ВПФ и файл конфигурации,я помогу...
05.12.2012 10:39
 
 
Денис (САМАРА)
Пост №33
Какой толк писать Вам советы, если все равно их не...
05.12.2012 10:51
 
 
ZhAmAn
Пост №34
Да не просто советы,а просто связаться со мной!
05.12.2012 11:01
 
 
Тэра
Пост №35
а ты пробовал с сайта в личку писать? попробуй, уз...
05.12.2012 11:06
 
 
ZhAmAn
Пост №36
Только что отправил.999.83@mail.ru
05.12.2012 11:08
 
 
ZhAmAn
Пост №37
Странно..мне моё же сообщения пришло,но с твоего e...
05.12.2012 11:10
 
 
Рисовод
Пост №38
Тэра на это и намекала, видимо! :-)
05.12.2012 11:11
 
 
Sh_S
Пост №39
да ладно, адрес то потом есть. думаю, догадаться м...
05.12.2012 11:12
 
 
Тэра
Пост №40
это я к тому, что он может и пытался, но безрезуль...
05.12.2012 11:12
 
 
ZhAmAn
Пост №41
Ну так я его тут и написал.
05.12.2012 11:17
 
 
Денис (САМАРА)
Пост №42
> думаю, догадаться можно, что делать дальше. Так ...
05.12.2012 11:43
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры