Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Бухгалтерия 8] Бухгалтерия 2.0
Белов Александр Васильевич
Пост №1
Белов Александр Васильевич
читатель
офлайн
Дата регистрации: 20.11.2012
Сообщений: 98
Пост №1
 
14.01.2013 12:45

"Помогите пожалуйста с печатной формой внешней приходный ордер М-4, на до доделать что бы она и в валюте считала, делал все как в типовой или подскажите что не так делаю?


Перем мВалютаРегламентированногоУчета Экспорт;Функция Печать() Экспорт   Перем ПодразделениеОтветственныхЛиц;   //Запрос шапки    Запрос = Новый Запрос;   Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);   Запрос.УстановитьПараметр("ДатаДок", СсылкаНаОбъект.Дата);   Запрос.УстановитьПараметр("Организация", СсылкаНаОбъект.Организация);   Запрос.Текст =    "ВЫБРАТЬ   |    ПоступлениеТоваровУслуг.Номер КАК Номер,   |    ПоступлениеТоваровУслуг.Дата КАК ДатаСоставления,   |    ПоступлениеТоваровУслуг.НомерВходящегоДокумента КАК НомерСопроводительногоДокумента,   |    ПоступлениеТоваровУслуг.Организация,   |    ПоступлениеТоваровУслуг.Организация КАК ЮрФизЛицо,   |    ПоступлениеТоваровУслуг.Склад КАК МестоПриемки,   |    ПоступлениеТоваровУслуг.Склад.Представление КАК СкладНаименование,   |    ПоступлениеТоваровУслуг.Контрагент.Код КАК ПоставщикКод,   |    ПоступлениеТоваровУслуг.Контрагент КАК Поставщик,   |    ЕСТЬNULL(ПоступлениеТоваровУслуг.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах, ЛОЖЬ) КАК РасчетыВУсловныхЕдиницах,   |    ПоступлениеТоваровУслуг.ВалютаДокумента,   |    ПоступлениеТоваровУслуг.КурсВзаиморасчетов КАК Курс,   |    ПоступлениеТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,   |    ПоступлениеТоваровУслуг.УчитыватьНДС,   |    ПоступлениеТоваровУслуг.СуммаВключаетНДС,   |    ПоступлениеТоваровУслуг.СчетУчетаРасчетовСКонтрагентом КАК СубСчет   |ИЗ   |    Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг   |ГДЕ   |    ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент";     Шапка_запрос = Запрос.Выполнить().Выбрать();   Шапка_запрос.Следующий();      //Запрос товаров   ЗапросПоТоварам = Новый Запрос();   ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);   ЗапросПоТоварам.УстановитьПараметр("Курс", ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));   ЗапросПоТоварам.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));   ЗапросПоТоварам.Текст = "ВЫБРАТЬ                           |    ПоступлениеТоваровУслуг.Номенклатура КАК Номенклатура,                           |    ВЫРАЗИТЬ(ПоступлениеТоваровУслуг.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК ТоварНаименование,                           |    ПоступлениеТоваровУслуг.Номенклатура.Код КАК ТоварКод,                           |    ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,                           |    ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код КАК ЕдиницаИзмеренияКод,                           |    ПоступлениеТоваровУслуг.СтавкаНДС КАК СтавкаНДС,                           |    СУММА(ПоступлениеТоваровУслуг.Количество) КАК КоличествоПринято,                           |    СУММА(ПоступлениеТоваровУслуг.Сумма * &Курс / &Кратность) КАК Стоимость,                           |    СУММА(ПоступлениеТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,                           |    МИНИМУМ(ПоступлениеТоваровУслуг.НомерСтроки) КАК НомерСтроки                           |ИЗ                           |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг                           |ГДЕ                           |    ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент                           |                           |СГРУППИРОВАТЬ ПО                           |    ПоступлениеТоваровУслуг.Номенклатура,                           |    ПоступлениеТоваровУслуг.ЕдиницаИзмерения,                           |    ПоступлениеТоваровУслуг.Цена,                           |    ПоступлениеТоваровУслуг.СтавкаНДС                           |                           |УПОРЯДОЧИТЬ ПО                           |    НомерСтроки";   Если Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить() = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда       ЗапросПоТоварам.Текст = СтрЗаменить(ЗапросПоТоварам.Текст, "Номенклатура.Код","Номенклатура.Артикул");   КонецЕсли;                          ЗапросТовары = ЗапросПоТоварам.Выполнить().Выгрузить();      Если Проведен И (Шапка.РасчетыВУсловныхЕдиницах       ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И Дата >= '20090101000000')) Тогда              Запрос = Новый Запрос;       Запрос.УстановитьПараметр("Ссылка", Ссылка);       Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", СчетУчетаРасчетовСКонтрагентом);       Текст =        "ВЫБРАТЬ       |    СУММА(Хозрасчетный.Сумма) КАК Сумма       |ИЗ       |    РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный       |ГДЕ       |    Хозрасчетный.Регистратор = &Ссылка       |    И Хозрасчетный.СчетКт = &СчетУчетаРасчетовСКонтрагентом       |    И Хозрасчетный.СчетДт В       |            (ВЫБРАТЬ РАЗЛИЧНЫЕ       |                ПоступлениеТоваровУслуг.СчетУчета       |            ИЗ       |                Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг       |            ГДЕ       |                ПоступлениеТоваровУслуг.Ссылка = &Ссылка       |       |           ОБЪЕДИНИТЬ       |       |            ВЫБРАТЬ РАЗЛИЧНЫЕ       |                ПоступлениеТоваровУслуг.СчетУчетаНДС       |            ИЗ       |                Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг       |            ГДЕ       |                ПоступлениеТоваровУслуг.Ссылка = &Ссылка)";                      Запрос.Текст = Текст;       СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;              РасчетСуммыНДСПоСтавке =  УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.ДатаСоставления);              Если НЕ СуммаВзаиморасчетов = NULL Тогда                      ЗапросТовары.Колонки.Добавить("СуммаБезНДС");                      МассивРаспределения = Новый Массив;                      Для Каждого СтрокаТовар Из ЗапросТовары Цикл                              СуммаСНДС = СтрокаТовар.Стоимость + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);               СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;               МассивРаспределения.Добавить(СуммаСНДС);               СтрокаТовар.СуммаБезНДС = СуммаБезНДС;                                          КонецЦикла;                      ЗапросТовары.Колонки.Добавить("СуммаРублевая");           УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ЗапросТовары, "СуммаРублевая");                      Для Каждого СтрокаТовар Из ЗапросТовары Цикл                              Если РасчетСуммыНДСПоСтавке Тогда                   //Выделение суммы НДС, Расчет суммы без НДС                   ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);                                      СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));                   СтрокаТовар.Стоимость = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;                                  Иначе                   МассивРаспределения.Очистить();                   МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);                   МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);                   МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);                   Если МассивРаспределенныхСумм <> Неопределено Тогда                       СтрокаТовар.Стоимость = МассивРаспределенныхСумм[0];                       СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];                   КонецЕсли;               КонецЕсли;                              Если Шапка.СуммаВключаетНДС Тогда                   СтрокаТовар.Стоимость = СтрокаТовар.Стоимость+СтрокаТовар.СуммаНДС;               КонецЕсли;                          КонецЦикла;                  КонецЕсли;          КонецЕсли;              // Зададим параметры макета   ТабДок=Новый ТабличныйДокумент;   ТабДок.ПолеСверху         = 0;   ТабДок.ПолеСлева          = 0;   ТабДок.ПолеСнизу          = 0;   ТабДок.ПолеСправа         = 0;   ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;   ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_М4";   Макет = ПолучитьМакет("М4");      //Заполним Шапку   Шапка=Макет.ПолучитьОбласть("Шапка");   Шапка.Параметры.Заполнить(Шапка);   СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка_запрос.Организация, Шапка_запрос.ДатаСоставления);   Адрес = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ЮридическийАдрес");   Телеф = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "Телефоны");    Шапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе);    Шапка.Параметры.ОрганизацияПоОКПО        = СведенияОПокупателе.КодПоОКПО;   Шапка.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка_запрос);   ТабДок.Вывести(Шапка);      // Заполним заголовок докмента   ЗаголовокДокумента=Макет.ПолучитьОбласть("ЗаголовокДокумента");   ЗаголовокДокумента.Параметры.Заполнить(ЗаголовокДокумента);   ЗаголовокДокумента.Параметры.Заполнить(Шапка_запрос);   ЗаголовокДокумента.Параметры.Дата = Шапка_запрос.ДатаСоставления;   ПредставлениеКонтрагента = Шапка_запрос.Поставщик;   ЗаголовокДокумента.Параметры.ПоставщикНаименование = ПредставлениеКонтрагента;   ТабДок.Вывести(ЗаголовокДокумента);   // Заполним ЗаголовокТаблицы   ЗаголовокТаблицы=Макет.ПолучитьОбласть("ЗаголовокТаблицы");   ЗаголовокТаблицы.Параметры.Заполнить(ЗаголовокТаблицы);   ТабДок.Вывести(ЗаголовокТаблицы);      //Заполним Строка   Строка=Макет.ПолучитьОбласть("Строка");   Строка.Параметры.Заполнить(Строка);   // Инициализация итогов в документе   ИтогоКоличествоПринято = 0;   ИтогоСуммаБезНДС       = 0;   ИтогоСуммаНДС          = 0;   ИтогоВсегоСНДС         = 0;   Ном                    = 0;   НомерСтраницы   = 1;   НомерСтроки     = 0;   КоличествоСтрок = ЗапросТовары.Количество();      Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл   Строка.Параметры.Заполнить(ВыборкаСтрок);       Кратность = ?(Шапка_запрос.Кратность = 0, 1, Шапка_запрос.Кратность);       ВсегоСНДС = (ВыборкаСтрок.Стоимость                 + ?(Шапка_запрос.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС));       КоличествоПринято = ВыборкаСтрок.КоличествоПринято;       СуммаНДС          = ВыборкаСтрок.СуммаНДС;       Цена              = (ВсегоСНДС - СуммаНДС) / ?(КоличествоПринято = 0, 1, КоличествоПринято);       Строка.Параметры.КоличествоПринято = КоличествоПринято;       Строка.Параметры.ВсегоСНДС         = ВсегоСНДС;       Строка.Параметры.СуммаБезНДС       = ВсегоСНДС - СуммаНДС;       Строка.Параметры.СуммаНДС          = СуммаНДС;       Строка.Параметры.Цена              = Цена;       Строка.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрок.ТоварНаименование);       ТабДок.Вывести(Строка);       ИтогоКоличествоПринято = ИтогоКоличествоПринято + КоличествоПринято;       ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС       + ВсегоСНДС - СуммаНДС;       ИтогоСуммаНДС          = ИтогоСуммаНДС          + СуммаНДС;       ИтогоВсегоСНДС         = ИтогоВсегоСНДС         + ВсегоСНДС;       КонецЦикла;          // Заполним Итого        Итого=Макет.ПолучитьОбласть("Итого");       Итого.Параметры.Заполнить(Итого);       Итого.Параметры.ИтогоКоличествоПринято = ИтогоКоличествоПринято;       Итого.Параметры.ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС;       Итого.Параметры.ИтогоСуммаНДС          = ИтогоСуммаНДС;       Итого.Параметры.ИтогоВсегоСНДС         = ИтогоВсегоСНДС;       ТабДок.Вывести(Итого);                  // Заполним Подвал       Подвал = Макет.ПолучитьОбласть("Подвал");       Подвал.Параметры.Заполнить(Подвал);       ПредставлениеКонтрагента = Шапка_запрос.Поставщик;       Подвал.Параметры.ФИОМОЛ=ПредставлениеКонтрагента;       Руководители = ОбщегоНазначения.ОтветственныеЛица(СсылкаНаОбъект.Организация, СсылкаНаобъект.Дата, ПодразделениеОтветственныхЛиц );               Подвал.Параметры.ДолжностьПоставщика = Руководители.РуководительДолжность;        Подвал.Параметры.ФИОПоставщика = Руководители.РуководительПредставление;       ТабДок.Вывести(Подвал);   Возврат ТабДок;    КонецФункции // Печать   
"

 
Белов Александр Васильевич
Пост №1
14.01.2013 12:45
 

"Помогите пожалуйста с печатной формой внешней приходный ордер М-4, на до доделать что бы она и в валюте считала, делал все как в типовой или подскажите что не так делаю?


Перем мВалютаРегламентированногоУчета Экспорт;Функция Печать() Экспорт   Перем ПодразделениеОтветственныхЛиц;   //Запрос шапки    Запрос = Новый Запрос;   Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);   Запрос.УстановитьПараметр("ДатаДок", СсылкаНаОбъект.Дата);   Запрос.УстановитьПараметр("Организация", СсылкаНаОбъект.Организация);   Запрос.Текст =    "ВЫБРАТЬ   |    ПоступлениеТоваровУслуг.Номер КАК Номер,   |    ПоступлениеТоваровУслуг.Дата КАК ДатаСоставления,   |    ПоступлениеТоваровУслуг.НомерВходящегоДокумента КАК НомерСопроводительногоДокумента,   |    ПоступлениеТоваровУслуг.Организация,   |    ПоступлениеТоваровУслуг.Организация КАК ЮрФизЛицо,   |    ПоступлениеТоваровУслуг.Склад КАК МестоПриемки,   |    ПоступлениеТоваровУслуг.Склад.Представление КАК СкладНаименование,   |    ПоступлениеТоваровУслуг.Контрагент.Код КАК ПоставщикКод,   |    ПоступлениеТоваровУслуг.Контрагент КАК Поставщик,   |    ЕСТЬNULL(ПоступлениеТоваровУслуг.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах, ЛОЖЬ) КАК РасчетыВУсловныхЕдиницах,   |    ПоступлениеТоваровУслуг.ВалютаДокумента,   |    ПоступлениеТоваровУслуг.КурсВзаиморасчетов КАК Курс,   |    ПоступлениеТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,   |    ПоступлениеТоваровУслуг.УчитыватьНДС,   |    ПоступлениеТоваровУслуг.СуммаВключаетНДС,   |    ПоступлениеТоваровУслуг.СчетУчетаРасчетовСКонтрагентом КАК СубСчет   |ИЗ   |    Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг   |ГДЕ   |    ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент";     Шапка_запрос = Запрос.Выполнить().Выбрать();   Шапка_запрос.Следующий();      //Запрос товаров   ЗапросПоТоварам = Новый Запрос();   ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);   ЗапросПоТоварам.УстановитьПараметр("Курс", ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));   ЗапросПоТоварам.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));   ЗапросПоТоварам.Текст = "ВЫБРАТЬ                           |    ПоступлениеТоваровУслуг.Номенклатура КАК Номенклатура,                           |    ВЫРАЗИТЬ(ПоступлениеТоваровУслуг.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК ТоварНаименование,                           |    ПоступлениеТоваровУслуг.Номенклатура.Код КАК ТоварКод,                           |    ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,                           |    ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код КАК ЕдиницаИзмеренияКод,                           |    ПоступлениеТоваровУслуг.СтавкаНДС КАК СтавкаНДС,                           |    СУММА(ПоступлениеТоваровУслуг.Количество) КАК КоличествоПринято,                           |    СУММА(ПоступлениеТоваровУслуг.Сумма * &Курс / &Кратность) КАК Стоимость,                           |    СУММА(ПоступлениеТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,                           |    МИНИМУМ(ПоступлениеТоваровУслуг.НомерСтроки) КАК НомерСтроки                           |ИЗ                           |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг                           |ГДЕ                           |    ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент                           |                           |СГРУППИРОВАТЬ ПО                           |    ПоступлениеТоваровУслуг.Номенклатура,                           |    ПоступлениеТоваровУслуг.ЕдиницаИзмерения,                           |    ПоступлениеТоваровУслуг.Цена,                           |    ПоступлениеТоваровУслуг.СтавкаНДС                           |                           |УПОРЯДОЧИТЬ ПО                           |    НомерСтроки";   Если Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить() = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда       ЗапросПоТоварам.Текст = СтрЗаменить(ЗапросПоТоварам.Текст, "Номенклатура.Код","Номенклатура.Артикул");   КонецЕсли;                          ЗапросТовары = ЗапросПоТоварам.Выполнить().Выгрузить();      Если Проведен И (Шапка.РасчетыВУсловныхЕдиницах       ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И Дата >= '20090101000000')) Тогда              Запрос = Новый Запрос;       Запрос.УстановитьПараметр("Ссылка", Ссылка);       Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", СчетУчетаРасчетовСКонтрагентом);       Текст =        "ВЫБРАТЬ       |    СУММА(Хозрасчетный.Сумма) КАК Сумма       |ИЗ       |    РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный       |ГДЕ       |    Хозрасчетный.Регистратор = &Ссылка       |    И Хозрасчетный.СчетКт = &СчетУчетаРасчетовСКонтрагентом       |    И Хозрасчетный.СчетДт В       |            (ВЫБРАТЬ РАЗЛИЧНЫЕ       |                ПоступлениеТоваровУслуг.СчетУчета       |            ИЗ       |                Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг       |            ГДЕ       |                ПоступлениеТоваровУслуг.Ссылка = &Ссылка       |       |           ОБЪЕДИНИТЬ       |       |            ВЫБРАТЬ РАЗЛИЧНЫЕ       |                ПоступлениеТоваровУслуг.СчетУчетаНДС       |            ИЗ       |                Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг       |            ГДЕ       |                ПоступлениеТоваровУслуг.Ссылка = &Ссылка)";                      Запрос.Текст = Текст;       СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;              РасчетСуммыНДСПоСтавке =  УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.ДатаСоставления);              Если НЕ СуммаВзаиморасчетов = NULL Тогда                      ЗапросТовары.Колонки.Добавить("СуммаБезНДС");                      МассивРаспределения = Новый Массив;                      Для Каждого СтрокаТовар Из ЗапросТовары Цикл                              СуммаСНДС = СтрокаТовар.Стоимость + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);               СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;               МассивРаспределения.Добавить(СуммаСНДС);               СтрокаТовар.СуммаБезНДС = СуммаБезНДС;                                          КонецЦикла;                      ЗапросТовары.Колонки.Добавить("СуммаРублевая");           УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ЗапросТовары, "СуммаРублевая");                      Для Каждого СтрокаТовар Из ЗапросТовары Цикл                              Если РасчетСуммыНДСПоСтавке Тогда                   //Выделение суммы НДС, Расчет суммы без НДС                   ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);                                      СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));                   СтрокаТовар.Стоимость = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;                                  Иначе                   МассивРаспределения.Очистить();                   МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);                   МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);                   МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);                   Если МассивРаспределенныхСумм <> Неопределено Тогда                       СтрокаТовар.Стоимость = МассивРаспределенныхСумм[0];                       СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];                   КонецЕсли;               КонецЕсли;                              Если Шапка.СуммаВключаетНДС Тогда                   СтрокаТовар.Стоимость = СтрокаТовар.Стоимость+СтрокаТовар.СуммаНДС;               КонецЕсли;                          КонецЦикла;                  КонецЕсли;          КонецЕсли;              // Зададим параметры макета   ТабДок=Новый ТабличныйДокумент;   ТабДок.ПолеСверху         = 0;   ТабДок.ПолеСлева          = 0;   ТабДок.ПолеСнизу          = 0;   ТабДок.ПолеСправа         = 0;   ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;   ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_М4";   Макет = ПолучитьМакет("М4");      //Заполним Шапку   Шапка=Макет.ПолучитьОбласть("Шапка");   Шапка.Параметры.Заполнить(Шапка);   СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка_запрос.Организация, Шапка_запрос.ДатаСоставления);   Адрес = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ЮридическийАдрес");   Телеф = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "Телефоны");    Шапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе);    Шапка.Параметры.ОрганизацияПоОКПО        = СведенияОПокупателе.КодПоОКПО;   Шапка.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка_запрос);   ТабДок.Вывести(Шапка);      // Заполним заголовок докмента   ЗаголовокДокумента=Макет.ПолучитьОбласть("ЗаголовокДокумента");   ЗаголовокДокумента.Параметры.Заполнить(ЗаголовокДокумента);   ЗаголовокДокумента.Параметры.Заполнить(Шапка_запрос);   ЗаголовокДокумента.Параметры.Дата = Шапка_запрос.ДатаСоставления;   ПредставлениеКонтрагента = Шапка_запрос.Поставщик;   ЗаголовокДокумента.Параметры.ПоставщикНаименование = ПредставлениеКонтрагента;   ТабДок.Вывести(ЗаголовокДокумента);   // Заполним ЗаголовокТаблицы   ЗаголовокТаблицы=Макет.ПолучитьОбласть("ЗаголовокТаблицы");   ЗаголовокТаблицы.Параметры.Заполнить(ЗаголовокТаблицы);   ТабДок.Вывести(ЗаголовокТаблицы);      //Заполним Строка   Строка=Макет.ПолучитьОбласть("Строка");   Строка.Параметры.Заполнить(Строка);   // Инициализация итогов в документе   ИтогоКоличествоПринято = 0;   ИтогоСуммаБезНДС       = 0;   ИтогоСуммаНДС          = 0;   ИтогоВсегоСНДС         = 0;   Ном                    = 0;   НомерСтраницы   = 1;   НомерСтроки     = 0;   КоличествоСтрок = ЗапросТовары.Количество();      Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл   Строка.Параметры.Заполнить(ВыборкаСтрок);       Кратность = ?(Шапка_запрос.Кратность = 0, 1, Шапка_запрос.Кратность);       ВсегоСНДС = (ВыборкаСтрок.Стоимость                 + ?(Шапка_запрос.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС));       КоличествоПринято = ВыборкаСтрок.КоличествоПринято;       СуммаНДС          = ВыборкаСтрок.СуммаНДС;       Цена              = (ВсегоСНДС - СуммаНДС) / ?(КоличествоПринято = 0, 1, КоличествоПринято);       Строка.Параметры.КоличествоПринято = КоличествоПринято;       Строка.Параметры.ВсегоСНДС         = ВсегоСНДС;       Строка.Параметры.СуммаБезНДС       = ВсегоСНДС - СуммаНДС;       Строка.Параметры.СуммаНДС          = СуммаНДС;       Строка.Параметры.Цена              = Цена;       Строка.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрок.ТоварНаименование);       ТабДок.Вывести(Строка);       ИтогоКоличествоПринято = ИтогоКоличествоПринято + КоличествоПринято;       ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС       + ВсегоСНДС - СуммаНДС;       ИтогоСуммаНДС          = ИтогоСуммаНДС          + СуммаНДС;       ИтогоВсегоСНДС         = ИтогоВсегоСНДС         + ВсегоСНДС;       КонецЦикла;          // Заполним Итого        Итого=Макет.ПолучитьОбласть("Итого");       Итого.Параметры.Заполнить(Итого);       Итого.Параметры.ИтогоКоличествоПринято = ИтогоКоличествоПринято;       Итого.Параметры.ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС;       Итого.Параметры.ИтогоСуммаНДС          = ИтогоСуммаНДС;       Итого.Параметры.ИтогоВсегоСНДС         = ИтогоВсегоСНДС;       ТабДок.Вывести(Итого);                  // Заполним Подвал       Подвал = Макет.ПолучитьОбласть("Подвал");       Подвал.Параметры.Заполнить(Подвал);       ПредставлениеКонтрагента = Шапка_запрос.Поставщик;       Подвал.Параметры.ФИОМОЛ=ПредставлениеКонтрагента;       Руководители = ОбщегоНазначения.ОтветственныеЛица(СсылкаНаОбъект.Организация, СсылкаНаобъект.Дата, ПодразделениеОтветственныхЛиц );               Подвал.Параметры.ДолжностьПоставщика = Руководители.РуководительДолжность;        Подвал.Параметры.ФИОПоставщика = Руководители.РуководительПредставление;       ТабДок.Вывести(Подвал);   Возврат ТабДок;    КонецФункции // Печать   
"

 
Prikum
Пост №2
"Слишком много букафф! © Вопрос в чем? Что не...
14.01.2013 12:53
 
 
Белов Александр Васильевич
Пост №3
"Вопрос такой как сделать что бы была в типавом ко...
14.01.2013 12:58
 
 
BubbleGumm
Пост №4
Мда. (устало) Ну дак и смотрите эти ошибки по поря...
14.01.2013 14:29
 
 
Белов Александр Васильевич
Пост №5
во первых я кучу текста не копировал и ставлю его ...
14.01.2013 14:46
 
 
BubbleGumm
Пост №6
Ну дык не томите, расскажите уже, на какую мысль в...
14.01.2013 15:03
 
 
Белов Александр Васильевич
Пост №7
сделал уже совсем по другому коновый внешнею печа...
14.01.2013 15:42
 
 
Белов Александр Васильевич
Пост №8
вот мой тупик может будеет у кого мысли
14.01.2013 15:45
 
 
ZhAmAn
Пост №9
Вы программист?
14.01.2013 15:52
 
 
Prikum
Пост №10
Нет!
14.01.2013 15:54
 
 
Белов Александр Васильевич
Пост №11
Нет любитель... программистов не дождешься...почит...
14.01.2013 16:06
 
 
ZhAmAn
Пост №12
Ссылка.Проведен и Ссылка.Дата и т.д
14.01.2013 16:10
 
 
Белов Александр Васильевич
Пост №13
Спасибо большое все сделал..все работает
14.01.2013 16:20
 
 
ZhAmAn
Пост №14
И еще,бросайте учиться по форуму программировать! ...
14.01.2013 16:21
 
 
Белов Александр Васильевич
Пост №15
спасибо за совет но я по форуму не программироваю ...
14.01.2013 16:37
 
 
Prikum
Пост №16
http://v8.1c.ru/Раздел "методическая поддержка"
14.01.2013 16:43
 
 
ZhAmAn
Пост №17
http://1c.chistov.pro/
14.01.2013 16:45
 
 
Денис (САМАРА)
Пост №18
И я, и я дам свою "любимую ссылку" :) spec8.ru
15.01.2013 20:48
 
 
Prikum
Пост №19
Ну да Фарит рулит!
15.01.2013 22:10
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры