Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Ошибки комплексной конфигурации 7.7

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №1
 
20.01.2010 20:49

"Ошибка 1 (релиз 7.70.493):
Отчет.ПодготовкаСведенийДляИМНС, примерное место - строка 2120
Имеем два одинаковых блока алгоритма, очевидно второй был просто скопирован с первого и подправлен:
//имущественные вычеты на которые сотрудник имел право
ОписаниеВычета311=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+ПоследнийМесяц-1,3).ПолучитьЗначение(5);
Если ТипЗначенияСтр(ОписаниеВычета311)="СписокЗначений" Тогда
ВсегоСуммаВычета311 = ОписаниеВычета311.ПолучитьЗначение(3);
НомерУведомления = ОписаниеВычета311.ПолучитьЗначение(4);
ДатаУведомления = Формат(ОписаниеВычета311.ПолучитьЗначение(5), "ДДДММГГГГ");
КодФНСУведомления = ОписаниеВычета311.ПолучитьЗначение(6);
КонецЕсли;

ОписаниеВычета312=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+ПоследнийМесяц-1,3).ПолучитьЗначение(6);
Если ТипЗначенияСтр(ОписаниеВычета312)="СписокЗначений" Тогда
ВсегоСуммаВычета312 = ОписаниеВычета312.ПолучитьЗначение(3);
НомерУведомления = ?(ПустоеЗначение(НомерУведомления)=1,ОписаниеВычета312.ПолучитьЗначение(4),НомерУведомления);
ДатаУведомления = ?(ПустоеЗначение(ДатаУведомления)=1,Формат(ОписаниеВычета311.ПолучитьЗначение(5), "ДДДММГГГГ"),ДатаУведомления);
КодФНСУведомления = ?(ПустоеЗначение(КодФНСУведомления)=1,ОписаниеВычета312.ПолучитьЗначение(6),КодФНСУведомления);
КонецЕсли;

Ошибка во втором блоке в строке ДатаУведомления= ..., при внимательном рассмотрении в самом деле видно, что это ошибка. Там должно быть написано "ОписаниеВычета312", а не "ОписаниеВычета311".

Ошибка 2 (релиз 7.70.493):
Обработка.РасчетЕСН. Таблица "13н_Раздел2". Колонка 36, строка 195. Ну, или относительно состава печатной формы, это строка "0600" в разделе 00002 и колонка "ТФОМС".
Имеем там в ячейке формулу:
Формат(ИтоговаяТаблица.ПолучитьЗначение(4,"Строка06ТФОМС")-ИтоговаяТаблица.ПолучитьЗначение(1,"Строка06ТФОМС"),"Ч-15."+Точность)
А она неправильная! Должна быть такая:
Формат(ИтоговаяТаблица.ПолучитьЗначение(4,"Строка06ТФОМС"),"Ч-15."+Точность)

Почему? А посмотрите соседние ячейки с этой и уловите логику. Очевидно, формула была тоже просто скопирована вместе с областью таблицы с другого места (с "0610" строки). Соседние подправили, а эту нет.

Ошибка 3 (релиз 7.70.493):
Если у нас в комплексной ведется учет более чем одного собственного юрлица, то в справочнике юрлиц имеем несколько элементов. Теперь смотрим в глобальный модуль:
Функция глВеличинаПроцентаСтавкиЕСН(ЮрЛицо, Код, ДатаАктуальности)
СпрСтавкиЕСН = СоздатьОбъект("Справочник.СтавкиЕСН");
СпрСтавкиЕСН.ИспользоватьВладельца(ЮрЛицо);
Если СпрСтавкиЕСН.НайтиПоКоду(Код,0) = 1 Тогда
       Возврат СпрСтавкиЕСН.Процент.Получить(ДатаАктуальности)
КонецЕсли;
Возврат 0
КонецФункции

Ошибка в "СпрСтавкиЕСН.НайтиПоКоду(Код,0)". Почему 0 то? Зачем вообще тогда было писать ИспользоватьВладельца(...), если поиск идет "по всему справочнику"? Что имеем в результате ошибки? А вот что. При аргументе ФлагПоиска=0 будет найден первый подходящий элемент справочника такой, который соответствует режиму упорядочивания элементов. То есть, практически, результат данного поиска зависит от того, в каком порядке отсортированы по наименованию элементы в справочнике. И мы получим вовсе не информацию о том есть у нас у юрлица ЕСН или нет, а просто какое то значение, с нужным нам юрлицом никак и не связанное. В итоге больничные листы могут при проведении в журнал документов записать либо кучу ненужных записей про особые режимы, либо не сделать этого в том случае когда это надо.

Ошибка 4 (релиз 7.70.493):
В модуле формы документа БольничныйЛист сделана процедура Печать2010(), но ниоткуда она не вызывается. В итоге отрабатывает Печать2007 и мы имеем печатную форму со сведениями о среднем заработке, в которой нет нижней части. Исправляем так:
В процедуре Печать добавляем/меняем строки:
Если ДатаНачалаСобытия >= '01.01.2010' Тогда
Печать2010(ПараметрПечати);
ИначеЕсли ((ДатаНачалаСобытия < '01.01.2007') и (Окончание >= '01.01.2007')) или (ДатаНачалаСобытия >= '01.01.2007') Тогда
...

Ошибка 5 (фича?) (релиз 7.70.493):
в правилах формирования проводок для ситуации "Реализация" выкинули правило установки во второе субконто счета 90.1.1 значения ставки НДС. Это очень плохо (прям сильно ругаюсь). Все бухи "мои" просто в недоумении. Это очень нужная информация! Зачем это сделали - понятно. Из за ввода реквизита "Рублевая оценка" в регистры (о проблемах с вводом этого ресурса я писал тут: http://www.buh.ru/forum/thread.jsp?id=451316). У нас тут все в рублях, поэтому я своим исправил просто. 1. Снова вернул ситуационную привязку к движению регистра КнигаПродаж, как это было в старых релизах. 2. В таблицу "Проводки" обработки "НастройкаФормированияПроводок" в строки, касающиеся этого события внес допустимый для выбора элемент правила "СтавкаНДС".
В результате у нас аналитика по ставкам на месте.

Ошибка 6 (релиз 7.70.493):
Документ.Сторно. Модуль проведения, почти самый конец. Имеются строки:
// Сразу закроем остатки по книге покупок (продаж), чтобы не анализировать их
// документом "Формирование книги покупок (продаж)"
....
Ага, отличные дела... А проводки кто делать будет? Регистры подвигали, а проводки не сделали, в итоге обороты в книге продаж верны, но с оборотами 68.2 не сходятся. "Документ.Сторно" в справочниках Хозяйственные операции + Проводки по ним отсутствует как событие, поэтому там и не описать нужные нам проводки. Я добавлял кусок алгоритма прямо тут в модуле проведения."

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
20.01.2010 23:30

Ошибка 7 :
неправильная обработка метода ОчиститьДвижения() для регистра Покупатели/Поставщики

если любой проведённый документ интерактивно перепровести, то метод ОчиститьДвижения() оставляет последние значение прошлого проведения
править процедуру глДвижениеДолгов()
подробнее http://www.forum.mista.ru/topic.php?id=440368

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
20.01.2010 23:34

Ошибка 8:
Поступление ТМЦ (Импорт)
возникновение лишних движений => и проводок
ошибка округления, подробнее http://www.forum.mista.ru/topic.php?id=433962

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
21.01.2010 14:25

пояснение про ошибку 7:
ОчиститьДвижения() не очищает последние движение любого регистра...

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
26.01.2010 22:57

"Еще одна ошибка закралась в новые релизы (493 и 494). При расчете больничного листа по уходу за ребенком задваивается сумма начисления. Практически в самом конце процедуры глСобратьДанныеДляБЛ2010 в строке 75028 вместо

СуммаПособияПоловинаДоляНеЕНВД = СуммаПособияПолная - СуммаПособияПоловинаДоляЕНВД;
должно быть
СуммаПособияПоловинаДоляНеЕНВД = СуммаПособияПоловина - СуммаПособияПоловинаДоляЕНВД;"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
27.01.2010 17:42

зарплатную часть кто-нибудь сравнивал 494 с http://infostart.ru/public/64134/?PAGEN_1=2#comm
?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №7
 
27.01.2010 20:06

Попунктно не сравнивал. Ссылку с infostart читал, при обновлениях ЗиК применял. В комплексной тоже проблемы схожие, но я там исправлял до того как с материалом на infostart-е ознакомился. Правил то что "выстрелило", не факт, что поправил или просмотрел все эти места. Сейчас что то работы привалило, некогда даже про ошибки комплексной продолжить. Потом вернусь к этой теме

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
27.01.2010 22:14

> Попунктно не сравнивал. Ссылку с infostart читал, при обновлениях ЗиК применял. В комплексной тоже проблемы схожие, но я там исправлял до того как с материалом на infostart-е ознакомился. Правил то что "выстрелило", не факт, что поправил или просмотрел все эти места. Сейчас что то работы привалило, некогда даже про ошибки комплексной продолжить. Потом вернусь к этой теме

ну я так понял, что ошибки в комплексной в сфере "ЗиКа" только в этом годы вылазят ?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №9
 
28.01.2010 09:29

Да, по больничным листам

Оболтус
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 29
Пост №10
 
28.01.2010 09:42

"Мои 5 копеек:

Комплексная, 493, КарточкаУчетаПоСтраховымВзносам

Процедура ПриОткрытии(ФлагЧтенияНастройки)

НачальныйГод = 2010;
КонечныйГод = Мин(ДатаГод(РабочаяДата()), 2010);

Если НачальныйГод>КонечныйГод Тогда
       СпЛет.ДобавитьЗначение(2010,"2010 г.");
       СпЛет.ТекущаяСтрока(1);
Иначе
       Для ГодВСписок = НачальныйГод По КонечныйГод Цикл
            СпЛет.ДобавитьЗначение(ГодВСписок,Строка(ГодВСписок)+" г.");
       КонецЦикла;
       СпЛет.ТекущаяСтрока(СпЛет.РазмерСписка());
КонецЕсли;

На мой взгляд, в этом месте всегда будет либо:

СпЛет.ДобавитьЗначение(2010,"2010 г.");
СпЛет.ТекущаяСтрока(1);

либо:

Для ГодВСписок = 2010 По 2010 Цикл

То есть, 2010 год навечно :)."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги