Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выгрузка в HTML

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №21
 
17.02.2010 13:56

"> XMLАнализатор = СоздатьОбъект("AddIn.XMLParser");
> {Обработка.HTML.Форма.Модуль(5)}: Неудачная попытка создания объекта (AddIn.XMLParser)
>
> наверное v7plus.dll не сильно свежая (7.70.0.1)

так её надо зарегить + загрузить !"

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №22
 
17.02.2010 14:26

скачал 7.70.0.11
зарегил
загрузил
не работает!
или ее нужно загружать при начале работы системы а не в обработке?

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №23
 
17.02.2010 14:32

> скачал 7.70.0.11
> зарегил
> загрузил
> не работает!
> или ее нужно загружать при начале работы системы а не в обработке?

В ОБРАБОТКЕ ДОСТАТОЧНО !!!

у меня ж всё работает

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №24
 
17.02.2010 14:45

А MS XML Parser установлен?

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №25
 
17.02.2010 14:51

если с win 2003 не идет, то не установлен

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №26
 
17.02.2010 16:11

Установил MS XML Parser
не помогло

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №27
 
17.02.2010 16:12

> Установил MS XML Parser
> не помогло

ось 2003 ?

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №28
 
17.02.2010 16:12

"+ что возращает ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"v7plus.dll"); ???"

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №29
 
17.02.2010 16:33

"да, 2003

на ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"v7plus.dll") не ругается
а тут ругается
XMLАнализатор = СоздатьОбъект("AddIn.XMLParser");
{Обработка.HTML.Форма.Модуль(5)}: Неудачная попытка создания объекта (AddIn.XMLParser)"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №30
 
17.02.2010 16:49

"так работает / что выведет???

Функция НайтиПервыйСуществующийФайл(СписокВозможныхМест)

Для Сч = 1 По СписокВозможныхМест.РазмерСписка() Цикл
ПолноеИмя = СписокВозможныхМест.ПолучитьЗначение(Сч);
Если Фс.СуществуетФайл(ПолноеИмя) = 1 Тогда Возврат(ПолноеИмя) КонецЕсли;
КонецЦикла;

Возврат("""");

КонецФункции

Процедура Сформировать()

СписокВозможныхМест = СоздатьОбъект("СписокЗначений");
СписокВозможныхМест.ДобавитьЗначение( КаталогИБ() + "v7plus.dll" );
СписокВозможныхМест.ДобавитьЗначение( КаталогПрограммы() + "v7plus.dll" );
СписокВозможныхМест.ДобавитьЗначение( КаталогИБ() + "ExtForms\" + "v7plus.dll" );

гПутьОбъекта_КомпонентаV7plus = НайтиПервыйСуществующийФайл(СписокВозможныхМест);

Если ПустаяСтрока(гПутьОбъекта_КомпонентаV7plus)=1 Тогда
Сообщиь("не найдена компонента!!!");
КонецЕсли;

Если ЗагрузитьВнешнююКомпоненту(гПутьОбъекта_КомпонентаV7plus) <> 1 Тогда
сообщить("Компонента v7plus.dll не найдена!");
СтатусВозврата(0); Возврат;
КонецЕсли;

XMLАнализатор = СоздатьОбъект("AddIn.XMLParser");
ДанныеXML = XMLАнализатор.СоздатьДокумент();
ШапкаXML=ДанныеXML.СоздатьПодчиненныйЭлемент("html");
ТелоXML=ШапкаXML.СоздатьПодчиненныйЭлемент("body");

Спр=СоздатьОбъект("Справочник.Номенклатура");
Спр.ВыбратьЭлементы(0);


Пока Спр.ПолучитьЭлемент(1)=1 Цикл
p=ТелоXML.СоздатьПодчиненныйЭлемент("p");
p.Значение = СокрЛП(Спр.Наименование);
КонецЦикла;
ДанныеXML.Записать("test.html");
КонецПроцедуры"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги