Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Выбор и запрет на изменение значения из списка в форме
m0s
Пост №1
m0s
читатель
офлайн
Дата регистрации: 11.03.2009
Сообщений: 18
Пост №1
 
23.04.2009 16:11

"Добрый день!
Данный вопрос возник из темы здесь же http://www.buh.ru/forum/thread.jsp?id=460950 но уже более конкретен и не вполне соответствует той теме.

Вкратце, 1С ТиС 7.7, есть формы (отчеты), в которых реализованы в зависимости от группы пользователя определенные ограничения на доступность некоторых элементов данной формы (выпадающий список, кнопки и тд).

Необходимо, чтобы у одной группы форма открывалась с одним значением из этого списка без возможности его изменить (поле = фильтр, и изначально пустым, с возможностью установки только 1го значения из всех - тоже не подходит, т.е. открывается форма и там должно быть уже установлено опред.значение списка)

На данный момент, не без помощи в другой ветке форума, я представляю это себе принудительным заданием значения поля списка (только как это можно сделать?) и затем блокировкой данного списка как элемента формы следующим способом: Форма.ВыбРекв.Доступность(0);

Скажите пожалуйста, как можно выбрать значение по умолчанию для выпадающего списка в форме?
Попробовал на примере поля с идентификатором ВыбСклад но строка
ВыбСклад.ТекущаяСтрока(1);

выдает ошибку:
ВыбСклад.ТекущаяСтрока(1);
{Отчет.ОстаткиТМЦ.Форма.Модуль(146)}: Поле агрегатного объекта не обнаружено (ТекущаяСтрока)

Задаю это в том же фрагменте где и описывается доступность данных элементов в зависимости от группы т.е. процедура с некоторыми сокращениями и комментариями:

Процедура УправлениеДиалогом()

Если Форма.Закладки.ТекущаяСтрока() = 1 Тогда      
Форма.ИспользоватьСлой("Шапка,Подвал,Основной1,Основной2,Разделитель"+СокрЛП(ВидРазделителя));
Если ЦенаТовара.ПолучитьЗначение(ЦенаТовара.ТекущаяСтрока()) = "из справочника цен" Тогда
Форма.ЦенаИзСправочника.Видимость(1);
Иначе
Форма.ЦенаИзСправочника.Видимость(0);
КонецЕсли;

Иначе
Форма.ИспользоватьСлой("Шапка,МФ,Подвал");
КонецЕсли;

//begin
Если ЭтоГруппа1()=1 Тогда
// здесь сокращен....
             //здесь ВыбСклад.ТекущаяСтрока(1); -???
Форма.ВыбСклад.Доступность(0);
Форма.кнХСклад.Доступность(0);
// здесь сокращен....
Иначе
//не Группа1
КонецЕсли;
//end

КонецПроцедуры //УправлениеДиалогом()"

 
m0s
Пост №1
23.04.2009 16:11
 

"Добрый день!
Данный вопрос возник из темы здесь же http://www.buh.ru/forum/thread.jsp?id=460950 но уже более конкретен и не вполне соответствует той теме.

Вкратце, 1С ТиС 7.7, есть формы (отчеты), в которых реализованы в зависимости от группы пользователя определенные ограничения на доступность некоторых элементов данной формы (выпадающий список, кнопки и тд).

Необходимо, чтобы у одной группы форма открывалась с одним значением из этого списка без возможности его изменить (поле = фильтр, и изначально пустым, с возможностью установки только 1го значения из всех - тоже не подходит, т.е. открывается форма и там должно быть уже установлено опред.значение списка)

На данный момент, не без помощи в другой ветке форума, я представляю это себе принудительным заданием значения поля списка (только как это можно сделать?) и затем блокировкой данного списка как элемента формы следующим способом: Форма.ВыбРекв.Доступность(0);

Скажите пожалуйста, как можно выбрать значение по умолчанию для выпадающего списка в форме?
Попробовал на примере поля с идентификатором ВыбСклад но строка
ВыбСклад.ТекущаяСтрока(1);

выдает ошибку:
ВыбСклад.ТекущаяСтрока(1);
{Отчет.ОстаткиТМЦ.Форма.Модуль(146)}: Поле агрегатного объекта не обнаружено (ТекущаяСтрока)

Задаю это в том же фрагменте где и описывается доступность данных элементов в зависимости от группы т.е. процедура с некоторыми сокращениями и комментариями:

Процедура УправлениеДиалогом()

Если Форма.Закладки.ТекущаяСтрока() = 1 Тогда      
Форма.ИспользоватьСлой("Шапка,Подвал,Основной1,Основной2,Разделитель"+СокрЛП(ВидРазделителя));
Если ЦенаТовара.ПолучитьЗначение(ЦенаТовара.ТекущаяСтрока()) = "из справочника цен" Тогда
Форма.ЦенаИзСправочника.Видимость(1);
Иначе
Форма.ЦенаИзСправочника.Видимость(0);
КонецЕсли;

Иначе
Форма.ИспользоватьСлой("Шапка,МФ,Подвал");
КонецЕсли;

//begin
Если ЭтоГруппа1()=1 Тогда
// здесь сокращен....
             //здесь ВыбСклад.ТекущаяСтрока(1); -???
Форма.ВыбСклад.Доступность(0);
Форма.кнХСклад.Доступность(0);
// здесь сокращен....
Иначе
//не Группа1
КонецЕсли;
//end

КонецПроцедуры //УправлениеДиалогом()"

 
Денис (САМАРА)
Пост №2
"> //здесь ВыбСклад.ТекущаяСтрока(1); -???СпрСклад...
24.04.2009 07:11
 
 
m0s
Пост №3
Ура!! Спасибо Вам большое, то что нужно!
28.04.2009 14:40
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат переплаты возмещение пособия за счет ФСС восстановление НДС выездная налоговая проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зачет страховых взносов защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от НДС освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков перерасчет налогов переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебные издержки суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ формы документов хроники 54-ФЗ штрафные санкции ЭДО экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры