Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Анализ неликвидов!Невыводит цену и сумму по складам!
Дмитрий Валерьевич
Пост №1
Дмитрий Валерьевич
читатель
офлайн
Дата регистрации: 25.03.2010
Сообщений: 2
Пост №1
 
25.03.2010 14:04

"Посмотрите и подскажите,почему не выводит сумму и цену в табл часть,если мы перебираем 1 из складов?
Что возможно сделать в этой ситуации?Заранее спасибо!

//*******************************************
Процедура Сформировать()


Перем Заг, СписокСчетов, Ит;
Перем НачДолг,КонДолг,СуммаНеликвидов;
перем ЦенаНеликвида, СуммаНеликвида;
//Создание объекта типа Запрос
Заг="На дату: "+Строка(ДатаКонца)+". За "+Строка(КолДней)+" дней";// Заголовок дата на 270 дней

Таб = СоздатьОбъект("Таблица");//Создание объекта Таблица
Таб.ИсходнаяТаблица("Неликвиды");//Исход Таб Неликвиды
Ит = СоздатьОбъект("БухгалтерскиеИтоги");// Объект БИ
СписокСчетов=СоздатьОбъект("СписокЗначений");// Объект СписокЗначений
СуммаНеликвидов=0;

Если ВыбВидОтчета=1 Тогда //выбор вида отчета(список счетов)

Заг="По товарам. Счета:";
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.1")); // добавляем счет 41.1
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.7"));
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.8"));
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ВыбТовар, 1); //выбираем товар из ВидСубконто Номенклатура

Если ПустоеЗначение(ВыбСклад)=0 Тогда /// если склад не выбран                                    
Заг=Заг+". По складу "+ВыбСклад.Наименование+".";
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСклад, 2);// выбор склада
КонецЕсли;                         ///
ИначеЕсли ВыбВидОтчета=2 Тогда //выбор вида отчета(список счетов)


Если ВыбСч10_1=1 Тогда //выбран счет 10.1
СписокСчетов.ДобавитьЗначение(СчетПоКоду("10.1"));//добаляем знчение счета 10.1
КонецЕсли;
Если ВыбСч10_5=1 Тогда //выбран счет 10.5
СписокСчетов.ДобавитьЗначение(СчетПоКоду("10.5")); //добаляем знчение счета 10.5
КонецЕсли;

Ит.ИспользоватьСубконто(ВидыСубконто.Материалы, ВыбТовар, 1);
Если ПустоеЗначение(ВыбСклад)=0 Тогда //
Заг=Заг+". По складу "+ВыбСклад.Наименование+".";//
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСклад, 2); //
КонецЕсли;
КонецЕсли;
Ит.ВыполнитьЗапрос(ДатаКонца-КолДней, ДатаКонца, СписокСчетов,,, 3, 1, 5);
Таб.ВывестиСекцию("Шапка");
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
Если ВыбВидОтчета=1 Тогда
Товар=Ит.Субконто(ВидыСубконто.Номенклатура);
ИначеЕсли ВыбВидОтчета=2 Тогда
Товар=Ит.Субконто(ВидыСубконто.Материалы);
КонецЕсли;
Ит.ВыполнитьЗапрос();

Если (Ит.СНД("К")>0) И (Ит.СКД("К")>0) Тогда
Ит.ВыбратьКорСчета();
Расход = 0;
КолНеликвида = 0;
ЦенаНеликвида = 0;
СуммаНеликвида = 0;
Пока Ит.ПолучитьКорСчет()=1 Цикл
Если Ит.КорСчет=СчетПоКоду("10") Тогда
Продолжить;
КонецЕсли;
Расход=Расход+Ит.КорКО("К");
КонецЦикла;
Если Расход<Ит.СКД("К") Тогда
КолНеликвида = Ит.СКД("К")-Расход;
ЦенаНеликвида = Ит.СКД("K")/Ит.СКД("К");
СуммаНеликвида = ЦенаНеликвида*КолНеликвида;
КонецЕсли;
Если КолНеликвида<=0 Тогда
Продолжить;
КонецЕсли;
СуммаНеликвидов=СуммаНеликвидов+СуммаНеликвида;
Таб.ВывестиСекцию("Товар");      
Если (ПоказатьСчет=1) И (ВыбВидОтчета=1) Тогда
Док = СоздатьОбъект("Документ.Счет");
Док.ОбратныйПорядок(1);
Док.ВыбратьДокументы(,ДатаКонца);
ЕстьТовар = 0;
Пока Док.ПолучитьДокумент()=1 Цикл
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
Если Док.Товар=Товар Тогда
ЕстьТовар = 1;
Прервать;
КонецЕсли;
КонецЦикла;
Если ЕстьТовар=1 Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Если ЕстьТовар=1 Тогда
Таб.ВывестиСекцию("Счет");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Таб.ВывестиСекцию("Итоги");
Таб.Опции(0,0,4,,"Неликвиды","ОкноНеликвиды",0);
Таб.ТолькоПросмотр(1);
Таб.Показать("Анализ неликвидов товаров (материалов)","""");
КонецПроцедуры
//}}БУХГАЛТЕРСКИЙ ЗАПРОС

Процедура ПриОткрытии()
ВыбСклад = глЗначениеПоУмолчанию("ОсновнойСклад");
ВыбСч10_1=1;
ВыбСч10_5=1;
ВыбВидОтчета=2;
ДатаКонца = ТекущаяДата();
КолДней = 270;
КонецПроцедуры


Процедура ОбработкаПодбора(ЗначПодбора)
Если (ЗначПодбора.Вид()="Номенклатура") ИЛИ (ЗначПодбора.Вид()="Материалы") Тогда
Если ВыбТовар.НайтиЗначение(ЗначПодбора)=0 Тогда
ВыбТовар.ДобавитьЗначение(ЗначПодбора);
ВыбТовар.ТекущаяСтрока(ВыбТовар.РазмерСписка());
КонецЕсли;
КонецЕсли;
КонецПроцедуры
//******************************************************************************

Процедура ВыбратьТовар(Реж)
Перем Фрм;
Перем Тек;

Если ВыбТовар.РазмерСписка()>0 Тогда
Тек=ВыбТовар.ПолучитьЗначение(ВыбТовар.ТекущаяСтрока());
КонецЕсли;
Если ВыбВидОтчета=1 Тогда
ОткрытьПодбор("Справочник.Номенклатура",,Фрм,Реж,Тек);
Фрм.ВыборГруппы(1);
ИначеЕсли ВыбВидОтчета=2 Тогда
ОткрытьПодбор("Справочник.Материалы",,Фрм,Реж,Тек);
Фрм.ВыборГруппы(1);
КонецЕсли;
КонецПроцедуры "

 
Дмитрий Валерьевич
Пост №1
25.03.2010 14:04
 

"Посмотрите и подскажите,почему не выводит сумму и цену в табл часть,если мы перебираем 1 из складов?
Что возможно сделать в этой ситуации?Заранее спасибо!

//*******************************************
Процедура Сформировать()


Перем Заг, СписокСчетов, Ит;
Перем НачДолг,КонДолг,СуммаНеликвидов;
перем ЦенаНеликвида, СуммаНеликвида;
//Создание объекта типа Запрос
Заг="На дату: "+Строка(ДатаКонца)+". За "+Строка(КолДней)+" дней";// Заголовок дата на 270 дней

Таб = СоздатьОбъект("Таблица");//Создание объекта Таблица
Таб.ИсходнаяТаблица("Неликвиды");//Исход Таб Неликвиды
Ит = СоздатьОбъект("БухгалтерскиеИтоги");// Объект БИ
СписокСчетов=СоздатьОбъект("СписокЗначений");// Объект СписокЗначений
СуммаНеликвидов=0;

Если ВыбВидОтчета=1 Тогда //выбор вида отчета(список счетов)

Заг="По товарам. Счета:";
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.1")); // добавляем счет 41.1
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.7"));
СписокСчетов.ДобавитьЗначение(СчетПоКоду("41.8"));
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ВыбТовар, 1); //выбираем товар из ВидСубконто Номенклатура

Если ПустоеЗначение(ВыбСклад)=0 Тогда /// если склад не выбран                                    
Заг=Заг+". По складу "+ВыбСклад.Наименование+".";
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСклад, 2);// выбор склада
КонецЕсли;                         ///
ИначеЕсли ВыбВидОтчета=2 Тогда //выбор вида отчета(список счетов)


Если ВыбСч10_1=1 Тогда //выбран счет 10.1
СписокСчетов.ДобавитьЗначение(СчетПоКоду("10.1"));//добаляем знчение счета 10.1
КонецЕсли;
Если ВыбСч10_5=1 Тогда //выбран счет 10.5
СписокСчетов.ДобавитьЗначение(СчетПоКоду("10.5")); //добаляем знчение счета 10.5
КонецЕсли;

Ит.ИспользоватьСубконто(ВидыСубконто.Материалы, ВыбТовар, 1);
Если ПустоеЗначение(ВыбСклад)=0 Тогда //
Заг=Заг+". По складу "+ВыбСклад.Наименование+".";//
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСклад, 2); //
КонецЕсли;
КонецЕсли;
Ит.ВыполнитьЗапрос(ДатаКонца-КолДней, ДатаКонца, СписокСчетов,,, 3, 1, 5);
Таб.ВывестиСекцию("Шапка");
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
Если ВыбВидОтчета=1 Тогда
Товар=Ит.Субконто(ВидыСубконто.Номенклатура);
ИначеЕсли ВыбВидОтчета=2 Тогда
Товар=Ит.Субконто(ВидыСубконто.Материалы);
КонецЕсли;
Ит.ВыполнитьЗапрос();

Если (Ит.СНД("К")>0) И (Ит.СКД("К")>0) Тогда
Ит.ВыбратьКорСчета();
Расход = 0;
КолНеликвида = 0;
ЦенаНеликвида = 0;
СуммаНеликвида = 0;
Пока Ит.ПолучитьКорСчет()=1 Цикл
Если Ит.КорСчет=СчетПоКоду("10") Тогда
Продолжить;
КонецЕсли;
Расход=Расход+Ит.КорКО("К");
КонецЦикла;
Если Расход<Ит.СКД("К") Тогда
КолНеликвида = Ит.СКД("К")-Расход;
ЦенаНеликвида = Ит.СКД("K")/Ит.СКД("К");
СуммаНеликвида = ЦенаНеликвида*КолНеликвида;
КонецЕсли;
Если КолНеликвида<=0 Тогда
Продолжить;
КонецЕсли;
СуммаНеликвидов=СуммаНеликвидов+СуммаНеликвида;
Таб.ВывестиСекцию("Товар");      
Если (ПоказатьСчет=1) И (ВыбВидОтчета=1) Тогда
Док = СоздатьОбъект("Документ.Счет");
Док.ОбратныйПорядок(1);
Док.ВыбратьДокументы(,ДатаКонца);
ЕстьТовар = 0;
Пока Док.ПолучитьДокумент()=1 Цикл
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
Если Док.Товар=Товар Тогда
ЕстьТовар = 1;
Прервать;
КонецЕсли;
КонецЦикла;
Если ЕстьТовар=1 Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Если ЕстьТовар=1 Тогда
Таб.ВывестиСекцию("Счет");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Таб.ВывестиСекцию("Итоги");
Таб.Опции(0,0,4,,"Неликвиды","ОкноНеликвиды",0);
Таб.ТолькоПросмотр(1);
Таб.Показать("Анализ неликвидов товаров (материалов)","""");
КонецПроцедуры
//}}БУХГАЛТЕРСКИЙ ЗАПРОС

Процедура ПриОткрытии()
ВыбСклад = глЗначениеПоУмолчанию("ОсновнойСклад");
ВыбСч10_1=1;
ВыбСч10_5=1;
ВыбВидОтчета=2;
ДатаКонца = ТекущаяДата();
КолДней = 270;
КонецПроцедуры


Процедура ОбработкаПодбора(ЗначПодбора)
Если (ЗначПодбора.Вид()="Номенклатура") ИЛИ (ЗначПодбора.Вид()="Материалы") Тогда
Если ВыбТовар.НайтиЗначение(ЗначПодбора)=0 Тогда
ВыбТовар.ДобавитьЗначение(ЗначПодбора);
ВыбТовар.ТекущаяСтрока(ВыбТовар.РазмерСписка());
КонецЕсли;
КонецЕсли;
КонецПроцедуры
//******************************************************************************

Процедура ВыбратьТовар(Реж)
Перем Фрм;
Перем Тек;

Если ВыбТовар.РазмерСписка()>0 Тогда
Тек=ВыбТовар.ПолучитьЗначение(ВыбТовар.ТекущаяСтрока());
КонецЕсли;
Если ВыбВидОтчета=1 Тогда
ОткрытьПодбор("Справочник.Номенклатура",,Фрм,Реж,Тек);
Фрм.ВыборГруппы(1);
ИначеЕсли ВыбВидОтчета=2 Тогда
ОткрытьПодбор("Справочник.Материалы",,Фрм,Реж,Тек);
Фрм.ВыборГруппы(1);
КонецЕсли;
КонецПроцедуры "

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры