Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Автозаполнение табл.части документа.Компонента "Бухгалтерский учет",релиз 7.70.279.
Saxarok
Пост №1
Saxarok
читатель
офлайн
Дата регистрации: 31.10.2007
Сообщений: 69
Пост №1
 
07.10.2010 22:24

"Добрый вечер.

Подскажите пожалуйста вот какой вопрос.
Есть Док.Калькуляция,который со списанием материалов в производство.
Для того,чтобы внести материалы по продукции,необходимо нажать на кнопку "Заполнить",
после чего происходит заполнение табличной части Док.Калькуляция.
Всё отлично!

Возникла задача автоматического формирования Док.Калькуляция за выбранный период на
основании введённых Расходных накладных.

Сделала в Журнале.Производство ЧУДО-кнопочку,по нажатию на которую(за выбранный период)
автоматически формируються Док.Калькуляция,и вроде все проводиться отлично
НННООО никак не получаеться в этом же режиме(речь идет об автоматическом формировании)
заполнить ТАБЛИЧНУЮ ЧАСТЬ.
Не пойму как правильно сделать процедуру Заполнить()

Подскажите кто-то понял из вышесказанного.

Вот часть кода:

// ===============================
Процедура Заполнить()
       ????????????Как же быть здесь???????????????
КонецПроцедуры

Процедура СформироватьКальк()
Перем Способ, ДатаС, ДатаПо;
СпособыЗаполнения = СоздатьОбъект("СписокЗначений");
СпособыЗаполнения.ДобавитьЗначение(1,"За текущую дату");
СпособыЗаполнения.ДобавитьЗначение(2,"За произвольный период");
СпособыЗаполнения.ВыбратьЗначение(Способ,"Выберите способ заполнения",2,0,1);
       ...

ТаблТМЦ = СоздатьОбъект("ТаблицаЗначений");
ТаблТМЦ.НоваяКолонка("ТМЦ");
ТаблТМЦ.НоваяКолонка("Кво");

РН = СоздатьОбъект("Документ.РасходнаяНакладная");
Кальк = СоздатьОбъект("Документ.Калькуляция");
РН.ВыбратьДокументы(ДатаС,ДатаПо);
       Пока РН.ПолучитьДокумент()=1 Цикл
Если РН.Фирма <> Константа.БазФирма тогда
Продолжить;
       иначе
Место = РН.МестоХранения;
РН.ВыбратьСтроки();
             Пока РН.ПолучитьСтроку() = 1 Цикл
ТаблТМЦ.НоваяСтрока();
ТаблТМЦ.ТМЦ = РН.ТМЦ;
ТаблТМЦ.Кво = РН.Кво;
             КонецЦикла;
       КонецЕсли;
КонецЦикла;

ТаблТМЦ.Свернуть("ТМЦ","Кво");

ТаблТМЦ.ВыбратьСтроки();
Пока ТаблТМЦ.ПолучитьСтроку() = 1 цикл
       Кальк.Новый();
Кальк.Фирма = Константа.БазФирма;
Кальк.ВидКалькуляции = Перечисление.ВидыКалькуляций.Предварительная;
...
      
Кальк.Продукция = ТаблТМЦ.ТМЦ;      
Кальк.КвоПродукции = ТаблТМЦ.Кво;
            
Кальк.АвтоВремяНачалоДня();
Кальк.Записать();
       Заполнить();
             Кальк.Провести();
      
Сообщить("По продукции " + Кальк.Продукция + " сформирована калькуляция - " + Кальк.НомерДок + " от " + Кальк.ДатаДок);
КонецЦикла;

КонецПроцедуры
"

 
Saxarok
Пост №1
07.10.2010 22:24
 

"Добрый вечер.

Подскажите пожалуйста вот какой вопрос.
Есть Док.Калькуляция,который со списанием материалов в производство.
Для того,чтобы внести материалы по продукции,необходимо нажать на кнопку "Заполнить",
после чего происходит заполнение табличной части Док.Калькуляция.
Всё отлично!

Возникла задача автоматического формирования Док.Калькуляция за выбранный период на
основании введённых Расходных накладных.

Сделала в Журнале.Производство ЧУДО-кнопочку,по нажатию на которую(за выбранный период)
автоматически формируються Док.Калькуляция,и вроде все проводиться отлично
НННООО никак не получаеться в этом же режиме(речь идет об автоматическом формировании)
заполнить ТАБЛИЧНУЮ ЧАСТЬ.
Не пойму как правильно сделать процедуру Заполнить()

Подскажите кто-то понял из вышесказанного.

Вот часть кода:

// ===============================
Процедура Заполнить()
       ????????????Как же быть здесь???????????????
КонецПроцедуры

Процедура СформироватьКальк()
Перем Способ, ДатаС, ДатаПо;
СпособыЗаполнения = СоздатьОбъект("СписокЗначений");
СпособыЗаполнения.ДобавитьЗначение(1,"За текущую дату");
СпособыЗаполнения.ДобавитьЗначение(2,"За произвольный период");
СпособыЗаполнения.ВыбратьЗначение(Способ,"Выберите способ заполнения",2,0,1);
       ...

ТаблТМЦ = СоздатьОбъект("ТаблицаЗначений");
ТаблТМЦ.НоваяКолонка("ТМЦ");
ТаблТМЦ.НоваяКолонка("Кво");

РН = СоздатьОбъект("Документ.РасходнаяНакладная");
Кальк = СоздатьОбъект("Документ.Калькуляция");
РН.ВыбратьДокументы(ДатаС,ДатаПо);
       Пока РН.ПолучитьДокумент()=1 Цикл
Если РН.Фирма <> Константа.БазФирма тогда
Продолжить;
       иначе
Место = РН.МестоХранения;
РН.ВыбратьСтроки();
             Пока РН.ПолучитьСтроку() = 1 Цикл
ТаблТМЦ.НоваяСтрока();
ТаблТМЦ.ТМЦ = РН.ТМЦ;
ТаблТМЦ.Кво = РН.Кво;
             КонецЦикла;
       КонецЕсли;
КонецЦикла;

ТаблТМЦ.Свернуть("ТМЦ","Кво");

ТаблТМЦ.ВыбратьСтроки();
Пока ТаблТМЦ.ПолучитьСтроку() = 1 цикл
       Кальк.Новый();
Кальк.Фирма = Константа.БазФирма;
Кальк.ВидКалькуляции = Перечисление.ВидыКалькуляций.Предварительная;
...
      
Кальк.Продукция = ТаблТМЦ.ТМЦ;      
Кальк.КвоПродукции = ТаблТМЦ.Кво;
            
Кальк.АвтоВремяНачалоДня();
Кальк.Записать();
       Заполнить();
             Кальк.Провести();
      
Сообщить("По продукции " + Кальк.Продукция + " сформирована калькуляция - " + Кальк.НомерДок + " от " + Кальк.ДатаДок);
КонецЦикла;

КонецПроцедуры
"

 
zak555 (398843952)
Пост №2
" Кальк.Новый();Кальк.Фирма = Константа.БазФ...
07.10.2010 22:31
 
 
zak555 (398843952)
Пост №3
+ изучаем Заполнить метод для ТЗ
07.10.2010 22:31
 
 
Saxarok
Пост №4
ой,ой как-то я не поминаю.Ну есть такой метод,толь...
07.10.2010 22:58
 
 
zak555 (398843952)
Пост №5
пример применения метода : http://www.buh.ru/forum...
07.10.2010 23:03
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат переплаты возмещение пособия за счет ФСС восстановление НДС выездная налоговая проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зачет страховых взносов защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от НДС освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков перерасчет налогов переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебные издержки суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ формы документов хроники 54-ФЗ штрафные санкции ЭДО экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры