Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Удаление нулевых строк в таблице...1с Автосервис
Янушка
Пост №1
Янушка
читатель
офлайн
Дата регистрации: 01.09.2010
Сообщений: 11
Пост №1
 
13.10.2010 12:39

"Здравствуйте!!!
У меня возникла проблема, есть небольшой отчет, который выводит всего 5 столбиков:

№ /Цех-ФИО / Количество Н/ Ч с [ДатаНачала] / Сумма выработки с [ДатаНачала] / Заработная плата с [ДатаНачала]

Соответственно, документ делает вывод всех сотрудников, у которых и есть суммы, у которых сумм нет...

Как сделать так, чтобы сотрудники у которых ЗП = 0 не выводились вообще в отчете?

Я начинающий, но очень интересно..делается это запросом или нет?

Вот код Модуля:
//*****************************************
//*******************************************
Процедура Сформировать()
Перем ВидРемонта[2];
Если ДатаКонца>ПолучитьДатуТА() Тогда
Предупреждение("Получить отчет за датой актуальности итогов невозможно");
Возврат;
КонецЕсли;
ВидРемонта[1]=Перечисление.ВидыРемонта.Текущий;
ВидРемонта[2]=Перечисление.ВидыРемонта.ПоГарантии;
Цех=СоздатьОбъект("Справочник.Цеха");
Исп=СоздатьОбъект("Справочник.Исполнители");
Рег=СоздатьОбъект("Регистр.ОбъемРабот");
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ПовторятьПриПечатиСтроки(3,3);
Таб.ВывестиСекцию("Шапка");
Цех.ВыбратьЭлементы();
Ном=0;
Пока Цех.ПолучитьЭлемент()=1 Цикл
СумКолНЧ=0;
ЗП=0;
СумКолРуб=0;
ТекДата=ДатаНачала;
Пока Дата(ТекДата)<=ДатаКонца Цикл
ПроцНДС=Константа.ОсновнаяСтавкаНДС.Значение.Получить(ТекДата);
БезНДС=1-ПроцНДС/(100+ПроцНДС);
Рег.ИспользоватьПериод(ДатаГод(ТекДата),ДатаМесяц(ТекДата),ДатаЧисло(ТекДата));
КолНЧЗаДень=0;
КолРубЗаДень=0;
ЗП=0;
Для Н=1 По 2 Цикл
Рег.СводныеИтоги(ВидРемонта[Н],Цех.ТекущийЭлемент(),);
КолНЧ=Рег.ОбъемНал+Рег.ОбъемБезНал+Рег.ОбъемНеОплач;
КолНЧЗаДень=КолНЧЗаДень+КолНЧ;
СумКолНЧ=СумКолНЧ+КолНЧ;
КолРуб=Пересчет(КолНЧ,Константа.ОсновнаяВалютаУслуги,Рубли,ТекДата);
КолРуб=КолРуб*БезНДС;
КолРубЗаДень=КолРубЗаДень+КолРуб;
СумКолРуб=СумКолРуб+КолРуб;
ЗП=СумКолРуб*0.400;
КонецЦикла;
ТекДата=ТекДата+1;
КонецЦикла;
Таб.ВывестиСекцию("Цех");
Исп.ИспользоватьВладельца(Цех.ТекущийЭлемент());
Исп.ВыбратьЭлементы();
Пока Исп.ПолучитьЭлемент()=1 Цикл
Если Исп.ЭтоГруппа()=1 Тогда
Продолжить;
КонецЕсли;
Ном=Ном+1;
СумКолНЧ=0;
СумКолРуб=0;
ЗП=0;
ТекДата=ДатаНачала;
Пока Дата(ТекДата)<=ДатаКонца Цикл
ПроцНДС=Константа.ОсновнаяСтавкаНДС.Значение.Получить(ТекДата);
БезНДС=1-ПроцНДС/(100+ПроцНДС);
Рег.ИспользоватьПериод(ДатаГод(ТекДата),ДатаМесяц(ТекДата),ДатаЧисло(ТекДата));
КолНЧЗаДень=0;
КолРубЗаДень=0;
Для Н=1 По 2 Цикл
Рег.Итоги(ВидРемонта[Н],Цех.ТекущийЭлемент(),Исп.ТекущийЭлемент());
КолНЧ=Рег.ОбъемНал+Рег.ОбъемБезНал+Рег.ОбъемНеОплач;
КолНЧЗаДень=КолНЧЗаДень+КолНЧ;
СумКолНЧ=СумКолНЧ+КолНЧ;
КолРуб=Пересчет(КолНЧ,Константа.ОсновнаяВалютаУслуги,Рубли,ТекДата);
КолРуб=КолРуб*БезНДС;
КолРубЗаДень=КолРубЗаДень+КолРуб;
СумКолРуб=СумКолРуб+КолРуб;
ЗП=СумКолРуб*0.400;
КонецЦикла;
ТекДата=ТекДата+1;
КонецЦикла;

Таб.ВывестиСекцию("Строка");

КонецЦикла;
КонецЦикла;

Таб.Защита(Константа.ФлагЗащитыТаблиц);
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,3,0,Портрет);
Таб.ПараметрыСтраницы(1,,,Константа.ПолеСлева,Константа.ПолеСправа,Константа.ПолеСверху,Константа.ПолеСнизу,,,1);
Таб.Показать("Персональная выработка","""");
КонецПроцедуры
//--------------------------------------


ДатаКонца=ПолучитьДатуТА();
ДатаНачала=НачМесяца(ДатаКонца);
//*********************************************


Заранее всем спасибо))))"

 
Янушка
Пост №1
13.10.2010 12:39
 

"Здравствуйте!!!
У меня возникла проблема, есть небольшой отчет, который выводит всего 5 столбиков:

№ /Цех-ФИО / Количество Н/ Ч с [ДатаНачала] / Сумма выработки с [ДатаНачала] / Заработная плата с [ДатаНачала]

Соответственно, документ делает вывод всех сотрудников, у которых и есть суммы, у которых сумм нет...

Как сделать так, чтобы сотрудники у которых ЗП = 0 не выводились вообще в отчете?

Я начинающий, но очень интересно..делается это запросом или нет?

Вот код Модуля:
//*****************************************
//*******************************************
Процедура Сформировать()
Перем ВидРемонта[2];
Если ДатаКонца>ПолучитьДатуТА() Тогда
Предупреждение("Получить отчет за датой актуальности итогов невозможно");
Возврат;
КонецЕсли;
ВидРемонта[1]=Перечисление.ВидыРемонта.Текущий;
ВидРемонта[2]=Перечисление.ВидыРемонта.ПоГарантии;
Цех=СоздатьОбъект("Справочник.Цеха");
Исп=СоздатьОбъект("Справочник.Исполнители");
Рег=СоздатьОбъект("Регистр.ОбъемРабот");
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ПовторятьПриПечатиСтроки(3,3);
Таб.ВывестиСекцию("Шапка");
Цех.ВыбратьЭлементы();
Ном=0;
Пока Цех.ПолучитьЭлемент()=1 Цикл
СумКолНЧ=0;
ЗП=0;
СумКолРуб=0;
ТекДата=ДатаНачала;
Пока Дата(ТекДата)<=ДатаКонца Цикл
ПроцНДС=Константа.ОсновнаяСтавкаНДС.Значение.Получить(ТекДата);
БезНДС=1-ПроцНДС/(100+ПроцНДС);
Рег.ИспользоватьПериод(ДатаГод(ТекДата),ДатаМесяц(ТекДата),ДатаЧисло(ТекДата));
КолНЧЗаДень=0;
КолРубЗаДень=0;
ЗП=0;
Для Н=1 По 2 Цикл
Рег.СводныеИтоги(ВидРемонта[Н],Цех.ТекущийЭлемент(),);
КолНЧ=Рег.ОбъемНал+Рег.ОбъемБезНал+Рег.ОбъемНеОплач;
КолНЧЗаДень=КолНЧЗаДень+КолНЧ;
СумКолНЧ=СумКолНЧ+КолНЧ;
КолРуб=Пересчет(КолНЧ,Константа.ОсновнаяВалютаУслуги,Рубли,ТекДата);
КолРуб=КолРуб*БезНДС;
КолРубЗаДень=КолРубЗаДень+КолРуб;
СумКолРуб=СумКолРуб+КолРуб;
ЗП=СумКолРуб*0.400;
КонецЦикла;
ТекДата=ТекДата+1;
КонецЦикла;
Таб.ВывестиСекцию("Цех");
Исп.ИспользоватьВладельца(Цех.ТекущийЭлемент());
Исп.ВыбратьЭлементы();
Пока Исп.ПолучитьЭлемент()=1 Цикл
Если Исп.ЭтоГруппа()=1 Тогда
Продолжить;
КонецЕсли;
Ном=Ном+1;
СумКолНЧ=0;
СумКолРуб=0;
ЗП=0;
ТекДата=ДатаНачала;
Пока Дата(ТекДата)<=ДатаКонца Цикл
ПроцНДС=Константа.ОсновнаяСтавкаНДС.Значение.Получить(ТекДата);
БезНДС=1-ПроцНДС/(100+ПроцНДС);
Рег.ИспользоватьПериод(ДатаГод(ТекДата),ДатаМесяц(ТекДата),ДатаЧисло(ТекДата));
КолНЧЗаДень=0;
КолРубЗаДень=0;
Для Н=1 По 2 Цикл
Рег.Итоги(ВидРемонта[Н],Цех.ТекущийЭлемент(),Исп.ТекущийЭлемент());
КолНЧ=Рег.ОбъемНал+Рег.ОбъемБезНал+Рег.ОбъемНеОплач;
КолНЧЗаДень=КолНЧЗаДень+КолНЧ;
СумКолНЧ=СумКолНЧ+КолНЧ;
КолРуб=Пересчет(КолНЧ,Константа.ОсновнаяВалютаУслуги,Рубли,ТекДата);
КолРуб=КолРуб*БезНДС;
КолРубЗаДень=КолРубЗаДень+КолРуб;
СумКолРуб=СумКолРуб+КолРуб;
ЗП=СумКолРуб*0.400;
КонецЦикла;
ТекДата=ТекДата+1;
КонецЦикла;

Таб.ВывестиСекцию("Строка");

КонецЦикла;
КонецЦикла;

Таб.Защита(Константа.ФлагЗащитыТаблиц);
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,3,0,Портрет);
Таб.ПараметрыСтраницы(1,,,Константа.ПолеСлева,Константа.ПолеСправа,Константа.ПолеСверху,Константа.ПолеСнизу,,,1);
Таб.Показать("Персональная выработка","""");
КонецПроцедуры
//--------------------------------------


ДатаКонца=ПолучитьДатуТА();
ДатаНачала=НачМесяца(ДатаКонца);
//*********************************************


Заранее всем спасибо))))"

 
ValeraH
Пост №2
"Никак Рарусовская конфигурация?Ну, окружи Таб.Выв...
13.10.2010 15:34
 
 
Янушка
Пост №3
Канечна РаРусовская....в 7.7 условие не прокатит, ...
13.10.2010 16:40
 
 
IceBeerg
Пост №4
"> в 7.7 условие не прокатитЧЕГО О_О !?!Если ЗП0 Т...
13.10.2010 17:02
 
 
ValeraH
Пост №5
Я не понял, у тебя отчет? Так с помощью условного ...
13.10.2010 17:03
 
 
Янушка
Пост №6
Простите))) очень даже всё получилось...спасибо)))...
14.10.2010 14:21
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры