Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Предприятие 7.7] РСВ-1 в Комплексной
Thorvardr
Пост №1
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3075
Пост №1
 
07.02.2011 21:42

"Комплект форм отчетности: Rp10q401
Релиз конфигурации: Комплексная 7.70.504
Задача уже неактуальна, но, возможно, баги останутся на следующий комплект, кто нибудь сумеет победить проблему, а может и представители 1С тему заметят, исправят.

Сегодня ходил делать обновление с 501 на 504. Между делом клиент пожаловался о том, что РСВ-1 заполняли вручную для одного из 16 юрлиц, учет которых ведется в базе, так как автозаполнение некорректно работает.
Особенности юрлица:
Страховой тариф = Организации, использующие ЕНВД (то есть, чистый ЕНВД, без распределений)
Наличие инвалидов = да

Стал смотреть алгоритм, обнаружились странные дела. Алгоритм задумывался как отличный, сделана попытка выяснения того является ли наш страховой тариф УСН/ЕНВД и является ли он единственным и если это так, то все данные, кроме инвалидов пытаемся включить в Раздел 1-2. Так и должно быть, судя по всему, так все клиенты хотели с самого начала.
В rcv102.ert
Исправление 1:
Строка 3527:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
КонецЕсли;

так... а где про "BUOUSL" (про комплексную)? Надо так:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
ИначеЕсли ИдентКонфигурации = "BUOUSL" Тогда
ПрименяетсяТолькоЕНВД = ?(ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
КонецЕсли;

Исправление 2:
Сразу следующий блок.
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") Тогда
ПониженныеСтавкиРавныОсновным = ПроверкаРавенстваОсновнойИПониженнойСтавок();
иначе      
ПониженныеСтавкиРавныОсновным = 0;
КонецЕсли;

тоже про "BUOUSL" забыли.
меняем на
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") ИЛИ (ИдентКонфигурации = "BUOUSL") Тогда

Исправление 3:
смотрим в ПроверкаРавенстваОсновнойИПониженнойСтавок(), это примерно строка 3268, видим что там про комплексную не забыли, но! Тут видим строчку:
ТаблицаОсновныхТарифов = ПолучитьТаблицуОсновныхТарифов();
смотрим в ПолучитьТаблицуОсновныхТарифов(), а там то про комплексную как раз забыли. Делаем там замену строки:
ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
на
Если ИдентКонфигурации = "BUOUSL" Тогда
ТаблицаОсновныхТарифов.ВидТарифа = ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
Иначе
ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
КонецЕсли;

комментарий по исправлениям 2 и 3:
пользователь сказал, что это неправильный ход и проверять ПониженныеСтавкиРавныОсновным вообще не надо, но что то я ей не поверил

Исправление 4:
смотрим примерно в строку 4104. Тут вообще забыли, что в комплексной есть разделитель учета. В результате по всем юрлицам идет запрос без фильтра к общим бухитогам и получается "куча". Нужно чтобы было так:
БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
Если ИдентКонфигурации = "BUOUSL" Тогда
БухИт.ИспользоватьРазделительУчета(ВыбраннаяФирма); //тут все верно, т.к. ВыбраннаяФирма.Вид()="СвоиЮрлица"
КонецЕсли;

Теперь смотрим в В rcv103.ert:
Исправление 5:
Строка 1732. Исправляем все так же как в исправлениях 1,2 и 3.

Исправление 6:
Смотрим внимательно на текст чуть ниже строки 1732:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU...
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтр...
КонецЕсли;
...
ПрименяетсяТолькоЕНВД = 0; //!!!??? - зачем тут эта строка? Выходит, что что бы ни было вычислено чуть выше, все равно принудительно ставится, что у нас ПрименяетсяТолькоЕНВД = 0. Как будто это тест был какой то и строку убрать забыли. Убираем ее.

Вот после этих исправлений отчет заполнился как положено."

 
Thorvardr
Пост №1
07.02.2011 21:42
 

"Комплект форм отчетности: Rp10q401
Релиз конфигурации: Комплексная 7.70.504
Задача уже неактуальна, но, возможно, баги останутся на следующий комплект, кто нибудь сумеет победить проблему, а может и представители 1С тему заметят, исправят.

Сегодня ходил делать обновление с 501 на 504. Между делом клиент пожаловался о том, что РСВ-1 заполняли вручную для одного из 16 юрлиц, учет которых ведется в базе, так как автозаполнение некорректно работает.
Особенности юрлица:
Страховой тариф = Организации, использующие ЕНВД (то есть, чистый ЕНВД, без распределений)
Наличие инвалидов = да

Стал смотреть алгоритм, обнаружились странные дела. Алгоритм задумывался как отличный, сделана попытка выяснения того является ли наш страховой тариф УСН/ЕНВД и является ли он единственным и если это так, то все данные, кроме инвалидов пытаемся включить в Раздел 1-2. Так и должно быть, судя по всему, так все клиенты хотели с самого начала.
В rcv102.ert
Исправление 1:
Строка 3527:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
КонецЕсли;

так... а где про "BUOUSL" (про комплексную)? Надо так:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
ИначеЕсли ИдентКонфигурации = "BUOUSL" Тогда
ПрименяетсяТолькоЕНВД = ?(ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);
КонецЕсли;

Исправление 2:
Сразу следующий блок.
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") Тогда
ПониженныеСтавкиРавныОсновным = ПроверкаРавенстваОсновнойИПониженнойСтавок();
иначе      
ПониженныеСтавкиРавныОсновным = 0;
КонецЕсли;

тоже про "BUOUSL" забыли.
меняем на
Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") ИЛИ (ИдентКонфигурации = "BUOUSL") Тогда

Исправление 3:
смотрим в ПроверкаРавенстваОсновнойИПониженнойСтавок(), это примерно строка 3268, видим что там про комплексную не забыли, но! Тут видим строчку:
ТаблицаОсновныхТарифов = ПолучитьТаблицуОсновныхТарифов();
смотрим в ПолучитьТаблицуОсновныхТарифов(), а там то про комплексную как раз забыли. Делаем там замену строки:
ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
на
Если ИдентКонфигурации = "BUOUSL" Тогда
ТаблицаОсновныхТарифов.ВидТарифа = ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
Иначе
ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));
КонецЕсли;

комментарий по исправлениям 2 и 3:
пользователь сказал, что это неправильный ход и проверять ПониженныеСтавкиРавныОсновным вообще не надо, но что то я ей не поверил

Исправление 4:
смотрим примерно в строку 4104. Тут вообще забыли, что в комплексной есть разделитель учета. В результате по всем юрлицам идет запрос без фильтра к общим бухитогам и получается "куча". Нужно чтобы было так:
БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
Если ИдентКонфигурации = "BUOUSL" Тогда
БухИт.ИспользоватьРазделительУчета(ВыбраннаяФирма); //тут все верно, т.к. ВыбраннаяФирма.Вид()="СвоиЮрлица"
КонецЕсли;

Теперь смотрим в В rcv103.ert:
Исправление 5:
Строка 1732. Исправляем все так же как в исправлениях 1,2 и 3.

Исправление 6:
Смотрим внимательно на текст чуть ниже строки 1732:
ПрименяетсяТолькоЕНВД = 0;
Если (ИдентКонфигурации = "BU...
ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтр...
КонецЕсли;
...
ПрименяетсяТолькоЕНВД = 0; //!!!??? - зачем тут эта строка? Выходит, что что бы ни было вычислено чуть выше, все равно принудительно ставится, что у нас ПрименяетсяТолькоЕНВД = 0. Как будто это тест был какой то и строку убрать забыли. Убираем ее.

Вот после этих исправлений отчет заполнился как положено."

 
zak555 (398843952)
Пост №2
ты в 1с на удалёнку от ста тыщ иди
07.02.2011 22:18
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С видео-уроки 1С водный налог возврат переплаты возмещение пособия за счет ФСС восстановление НДС выездная налоговая проверка выплата зарплаты выплаты иностранному работнику выплаты по ГПД выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственный реестр гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по налогу на прибыль декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ежемесячная отчетность ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зачет страховых взносов защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новости нормы естественной убыли нулевая декларация обзор обзор бухгалтерских событий обзор новостей обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ онлайн-сервис освобождение от налогообложения освобождение от ндс освобождение от НДС освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы перенос убытков перерасчет налогов переход на усн персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверка ИНН/КПП продажа алкогольной продукции производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реконструкция основных средств ремонт основных средств реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебные издержки суточные счет-фактура таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет расходов при УСН учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ формы документов хроники 54-ФЗ штрафные санкции ЭДО экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры