Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Внешняя печатная форма
Лянка
Пост №1
Лянка
читатель
офлайн
Дата регистрации: 05.08.2010
Сообщений: 124
Пост №1
 
24.03.2011 11:22

"Добрый день! Создаю внешнюю печатную форму Заявка на расходование средств.
Проверяю модуль на синтаксические ошибки говорит что нет ошибок

Функция ПечатьЗаявка() Экспорт


СсылкаНаОбъект.РасчетыСКонтрагентами = СсылкаНаОбъект.ВидОперации;
СсылкаНаОбъект.РасчетыСПодотчетником = СсылкаНаОбъект.ВидОперации;

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаявкаНаРасходованиеСредств";

Макет = ПолучитьМакет("Заявка");
Обл = Макет.ПолучитьОбласть("Шапка");
Обл.Параметры.ЗаголовокЗаявки=""""+ЭтотОбъект+СсылкаНаОбъект.Символы.ПС+СсылкаНаОбъект.ВидОперации;

Обл.Параметры.Заполнить(СсылкаНаОбъект);
ТабДокумент.Вывести(Обл);


Если СсылкаНаОбъект.РасчетыСПодотчетником тогда
ОбластьСтрока = Макет.ПолучитьОбласть("ТаблицаПодотчетник");
ОбластьСтрока.Параметры.ДолгПодотчетника =СсылкаНаОбъект.Ссылка;
Иначе
ОбластьСтрока = Макет.ПолучитьОбласть("ТаблицаКонтрагент");
КонецЕсли;
ОбластьСтрока.Параметры.Заполнить(ЭтотОбъект);




ТабДокумент.Вывести(ОбластьСтрока);


Обл = Макет.ПолучитьОбласть("Подвал");
Обл.Параметры.Заполнить(СсылкаНаОбъект);
Обл.Параметры.РуководительЦФО = СсылкаНаОбъект.РуководительЦФО;

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ОтветственныеЛицаОрганизацииСрезПоследних.ОтветственноеЛицо,
| ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо
|ИЗ
| РегистрСведений.ОтветственныеЛицаОрганизации.СрезПоследних(&Дата, СтруктурнаяЕдиница = &Организация) КАК ОтветственныеЛицаОрганизацииСрезПоследних";
Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Организация",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий()Цикл
Если Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.ГлавныйБухгалтер Тогда
Обл.Параметры.ГлБухгалтер = СсылкаНаОбъект.Выборка.ФизическоеЛицо;
ИначеЕсли Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.БюджетныйКонтролер Тогда
Обл.Параметры.БюджетныйКонтролер = СсылкаНаОбъект.Выборка.ФизическоеЛицо;
ИначеЕсли Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.ФинДиректор Тогда
Обл.Параметры.ФинДиректор =СсылкаНаОбъект.Выборка.ФизическоеЛицо;
КонецЕсли;
КонецЦикла;


ТабДокумент.Вывести(Обл);

Возврат ТабДокумент;
КонецФункции


но когда тестирую выдает ошибку

Ошибка при вызове метода контекста (ПолучитьФорму): Недопустимое значение параметра (параметр номер '1')
Что я не так делаю?"

 
Лянка
Пост №1
24.03.2011 11:22
 

"Добрый день! Создаю внешнюю печатную форму Заявка на расходование средств.
Проверяю модуль на синтаксические ошибки говорит что нет ошибок

Функция ПечатьЗаявка() Экспорт


СсылкаНаОбъект.РасчетыСКонтрагентами = СсылкаНаОбъект.ВидОперации;
СсылкаНаОбъект.РасчетыСПодотчетником = СсылкаНаОбъект.ВидОперации;

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаявкаНаРасходованиеСредств";

Макет = ПолучитьМакет("Заявка");
Обл = Макет.ПолучитьОбласть("Шапка");
Обл.Параметры.ЗаголовокЗаявки=""""+ЭтотОбъект+СсылкаНаОбъект.Символы.ПС+СсылкаНаОбъект.ВидОперации;

Обл.Параметры.Заполнить(СсылкаНаОбъект);
ТабДокумент.Вывести(Обл);


Если СсылкаНаОбъект.РасчетыСПодотчетником тогда
ОбластьСтрока = Макет.ПолучитьОбласть("ТаблицаПодотчетник");
ОбластьСтрока.Параметры.ДолгПодотчетника =СсылкаНаОбъект.Ссылка;
Иначе
ОбластьСтрока = Макет.ПолучитьОбласть("ТаблицаКонтрагент");
КонецЕсли;
ОбластьСтрока.Параметры.Заполнить(ЭтотОбъект);




ТабДокумент.Вывести(ОбластьСтрока);


Обл = Макет.ПолучитьОбласть("Подвал");
Обл.Параметры.Заполнить(СсылкаНаОбъект);
Обл.Параметры.РуководительЦФО = СсылкаНаОбъект.РуководительЦФО;

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ОтветственныеЛицаОрганизацииСрезПоследних.ОтветственноеЛицо,
| ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо
|ИЗ
| РегистрСведений.ОтветственныеЛицаОрганизации.СрезПоследних(&Дата, СтруктурнаяЕдиница = &Организация) КАК ОтветственныеЛицаОрганизацииСрезПоследних";
Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Организация",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий()Цикл
Если Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.ГлавныйБухгалтер Тогда
Обл.Параметры.ГлБухгалтер = СсылкаНаОбъект.Выборка.ФизическоеЛицо;
ИначеЕсли Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.БюджетныйКонтролер Тогда
Обл.Параметры.БюджетныйКонтролер = СсылкаНаОбъект.Выборка.ФизическоеЛицо;
ИначеЕсли Выборка.ОтветственноеЛицо = СсылкаНаОбъект.ОтветственныеЛицаОрганизации.ФинДиректор Тогда
Обл.Параметры.ФинДиректор =СсылкаНаОбъект.Выборка.ФизическоеЛицо;
КонецЕсли;
КонецЦикла;


ТабДокумент.Вывести(Обл);

Возврат ТабДокумент;
КонецФункции


но когда тестирую выдает ошибку

Ошибка при вызове метода контекста (ПолучитьФорму): Недопустимое значение параметра (параметр номер '1')
Что я не так делаю?"

 
BelikovS
Пост №2
А Функция Печать () все-таки присутствует?
24.03.2011 12:06
 
 
Лянка
Пост №3
"Да!Функция Печать() Экспорт ТабДокумент = ПечатьЗ...
24.03.2011 12:10
 
 
Thorvardr
Пост №4
"А я так делал, в этом случае оно вписывается в за...
24.03.2011 12:19
 
 
BelikovS
Пост №5
А что подразумевалось под> но когда тестируюВы под...
24.03.2011 12:22
 
 
Лянка
Пост №6
но у меня не типовая :( У меня УПП проф 1.2. (.1.2...
24.03.2011 12:23
 
 
Лянка
Пост №7
> А что подразумевалось под> > но когда тестирую> ...
24.03.2011 12:24
 
 
BelikovS
Пост №8
Приведите полный текст ошибки - там еще должна быт...
24.03.2011 12:27
 
 
BelikovS
Пост №9
Ничего себе не типовая :)С изменениями наверно, но...
24.03.2011 12:28
 
 
Лянка
Пост №10
> Приведите полный текст ошибки - там еще должна б...
24.03.2011 13:37
 
 
ВРедная
Пост №11
"даже когда дойдет до кода, это не должно работать...
24.03.2011 21:26
 
 
Лянка
Пост №12
Спасибо!!
28.03.2011 11:25
 
 
Лянка
Пост №13
Вредная понимаешь я не программист. Интересно ста...
28.03.2011 11:29
 
 
ВРедная
Пост №14
Спасибо то, конечно, хорошо, но что получилось то?...
28.03.2011 14:30
 
 
Лянка
Пост №15
Пытаюсь написать модуль сама ,а не из образца (Обр...
28.03.2011 15:27
 
 
ВРедная
Пост №16
Да, так лучше. По крайней мере разберетесь, что та...
28.03.2011 15:41
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры