Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Зарплата и управление персоналом 8] Формирование отчета по времени
Piratik
Пост №1
Piratik
читатель
офлайн
Дата регистрации: 22.09.2009
Сообщений: 76
Пост №1
 
29.12.2011 11:00

"Доброе время суток. У меня следующая проблема, разработали отчет по отработанному времени рабочих. Если допустим задать период с 01.01.2011 по 31.12.2011 и человек принят на предприятие 01.03.2011 то при формировании отчеты отработанные часы проставляются начиная с января месяца т.е как бы сдвигаются. Проверил запрос в консуле все нормально, отработанное время начинается с 01.03.2011. Как я понимаю ошибка допущена на стадии формирования таблицы.

http://imageshack.us/photo/my-images/694/566jh.jpg/

Ячейки
на скриншоте помеченные желтым должны быть пустые, так как человек не работал в эти месяца.

Кусок кода отвечающего за формирование:



 Запрос.Текст = "ВЫБРАТЬ
| СУММА(РабочееВремяРаботниковОрганизацийОбороты.ЧасовОборот) КАК явка,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо КАК Сотрудник,
| РабочееВремяРаботниковОрганизацийОбороты.Период КАК Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации КАК ПодразделениеОрганизации
|ИЗ
| РегистрНакопления.РабочееВремяРаботниковОрганизаций.Обороты(&НачПериод, &КонПериод, Месяц, (НЕ ВидИспользованияРабочегоВремени В (&СписокЗначенийВидВремени))) КАК РабочееВремяРаботниковОрганизацийОбороты
|
|СГРУППИРОВАТЬ ПО
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо,
| РабочееВремяРаботниковОрганизацийОбороты.Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации
|
|УПОРЯДОЧИТЬ ПО
| Период
|ИТОГИ
| СУММА(явка)
|ПО
| ПодразделениеОрганизации,
| Сотрудник,
| Период";

СписокЗначенийВидВремени = Новый СписокЗначений;
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасыАдминистраторов);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.Командировка);
Запрос.УстановитьПараметр("СписокЗначенийВидВремени",СписокЗначенийВидВремени);

Результат = Запрос.Выполнить();

НомерПП = 1;
ИтогЯвка = 0;
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаПодразделение = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПодразделениеОрганизации");
Пока ВыборкаПодразделение.Следующий() Цикл
       ОбластьСтрокаПодразделение = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСотрудник");
       ОбластьСтрокаПодразделение.Параметры.Заполнить(ВыборкаПодразделение);
       ТабДок.Вывести(ОбластьСтрокаПодразделение,ВыборкаПодразделение.Уровень());
       Для н=0 по КолвоМесяцев Цикл
            ОбластьСтрока = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСтроки");
            ТабДок.Присоединить(ОбластьСтрока);
       КонецЦикла;
      
       Выборка = ВыборкаПодразделение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Сотрудник");
       Пока Выборка.Следующий() Цикл
            ОбластьСтрокаСотрудник = Макет.ПолучитьОбласть("Строка|КолонкаСотрудник");
            ОбластьСтрокаСотрудник.Параметры.Заполнить(Выборка);
            ОбластьСтрокаСотрудник.Параметры.НомерПП = НомерПП;
            ТабДок.Вывести(ОбластьСтрокаСотрудник,Выборка.Уровень());
            
            ЧасовНакопительно = 0;
            ВыборкаПоПериодам = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
            Для н=0 по КолвоМесяцев Цикл
             Если ВыборкаПоПериодам.Следующий() Тогда
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ЧасовНакопительно = ЧасовНакопительно + ВыборкаПоПериодам.явка;
                   ОбластьСтрока.Параметры.Заполнить(ВыборкаПоПериодам);
                   ОбластьСтрока.Параметры.явкаНакоп = ЧасовНакопительно;
                   ТабДок.Присоединить(ОбластьСтрока);            
             Иначе
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ТабДок.Присоединить(ОбластьСтрока);
             КонецЕсли;
            КонецЦикла;
            
            ИтогЯвка = ИтогЯвка + Выборка.явка;
            НомерПП = НомерПП + 1;
       КонецЦикла;
      
КонецЦикла;




Помогите пожалуйста с решением проблемы. Заранее благодарен."

 
Piratik
Пост №1
29.12.2011 11:00
 

"Доброе время суток. У меня следующая проблема, разработали отчет по отработанному времени рабочих. Если допустим задать период с 01.01.2011 по 31.12.2011 и человек принят на предприятие 01.03.2011 то при формировании отчеты отработанные часы проставляются начиная с января месяца т.е как бы сдвигаются. Проверил запрос в консуле все нормально, отработанное время начинается с 01.03.2011. Как я понимаю ошибка допущена на стадии формирования таблицы.

http://imageshack.us/photo/my-images/694/566jh.jpg/

Ячейки на скриншоте помеченные желтым должны быть пустые, так как человек не работал в эти месяца.

Кусок кода отвечающего за формирование:



 Запрос.Текст = "ВЫБРАТЬ
| СУММА(РабочееВремяРаботниковОрганизацийОбороты.ЧасовОборот) КАК явка,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо КАК Сотрудник,
| РабочееВремяРаботниковОрганизацийОбороты.Период КАК Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации КАК ПодразделениеОрганизации
|ИЗ
| РегистрНакопления.РабочееВремяРаботниковОрганизаций.Обороты(&НачПериод, &КонПериод, Месяц, (НЕ ВидИспользованияРабочегоВремени В (&СписокЗначенийВидВремени))) КАК РабочееВремяРаботниковОрганизацийОбороты
|
|СГРУППИРОВАТЬ ПО
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо,
| РабочееВремяРаботниковОрганизацийОбороты.Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации
|
|УПОРЯДОЧИТЬ ПО
| Период
|ИТОГИ
| СУММА(явка)
|ПО
| ПодразделениеОрганизации,
| Сотрудник,
| Период";

СписокЗначенийВидВремени = Новый СписокЗначений;
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасыАдминистраторов);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.Командировка);
Запрос.УстановитьПараметр("СписокЗначенийВидВремени",СписокЗначенийВидВремени);

Результат = Запрос.Выполнить();

НомерПП = 1;
ИтогЯвка = 0;
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаПодразделение = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПодразделениеОрганизации");
Пока ВыборкаПодразделение.Следующий() Цикл
       ОбластьСтрокаПодразделение = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСотрудник");
       ОбластьСтрокаПодразделение.Параметры.Заполнить(ВыборкаПодразделение);
       ТабДок.Вывести(ОбластьСтрокаПодразделение,ВыборкаПодразделение.Уровень());
       Для н=0 по КолвоМесяцев Цикл
            ОбластьСтрока = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСтроки");
            ТабДок.Присоединить(ОбластьСтрока);
       КонецЦикла;
      
       Выборка = ВыборкаПодразделение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Сотрудник");
       Пока Выборка.Следующий() Цикл
            ОбластьСтрокаСотрудник = Макет.ПолучитьОбласть("Строка|КолонкаСотрудник");
            ОбластьСтрокаСотрудник.Параметры.Заполнить(Выборка);
            ОбластьСтрокаСотрудник.Параметры.НомерПП = НомерПП;
            ТабДок.Вывести(ОбластьСтрокаСотрудник,Выборка.Уровень());
            
            ЧасовНакопительно = 0;
            ВыборкаПоПериодам = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
            Для н=0 по КолвоМесяцев Цикл
             Если ВыборкаПоПериодам.Следующий() Тогда
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ЧасовНакопительно = ЧасовНакопительно + ВыборкаПоПериодам.явка;
                   ОбластьСтрока.Параметры.Заполнить(ВыборкаПоПериодам);
                   ОбластьСтрока.Параметры.явкаНакоп = ЧасовНакопительно;
                   ТабДок.Присоединить(ОбластьСтрока);            
             Иначе
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ТабДок.Присоединить(ОбластьСтрока);
             КонецЕсли;
            КонецЦикла;
            
            ИтогЯвка = ИтогЯвка + Выборка.явка;
            НомерПП = НомерПП + 1;
       КонецЦикла;
      
КонецЦикла;




Помогите пожалуйста с решением проблемы. Заранее благодарен."

 
Денис (САМАРА)
Пост №2
Что-то не видно в коде условия на дату принятия со...
29.12.2011 13:27
 
 
Алавир
Пост №3
Ощущение, что даты у этих проблемных просто сдвину...
29.12.2011 21:05
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры