Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Другие решения на платформе "1С:Предприятие 8"] Заполнить реквизит справочника из другого справочника
EL Khan
Пост №1
EL Khan
читатель
офлайн
Дата регистрации: 10.02.2012
Сообщений: 92
Пост №1
 
12.09.2012 15:25

"

Процедура КнопкаВыполнитьНажатие(Кнопка)    Запрос = Новый Запрос;        Запрос.Текст =        "ВЫБРАТЬ     |    ИК.Ссылка     |ИЗ     |    Справочник.ИнформационныеКарты КАК ИК     |ГДЕ     |    ИК.Ссылка " +?(ВГруппеИлиРавно="равно","=&Ссылка", "В ИЕРАРХИИ (&Ссылка)");          Запрос.УстановитьПараметр("Ссылка",Контрагент);          Результат = Запрос.Выполнить().Выбрать();         Пока Результат.Следующий() ЦИКЛ                ИК = Результат.Ссылка.ПолучитьОбъект();        Сообщить(ИК);    Если ИК.ЭтоГруппа Тогда        Продолжить;    КонецЕсли;    НужныйОбъект = Справочники.Контрагенты.ПолучитьСсылку();    Если НужныйОбъект.Код          = ИК.Код И         НужныйОбъект.Наименование = ИК.Наименование    Тогда    Выборка = ИК.ВладелецКарты.Выбрать();    Пока Выборка.Следующий() Цикл    Объект = Выборка.ПолучитьОбъект();    Объект.ВладелецКарты = НужныйОбъект.Ссылка;    Попытка        Объект.Записать();    Исключение        Предупреждение("Не удалось записать объект """"" + Объект + """""                       |" + ОписаниеОшибки(),60);    КонецПопытки;    КонецЦикла;            КонецЕсли;    КонецЦикла;КонецПроцедуры



подправьте пожалуйста. проблема в

НужныйОбъект = Справочники.Контрагенты.ПолучитьСсылку();    Если НужныйОбъект.Код          = ИК.Код И         НужныйОбъект.Наименование = ИК.Наименование    Тогда    Выборка = ИК.ВладелецКарты.Выбрать();    Пока Выборка.Следующий() Цикл    Объект = Выборка.ПолучитьОбъект();    Объект.ВладелецКарты = НужныйОбъект.Ссылка;    Попытка        Объект.Записать();



как написать правильней?"

 
EL Khan
Пост №1
12.09.2012 15:25
 

"

Процедура КнопкаВыполнитьНажатие(Кнопка)    Запрос = Новый Запрос;        Запрос.Текст =        "ВЫБРАТЬ     |    ИК.Ссылка     |ИЗ     |    Справочник.ИнформационныеКарты КАК ИК     |ГДЕ     |    ИК.Ссылка " +?(ВГруппеИлиРавно="равно","=&Ссылка", "В ИЕРАРХИИ (&Ссылка)");          Запрос.УстановитьПараметр("Ссылка",Контрагент);          Результат = Запрос.Выполнить().Выбрать();         Пока Результат.Следующий() ЦИКЛ                ИК = Результат.Ссылка.ПолучитьОбъект();        Сообщить(ИК);    Если ИК.ЭтоГруппа Тогда        Продолжить;    КонецЕсли;    НужныйОбъект = Справочники.Контрагенты.ПолучитьСсылку();    Если НужныйОбъект.Код          = ИК.Код И         НужныйОбъект.Наименование = ИК.Наименование    Тогда    Выборка = ИК.ВладелецКарты.Выбрать();    Пока Выборка.Следующий() Цикл    Объект = Выборка.ПолучитьОбъект();    Объект.ВладелецКарты = НужныйОбъект.Ссылка;    Попытка        Объект.Записать();    Исключение        Предупреждение("Не удалось записать объект """"" + Объект + """""                       |" + ОписаниеОшибки(),60);    КонецПопытки;    КонецЦикла;            КонецЕсли;    КонецЦикла;КонецПроцедуры



подправьте пожалуйста. проблема в

НужныйОбъект = Справочники.Контрагенты.ПолучитьСсылку();    Если НужныйОбъект.Код          = ИК.Код И         НужныйОбъект.Наименование = ИК.Наименование    Тогда    Выборка = ИК.ВладелецКарты.Выбрать();    Пока Выборка.Следующий() Цикл    Объект = Выборка.ПолучитьОбъект();    Объект.ВладелецКарты = НужныйОбъект.Ссылка;    Попытка        Объект.Записать();



как написать правильней?"

 
EL Khan
Пост №2
Хочу заполнить реквизит "ВладелецКарты" справочник...
12.09.2012 15:27
 
 
Денис (САМАРА)
Пост №3
Ты в запросе ставишь условие на ссылку ИК, а в пар...
13.09.2012 08:56
 
 
EL Khan
Пост №4
Контрагент это поле ввода Справочник.Информационны...
13.09.2012 10:50
 
 
Денис (САМАРА)
Пост №5
А это что вообще делается?
13.09.2012 10:56
 
 
EL Khan
Пост №6
Есть справочник ИнформационныеКарты и Контрагенты....
13.09.2012 11:04
 
 
Денис (САМАРА)
Пост №7
А сейчас реквизит "ВладелецКарты" никак не заполне...
13.09.2012 12:08
 
 
EL Khan
Пост №8
да, через обработку. я групповой обработкой заполн...
13.09.2012 12:23
 
 
Денис (САМАРА)
Пост №9
> я групповой обработкой заполнил во всех элемента...
13.09.2012 13:03
 
 
EL Khan
Пост №10
это ответ на вопрос:>А сейчас реквизит "ВладелецКа...
13.09.2012 13:23
 
 
Денис (САМАРА)
Пост №11
"НачатьТранзакцию();Запрос = Новый Запрос;Запрос.Т...
13.09.2012 15:22
 
 
Prikum
Пост №12
"Не замучается жать кнопку "Да"? ;) Или это для то...
13.09.2012 15:59
 
 
EL Khan
Пост №13
Даже не знаю как отблагодарить, большое Вам спасиб...
13.09.2012 16:00
 
 
Денис (САМАРА)
Пост №14
Я вроде бы "Вопрос" не в цикле поставил...
13.09.2012 16:07
 
 
Денис (САМАРА)
Пост №15
> Даже не знаю как отблагодарить Литр Jack Daniel`...
13.09.2012 16:08
 
 
Prikum
Пост №16
А... , точно, я не досмотрел!
13.09.2012 16:13
 
 
Денис (САМАРА)
Пост №17
Я же запускаю код на исполнение, а не тупо набиваю...
13.09.2012 16:36
 
 
EL Khan
Пост №18
Приеду в Россию, отметим)
13.09.2012 16:55
 
 
Тэра
Пост №19
Э-э...Откуда?
13.09.2012 16:56
 
 
EL Khan
Пост №20
из Азербайджана
13.09.2012 16:58
 
 
Денис (САМАРА)
Пост №21
Тогда вези чего-нибудь национального. :) P.S. А я ...
13.09.2012 17:10
 
 
Prikum
Пост №22
Тогда скорее зададут из Вьетнама или Германии!
13.09.2012 17:12
 
 
Тэра
Пост №23
вы в Азербайджане работаете на российской 1с-ке?
13.09.2012 17:14
 
 
Prikum
Пост №24
А что в торговле могут быть какие то трудности?
13.09.2012 17:18
 
 
EL Khan
Пост №25
дай бог)
13.09.2012 17:20
 
 
EL Khan
Пост №26
почему бы и нет, очень подходит
13.09.2012 17:21
 
 
Тэра
Пост №27
т.е. у вас не адаптированная под ваше законодатель...
13.09.2012 17:23
 
 
EL Khan
Пост №28
адаптированная. настраивал не я конечно же)) а ква...
13.09.2012 17:26
 
 
Тэра
Пост №29
Наверно, я не очень точно формулирую вопрос. Я пыт...
13.09.2012 17:29
 
 
EL Khan
Пост №30
конечно можно, и не только УТ, но и УПП, БП и т.д....
14.09.2012 08:28
 
 
Тэра
Пост №31
>только в проводках несоответствие, что устраняют ...
14.09.2012 08:36
 
 
EL Khan
Пост №32
обходиться можно, если это не так важно. допустим ...
14.09.2012 08:42
 
 
Тэра
Пост №33
Знаете, в случае УТ я ещё могу это представить. Но...
14.09.2012 08:47
 
 
EL Khan
Пост №34
почему? какие несоответствия представляете?
14.09.2012 08:51
 
 
Тэра
Пост №35
Ну это же бухгалтерский и налоговый учет,отчетност...
14.09.2012 08:59
 
 
Денис (САМАРА)
Пост №36
Тань, ты же вроде бы освоила "правовые системы". П...
14.09.2012 09:00
 
 
Тэра
Пост №37
Денис, мне делать больше нечего, что ли? При налич...
14.09.2012 09:06
 
 
Денис (САМАРА)
Пост №38
А чего до Эль Хана докопалась? :) Ему бы с запроса...
14.09.2012 09:10
 
 
EL Khan
Пост №39
1С у нас используют в основном как управленческий ...
14.09.2012 09:12
 
 
Тэра
Пост №40
Ладно, спасибо за информацию. А то тут некоторые у...
14.09.2012 09:15
 
 
EL Khan
Пост №41
Не за что. будут вопросы, задавайте, желательно не...
14.09.2012 09:30
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 6-НДФЛ CRM Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база 1с база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет Бытовые услуги. Учет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ВАС РФ Вахтовый метод.Оплата ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм видео 1С водный налог возврат переплаты восстановление НДС вывоз товаров выездная налоговая проверка выездная проверка выплата зарплаты выплаты иностранному работнику выплаты работникам выплаты физическим лицам высококвалифицированные специалисты вычет НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация государственные и муниципальные закупки гражданско-правовой договор графики работы двойное налогообложение дебиторка декларация по алкоголю декларация по ЕНВД декларация по НДС денежные документы День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договор транспортной экспедиции договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ ежемесячная отчетность ЕНВД ЕСН ЕСХН задержка заработной платы задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги зарубежная командировка защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 имущественные вычеты имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции КБК квоты на иностранных рабочих КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консервация основных средств консолидированная группа контролируемые сделки корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курортный сбор курсовые разницы лизинг лизинговое имущество ликвидация организации лицензирование льготы по ндс малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал международные стандарты миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая база по НДС налоговая декларация налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговое администрирование налоговые каникулы налоговые льготы налоговые проверки налоговый агент налоговый агент НДФЛ налоговый агент по НДС налоговый агент по НДФЛ налоговый агент по ндфл налоговый вычет налоговый контроль налоговый мониторинг налоговый учет налогообложение доходов налогоплательщик начисление пени НДПИ НДС НДС по ставке 10% НДС при ввозе НДС при экспорте НДС-2015 НДФЛ некоммерческие организации учет неотделимые улучшения нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нормы естественной убыли нулевая декларация нулевая ставка обзор обзор бухгалтерских событий обзор новостей обмен документами обновление КЛАДР обособленное подразделение обособленные подразделения обучение 1с оказание услуг ОКВЭД2 ОКПД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от НДС основные средства отпускные отходы отчетность в ПФР отчетность в росстат отчетность в Росстат отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры охрана труда патентная система ПБУ 18 первичные документы перенос убытков персонифицированный учет план счетов плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с платежный агент платежный терминал повышение ставок подакцизные товары подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф поправки в ТК РФ порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособия за счет ФСС посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений приказ Минфина применение ККТ приостановление операций по счету проверка ИНН/КПП проверка контрагентов продажа алкогольной продукции производственный календарь проф. Пятов профессиональные вычеты ПСН псн путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет отпускных расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация недвижимости регистрация юридических лиц реконструкция основных средств ремонт основных средств реорганизация росалкогольрегулирование РСВ-1 рыночные цены самозанятые граждане свод отчетов сдача имущества в аренду секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совместители совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставка УСН стандартные вычеты стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы в ФСС страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебные издержки суммовые разницы суточные счет-фактура такси таможенные платежи таможенный союз ТК РФ торг-12 торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность удержание алиментов УКД универсальный корректировочный документ УПД уплата налога уплата налогов упрощенная система налогообложения УСН уставный капитал уточненка утрата права на усн учет аренды учет в АО учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при УСН учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при УСН учет расходов при усн учет реализации учет скидок учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика учредительные документы факсимиле ФИАС финансовый анализ финансовый результат ФНС РФ форма 6-НДФЛ формы документов ФСС штрафные санкции ЭДО экологические платежи экспорт в страны ЕАЭС экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги
X

Яндекс-виджет: Новости
Яндекс-виджет: Полезные материалы
Информеры