Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1C и Excel

kalisto
читатель
офлайн
Дата регистрации: 12.01.2005
Сообщений: 216
Пост №1
 
22.04.2005 15:46

Привет всем. Подскажите, где можно взять подробное описание как написать обработку, которая будет загружать данные из Excel в 1с.

Olex
читатель
офлайн
Дата регистрации: 04.02.2005
Сообщений: 198
Пост №2
 
22.04.2005 16:28

"В любой книжке по Excel, где в оглавлении есть слова OLE или COM. А так же раздел документации 1С, посвящённый работе с OLE. Кажется, "Описание встроенного языка", второй том. Ниже пример кода, который из счет-фактуры Excel загружает данные в 1С.<br><br>//**************<br><br>Попытка<br><br> // запускаем Excel-Server<br><br> ВходExcel = СоздатьОбъект("Excel.Application");<br><br> ЗапущенExcel = 1;<br><br>Исключение<br><br> ЗапущенExcel = 0;<br><br> Предупреждение("MS Excel не загружен!");<br><br> Возврат;<br><br>КонецПопытки;<br><br>Если ЗапущенExcel=1 Тогда<br><br> Попытка<br><br> // открываем файл<br><br> ВходExcel.Application.Workbooks.Open(ИмяФайла);<br><br> Исключение<br><br> ВходExcel.Quit();<br><br> Предупреждение("Не удается открыть Файл!");<br><br> Возврат;<br><br> КонецПопытки;<br><br>КонецЕсли;<br><br><br><br>НомСтр = 18; //данные начинаются в 18 строке<br><br>Пока 1 = 1 Цикл<br><br> Артикул = ВходExcel.ActiveSheet.Cells(НомСтр,1).Value;<br><br> Наименование = ВходExcel.ActiveSheet.Cells(НомСтр,2).Value;<br><br> Если ПустоеЗначение(Артикул) * ПустоеЗначение(Наименование) = 1 Тогда //пустая строка?<br><br> Прервать;<br><br> КонецЕсли;<br><br> НомСтр = НомСтр + 1;<br><br>КонецЦикла;<br><br>ВсегоСтрок = НомСтр - 1; //последняя непустая строка<br><br><br><br>Для НомСтр = 18 По ВсегоСтрок Цикл<br><br> <br><br> Артикул = СокрЛП(ВходExcel.ActiveSheet.Cells(НомСтр,1).Value);<br><br> Наименование = СокрЛП(ВходExcel.ActiveSheet.Cells(НомСтр,2).Value);<br><br> Количество = Число(ВходExcel.ActiveSheet.Cells(НомСтр,4).Value);<br><br> Сумма = Число(ВходExcel.ActiveSheet.Cells(НомСтр,7).Value);<br><br> <br><br> Сообщить("Товар: "+Наименование+". Код: "+Артикул+". Кол: "+Количество+". Сумма: "+Сумма, "!");<br><br> <br><br>КонецЦикла;<br><br>ВходExcel.ActiveWindow.Close();<br><br><br><br>"

Roman_
читатель
офлайн
Дата регистрации: 27.04.2005
Сообщений: 36
Пост №3
 
27.04.2005 09:51

За 20$ Пришлю обработку, да и технология загрузки там видна на лицо

kalisto
читатель
офлайн
Дата регистрации: 12.01.2005
Сообщений: 216
Пост №4
 
28.04.2005 14:00

За 10$ я согласна.

ZloyBuhgalter
новичок
офлайн
Пост №5
 
28.04.2005 14:25

Сайт http://1c.proclub.ru <br><br>Конвертация MXL в XLS<br><br>Главная : 1С:Предприятие 7.7<br><br>Автор: Natalia<br><br>Принял: Natalia<br><br>Описание:<br><br><br><br>Попытка сохранять в Excel красиво - с нормальной трактовкой дат, разделителей разрядов, с сохранением ячеек с длиной строки больше 255 символов, с ярлычками листов, с соответствующими оригиналу объединениями ячеек ... Подробнее об обработке и о возможности ее практического применения , а также иллюстрации замеченных мной недостатков стандартной конвертации, которые полностью устраняются обработкой - на таблице при открытии обработки.<br><br><br><br>konv_xls.zip<br><br><br><br>

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

12 октября 2022 годаЕДИНЫЙ ОНЛАЙН-СЕМИНАР 1С для бухгалтеров и руководителей

28 октября 2022 годаБизнес-форум 1С:ERP

1C:Лекторий: 29 сентября 2022 года (четверг, начало в 10:00, все желающие)Онлайн-кассы: практика применения, ответы на наиболее часто задаваемые вопросы

1C:Лекторий: 4 октября 2022 года (все желающие)Новое в "1С:Бухгалтерии 8" - обзор актуальных обновлений

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С