Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как отсортировать документы по времени

Aptem
читатель
офлайн
Дата регистрации: 30.03.2005
Сообщений: 7
Пост №1
 
14.05.2005 06:43

Доброго времени суток!<br><br><br><br>У меня такая проблема. Имеется выборка документов за какой-то один день. Необходимо найти документы в заданном временном интервале, например, с 14:00:00 по 17:00:00. Точнее документ с максимальным временем. Как это организовать??<br><br><br><br>Спасибо за внимание.

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №2
 
14.05.2005 09:36

Собственно в чём проблема? Перебераешь документы и смотришь их время. (метод - ПолучитьВремя(...))<br><br>И выбираешь док с максимальным временем.<br><br>А если надо отсортировать, то самый простой способ это записать все доки в таблицу значений, потом вызываешь Сортировать() и само отсортируется.

Olex
читатель
офлайн
Дата регистрации: 04.02.2005
Сообщений: 198
Пост №3
 
14.05.2005 09:42

СформироватьПозициюДокумента(<Дата>,<Час>,<Мин>,<Сек>,<ФлагКонцаСекунды>)<br><br><br><br>ВыбратьДокументы(<Дата1>,<Дата2>)<br><br><Дата1> - дата, документ или позиция начала выборки документов. Если данный параметр опущен, то выборка начинается с самого первого существующего в системе документа.<br><br><Дата2> - дата, документ или позиция конца выборки документов. Если данный параметр опущен, то выборка заканчивается самым последним существующим в системе документом.<br><br>

ValeraH
читатель
офлайн
Дата регистрации: 31.03.2004
Сообщений: 264
Пост №4
 
14.05.2005 12:28

"Если выборку получаешь запросом, то можно использовать:<br><br>Группировка Докум упорядочить по Докум.ДатаДок, Докум.ВремяДок;"

Alexor
читатель
офлайн
Дата регистрации: 08.07.2003
Сообщений: 201
Пост №5
 
14.05.2005 12:57

"Примерно так<br><br><br><br>Док=СоздатьОбъект("Документ");<br><br><br><br>Док.ВыбратьДокументы(Дата1,Дата2);<br><br>Док.ОбратныйПорядок(1);<br><br>Найдено=0;<br><br>Пока Док.ПолучитьДокумент()=1 Цикл<br><br> Док.ПолучитьВремя(Часы,Минуты,Секунды);<br><br> Если Часы=<17 Тогда // дописать в соотв. с треб. уловием<br><br>      Найдено=1;<br><br>      Прервать;<br><br> КонецЕсли;<br><br>КонецЦикла;<br><br><br><br>Если Найдено=1 Тогда<br><br> // док нашли<br><br>иначе<br><br> // док не найден<br><br>КонецЕсли;<br><br><br><br><br><br>"

Aptem
читатель
офлайн
Дата регистрации: 30.03.2005
Сообщений: 7
Пост №6
 
15.05.2005 10:10

Простой перебор всех документов не пойдет. Документов очень много, необходимо как-то оптимизировать этот поиск!

Квазимодо
читатель
офлайн
Дата регистрации: 12.05.2004
Сообщений: 559
Пост №7
 
16.05.2005 00:54

"тебе ведь уже написали:<br><br><br><br>Док=СоздатьОбъект("Документ"); <br><br><br><br>Док.ВыбратьДокументы(Дата1,Дата2); <br><br>Док.ОбратныйПорядок(1); //!!!!!!<br><br>"

Aptem
читатель
офлайн
Дата регистрации: 30.03.2005
Сообщений: 7
Пост №8
 
17.05.2005 05:35

Такой способ поиска ищет документы в интервале времени от 00:00:00 до 23:59:59. А что если мне необходимо найти максимальное время на интервале 03:00:00 до 05:00:00?

Olex
читатель
офлайн
Дата регистрации: 04.02.2005
Сообщений: 198
Пост №9
 
17.05.2005 09:33

"Дата1 = СформироватьПозициюДокумента(<Дата>,3,0,0,0);<br><br>Дата2 = СформироватьПозициюДокумента(<Дата>,5,0,0,1);<br><br><br><br>//А дальше как говорит Квазимодо:<br><br>Док=СоздатьОбъект("Документ"); <br><br>Док.ВыбратьДокументы(Дата1,Дата2); <br><br>Док.ОбратныйПорядок(1); //!!!!!!"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

12 октября 2022 годаЕДИНЫЙ ОНЛАЙН-СЕМИНАР 1С для бухгалтеров и руководителей

28 октября 2022 годаБизнес-форум 1С:ERP

1C:Лекторий: 29 сентября 2022 года (четверг, начало в 10:00, все желающие)Онлайн-кассы: практика применения, ответы на наиболее часто задаваемые вопросы

1C:Лекторий: 4 октября 2022 года (все желающие)Новое в "1С:Бухгалтерии 8" - обзор актуальных обновлений

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С