Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Проблема с обновлением справочника

Finansov
читатель
офлайн
Дата регистрации: 25.10.2005
Сообщений: 26
Пост №1
 
02.03.2006 15:14

"Есть справочник "Контрагенты". Там есть поле Контактное лицо. Есть документ "Предложение".
В этом документе есть два поля "Контрагент" и "Контактное лицо". Оба эти поля берутся из одного и того же справочника. Но вот загвозка. Мне нужно чтобы поле "Контактное лицо" было заполенено обязательно. и получается что если поле не заполенено его нужно обязатедльно ввести..но после того как его вводишь, оно не отображаеться в документе. Подскажите где у меня ошибка. Заранее спасибо.

Процедура ПриВыбореКлиента()
Спр = СоздатьОбъект("Справочник.Контрагенты");
Спр = Контрагент;
Если ПустоеЗначение(Спр.КонтактЛицо) = 1 Тогда
Предупреждение("Введите пожалуйста контактное лицо","10");
ОткрытьФормуМодально(Контрагент,,0);
КонецЕсли;
КонтЛицо = Спр.КонтактЛицо;

КонецПроцедуры"

Finansov
читатель
офлайн
Дата регистрации: 25.10.2005
Сообщений: 26
Пост №2
 
03.03.2006 17:47

"Добрые люди посоветовали, и я сделал вот так
Процедура ПриВыбореКлиента()
Если ПустоеЗначение(Контрагент.КонтактЛицо)=1 Тогда
Предупреждение("Введите пожалуйста контактное лицо");
ОткрытьФормуМодально(Контрагент,,0);
КонецЕсли;
Спр=СоздатьОбъект("Справочник.Контрагенты");
Если Спр.НайтиПоКоду(Клиент.Код,0)=1 Тогда
КонтЛицо = Спр.КонтактЛицо;
КонецЕсли;
КонецПроцедуры

И плюс при закрытии сделал (Также по совету добрых людей):
Спр = СоздатьОбъект("Справочник.Контрагенты");
Если Спр.НайтиПоКоду(Клиент.Код,0)=1 Тогда
Спр.КонтактЛицо=КонтЛицо;


Спр.Записать();
Т.е.происходит двойная проверка...Не знаю мне показалось что так будет точнее...Хотя может быть последнее нужно и убрать..."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги