Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как перенести элемент справочника из группы в группу программно?

Натусик.Ру
читатель
офлайн
Дата регистрации: 10.11.2004
Сообщений: 52
Пост №1
 
30.03.2006 10:55

"Требуется изменить Родителя элемента справочника, а именно - сделать так, чтобы он не входил ни в какую группу.
Пишу так:
Спр.ВыбратьЭлементы;
Пока Спр.ПолучитьЭлемент()=1 Цикл
ТекЭл=Спр.ТекущийЭлемент();
Если (ТекЭл.ЭтоГруппа()=0) и (ТекЭл.Уровень()>1) Тогда
ТекЭл.Родитель=ПолучитьПустоеЗначение("Справочник.Номенклатура");
КонецЕсли;
КонецЦикла;

Выдает: Объект не может быть перепозиционирован!
Похожий вопрос нашла на форуме, но четкого ответа там нет.

Подскажите, пожалуйста, может я что не так делаю?"

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №2
 
30.03.2006 12:57

"стоит попробовать так:

Спр.УстановитьАтрибут("Родитель", ПолучитьПустоеЗначение("Справочник.ОсновныеСредства"));
Спр.Записать();


Однако у меня возникают сомнения по поводу такого перебора. Как никак начинается перебор всех элементов в справочнике, и тут же они переносятся. Не уверен что цикл отработает до конца."

vim
читатель
офлайн
Дата регистрации: 25.03.2005
Сообщений: 38
Пост №3
 
30.03.2006 13:41

Переносила элементы справочника из группы в группу (существующую). Группы выбирались в диалоге как ОТКУДА и КУДА.
1. Считываем элементы группы ОТКУДА в таблицу значений.
2. При просмотре полученной таблицы значений в цикле, позиционируемся на совпадающий элем-т справочника,и устанавливаем для него ОС1.Родитель=КУДА      (это группа выбранная в диалоге)
Программа работает, текст не могу привести, т.к.получается непонятный шрифт.

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №4
 
31.03.2006 06:09

если копируете текст из 1С то перед копированием русского текста нужно переключить раскладку клавиатуры на русский, тогда копирует нормально. если будет включён английский то при копировании фигня всякая получается. Глюк программы 1С. :-)

vim
читатель
офлайн
Дата регистрации: 25.03.2005
Сообщений: 38
Пост №5
 
31.03.2006 09:07

"Спасибо за подсказку. Правда, все получается.

Процедура Сформировать()
О1 = СоздатьОбъект("ТаблицаЗначений");
О1.НоваяКолонка("ИнвНомер");
ОС1 = СоздатьОбъект("Справочник.ОсновныеСредства");
ОС1.ИспользоватьДату(Дата("31.12.2004"));
      ОС1.ПорядокНаименований();
ОС1.ВыбратьЭлементы();
Пока ОС1.ПолучитьЭлемент()>0 Цикл
Если ОС1.ЭтоГруппа()=1 Тогда
       Продолжить;
КонецЕсли;
Если ОС1.ПринадлежитГруппе(ВыбГр)=1 Тогда
О1.НоваяСтрока();
О1.ИнвНомер=ОС1.Код;
       КонецЕсли;
КонецЦикла;

О1.ВыбратьСтроки();
Пока О1.ПолучитьСтроку()>0 Цикл
// Сообщить(О1.ИнвНомер);
Код=СокрЛП(О1.ИнвНомер);
      ОС1.ВыбратьЭлементы();
      Пока ОС1.ПолучитьЭлемент()>0 Цикл

Если ОС1.ЭтоГруппа()=1 Тогда
       Продолжить;
КонецЕсли;
Если ОС1.Код=Код Тогда
ОС1.Родитель=Куда;
ОС1.Записать();
КонецЕсли;
      КонецЦикла;
КонецЦикла;
"

DavidSed
читатель
офлайн
Дата регистрации: 03.03.2006
Сообщений: 19
Пост №6
 
31.03.2006 10:56

"Попробуйте вот так
ТекЭл.Родитель=0; "

vim
читатель
офлайн
Дата регистрации: 25.03.2005
Сообщений: 38
Пост №7
 
31.03.2006 12:08

Попробовала свою программу в следующем варианте
Ку=ОС1.Родитель //когда выбран элемент справочника из корня (если не было, то временно перенесла в корень любой элемент), т.е.определили чему равен Родитель в корне.

Далее ОС1.Родитель=Ку

Нормально все переносится в корень.

Натусик.Ру
читатель
офлайн
Дата регистрации: 10.11.2004
Сообщений: 52
Пост №8
 
31.03.2006 14:00

Получился вариант со списком и методом НайтиЭлемент. Большое спасибо всем, кто откликнулся!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги