Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

проблема с реквизитом регистра

rassigor
читатель
офлайн
Дата регистрации: 27.02.2006
Сообщений: 14
Пост №1
 
16.04.2006 23:46

"Нужно реализовать систему учета нал, б/нал, я создаю регистр товары
Измерения:товар, склад, ресурсы:количество, партия, реквизиты:Сумма, вр.
В самой форме расходной накладной поставил переключатель, когда он 0 то нал, 1 то безнал. В модуле документа пишу

Процедура ОбработкаПроведения()

// Проверка на наличие на остатке

ФлагОтказа=0;

ВыбратьСтроки();
Пока ПолучитьСтроку() > 0 Цикл
Остат=Регистр.Товары.СводныйОстаток(Товар,Склад,"Кол");
Если Остат<Количество Тогда
      Сообщить("Нет товара № "
+СокрЛП(Товар.Код)+"/"
+СокрЛП(Товар)+" в колич. "
+Количество+" (имеется "+Остат+")");
      ФлагОтказа=1;
КонецЕсли;
Если ФлагОтказа=1 Тогда
НеПроводитьДокумент();
Возврат;
КонецЕсли;
Регистр.Товары.Товар = Товар;
Сообщить(Регистр.Товары.Товар);
Регистр.Товары.Склад = Склад;
Сообщить(Регистр.Товары.склад);
Регистр.Товары.Кол = Количество;
Сообщить(Регистр.Товары.кол);
Регистр.Товары.Сумма = Сумма;
Сообщить(Регистр.Товары.сумма);
Сообщить("флаг"+флаг);
если флаг=0 тогда //проверка нал(вр=1), бнал(вр=0),
Регистр.Товары.ВР = 1;
Сообщить("ВР"+Регистр.Товары.вр);
иначе
Регистр.Товары.ВР = 0;
Сообщить(Регистр.Товары.вр);
конецесли;
Регистр.Товары.Партия = Текущийдокумент();
Регистр.Товары.ДвижениеРасходВыполнить();
КонецЦикла;
КонецПроцедуры

когда Сообщить("ВР"+Регистр.Товары.вр) то выводиться 1, то есть вроде правильно записывает.

Таким же образом прописываю для товара и количества.
Создаю отчет, там вывожу товар, количество и вр(признак нала или безнала),но там ставятся 0

// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Товар = Регистр.Товары.Товар;
|Кол = Регистр.Товары.Кол;
|ВР=Регистр.Товары.ВР;
|Партия=Регистр.Товары.Партия;
|Сумма=Регистр.Товары.Сумма;
|Функция КолКонОст = КонОст(Кол);
|Группировка Товар упорядочить по Товар.Наименование;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Товар
Сообщить(Регистр.Товары.ВР);
Сообщить(запрос.вр);
Таб.ВывестиСекцию("Товар");
КонецЦикла;
// Заполнение полей "Итого"
Таб.ВывестиСекцию("Итого");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", """");
КонецПроцедуры


Количество выводиться, товар выводиться а признак ВР ставить 0, что я не так делаю
"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги