Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Необычная проблема с OLE на 1С 7.7

kutanou
читатель
офлайн
Дата регистрации: 23.11.2005
Сообщений: 2
Пост №1
 
20.04.2006 06:40

"Ситуация.
Осуществляется OLE синхронизация базы на одном сервере с другой базой на другом (ОС - Win 2003 /лиц./, железо хорошее. 1С 7.7 /лиц./, сетевая, 25 релиз).
Кроме того после установления коннекта через OLE для ускорения некоторых операций синхронизации цепляемся к другой базе на уровне dbf-файлов через ODBC.
И понеслась ...
Это все происходит по ночам после сохранения базы и ее переиндексации (по событию "ОбработкаОжидания").
По ночам у нас никто не работает.      
После того как синхронизация отрабатывает 1С закрывается.

Все прекрасно работало уже больше года до предыдущих выходных.
После них при ночном старте обработки по расписанию появляется сообщение
Заголовок окна - "Сервер занят"
Само сообщение -
"Действие не может быть завершено, так как другая программа занята
Для перехода к этой программе воспользуйтесь кнопкой "Переключится""""
и три кнопки "Переключится", "Повторить" и "Отмена" (неактивная)

После нажатия клавиши "Переключится" все замечательно работает. В ручном режиме
когда запускаешь обработку никаких впоросов и сообщений не возникает - в не зависимости
от того сколько пользователей в какой базе работает.

Вопрос.
Как сделать так чтобы это окошко не появлялось или автоматически в нем нажималась бы кнопка "переключится"?
Из-за чего оно стало появлятся если в исходном коде и в расписании синхронизаций никто ничего не менял?

// 1) Запуск OLE
---------------
Если ФС.СуществуетФайл(Пут+"1Cv7.md")=1 Тогда
Попытка
Открыта=База.Initialize(База.RMTrade," /d"+Пут+" /N" + ПользовательДиалог+ " /P" +Пароль, "NO_SPLASH_SHOW");
...
---------------

// 2) Цепляемся через ODBC драйвер
---------------
Попытка
конект_l1 = СоздатьОбъект("ODBCRecordSet");
Исключение
      Если ЗагрузитьВнешнююКомпоненту("1cpp.dll")=0 тогда
       Предупреждение ("Компонента 1с++ не найдена");
       СтатусВозврата(0);
       Возврат;
      КонецЕсли;
      конект_l1 = СоздатьОбъект("ODBCRecordSet");
КонецПопытки;

м = СоздатьОбъект("MetaInfoClasses");
Если м.ЭтоSQL_Версия()=0 тогда
      СтрокаПодключения = "driver=Microsoft Visual FoxPro Driver;Exclusive=No;SourceType=DBF;SourceDB="+СокрЛП(Пут);
      Одбс = СоздатьОбъект("ODBCDatabase");
      ДрК = Одбс.DriverConnect(СтрокаПодключения);
Если ДрК = 0 Тогда
      Сообщить(Одбс.ПолучитьОписаниеОшибки());
КонецЕсли;
конект_l1.УстБД(Одбс);

КонецЕсли;
---------------
"

IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №2
 
26.04.2006 17:26

Как вариант: написать свою резидентную приблуду, пусть в памяти висит и ждет окна с заголовком "Сервер занят", как находит отлавливает хендл нужной кнопки в окне и постит ей сообщения wm_LButtonDown и за ним wm_LButtonUp.

SB
читатель
офлайн
Дата регистрации: 26.04.2003
Сообщений: 19
Пост №3
 
26.04.2006 20:04

Сталкивался с аналогичной проблемой. Пока обработка OLE проходила не слишком долго (конкретное время не помню) все было хорошо. Как только длительность обработки превысила некоторое критическое значение, стало вываливаться аналогичное сообщение. Вылечилось оптимизацией обработки по времени выполнения.

Feanor
читатель
офлайн
Дата регистрации: 12.04.2006
Сообщений: 20
Пост №4
 
28.04.2006 04:14

Лучше эмулировать нажатие кнопки через событие BM_CLICK. Могу тебе заслать програмульку, которая это делает, думаю, дописать не проблема. А вообще это борьба со следствием, а не с причиной...

Ответили: пост №5
Pavel Pozdeev
читатель
офлайн
Дата регистрации: 24.10.2016
Сообщений: 1
Пост №5
 
24.10.2016 15:55
Ответ на пост №4

Feanor, просьба отправить программу на почту, которая кликает через событие BM_CLICK

Ответили: пост №6
Рисовод
активный пользователь
онлайн
Дата регистрации: 26.12.2007
Сообщений: 25145
Пост №6
 
24.10.2016 16:44
Ответ на пост №5

Pavel Pozdeev, Пост №4

28.04.2006 04:14

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги