Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Проблема с ЗиК!!!

Olga3891
читатель
офлайн
Дата регистрации: 10.10.2006
Сообщений: 497
Пост №1
 
18.01.2007 12:01

Проблема заключается в следующем. Неправильно формируются элементы справочника НАЧИСЛЕНИЯУДЕРЖАНИЯ,подчиненного<br>справочнику СОТРУДНИКИ.<br>Формирую 3 документа: Ввод расчета списку сотрудников. (начисление отражается в спр. НачисленияУдержания). <br>1. 15.01.07 - 17.01.07 <br>2. 11.01.07 - 13.01.07 <br>3. 01.01.07 - 10.01.07 <br>Если провожу их в порядке 1-2-3, то запись в НАЧИСЛЕНИЯУДЕРЖАНИЯ формируется не правильно и периодический реквизит ДЕЙСТВУЕТ.<br>Если провожу в порядке 1-3-2 или 3-2-1, то все правильно. <br>Ошибка в процедуре глПолучитьСвободноеНачислениеУдержание(,,,). <br>Почему нет соответствующей проверки при проведении в порядке 1-2-3. <br>Наша ситуация: работает 3 расчетчика. у каждого по одному такому документу. проводят в порядке 1-2-3. В итоге начиление<br>з/п НЕПРАВИЛЬНО. У нас нет возможности согласовывать между собой порядок проведения документов.<br>Если сделать только один документ Ввод расчета списку сотрудников с таким же порядком периодов, т.е. : <br>15.01.07 - 17.01.07 <br>11.01.07 - 13.01.07 <br>01.01.07 - 10.01.07 <br>ТО СИТУАЦИЯ ТАКАЯ ЖЕ.

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №2
 
18.01.2007 13:25

Лучше поясните, что значит "...формирует неправильно и периодический реквизит ДЕЙСТВУЕТ"<br>А так же в чём заключается неправильное формирование? В сумме? какой из документов не правильно формирует, на сколько отличается?

Olga3891
читатель
офлайн
Дата регистрации: 10.10.2006
Сообщений: 497
Пост №3
 
18.01.2007 13:47

Есть документ Ввод расчета списку сотрудников1: Начисление (назовем его Нач) отражается в спр. НачисленияУдержания. Начисление - процентом от базы.<br>таб.часть документа. период с 15.01.07 по 17.01.07. Документ проводим. при проведении формируются записи в спр. НачисленияУдержания следующие. т.к. в спр. НачисленияУдержания нет запичей с видом расчета НАЧ, то эта запись создается. Значения периодического реквизита ДЕЙСТВУЕТ устанавливаются следующие(Буду писать дату и значение реквизита):<br>15.01.07      1<br>18.01.07      0<br>Есть документ Ввод расчета списку сотрудников2: Начисление такое же. период с 11.01.07 по 13.01.07. Провожу его.<br>Значение переодического реквизита ДЕЙСТВУЕТ устанавливаются следующие:<br>11.01.07      1<br>14.01.07      0<br>15.01.07      1<br>18.01.07      0<br>Есть документ Ввод расчета списку сотрудников3: Начисление такое же. период с 01.01.07 по 10.01.07. Провожу его.<br>Значение переодического реквизита ДЕЙСТВУЕТ устанавливаются следующие:<br>01.01.07      1<br>11.01.07      0<br>14.01.07      0<br>15.01.07      1<br>18.01.07      0<br>В итоге при начислении з/п в журнале появляется только две строчки:<br>01.01.07-10.01.07<br>15.01.07-17.01.07.<br>А ДОЛЖНО БЫТЬ<br>01.01.07-10.01.07<br>11.01.07-13.01.07<br>15.01.07-17.01.07<br>Как более понятно обяснить я не знаю!!!!<br>Помогите пож-та советом...

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №4
 
19.01.2007 07:46

Ага. есть такое. Сейчас посмотрел модуль документа и там нет проверки на то, что этот вид расчёта действует ещё когда-то, а тупо Окончание+1 пишет 0.<br>Выход: подправить модуль документа, дописав проверку.<br>За одно и в хотлайн написать следует.

Olga3891
читатель
офлайн
Дата регистрации: 10.10.2006
Сообщений: 497
Пост №5
 
19.01.2007 09:15

Так тут по-моему надо править не модуль документа НачислениеУдержаниеСписком, а глобальную процедуру глПолучитьСвободноеНачислениеУдержание(...). Или я не права???

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №6
 
19.01.2007 10:19

"Да что вы привязались к этой процедуре? Ведь в журнал расчета попадают только 2-е записи и справочник неправильно обрабатывается.<br>В конфигураторе откройте модуль документа и в процедуре ОбработкаПроведения(...) найдите строки<br><br>Если ПустоеЗначение(Окончание)=0 Тогда<br> УстановитьРеквизитСправочника(НачислениеУдержание.ТекущийЭлемент(),"Действует",0,Окончание+1);<br>КонецЕсли;<br><br>И дополните их так:<br><br>Если ПустоеЗначение(Окончание)=0 Тогда<br> пп = СоздатьОбъект("Периодический");<br> пп.ИспользоватьОбъект("Действует", НачислениеУдержание.ТекущийЭлемент());<br> Если пп.НайтиЗначение(Окончание+1, 0) = 0 тогда<br> УстановитьРеквизитСправочника(НачислениеУдержание.ТекущийЭлемент(),"Действует",0,Окончание+1);<br> КонецЕсли;<br>КонецЕсли;<br><br>Вроде там в нескольких местах такое есть<br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С