Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Зарплата+Кадры ТК 7.70.270 форма - отчет по ПФР

Ludmila_KP
Пост №1
Ludmila_KP
читатель
офлайн
Дата регистрации: 18.01.2006
Сообщений: 102
Пост №1
 
19.01.2007 15:41

Подскажите, пожалуйста, как написать условие с вложенным внутрь еще одним ЕСЛИ.
Пришлось добавить в форму-отчет ПФР в СЗВ-4-1 для вывода в "Исчисление трудового стажа" Основание(код) строку:
      ?(КодПрофессии="12205000-1754б      ", "27-1", "27-2")
а надо еще учесть, что
       если КодПрофессии здесь = " ", то должно быть " ", а не 27-2.

basil_m
Пост №2
basil_m
читатель
офлайн
Дата регистрации: 12.01.2007
Сообщений: 35
Пост №2
 
19.01.2007 16:23

"Если КодПрофессии="12205000-1754б      " Тогда
Х="27-1";
ИначеЕсли КодПрофессии=" " Тогда
Х=" ";
Иначе
Х="27-2";
КонецЕсли;"

Ludmila_KP
Пост №3
Ludmila_KP
читатель
офлайн
Дата регистрации: 18.01.2006
Сообщений: 102
Пост №3
 
19.01.2007 16:42

спасибо большое Вам за отклик, но я не знаю как это написать именно в отчете, в самой таблице, думаю, должно быть что-то типа с квадратными скобками, как, например, в расчетных листках :)
       [ТарифОклад][?(ПустоеЗначение(ФормаТруда) = 1,",":")] [СуммаОклада] [ВалютаОклада] [ПредставлениеРазряда]

Ludmila_KP
Пост №4
Ludmila_KP
читатель
офлайн
Дата регистрации: 18.01.2006
Сообщений: 102
Пост №4
 
19.01.2007 16:53

т.е. в самой ячейке таблицы СЗВ-4-1

Skynin
Пост №5
Skynin
читатель
офлайн
Дата регистрации: 18.08.2006
Сообщений: 30
Пост №5
 
19.01.2007 16:59

"В операторе ?(Усл, рез1, рез2) допускаются вложение.

Получится у Вас жуткое на вид условие:
?(Усл, ?(Усл, ?(Усл, рез1, рез2), рез2), рез2)

?(Усл, рез1, рез2)
это тоже самое что
Если Усл Тогда
Рез1
Иначе
Рез2
КонецЕсли;

А
Если Усл Тогда
Рез1
ИначеЕсли Усл2
Рез2
Иначе
Рез3
КонецЕсли;

будет выглядеть
?(Усл, Рез1, ?(Усл2, Рез2, Рез3))"

Ludmila_KP
Пост №6
Ludmila_KP
читатель
офлайн
Дата регистрации: 18.01.2006
Сообщений: 102
Пост №6
 
19.01.2007 17:16

спасибо, поняла.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.