Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

ЗиК v7 При расчете среднего заработка цепляет «левый» документ

danil
читатель
офлайн
Дата регистрации: 15.10.2004
Сообщений: 45
Пост №1
 
24.01.2007 08:42

"Программные средства:1С Предприятие 7.7 (сетевая версия) (7.70.025) Типовая конфигурация Зарплата+Кадры, редакция 2.3 (7.70.271)
Описание проблемы.
При вводе документа «Начисление отпуска» в январе 2007 на вкладке «Средний заработок» заполняем данные по среднему заработку за 3 месяца (10,11,12). Установлен флаг «Средний часовой заработок». Хотя в декабре сотрудник не работал (отпуск), ему прописывается некий заработок в этом месяце. Эта же сумма в декабре прописывается в справке 2_НДФЛ за 2006 год.
Начинаю смотреть в отладчике в глобальном модуле процедуру глЗаполнитьДанныеСреднегоЗаработкаОтпуска(…)

Месяцев = 1;
Пока Месяцев <= МесяцевРасчетногоПериода Цикл
Сумма = 0;
СуммаОкладаПоЗваниюНадбавкиЗаРазряд = 0;
ДнейОтработано = 0;
ОтработаноФактически = 0;
НачалоОчередногоПериода = ЖрнЗарплата.НачалоПериодаПоДате(ОчереднаяДата);
ОкончаниеОчередногоПериода = ЖрнЗарплата.КонецПериодаПоДате(ОчереднаяДата);
ЖрнЗарплата.ВыбратьЗаписиПоОбъекту(Сотрудник, НачалоОчередногоПериода, ОчереднаяДата);

Пока ЖрнЗарплата.ПолучитьЗапись() > 0 Цикл
Если (ЖрнЗарплата.Результат = 0) и (ЖрнЗарплата.Дни = 0) и (ЖрнЗарплата.Часы = 0) Тогда
Продолжить
КонецЕсли;
ИспытуемыйВР=ЖрнЗарплата.ВидРасч;
Если (ИспытуемыйВР = ВидРасчета.РайонныйКоэффициент) или (ИспытуемыйВР = ВидРасчета.СевернаяНадбавка) Тогда
Продолжить
КонецЕсли;
Если (ИспытуемыйВР=ВидРасчета.ПремияРазовая) или (ИспытуемыйВР.ВходитВГруппу(ГруппаРасчетов.ПремииКвартальные)=1)
или (ИспытуемыйВР=ВидРасчета.ПремияПоИтогамГодаСуммой) или (ИспытуемыйВР=ВидРасчета.ПремияПоИтогамГода) Тогда
Продолжить
КонецЕсли;
Если (глВходитВБазу(ИспытуемыйВР, ВидРасчета.ОплатаПоСреднемуЗаработку, ГруппаРасчетов.БазаРасчетовОплатыПоСреднему, Счетчик) = 1) Тогда

При переборе записей журнала зарплата за декабрь месяц почему-то цепляется документ «Табель отработанного времени № ХХ (31.12.2006)» и соответственно виды расчетов с суммами из него. Когда заходим в журнал расчетов зарплаты, то там нет записей по такому документу в декабре. Более того, в журнале документов есть документ с таким номером, но дата у него 30.11.2006 и вообще он по другому сотруднику, то есть это вообще «левый» документ.

Вопрос. Что можно сделать?
"

StarS
читатель
офлайн
Дата регистрации: 15.07.2003
Сообщений: 1623
Пост №2
 
24.01.2007 11:17

Похоже - "Тестирование и исправление ИБ"

danil
читатель
офлайн
Дата регистрации: 15.10.2004
Сообщений: 45
Пост №3
 
25.01.2007 06:06

Не помогает!

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №4
 
25.01.2007 06:42

Если вы проходили отладчиком, то должны были узнать кроме документа так же, что это за вид расчета, период действия, а так же нмер строки документа. И ищите документ этот.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.