Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выбор элемента подчиненного субконто

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №1
 
24.04.2003 13:49

Доброго времени суток!<br><br>Например, в отчете ОСВ по счету, если выбрано первое субконто - конкретный контрагент, то при выборе второго субконто Договоры выдается список подчиненных элементов, т.е. договора этого самого контрагента.<br><br>Никак не разберусь как это реализовано. Хотелось применить это дело во внешней обработке. <br><br>Может кто подскажет?<br><br><br><br>Добавлено 25/04/03<br><br>Неплохо бы подключить к форуму парочку технических специалистов из самой фирмы 1с. А то как то вяло протекает жизнь на форуме.

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №2
 
29.04.2003 08:20

"Для начала неплохо бы почитать об языке программирования.<br><br><br><br>Контр = СоздатьОбъект("Справочник.Контрагенты");<br><br>Док = СоздатьОбъект("Справочник.Документы");<br><br>Контр.ВыбратьЭлементы();<br><br>Пока Контр.ПолучитьЭлемент() = 1 Цикл<br><br> Док.ИспользоватьВладельца(Контр.ТекущийЭлемент());<br><br> Док.ВыбратьЭлементы();<br><br> Пока Док.ПолучитьЭлемент() = 1 Цикл<br><br>       ........//здесь мы получаем документ<br><br> КонецЦикла;<br><br>КонецЦикла;<br><br>"

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №3
 
29.04.2003 11:58

Описание языка читал уже давно и многие вещи забыл. Конкретизирую вопрос: если открыть модуль отчета ОборотноСальдоваяВедомостьПоСчету и запустить поиск слова Контрагент или Договор - ничего не находит, тем не менее, все работает. Вопрос: Как это реализовано?

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №4
 
29.04.2003 12:44

"Все достаточно просто:<br><br>В твоём примере ищи процедуру ПоСубконто и проанализируй её.<br><br>А вообще: <br><br>ВыбратьСубконто();<br><br>Пока ПолучитьСубконто() = 1 Цикл<br><br>ВыбратьСубконто(2);<br><br>Пока ПолучитьСубконто(2) = 1 Цикл<br><br> ____и т.д.<br><br>КонецЦикла;<br><br>КонецЦикла;"

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №5
 
05.05.2003 15:36

ПоСубконто() вызывается из процедуры Сформировать() и с ней более-менее все ясно. Вопрос касается диалога до нажатия на кнопку Сформировать или ОК. Зашито ли это в экзешнике или реализовано в конфигурации? Пожалуйста, внимательнее читайте вопрос, прежде чем отвечать

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №6
 
06.05.2003 09:19

"Посмотри процедуру ПриВыбореСчета(), в конце есть 3 строки:<br><br>УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто1);<br><br>УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто2);<br><br>УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто3);<br><br>И проанализируй эту процедуру (УстановитьВладельца)."

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №7
 
07.05.2003 11:08

"ИМХО, УстановитьВладельца() нужна для работы с разделителями учета (РУ), а т.к. у нас они не используются, то даже удалив ее мы не шибко много потеряем. Похоже, что за сабж отвечает НазначитьСчет(). Но там, видимо, подразумевается работа с идентификаторами Субконто1,Субконто2 и Субконто3. Мне же в обработке надо иметь два ряда субконто для одного счета: Субконто1с, Субконто2с, Субконто3с; Субконто1н, Субконто2н, Субконто3н. <br><br>Получается, что сие не реализуемо. Ну и х. с ним. Не умрут бухи от пары лишних мышиных кликов. Спасибо за ответы."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С