Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выбор элемента подчиненного субконто

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №1
 
24.04.2003 13:49

Доброго времени суток!

Например, в отчете ОСВ по счету, если выбрано первое субконто - конкретный контрагент, то при выборе второго субконто Договоры выдается список подчиненных элементов, т.е. договора этого самого контрагента.

Никак не разберусь как это реализовано. Хотелось применить это дело во внешней обработке.

Может кто подскажет?



Добавлено 25/04/03

Неплохо бы подключить к форуму парочку технических специалистов из самой фирмы 1с. А то как то вяло протекает жизнь на форуме.

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №2
 
29.04.2003 08:20

"Для начала неплохо бы почитать об языке программирования.



Контр = СоздатьОбъект("Справочник.Контрагенты");

Док = СоздатьОбъект("Справочник.Документы");

Контр.ВыбратьЭлементы();

Пока Контр.ПолучитьЭлемент() = 1 Цикл

Док.ИспользоватьВладельца(Контр.ТекущийЭлемент());

Док.ВыбратьЭлементы();

Пока Док.ПолучитьЭлемент() = 1 Цикл

       ........//здесь мы получаем документ

КонецЦикла;

КонецЦикла;

"

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №3
 
29.04.2003 11:58

Описание языка читал уже давно и многие вещи забыл. Конкретизирую вопрос: если открыть модуль отчета ОборотноСальдоваяВедомостьПоСчету и запустить поиск слова Контрагент или Договор - ничего не находит, тем не менее, все работает. Вопрос: Как это реализовано?

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №4
 
29.04.2003 12:44

"Все достаточно просто:

В твоём примере ищи процедуру ПоСубконто и проанализируй её.

А вообще:

ВыбратьСубконто();

Пока ПолучитьСубконто() = 1 Цикл

ВыбратьСубконто(2);

Пока ПолучитьСубконто(2) = 1 Цикл

____и т.д.

КонецЦикла;

КонецЦикла;"

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №5
 
05.05.2003 15:36

ПоСубконто() вызывается из процедуры Сформировать() и с ней более-менее все ясно. Вопрос касается диалога до нажатия на кнопку Сформировать или ОК. Зашито ли это в экзешнике или реализовано в конфигурации? Пожалуйста, внимательнее читайте вопрос, прежде чем отвечать

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №6
 
06.05.2003 09:19

"Посмотри процедуру ПриВыбореСчета(), в конце есть 3 строки:

УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто1);

УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто2);

УстановитьВладельца(ПоВсемРУ, РазделительУчета, Субконто3);

И проанализируй эту процедуру (УстановитьВладельца)."

Этуземец
читатель
офлайн
Дата регистрации: 10.12.2002
Сообщений: 28
Пост №7
 
07.05.2003 11:08

"ИМХО, УстановитьВладельца() нужна для работы с разделителями учета (РУ), а т.к. у нас они не используются, то даже удалив ее мы не шибко много потеряем. Похоже, что за сабж отвечает НазначитьСчет(). Но там, видимо, подразумевается работа с идентификаторами Субконто1,Субконто2 и Субконто3. Мне же в обработке надо иметь два ряда субконто для одного счета: Субконто1с, Субконто2с, Субконто3с; Субконто1н, Субконто2н, Субконто3н.

Получается, что сие не реализуемо. Ну и х. с ним. Не умрут бухи от пары лишних мышиных кликов. Спасибо за ответы."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги