Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Регистрация внешних печатных форм в БУ, ред.4.4

RSt
читатель
офлайн
Дата регистрации: 26.04.2003
Сообщений: 3
Пост №1
 
26.04.2003 16:39

Что-то мне непонятен смысл этой фичи: какой резон регистрировать внешние обработки, если можно было бы цеплять сразу таблицы в формате mxl. <br><br>Ну и даже если создать обработку, то как заставить при выборе её для печати выводить сразу таблицу, а не диалог самой обработки? Заранее спасибо за помощь.

toxy
читатель
офлайн
Дата регистрации: 11.04.2003
Сообщений: 8
Пост №2
 
28.04.2003 15:21

"Если я вас правильно понял...<br><br> Это внешняя печатная форма, почти готовая :)<br><br>Процедура Печать()<br><br>       ...<br><br>       ИсхТабл = СоздатьОбъект("Таблица");<br><br>       НачПовт = 0; КонПовт = 0;<br><br>       НаименованиеОрганизация = СокрЛП(Докум.Фирма.ЮрЛицо.ПолнНаименование) + " " + глПредставлениеАдреса(Докум.Фирма.ЮрЛицо.ЮрАдрес);<br><br>       ...<br><br> вообщем как обычно :)<br><br><br><br>КонецПроцедуры<br><br><br><br>Процедура ПриОткрытии()<br><br> Если ПустоеЗначение(Форма.Параметр) = 0 Тогда<br><br> Докум      = Форма.Параметр.Получить("Контекст");<br><br> Устройство = Форма.Параметр.Получить("Устройство");<br><br> КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");<br><br> <br><br> Печать(Докум, Устройство, КолвоКопий);<br><br> Статусвозврата(0);<br><br> Возврат;<br><br> КонецЕсли;<br><br>КонецПроцедуры // ПриОткрытии()<br><br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С