Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Регистрация внешних печатных форм в БУ, ред.4.4

RSt
читатель
офлайн
Дата регистрации: 26.04.2003
Сообщений: 3
Пост №1
 
26.04.2003 16:39

Что-то мне непонятен смысл этой фичи: какой резон регистрировать внешние обработки, если можно было бы цеплять сразу таблицы в формате mxl.

Ну и даже если создать обработку, то как заставить при выборе её для печати выводить сразу таблицу, а не диалог самой обработки? Заранее спасибо за помощь.

toxy
читатель
офлайн
Дата регистрации: 11.04.2003
Сообщений: 8
Пост №2
 
28.04.2003 15:21

"Если я вас правильно понял...

Это внешняя печатная форма, почти готовая :)

Процедура Печать()

       ...

       ИсхТабл = СоздатьОбъект("Таблица");

       НачПовт = 0; КонПовт = 0;

       НаименованиеОрганизация = СокрЛП(Докум.Фирма.ЮрЛицо.ПолнНаименование) + " " + глПредставлениеАдреса(Докум.Фирма.ЮрЛицо.ЮрАдрес);

       ...

вообщем как обычно :)



КонецПроцедуры



Процедура ПриОткрытии()

Если ПустоеЗначение(Форма.Параметр) = 0 Тогда

Докум      = Форма.Параметр.Получить("Контекст");

Устройство = Форма.Параметр.Получить("Устройство");

КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");



Печать(Докум, Устройство, КолвоКопий);

Статусвозврата(0);

Возврат;

КонецЕсли;

КонецПроцедуры // ПриОткрытии()

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги