Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Сохранение информационной базы 1с

slavbuch
читатель
офлайн
Дата регистрации: 29.04.2003
Сообщений: 2
Пост №1
 
29.04.2003 11:25

У меня один компьютер. Стоит 1С допустим если полетит операционка WindowsXP При установке заново возможно ли сохранение информации 1С и работа данной программы под новой операционкой?

(вариант установка изначально 1С на диск d:\)

Какие варианты можно использовать и как это самое реализовывается ? Спасибо заранее

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №2
 
29.04.2003 12:49

Способов несколько.

1) Тупое копирование базы в другую директорию :)

2) Зайти под конфигуратором и в меню Администрирование -> Сохранить данные, что более правильно и менее ресурсоёмко.



ПС: Для восстановления данных сохранённых по пункту 2, делаем то же самое, только вместо "Сохранить данные" выбираем "Восстановить данные".

Marat
читатель
офлайн
Дата регистрации: 05.01.2003
Сообщений: 32
Пост №3
 
08.05.2003 10:00

"Повесь в меню следующую обработку:



Процедура Коп();

Если МонопольныйРежим()=1 Тогда

Предупреждение("В монопольном режиме копирование файлов невозможно!");

Иначе;

КБ = КаталогИБ();

КК = "С:\1SbDb";

Если ФС.СуществуетФайл(КК) = 0 Тогда

ФС.СоздатьКаталог(КК);

КонецЕсли;

ЗапуститьПриложение("xcopy "+КБ+"*.dbf "+КК+" /y");

ЗапуститьПриложение("xcopy "+КБ+"1cv7.md "+КК+" /y");

ЗапуститьПриложение("xcopy "+КБ+"1cv7.dd "+КК+" /y");

КонецЕсли;

ЗавершитьРаботуСистемы();

КонецПроцедуры



Запускай ее в конце рабочего дня. На диске С: всегда будет свежая копия.

"

Elena
читатель
офлайн
Дата регистрации: 16.05.2003
Сообщений: 59
Пост №4
 
16.05.2003 09:35

Сохранять данные,кстати говоря, можно автоматически используя пакетный режим запуска конфигуратора, прописав соответствующую командную строку в планировщике заданий.

trofa
читатель
офлайн
Дата регистрации: 16.05.2008
Сообщений: 1
Пост №5
 
16.05.2008 12:26

"длинные имена не поддерживает.
лучше так
создать в 1с внешний отчет
добавить текстовое поле в форму идентификатор-выбпуть, тип строка, длина 60
добавить кнопку в форму заголовок-О, формула-ВыборКаталога()

В модуле формы



//*******************************************
Процедура Сформировать()
Если МонопольныйРежим()=1 Тогда
Предупреждение("В монопольном режиме копирование файлов невозможно!");
Иначе;
ФС.УстТекКаталог(каталогИБ());

Попытка
ИБ=СокрЛП(строка(константа.ПрефиксИБ));
Исключение
ИБ="""";
КонецПопытки;
КК = СокрЛП(Строка(ВыбПуть))+Строка("\")+ИБ+СокрЛП(строка(ТекущаяДата()));
Если ФС.СуществуетФайл(КК) = 0 Тогда
ФС.СоздатьКаталог(КК);
КонецЕсли;
ЗапуститьПриложение("xcopy *.dbf "+КК+" /y");
ЗапуститьПриложение("xcopy 1cv7.md "+КК+" /y");
ЗапуститьПриложение("xcopy cv7.dd "+КК+" /y");
ЗапуститьПриложение("xcopy users.usr "+КК+" /y");
ЗапуститьПриложение("xcopy *.DLL "+КК+" /y");
КонецЕсли;
//ЗавершитьРаботуСистемы();

КонецПроцедуры


Процедура ВыборКаталога()
Если ФС.ВыбратьКаталог(ВыбПуть,"Выбор Каталога",60)=1 Тогда
КонецЕсли;
КонецПроцедуры

Выбпуть="G:\1C";

///////////////////////////////////


"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги