Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Сохранение информационной базы 1с

slavbuch
читатель
офлайн
Дата регистрации: 29.04.2003
Сообщений: 2
Пост №1
 
29.04.2003 11:25

У меня один компьютер. Стоит 1С допустим если полетит операционка WindowsXP При установке заново возможно ли сохранение информации 1С и работа данной программы под новой операционкой?<br><br>(вариант установка изначально 1С на диск d:\)<br><br>Какие варианты можно использовать и как это самое реализовывается ? Спасибо заранее

zondor33
читатель
офлайн
Дата регистрации: 17.12.2002
Сообщений: 69
Пост №2
 
29.04.2003 12:49

Способов несколько.<br><br>1) Тупое копирование базы в другую директорию :)<br><br>2) Зайти под конфигуратором и в меню Администрирование -> Сохранить данные, что более правильно и менее ресурсоёмко.<br><br><br><br>ПС: Для восстановления данных сохранённых по пункту 2, делаем то же самое, только вместо "Сохранить данные" выбираем "Восстановить данные".

Marat
читатель
офлайн
Дата регистрации: 05.01.2003
Сообщений: 32
Пост №3
 
08.05.2003 10:00

"Повесь в меню следующую обработку:<br><br><br><br>Процедура Коп();<br><br> Если МонопольныйРежим()=1 Тогда<br><br> Предупреждение("В монопольном режиме копирование файлов невозможно!");<br><br> Иначе; <br><br> КБ = КаталогИБ();<br><br> КК = "С:\1SbDb";<br><br> Если ФС.СуществуетФайл(КК) = 0 Тогда<br><br> ФС.СоздатьКаталог(КК); <br><br> КонецЕсли;<br><br> ЗапуститьПриложение("xcopy "+КБ+"*.dbf "+КК+" /y");<br><br> ЗапуститьПриложение("xcopy "+КБ+"1cv7.md "+КК+" /y");<br><br> ЗапуститьПриложение("xcopy "+КБ+"1cv7.dd "+КК+" /y");<br><br> КонецЕсли;<br><br> ЗавершитьРаботуСистемы();<br><br>КонецПроцедуры <br><br><br><br>Запускай ее в конце рабочего дня. На диске С: всегда будет свежая копия.<br><br>"

Elena
читатель
офлайн
Дата регистрации: 16.05.2003
Сообщений: 59
Пост №4
 
16.05.2003 09:35

Сохранять данные,кстати говоря, можно автоматически используя пакетный режим запуска конфигуратора, прописав соответствующую командную строку в планировщике заданий.

trofa
читатель
офлайн
Дата регистрации: 16.05.2008
Сообщений: 1
Пост №5
 
16.05.2008 12:26

"длинные имена не поддерживает.<br>лучше так<br>создать в 1с внешний отчет<br>добавить текстовое поле в форму идентификатор-выбпуть, тип строка, длина 60<br>добавить кнопку в форму заголовок-О, формула-ВыборКаталога()<br><br>В модуле формы<br><br><br><br>//*******************************************<br>Процедура Сформировать()<br>Если МонопольныйРежим()=1 Тогда <br>Предупреждение("В монопольном режиме копирование файлов невозможно!"); <br>Иначе; <br>ФС.УстТекКаталог(каталогИБ()); <br><br>Попытка<br>ИБ=СокрЛП(строка(константа.ПрефиксИБ));<br>Исключение <br>ИБ="""";<br>КонецПопытки;<br>КК = СокрЛП(Строка(ВыбПуть))+Строка("\")+ИБ+СокрЛП(строка(ТекущаяДата())); <br>Если ФС.СуществуетФайл(КК) = 0 Тогда <br>ФС.СоздатьКаталог(КК); <br>КонецЕсли;<br>ЗапуститьПриложение("xcopy *.dbf "+КК+" /y"); <br>ЗапуститьПриложение("xcopy 1cv7.md "+КК+" /y"); <br>ЗапуститьПриложение("xcopy cv7.dd "+КК+" /y"); <br>ЗапуститьПриложение("xcopy users.usr "+КК+" /y"); <br>ЗапуститьПриложение("xcopy *.DLL "+КК+" /y"); <br>КонецЕсли; <br>//ЗавершитьРаботуСистемы(); <br><br>КонецПроцедуры <br><br><br>Процедура ВыборКаталога()<br>Если ФС.ВыбратьКаталог(ВыбПуть,"Выбор Каталога",60)=1 Тогда<br>КонецЕсли;<br>КонецПроцедуры <br><br>Выбпуть="G:\1C";<br><br>///////////////////////////////////<br><br><br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С