Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как вывести начисления сотрудника в конф. ЗиК, р.2.3

Buhgalter2011
читатель
офлайн
Дата регистрации: 21.05.2003
Сообщений: 41
Пост №1
 
30.06.2003 09:23

Всем ПРИВЕТ!

Я начинающищий, меня попросили создать приложение в конфигурации ЗиК, р.2.3, которая выводила бы справку о зарплате для работника, я создал, но все начисления в форму надо вводить вручную, чтобы далее программка рассчитала "среднюю", "всего" и вывела печатную форму, а как сделать так, чтобы начисления формировались на печатной форме автоматически, как их вытащить из журнала расчетов, что написать? Подскажите профи в какую сторну мне идти чтобы найти истину.

Splav
читатель
офлайн
Дата регистрации: 02.07.2003
Сообщений: 3
Пост №2
 
02.07.2003 09:22

"//Можно так:

Спр = СоздатьОбъект("Справочник.Сотрудники")

ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");

//Выбираем в Журнале расчетов записи по сотруднику "Иванов"

//за период с 01.07.03 по 31.07.03

Спр.НайтиПоНаименованию("Иванов Иван Иванович",0,1);

Сотрудник = Спр.ТекущийЭлемент();

Если ЖР.ВыбратьЗаписиПоОбъекту(Сотрудник,'01.07.03','31.07.03') = 1 Тогда

//В цикле получаем записи по сотруднику

Пока ЖР.ПолучитьЗапись()=1 Цикл

      //Если нужны только начисления то проверяем

      //на вхождение в группу "ВсеНачисления"

      Если ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда

       НазваниеРасчета = ЖР.Расчет;

       РезультатРасчета = ЖР.Результат;

      КонецЕсли;

КонецЦикла;

КонецЕсли;



//Если нужно получить по списку сотрудников, то

//лучше использовать запрос и в цикле пробегая по

//запросу выводить в таблицу отчета нужные данные

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги