Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как вывести начисления сотрудника в конф. ЗиК, р.2.3

Buhgalter2011
читатель
офлайн
Дата регистрации: 21.05.2003
Сообщений: 44
Пост №1
 
30.06.2003 09:23

Всем ПРИВЕТ!<br><br> Я начинающищий, меня попросили создать приложение в конфигурации ЗиК, р.2.3, которая выводила бы справку о зарплате для работника, я создал, но все начисления в форму надо вводить вручную, чтобы далее программка рассчитала "среднюю", "всего" и вывела печатную форму, а как сделать так, чтобы начисления формировались на печатной форме автоматически, как их вытащить из журнала расчетов, что написать? Подскажите профи в какую сторну мне идти чтобы найти истину.

Splav
читатель
офлайн
Дата регистрации: 02.07.2003
Сообщений: 3
Пост №2
 
02.07.2003 09:22

"//Можно так:<br><br>Спр = СоздатьОбъект("Справочник.Сотрудники")<br><br>ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");<br><br>//Выбираем в Журнале расчетов записи по сотруднику "Иванов" <br><br>//за период с 01.07.03 по 31.07.03<br><br>Спр.НайтиПоНаименованию("Иванов Иван Иванович",0,1);<br><br>Сотрудник = Спр.ТекущийЭлемент();<br><br>Если ЖР.ВыбратьЗаписиПоОбъекту(Сотрудник,'01.07.03','31.07.03') = 1 Тогда<br><br>//В цикле получаем записи по сотруднику <br><br> Пока ЖР.ПолучитьЗапись()=1 Цикл<br><br>      //Если нужны только начисления то проверяем <br><br>      //на вхождение в группу "ВсеНачисления"<br><br>      Если ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда<br><br>       НазваниеРасчета = ЖР.Расчет;<br><br>       РезультатРасчета = ЖР.Результат; <br><br>      КонецЕсли; <br><br> КонецЦикла; <br><br>КонецЕсли;<br><br><br><br>//Если нужно получить по списку сотрудников, то <br><br>//лучше использовать запрос и в цикле пробегая по <br><br>//запросу выводить в таблицу отчета нужные данные<br><br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С