Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выгрузка в формате DBF

AnnaBels
читатель
офлайн
Дата регистрации: 17.02.2005
Сообщений: 104
Пост №1
 
01.02.2008 11:32

необходимо создать файл выгрузки для Сбербанка , содержащий сведения о суммах з/п, номера лиц.счетов в формате dbf<br>поля описала(они строковые), кидаю значения, а когда идет функция Записать() сведения исчезают. прогоняла в Отладчике : все норм. значения в ячейки цепляет, строки создает. а при записи все поля пустые. <br>и еще вопрос почему когда открываю в excel этот файл описанные ячейки прячутся

iss52
читатель
офлайн
Дата регистрации: 28.11.2007
Сообщений: 6
Пост №2
 
01.02.2008 13:17

"Процедура Сформировать()<br> <br> Б= СоздатьОбъект("XBase"); <br> Б.ДобавитьПоле("A",2,30,0);<br> Б.ДобавитьПоле("B",2,30,0);<br> Б.ДобавитьПоле("C",2,30,0);<br> Б.ДобавитьПоле("D",2,30,0);<br> Б.ДобавитьПоле("E",2,30,0);<br> Б.ДобавитьПоле("F",2,30,0);<br> Б.ДобавитьПоле("G",2,30,0); <br> Ф = "C:\ОбменСБ\bk"+Дог+НомР; <br> Б.КодоваяСтраница(1);<br> Б.СоздатьФайл(Ф); <br> <br> Если Б.Открыта()= 1 тогда<br> //Заголовок<br> Б. Добавить();<br> Б.A=Банк;<br> Б.Записать(); <br> Б. Добавить();<br> Б.A="К платежному поручению №";<br> Б.B=НомПП;<br> Б.C="от";<br> Б.D=Строка(ДатаПП);<br> Б.Записать(); <br> Б. Добавить();<br> Б.A="Зачисление";<br> Б.B="01";<br> Б.Записать(); <br> Б. Добавить();<br> Б.A="Наименование, ОГРН";<br> Б.B=СокрЛП(Константа.НазваниеОрганизации);//+СокрЛП(Константа.ОГРН);<br> Б.C=РС;<br> Б.Записать(); <br> Б. Добавить();<br> Б.A="По договору";<br> Б.B=Дог;<br> Б.C="от";<br> Б.D=Строка(ДатаДог);<br> Б.Записать(); <br> Б. Добавить();<br> Б.A="№ п/п";<br> Б.B="Номер счета";<br> Б.C="Фамилия";<br> Б.D="Имя";<br> Б.E="Отчество";<br> Б.F="Сумма";<br> Б.G="Примечание";<br> Б.Записать();<br> //Сотрудники<br> Если Ведомость.Выбран()=1 тогда<br> Ведомость.ВыбратьСтроки();<br> Нпп=1; <br> Итого=0.00;<br> Пока Ведомость.ПолучитьСтроку()=1 цикл<br> Б.Добавить();<br> Б.A= Сокрлп(строка(нпп));<br> Б.B=СокрЛП(Ведомость.Сотрудник.НомерЗарплатногоСчета); <br> ФИО=Ведомость.Сотрудник.Наименование;<br> Ф="""";Им="""";О="""";<br> ПолучитьФИОСотрудника(ФИО,Ф,Им,О);<br> Б.C=Ф;<br> Б.D=Им;<br> Б.E=О;<br> Б.F=Формат(Ведомость.Сумма,"Ч15.2");<br> Нпп=Нпп+1;<br> Итого = Итого+Ведомость.Сумма;<br> Б.Записать(); <br> КонецЦикла;<br> //Итого<br> Б.Добавить();<br> Б.B="Итого";<br> Б.F=Формат(Итого,"Ч15.2");<br> б.Записать();<br> КонецЕсли;<br> КонецЕсли; <br> Б.первая();<br> Сообщить(Б.A+"!"+Б.B+"!"+Б.C+"!"+Б.D+"!"+Б.E+"!"+Б.F+"!"+Б.G+"!");<br> <br> Пока б.Следующая()=1 цикл<br> Сообщить(Б.A+"!"+Б.B+"!"+Б.C+"!"+Б.D+"!"+Б.E+"!"+Б.F+"!"+Б.G+"!");<br> КонецЦикла; <br> Б.ЗакрытьФайл(); <br>КонецПроцедуры"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С