Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Конфигурация ЗиК р.2.3 профи помогите найти ошибку.

Buhgalter2011
читатель
офлайн
Дата регистрации: 21.05.2003
Сообщений: 44
Пост №1
 
04.07.2003 10:58

" Конфигурация ЗиК р.2.3. В журнале расчетов наменование вида расчета с порядком расчета "Суммой, пропорц-но отработанным дням" появляется, но результат равен 0,<br><br> при том, что документ "Ввод расчета сотруднику" с<br><br> суммой и видом расчета проводится,расчет результата производится в глобальном модуле, ниже отрывок из глоб. модуля, целый день я его изучал, что-то менял, все безрезультатно, профи помогите найти ошибку. <br><br> <br><br>Примечание: Перечисление.ХарактерНачисления.Суммой - порядок расчета <br><br> "Суммой, пропорц-но отработанным дням" <br><br> <br><br> /получим норму дней с учетом того, что сотрудник мог менять графики в течение месяца:<br><br> НормаДней = глНормаДнейЧасовЗаПериод(ЖурналРасчетов.Объект,ЖурналРасчетов.НачалоПериодаПоДате(ДатаНачалаДоплаты),ЖурналРасчетов.КонецПериодаПоДате(ДатаОкончанияДоплаты),"Дней");<br><br><br><br> Если Порядок = Перечисление.ХарактерНачисления.Суммой Тогда<br><br> // суммой, пропорционально отработанному времени... - с учетом дней<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "Всего рабочих дней по графику работника: " + НормаДней, 0, 1);<br><br> Если НормаДней <> 0 Тогда<br><br> Если глЗаполнитьМассивДней(МассивДней, ЖурналРасчетов.Объект, ДатаНачалаДоплаты, ДатаОкончанияДоплаты,1) = 1 Тогда<br><br> ДнейПоДоплате = глПолучитьКоличествоФактическиОтработанныхДнейЧасов(МассивДней, ДатаНачалаДоплаты, ДатаОкончанияДоплаты);<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "Отработано дней: " + ДнейПоДоплате , 0, 0);<br><br> Результат = глПолучитьСуммуИзРеквизита(Величина, ДатаОкончанияДоплаты);<br><br> Если ДокументИзЖурнала.Вид()="НачислениеЗаработнойПлаты" Тогда<br><br> Ставка = ЖурналРасчетов.Объект.Ставка.Получить(ДатаОкончанияДоплаты);<br><br> Если Ставка <> 1 Тогда<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "По состоянию на _П01 работник занимал: "+ Ставка + " "+ Нрег(глФормаМножественногоЧисла("ставку","ставки","ставок", Ставка)), 0, 1, ДатаОкончанияДоплаты, "ДДДММММГГГГ");<br><br> КонецЕсли;<br><br> Результат = Результат * Ставка;<br><br> КонецЕсли;<br><br> Результат = Результат / НормаДней * ДнейПоДоплате;<br><br> ИначеЕсли (ДатаНачалаДоплаты = ЖрнЗарплата.НачалоПериодаПоДате(ДатаНачалаДоплаты)) и (ДатаОкончанияДоплаты = ЖрнЗарплата.КонецПериодаПоДате(ДатаОкончанияДоплаты)) Тогда<br><br> ДнейПоДоплате = МассивДней[НомерДняГода(ДатаНачалаДоплаты)+1]; // всего дней из документа Табель<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "Отработано дней: " + ДнейПоДоплате , 0, 0);<br><br> Результат = глПолучитьСуммуИзРеквизита(Величина, ДатаОкончанияДоплаты);<br><br> <br><br> Результат = Результат / НормаДней * ДнейПоДоплате;<br><br> Иначе<br><br> Сотрудник = ЖурналРасчетов.Объект;<br><br> Если глРежимТрассировки = 1 Тогда<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "Сотруднику "+Сотрудник+" в "+ЖрнЗарплата.ОписательПериода(ДатаОкончанияДоплаты) + " был введен Табель отработанного времени в целом за месяц!", 0, 0);<br><br> глСообщениеТрассировки(глСообщенияТрассировки, "Расчет """"_П01"""" с _П02 по _П03 не проводился!", 1, 0,ВР,,ДатаНачалаДоплаты,"ДДДММММГГГГ",ДатаОкончанияДоплаты,"ДДДММММГГГГ");<br><br> Иначе<br><br> глДобавитьСообщение(глОбработчикСообщений, "Сотруднику "+Сотрудник+" в "+ЖрнЗарплата.ОписательПериода(ДатаОкончанияДоплаты) + " был введен Табель отработанного времени в целом за месяц! Расчет """""+глПредставлениеВидаРасчета(ВР)+""""" с "+ДатаНачалаДоплаты+" по "+ДатаОкончанияДоплаты+" не проводился! Введите подробные данные об отработанном времени.", , , );<br><br> КонецЕсли;<br><br> КонецЕсли;;<br><br> КонецЕсли;"

moroder
читатель
офлайн
Дата регистрации: 16.06.2002
Сообщений: 526
Пост №2
 
04.07.2003 12:59

А график работы у сотрудника прописан?<br><br>Если прописан, то заполнен?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00, все желающие)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С