Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Конфигурация ЗиК р.2.3 профи помогите найти ошибку.

Buhgalter2011
читатель
офлайн
Дата регистрации: 21.05.2003
Сообщений: 41
Пост №1
 
04.07.2003 10:58

" Конфигурация ЗиК р.2.3. В журнале расчетов наменование вида расчета с порядком расчета "Суммой, пропорц-но отработанным дням" появляется, но результат равен 0,

при том, что документ "Ввод расчета сотруднику" с

суммой и видом расчета проводится,расчет результата производится в глобальном модуле, ниже отрывок из глоб. модуля, целый день я его изучал, что-то менял, все безрезультатно, профи помогите найти ошибку.



Примечание: Перечисление.ХарактерНачисления.Суммой - порядок расчета

"Суммой, пропорц-но отработанным дням"



/получим норму дней с учетом того, что сотрудник мог менять графики в течение месяца:

НормаДней = глНормаДнейЧасовЗаПериод(ЖурналРасчетов.Объект,ЖурналРасчетов.НачалоПериодаПоДате(ДатаНачалаДоплаты),ЖурналРасчетов.КонецПериодаПоДате(ДатаОкончанияДоплаты),"Дней");



Если Порядок = Перечисление.ХарактерНачисления.Суммой Тогда

// суммой, пропорционально отработанному времени... - с учетом дней

глСообщениеТрассировки(глСообщенияТрассировки, "Всего рабочих дней по графику работника: " + НормаДней, 0, 1);

Если НормаДней <> 0 Тогда

Если глЗаполнитьМассивДней(МассивДней, ЖурналРасчетов.Объект, ДатаНачалаДоплаты, ДатаОкончанияДоплаты,1) = 1 Тогда

ДнейПоДоплате = глПолучитьКоличествоФактическиОтработанныхДнейЧасов(МассивДней, ДатаНачалаДоплаты, ДатаОкончанияДоплаты);

глСообщениеТрассировки(глСообщенияТрассировки, "Отработано дней: " + ДнейПоДоплате , 0, 0);

Результат = глПолучитьСуммуИзРеквизита(Величина, ДатаОкончанияДоплаты);

Если ДокументИзЖурнала.Вид()="НачислениеЗаработнойПлаты" Тогда

Ставка = ЖурналРасчетов.Объект.Ставка.Получить(ДатаОкончанияДоплаты);

Если Ставка <> 1 Тогда

глСообщениеТрассировки(глСообщенияТрассировки, "По состоянию на _П01 работник занимал: "+ Ставка + " "+ Нрег(глФормаМножественногоЧисла("ставку","ставки","ставок", Ставка)), 0, 1, ДатаОкончанияДоплаты, "ДДДММММГГГГ");

КонецЕсли;

Результат = Результат * Ставка;

КонецЕсли;

Результат = Результат / НормаДней * ДнейПоДоплате;

ИначеЕсли (ДатаНачалаДоплаты = ЖрнЗарплата.НачалоПериодаПоДате(ДатаНачалаДоплаты)) и (ДатаОкончанияДоплаты = ЖрнЗарплата.КонецПериодаПоДате(ДатаОкончанияДоплаты)) Тогда

ДнейПоДоплате = МассивДней[НомерДняГода(ДатаНачалаДоплаты)+1]; // всего дней из документа Табель

глСообщениеТрассировки(глСообщенияТрассировки, "Отработано дней: " + ДнейПоДоплате , 0, 0);

Результат = глПолучитьСуммуИзРеквизита(Величина, ДатаОкончанияДоплаты);



Результат = Результат / НормаДней * ДнейПоДоплате;

Иначе

Сотрудник = ЖурналРасчетов.Объект;

Если глРежимТрассировки = 1 Тогда

глСообщениеТрассировки(глСообщенияТрассировки, "Сотруднику "+Сотрудник+" в "+ЖрнЗарплата.ОписательПериода(ДатаОкончанияДоплаты) + " был введен Табель отработанного времени в целом за месяц!", 0, 0);

глСообщениеТрассировки(глСообщенияТрассировки, "Расчет """"_П01"""" с _П02 по _П03 не проводился!", 1, 0,ВР,,ДатаНачалаДоплаты,"ДДДММММГГГГ",ДатаОкончанияДоплаты,"ДДДММММГГГГ");

Иначе

глДобавитьСообщение(глОбработчикСообщений, "Сотруднику "+Сотрудник+" в "+ЖрнЗарплата.ОписательПериода(ДатаОкончанияДоплаты) + " был введен Табель отработанного времени в целом за месяц! Расчет """""+глПредставлениеВидаРасчета(ВР)+""""" с "+ДатаНачалаДоплаты+" по "+ДатаОкончанияДоплаты+" не проводился! Введите подробные данные об отработанном времени.", , , );

КонецЕсли;

КонецЕсли;;

КонецЕсли;"

moroder
читатель
офлайн
Дата регистрации: 16.06.2002
Сообщений: 526
Пост №2
 
04.07.2003 12:59

А график работы у сотрудника прописан?

Если прописан, то заполнен?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги