Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бухгалтерские итоги, ВыбратьПериоды не работает

Елена_В
активный пользователь
офлайн
Дата регистрации: 26.10.2007
Сообщений: 611
Пост №1
 
15.04.2008 10:44

"В разрезе указанных субконто нужно получить даты поступления и выбытия со счтеа МЦ.04. Почему БИ_МЦ04.ВыбратьПериоды(1) возвращает 0?<br><br> БИ_МЦ04 = СоздатьОбъект("БухгалтерскиеИтоги");       <br> БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Материалы);<br> БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Сотрудники);<br> БИ_МЦ04.ВыполнитьЗапрос(ВыбНачПериода,ВыбКонПериода, "МЦ.04",,,,"Проводка", "СК"); <br> БИ_МЦ04.ВыбратьПериоды(1); <br> Пока БИ_МЦ04.ПолучитьПериод(,)=1 Цикл <br>                         ... <br> КонецЦикла; <br>"

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №2
 
15.04.2008 10:57

"Используйте:<br>БИ.ВыбратьСубконто(..); ПолучитьСубконто(..)"

Елена_В
активный пользователь
офлайн
Дата регистрации: 26.10.2007
Сообщений: 611
Пост №3
 
15.04.2008 11:07

"Уже пробовала так делать. <br> БИ_МЦ04 = СоздатьОбъект("БухгалтерскиеИтоги");       <br> БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Материалы);<br> БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Сотрудники);<br> БИ_МЦ04.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.04",,,,"Проводка", "СК"); <br> БИ_МЦ04.ВыбратьСубконто(1); <br> Пока БИ_МЦ04.ПолучитьСубконто(1)=1 Цикл<br> ТЗ.НоваяСтрока();<br> ТЗ.Счет = Строка(БИ_МЦ04.Счет);<br> ТЗ.Материал = Строка(БИ_МЦ04.Субконто(1));<br> ТЗ.Количество = Строка(БИ_МЦ04.СКД("К"));<br> БИ_МЦ04.ВыбратьСубконто(2);<br> БИ_МЦ04.ПолучитьСубконто(2);<br> ТЗ.Сотр = Строка(БИ_МЦ04.Субконто(2));<br> КонецЦикла; <br><br>Но как тут получить даты?<br>мне нужен отчет в след. виде:<br>|Материал | сотрудник | первонач. стоимость | дата пост-я | дата выбытия | сумма | кол-во"

Daedal
читатель
офлайн
Дата регистрации: 20.09.2004
Сообщений: 632
Пост №4
 
15.04.2008 12:49

"У вас 2 субконто, следовательно вложенная выборка:<br>БИ_МЦ04.ВыбратьСубконто(1); <br>Пока БИ_МЦ04.ПолучитьСубконто(1)=1 Цикл<br> БИ_МЦ04.ВыбратьСубконто(2); <br> Пока БИ_МЦ04.ПолучитьСубконто(2)=1 Цикл<br> ...<br> КонецЦикла; <br>КонецЦикла; <br><br>получаем доступ к документу в выборке<br>док = БИ_МЦ04.Операция.ТекущийДокумент();"

Alexandr VA
читатель
офлайн
Дата регистрации: 07.01.2007
Сообщений: 1666
Пост №5
 
15.04.2008 20:42

"<br>> получаем доступ к документу в выборке<br>> док = БИ_МЦ04.Операция.ТекущийДокумент();<br><br>Неверно. У объекта Операция нет метода ТекущийДокумент(), есть атрибут Документ.<br><br>Надо так:<br><br>док = БИ_МЦ04.Операция.Документ;<br><br>Ссылка работает.<br><br>Дату операции можно получить через атрибут ДатаОперации, например:<br><br>ТекДата = БИ_МЦ04.Операция.ДатаОперации;<br><br><br><br>"

Елена_В
активный пользователь
офлайн
Дата регистрации: 26.10.2007
Сообщений: 611
Пост №6
 
16.04.2008 08:16

Спасибо, всё работает :)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00, все желающие)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С