Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Расшифровка ячейки таблицы

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 610
Пост №1
 
15.04.2008 16:25

Как сделать расшифровку ячейки таблицы, если в ячейку записываю ТЗ.Документ?<br><br>ТЗ.Документ = Строка(БИ_МЦ.Операция.Документ)

Tanya
читатель
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8412
Пост №2
 
15.04.2008 16:42

А зачем вы переводите в строку? Если останентся ссылкой, то откроется стандартной расшифровкой.

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 610
Пост №3
 
15.04.2008 16:44

Иначе в ячейке печатной формы отчета вижу не "Поступление материалов 0001 (20.03.08)", а "51571 11534"

Tanya
читатель
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8412
Пост №4
 
15.04.2008 16:51

Воодще то не должна. <br>Как формируете отчет. Что стоит в ячейке отчета и как вы ее заполняете

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 610
Пост №5
 
15.04.2008 16:56

" БИ_МЦ = СоздатьОбъект("БухгалтерскиеИтоги");       <br> БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Материалы);<br> БИ_МЦ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);<br> БИ_МЦ.ВыполнитьЗапрос(ВыбНачПериода,ВыбКонПериода, "МЦ.04,МЦ.05,МЦ.06,МЦ.07,МЦ.08",,,,"Проводка", "СК"); <br> БИ_МЦ.ВыбратьСчета();<br> Пока БИ_МЦ.ПолучитьСчет()=1 Цикл<br> БИ_МЦ.ВыбратьСубконто(1); <br> Пока БИ_МЦ.ПолучитьСубконто(1)=1 Цикл<br> БИ_МЦ.ВыбратьСубконто(2);<br> Пока (БИ_МЦ.ПолучитьСубконто(2))=1 Цикл <br> ТЗ.НоваяСтрока();<br> ТЗ.Счет = Строка(БИ_МЦ.Счет.Наименование);<br> ТЗ.Материал = Строка(БИ_МЦ.Субконто(1)); <br> ТЗ.Сотр = Строка(БИ_МЦ.Субконто(2)); <br> ТЗ.СНД_Кол = (БИ_МЦ.СНД("К"));<br> ТЗ.СНД_Сум = (БИ_МЦ.СНД("С"));<br> ТЗ.СКД_Кол = (БИ_МЦ.СКД("К"));<br> ТЗ.СКД_Сум = (БИ_МЦ.СКД("С"));<br> ТЗ.ДО_Кол = (БИ_МЦ.ДО("К"));<br> ТЗ.ДО_Сум = (БИ_МЦ.ДО("С"));<br> ТЗ.КО_Кол = (БИ_МЦ.КО("К"));<br> ТЗ.КО_Сум = (БИ_МЦ.КО("С"));<br> Если (ТЗ.ДО_Кол = 0) и (ТЗ.ДО_Сум = 0) и (ТЗ.КО_Кол = 0) и (ТЗ.КО_Сум = 0) Тогда<br> ТЗ.Документ = Строка("""");<br> Иначе<br> ТЗ.Документ = Строка(БИ_МЦ.Операция.Документ);<br> КонецЕсли;<br> КонецЦикла;<br> КонецЦикла; <br> КонецЦикла;<br><br>В ячейку пишу ТЗ.Документ. Есть много недочетов:<br>1) Если оборотов не было за указанный период, то в ячейку возвращается значение <Объект не найден>, если обороты были, то , н-р, "Перемещение материалов..."<br>2) Если БИ_МЦ.ДО=0, а БИ_МЦ.КО<>0 , то в яцейке так же <Объект не найден><br>3) расшифровка в любом случае не получается"

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20620
Пост №6
 
15.04.2008 17:54

"Так ведь у ТЗ это таблицаЗначений. Какой тип у Колонки "Документ"? Если строка, то присвоение ТЗ.Документ = БИ_МЦ.Операция.Документ будет присваивать именно "55542 5343". Для того, чтобы занести в ТЗ.Документ именно ссылку на документ, тип колонки должет быть "Документ". Напрмер : ТЗ.НоваяКолонка("Документ","Документ");"

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 610
Пост №7
 
16.04.2008 10:56

Точно, нужно было сделать тип строки Документ. Спасибо, теперь расшифровка работает.<br>Но по-прежнему, если за указанный период обороты только по кредиту, то в ячейке Документ <Объект не найден>

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20620
Пост №8
 
16.04.2008 12:16

У вас обороты по забалансовому счету, там может и не быть дебетовых обротов, так как для забаланса допускаеться оборот только по одной стороне и чем создаються кредитовые обороты?

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 610
Пост №9
 
16.04.2008 13:39

кредитовые обороты создаются документом Бух.справка. Они есть, потому что в отчете видно конкретные суммы, а вот каким документом - отчет не показывает

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20620
Пост №10
 
16.04.2008 13:56

А точно бух.справкой? Может быть операцией? Тогда можно попробовать при кред.оборотах присваивать Операция. А вообще то надо смотреть в отладчике, встать при кредитовом обороте и смотреть, что там в запросе!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С