Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Нумерация

Electric
читатель
офлайн
Дата регистрации: 24.06.2003
Сообщений: 6
Пост №1
 
01.08.2003 21:58

В последних конфигурациях 1С числовой код поменяли на текстовый. Пользоватьль ввел номер документа, теперь при вводе нового документа номер всегда один и тот-же. Что делать?

tolik1
читатель
офлайн
Дата регистрации: 27.07.2003
Сообщений: 43
Пост №2
 
02.08.2003 15:04

"найди "кривой" номер и добей лидирующие нули ...



а если таких много, запусти:



Док = СоздатьОбъект("Документ.Х"); // где Х-идентификатор

Док.ВыбратьДокументы();

Пока Док.ПолучитьДокумент() = 1 Цикл

НомерДок = СокрЛП(Док.НомерДок);

Пока СтрДлина(НомерДок)
НомерДок = "0"+НомерДок;

КонецЦикла;

Док.НомерДок=НомерДок;

Попытка

Док.Записать();

Исключение

Сообщить("Двойник: "+Док.ТекущийДокумент());

КонецПопытки;

КонецЦикла;



"

El Gato
читатель
офлайн
Дата регистрации: 16.08.2006
Сообщений: 3
Пост №3
 
16.08.2006 13:31

"Если у вас символьная нумерация, то лучше сделать вот так:

Док = СоздатьОбъект("Документ.РеализацияРозница"); // либо другой документ
Док.ВыбратьДокументы('01.05.06','01.09.06'); // дату указываете сами
                                                       // (если надо), либо уберите этоу строку
Пока Док.ПолучитьДокумент() = 1 Цикл
НомерДок = СокрЛП(Док.НомерДок);
НомерДок = СокрЛП(Сред(Док.НомерДок,5)); //Берем кол-во символов в префиксе+1
Преф=Лев(Док.НомерДок,4); // А здесь именно кол-во символов в префиксе "ААА-"

Пока СтрДлина(НомерДок)<6 Цикл // Вместо 6 подставляем Разрядность - кол-во символов
                                     // в префиксе
НомерДок = "0"+НомерДок;
КонецЦикла;

Док.НомерДок=Преф+НомерДок;
Сообщить(Док.НомерДок);
Попытка
Док.Записать();
Исключение
Сообщить("Двойник: "+Док.ТекущийДокумент());
КонецПопытки;
КонецЦикла; "

Andy2C
новичок
офлайн
Пост №4
 
21.08.2006 18:11

А в конфигурации от 1С слабо дописать в глобальном модуле, чтоб нули сами дописывались, или так и будут мучиться пользователи?

Оберон
новичок
офлайн
Пост №5
 
21.08.2006 21:08

поможет Вам, перенумерация документов начиная с самаго первого "кривого", используйте стандартные универсальные обработки 1С.
будут вопросы, пишите - помогу в проблемой...

очки
читатель
офлайн
Дата регистрации: 30.06.2006
Сообщений: 23
Пост №6
 
31.08.2006 21:59

на глаз от нуля почти неотличимо, а русское О от латинского О - так вообще безнадежно.

Vlad Larin
читатель
офлайн
Дата регистрации: 06.07.2006
Сообщений: 49
Пост №7
 
03.09.2006 23:35

Есть ещё полушаманский метод. Делаем резервную копию ИБ, грузимся в конфигураторе, в проблемном типе документов ставим тип кода "числовой". Сохраняем метаданные. Меняем код обратно. Снова сохраняем. Лидирующие нули добиты везде. :) Хотя могут появиться дубликаты, например, если были введены документы с номерами "0001" и "01".

Повторяю, РЕЗЕРВНУЮ КОПИЮ ДЕЛАТЬ ОБЯЗАТЕЛЬНО. Я предупредил. :)

janco
читатель
офлайн
Дата регистрации: 07.09.2006
Сообщений: 46
Пост №8
 
07.09.2006 14:19

существует же обработка repval, если мне не изменяет память, для перенумерации документов, зачем столько сложностей?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги