Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Что-то торможу...

Lubanya
читатель
офлайн
Дата регистрации: 20.05.2008
Сообщений: 30
Пост №1
 
20.05.2008 16:48

"Помогите, пожалуйста!!! Требуется переименовать часть реквизита.Т.е. есть сокращенные названия объектов и их небольшая характеристика. Необходимо, чтобы вместо сокращений были полные названия, но характеристика осталась. Мне кажется это должно выглядеть примерно так:<br>Процедура Переименовать() <br> Спр_ОС = СоздатьОбъект ("Справочник.ОсновныеСредства");<br> Спр_ОС.ВыбратьЭлементы ();<br> Пока Спр_ОС.ПолучитьЭлемент () = 1 Цикл<br> Если Лев(Спр_ОС.Наименование,8) = "Каб.лин." Тогда<br>              Спр_ОС.Наименование = "Кабельные Линии" +Сред(Спр_ОС. Наименование,8);<br> Спр_ОС.Записать();                                                                          КонецЕсли;<br>       <br> КонецЦикла; <br> КонецПроцедуры<br>Подскажите, пожалуйста, я на правильном пути? Что не так?"

Станислав Зворыкин
читатель
офлайн
Дата регистрации: 20.03.2008
Сообщений: 128
Пост №2
 
20.05.2008 17:05

Вроде все правильно,а что смущает?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №3
 
21.05.2008 21:01

"Получите сообщение "Нарушен порядок выборки"<br>Нужно:<br>Процедура Переименовать() <br>СписокЭлементовДляПереименования=СоздатьОбъект("СписокЗначений");<br>Спр_ОС = СоздатьОбъект("Справочник.ОсновныеСредства");<br>Спр_ОС.ВыбратьЭлементы(0);<br>Пока Спр_ОС.ПолучитьЭлемент(1) = 1 Цикл<br>Если Лев(Спр_ОС.Наименование,8) = "Каб.лин." Тогда<br>СписокЭлементовДляПереименования.ДобавитьЗначение(Спр_ОС.ТекущийЭлемент());<br>КонецЕсли;<br>КонецЦикла;<br>Для i=1 По СписокЭлементовДляПереименования.РазмерСписка() Цикл<br>Если Спр_ОС.НайтиЭлемент(СписокЭлементовДляПереименования.ПолучитьЗначение(i))=1 Тогда<br>Спр_ОС.Наименование = "Кабельные Линии" +Сред(Спр_ОС. Наименование,8);<br>Спр_ОС.Записать();<br>КонецЕсли;<br>КонецЦикла;<br>КонецПроцедуры"

Tanya
читатель
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8412
Пост №4
 
22.05.2008 09:57

"предлагаю вариант через запрос<br><br>Процедура Сформировать()<br>Перем Запрос, ТекстЗапроса, Таб;<br>//Создание объекта типа Запрос<br>Запрос = СоздатьОбъект("Запрос");<br>ТекстЗапроса = <br>"//{{ЗАПРОС(Сформировать)<br>|Обрабатывать НеПомеченныеНаУдаление;<br>|Без итогов;<br>|ТекущийЭлемент = Справочник.ОсновныеСредства.ТекущийЭлемент;<br>|Наименование = Справочник.ОсновныеСредства.Наименование;<br>|Группировка ТекущийЭлемент;<br>|Условие(лев(Наименование,8) = ВыбНаименование);<br>|"//}}ЗАПРОС<br>;<br>Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда<br> Возврат;<br>КонецЕсли;<br><br>спр=СоздатьОбъект("Справочник.ОсновныеСредства");<br>Пока Запрос.Группировка() = 1 Цикл            <br> если спр.найтиэлемент(запрос.ТекущийЭлемент)=1 тогда<br> спр.наименование=новоенаименование+Сред(Спр.Наименование,8);<br> спр.записать();<br>конецесли;<br>КонецЦикла;<br>КонецПроцедуры<br><br>сделано через форму , поэтому<br>ВыбНаименование= то что ищем<br>новоенаименование = на что меняем<br><br>Удачи."

Lubanya
читатель
офлайн
Дата регистрации: 20.05.2008
Сообщений: 30
Пост №5
 
29.05.2008 09:50

Спасибо всем огромное!!!Thorvardr отдельный респект!!!Я пока не сталкивалась с запросами, поэтому Ваш вариант мне наиболее близок и понятен.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С