Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

COM соединение

gprogman
читатель
офлайн
Дата регистрации: 17.06.2008
Сообщений: 25
Пост №1
 
17.06.2008 14:10

ПОдскажите пожалуйста как вытащить реквизиты документа из удаленной базы в местную? Параметры документа(Вид документа, номер) вводятся пользователем в соответствующие поля. далее прога получает этот документ из удаленной базы. требуется его в местной базе сохранить, а универсального механизма для чтения всех реквизитов документа в оле я не знаю.

BelAS
читатель
офлайн
Дата регистрации: 11.12.2002
Сообщений: 542
Пост №2
 
18.06.2008 04:21

"Вот примерно так. Куски реального кода.<br><br>... <br> Коннектор = Новый COMОбъект("V81.COMConnector");<br> Попытка<br> Состояние("Попытка COM-соединения...");<br> Соединение = Коннектор.Connect(СтрокаПодключения);<br> Состояние("Открыто COM-соединение...");<br> РезультатПодключения = Истина;<br> Исключение<br> РезультатПодключения = Ложь;<br> КонецПопытки;<br>...<br><br>Функция ПолучитьДокументРеализацияТоваров(Ссылка)<br> Если Ссылка = Неопределено Тогда<br> Возврат Неопределено;<br> КонецЕсли;<br> Если Ссылка.Пустая() Тогда<br> Возврат Соединение.Документы.РеализацияТоваровУслуг.ПустаяСсылка();<br> КонецЕсли;<br><br> БухСсылка = Соединение.Документы.РеализацияТоваровУслуг.ПустаяСсылка();<br> БухЗапрос = Соединение.NewObject("Запрос");<br> БухЗапрос.Текст = "ВЫБРАТЬ<br> |РеализацияТоваровУслуг.Ссылка<br> |ИЗ<br> | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг<br> |ГДЕ<br> | РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНачалоДня И &ДатаКонецДня";<br> <br> БухЗапрос.УстановитьПараметр("ДатаНачалоДня", НачалоДня(Ссылка.Дата));<br> БухЗапрос.УстановитьПараметр("ДатаКонецДня", КонецДня(Ссылка.Дата));<br><br> БухВыборка = БухЗапрос.Выполнить().Выбрать();<br> Если БухВыборка.Следующий() Тогда<br> БухСсылка = БухВыборка.Ссылка;<br> КонецЕсли;<br> Если БухСсылка.Пустая() Тогда<br> БухОбъект = Соединение.Документы.РеализацияТоваровУслуг.СоздатьДокумент();<br> Иначе<br> БухОбъект = БухСсылка.ПолучитьОбъект();<br> КонецЕсли;<br> <br> БухОбъект.Дата = Ссылка.Дата;<br> БухОбъект.ВидОперации = Соединение.Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;<br> БухОбъект.Организация = БухОрганизация;<br>...<br>и т.д."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 19 октября 2021 года (вторник, начало в 12:00, все желающие)Маркировка лекарственных средств на примере "1С:Управление аптечной сетью" и "ОКСи:Рабочее место кассира"

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С