Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Событие формы списка справочника при закрытии формы диалога элемента.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №1
 
20.06.2008 15:18

Платформа 7.7<br>Как поймать событие закрытия формы редактирования элемента справочника в контексте формы списка этого же спрвочника? Формы немодальные.<br><br>Смысл: пусть имеется справочник, например Контрагенты. Прямо в его форме списка я вставляю таблицу договоров, которая заполняется динамически. Открываем форму редактирования элемента (редактирование в форме диалога). Там есть аналогичная таблица (и не одна), в которой можно поредактировать договоры, поменять их названия, поудалять элементы, новые создить и т.п. Когда форма диалога закрывается, мы видим, что в форме списка табличка осталась неперезаполненной и актуализируется она после первого движения по списку элементов. Как ее обновить после закрытия фирмы диалога?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №2
 
24.06.2008 11:49

"В общем, пока сделал через FormEx, если у кого мысли будут по реализации стандартным функционалом, пишите. Вот как оно на сегодняшний момент:<br>В форме списка:<br><br>Функция ЗаполнитьТаблицуДоговоров(ПринудительноОбновить=0)<br>...<br>КонецФункции<br><br>Процедура ПриОткрытии()<br> Форма.ОбработкаВыбораСтроки(1);<br>КонецПроцедуры<br><br>Процедура ПриВыбореСтроки()<br> ТекЭлемент=ТекущийЭлемент();<br> Если ПустоеЗначение(ТекЭлемент)=0 Тогда<br>       СписокПараметров=СоздатьОбъект("СписокЗначений");<br>       СписокПараметров.Установить("Контекст",Контекст);<br>       ОткрытьФорму(ТекЭлемент,СписокПараметров,0);<br> КонецЕсли;<br>КонецПроцедуры<br><br>В форме элемента:<br>Процедура ПриЗакрытии()<br> Парам=Форма.Параметр;<br> Если ПустоеЗначение(Парам)=0 Тогда<br>       Если ТипЗначенияСтр(Парам)="СписокЗначений" Тогда<br>            Конт=Парам.Получить("Контекст");<br>            Сервис=СоздатьОбъект("Сервис");<br>            СписокАргументов=СоздатьОбъект("СписокЗначений");<br>            СписокАргументов.ДобавитьЗначение(1);<br>            Результат="""";<br>            Сервис.ВыполнитьФункцию(Конт, "ЗаполнитьТаблицуДоговоров", СписокАргументов, Результат);<br>       КонецЕсли;<br> КонецЕсли;<br>КонецПроцедуры<br><br>ключевое место - Сервис.ВыполнитьФункцию(...)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00, все желающие)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С