Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

как переписать правильно?

kostik007
читатель
офлайн
Дата регистрации: 16.08.2003
Сообщений: 2
Пост №1
 
16.08.2003 17:20

"

Процедура ФормированиеТаблицы()

перем обр, код;



for код=1 по 6 do

обр=Создатьобъект("Справочник.Образование_2");

сообщить(обр.ТекущийДокумент());

Enddo

КонецПроцедуры "

tolik1
читатель
офлайн
Дата регистрации: 27.07.2003
Сообщений: 43
Пост №2
 
16.08.2003 20:35

"Если ты русский, так и пиши по русски ...

а если создаёшь "справочник", так и получай "Элемент", а не "Документ" а не выё .... живайся :))

и, докучи, неплохо бы сначала спозиционироваться, а уж потом Сообщить(...)

Так криво спросил, что не остановиться :))



Процедура ФормированиеТаблицы()

For Код=1 to 6 Do

Обр = CreateObject("Справочник.Образование_2");

//а теперь стоит подумать, зачем это всё, например

If Обр.FindByCode(Код,0) = 1 Then

      Message(Обр.CurrentItem());

EndIf;

EndDo;

КонецПроцедуры



"

vela
читатель
офлайн
Дата регистрации: 18.08.2003
Сообщений: 20
Пост №3
 
19.08.2003 10:24

"Даже если за тем же, то нет смысла н раз создавать объект



Процедура ФормированиеТаблицы()

Обр = СоздатьОбъект("Справочник.Образование_2");

Для Код=1 по 6 Цикл

Если Обр.НайтиПоКоду(Код,0) = 1 Тогда

Сообщить(Обр.ТекущийЭлемент());

КонецЕсли;

КонецЦикла;

КонецПроцедуры



"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги