Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

как переписать правильно?

kostik007
читатель
офлайн
Дата регистрации: 16.08.2003
Сообщений: 2
Пост №1
 
16.08.2003 17:20

" <br><br>Процедура ФормированиеТаблицы()<br><br> перем обр, код;<br><br> <br><br>for код=1 по 6 do<br><br>обр=Создатьобъект("Справочник.Образование_2"); <br><br>сообщить(обр.ТекущийДокумент());<br><br> Enddo<br><br>КонецПроцедуры "

tolik1
читатель
офлайн
Дата регистрации: 27.07.2003
Сообщений: 43
Пост №2
 
16.08.2003 20:35

"Если ты русский, так и пиши по русски ...<br><br>а если создаёшь "справочник", так и получай "Элемент", а не "Документ" а не выё .... живайся :))<br><br>и, докучи, неплохо бы сначала спозиционироваться, а уж потом Сообщить(...)<br><br>Так криво спросил, что не остановиться :))<br><br><br><br>Процедура ФормированиеТаблицы() <br><br> For Код=1 to 6 Do <br><br> Обр = CreateObject("Справочник.Образование_2"); <br><br> //а теперь стоит подумать, зачем это всё, например <br><br> If Обр.FindByCode(Код,0) = 1 Then<br><br>      Message(Обр.CurrentItem()); <br><br> EndIf;<br><br> EndDo; <br><br>КонецПроцедуры <br><br><br><br> "

vela
читатель
офлайн
Дата регистрации: 18.08.2003
Сообщений: 20
Пост №3
 
19.08.2003 10:24

"Даже если за тем же, то нет смысла н раз создавать объект<br><br><br><br>Процедура ФормированиеТаблицы() <br><br>Обр = СоздатьОбъект("Справочник.Образование_2"); <br><br>Для Код=1 по 6 Цикл <br><br>Если Обр.НайтиПоКоду(Код,0) = 1 Тогда <br><br>Сообщить(Обр.ТекущийЭлемент()); <br><br>КонецЕсли; <br><br>КонецЦикла; <br><br>КонецПроцедуры <br><br><br><br>"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С